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PREFACE

Human civilization achieved the highest peak with the
development of computer known as “Computer era”.
Literate are those who have the knowledge
in using the computer whereas others
are considered illiterate inspite of the
other degrees obtained.
The growth of the nation at present lies
in the
hands of the youth, hence the content of
this book is prepared in such a way so as to attain utmost
knowledge considering the future needs of the youth.

This book does not require
prior knowledge in computer
Technology
Each unit comprises of simple
activities and demonstrations
which can be done by the teacher
and also students.

HOW
TO USE
THE BOOK?

Technical terminologies are listed
in glossary for easy understanding
The “ Do you know?” boxes enrich the knowledge of reader with
additional information
Workshops are introduced to solve the exercises using software
applications
QR codes are used to link supporting additional
materials in digital form

How to get connected to QR Code?
o

Download the QR code scanner from the google play store/
apple app store into your smartphone

o

Open the QR code scanner application

o

Once the scanner button in the application is clicked, camera opens
and then bring it closer to the QR code in the textbook.

o

Once the camera detects the QR code, a URL appears in the screen.
Click the URL and go to the content page.
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CAREER GUIDANCE AFTER 12TH
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B.E / B.Tech

COLLEGES/
UNIVERSITIES
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Software Engineer, Hardware
All University and their affiliated
Engineer, Software
Colleges and Self financing Colleges in
Development, Healthcare
India and Abroad.
Section, IT & ITEs

Science and Humanities
B.Sc (Computer Science)
BCA
B.Sc ( Maths, Physics, Chemistry,
Bio-Chemistry, Geography,
journalism, Library Sciences,
Political Science, Travel and
Tourism)

All University and their affiliated
Government Job and Private
Colleges and Self financing Colleges in Company BPO, Geologist,
India and Abroad.
Journalist

LAW
LLB
B.A+LLB
B.Com
BBM+LLB
BBA+LLB
CA
Diploma

All University and their affiliated
Lawyer, Legal Officer, Govt
Colleges and Self financing Colleges in
Job
India and Abroad.
The Institute of Chartered Accountant
of India (ICAI)
Government Polytechnic and Selffinancing colleges

CA Private and Govt.
Junior Engineer (Government
and Private)

Commerce Courses
B.com-Regular,
B.com-Taxation & Tax Procedure,
B.com-Travel &Tourism,
B.com-Bank Management,
B.com-Professional,
BBA/BBM-Regular,
BFM- Bachelors in Financial
All University and their affiliated
Markets,
BMS-Bachelors in Management
Colleges and Self financing Colleges in
India and Abroad.
Studies,
BAF- Bachelors in Accounting &
Finance,
Certified Stock Broker &
Investment Analysis,
Certified Financial Analyst,
Certified Financial Planner,
Certified Investment Banker

Private Organization ,
Government ,Banking sectors
and prospects for self –
employment.
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COURSES

COLLEGES/
UNIVERSITIES

PROFESSION

Management Courses
Business Management
Bank Management
Event Management
Hospital Management
Human Resource Management
Logistics Management

Private Organization ,
All University and their affiliated
Government ,Banking sectors
Colleges and Self financing Colleges in
and prospects for self –
India and Abroad.
employment.

LAW
LLB
B.A+LLB
B.Com
BBM+LLB
BBA+LLB
CA-Chartered Accountant
CMA-Cost Management
Accountant.
CS-Company Secretary
(Foundation)
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All University and their affiliated
Organization , Government,
Colleges and Self financing Colleges in
Banking sectors and prospects
India and Abroad.
for self – employment
The Institute of Chartered Accountant
of India (ICAI)

CA, Private Organization,
Government ,Banking sectors
and prospects for self –
employment.

Science and Humanities
B.Sc.Botany
B.Sc.Zoology
B.Sc.Dietician & Nutritionist
B.Sc.Home Science
B.Sc.Food Technology
B.Sc.Dairy Technology
B.Sc. Hotel Management
B.Sc. Fashion Design
B.Sc. Mass Communication
B.Sc. Multimedia
B.Sc. -3D Animation

All University and their affiliated
Government Job and Private
Colleges and Self financing Colleges in Company BPO, Geologist,
India and Abroad
Journalist

LAW
LLB
B.A+LLB
B.Com
BBM+LLB
BBA+LLB
CA
Diploma

All University and their affiliated
Lawyer, Legal Officer, Govt
Colleges and Self financing Colleges in
Job
India and Abroad.
The Institute of Chartered Accountant
of India (ICAI)
Government Polytechnic and Selffinancing colleges

CA Private and Govt.
Junior Engineer (Government
and Private)
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Unit I

Fundamentals of Computers

CHAPTER

1

Introduction to Computers
1.1 Introduction to Computers

Learning Objectives

Computers are seen everywhere
around us, in all spheres of life, in the field
of education, research, travel and tourism,
weather forecasting, social networking,
e-commerce etc. Computers have now
become an indispensable part of our lives.
Computers have revolutionised our lives with
their accuracy and speed of performing a job,
it is truly remarkable. Today, no organisation
can function without a computer. In fact,
various organisations have become paperless.
Computers have evolved over the years from
a simple calculating device to high speed
portable computers.
The growth of computer industry started
with the need for performing fast calculations.
The manual method of computing was slow
and prone to errors. So, attempts were made
to develop fast calculating devices, the journey
started from the first known calculating device
(Abacus) which has led us today to an extremely
high speed calculating devices.

After learning the concepts in this chapter,
the students will be able
• To know about Computers
• To learn about various generations of
computer
• To understand the basic operations of
computers
• To know the components and their
functions.
• To know about booting of a computer
Father of Computer
Charles Babbage
is
considered
to
be
the
father of computer,
for his invention
and the concept of
Analytical Engine in
1837. The Analytical
Engine contained an
Arithmetic Logic Unit
(ALU), basic flow
control, and integrated
memory; which led
to the development of first generalpurpose
computer
concept.

SN

1

Generation

First
Generation

Period

1.2 Generations of Computers

Growth in the computer industry is
determined by the development in technology.

Based on various stages of development,
computers can be categroised into different
generations.
Main Component
Merits/Demerits
used

19401956
Vacuum tubes

•
•
•
•

Big in size
Consumed more power
Malfunction due to overheat
Machine Language was used

1
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First Generation Computers - ENIAC , EDVAC , UNIVAC 1
ENIAC weighed about 27 tons, size 8 feet × 100 feet × 3 feet and consumed around 150
watts of power
• Smaller compared to First
Generation
• Generated Less Heat
• Consumed less power
compared to first generation
Second
1956• Punched cards were used
2
• First operating system was
Generation
1964
developed - Batch Processing
and Multiprogramming
Transistors
Operating System
• Machine language as well as
Assembly language was used.
Second Generation Computers IBM 1401, IBM 1620, UNIVAC 1108

Third
Generation

3

1964
-1971

Integrated
Circuits (IC)

• Computers were smaller,
faster and more reliable
• Consumed less power
• High Level Languages were
used

Third Generation Computers IBM 360 series, Honeywell 6000 series

4

5

Fourth
Generation

Fifth
Generation

19711980

1980 - till
date

Microprocessor
Very Large Scale
Integrated Circuits
(VLSI)

• Smaller and Faster
• Microcomputer series such
as IBM and APPLE were
developed
• Portable Computers were
introduced.

• Parallel Processing
• Super conductors
• Computers size was drastically
reduced.
• Can recognise Images and
Graphics
• Introduction of Artificial
Intelligence and Expert
Systems
Ultra Large
Scale Integration • Able to solve high complex
problems including decision
(ULSI)
making and logical reasoning
2
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6

Sixth
Generation

• Parallel and Distributed
computing
• Computers have become
smarter, faster and smaller
• Development of robotics
• Natural Language Processing
• Development of Voice
Recognition Software

In future

Table1.1 Generations of computers
Optical
Character
Recognition
(Optical
Grapheme Recognition) engine
for the Indus Scripts has been
developed using Deep Learning Neural
Networks (a sub-field of Artificial
Intelligence).
Given photographs, scans, or any image
feed of an Indus Valley Civilization
artifact, the system will
be able to recognise the
inscriptions (the symbol/
grapheme
sequences)
from the image. There
are totally 417 Symbols/
Graphemes/Characters in the Indus
Scripts and just 3700+ text inscriptions
of data for the machine to learn and
attain expert-level status.

The first digital computer
The ENIAC (Electronic Numerical
Integrator
And
Calculator)
was invented by J. Presper Eckert and
John Mauchly at
the University of
Pennsylvania and
began construction
in 1943 and was
not completed until
1946. It occupied about 1,800 square feet and
used about 18,000 vacuum tubes, weighing
almost 50 tons. ENIAC was the first digital
computer because it was fully functional.

1.3 Sixth Generation Computing
In the Sixth Generation, computers
could be defined as the era of intelligent
computers, based on Artificial Neural
Networks. One of the most dramatic
changes in the sixth generation will be the
explosive growth of Wide Area Networking.
Natural Language Processing (NLP) is
a component of Artificial Intelligence
(AI). It provides the ability to develop the
computer program to understand human
language.

1.4. Data and Information
We all know what a computer is? It
is an electronic device that processes the
input according to the set of instructions
provided to it and gives the desired output
3
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at a very fast rate. Computers are very
versatile as they do a lot of different tasks
such as storing data, weather forecasting,
booking airlines, railway or movie tickets
and even playing games.

programs or instructions. Both hardware
and software together make the computer
system to function.

Data: Data is defined as an unprocessed collection of raw facts, suitable
for communication, interpretation or
pro cessing.
For example, 134, 16 ‘Kavitha’, ‘C’
are data. This will not give any meaningful
message.

Figure 1.2: Computer

Information: Information is a
collection of facts from which conclusions
may be drawn. In simple words we can say
that data is the raw facts that is processed
to give meaningful, ordered or structured
information. For example Kavitha is
16 years old. This information is about
Kavitha and conveys some meaning. This
conversion of data into information is
called data processing.
INPUT

PROCESS

Let us first have a look at the
functional components of a computer.
Every task given to a computer follows an
Input- Process- Output Cycle (IPO cycle).
It needs certain input, processes that
input and produces the desired output.
The input unit takes the input, the central
processing unit does the processing of
data and the output unit produces the
output. The memory unit holds the data
and instructions during the processing.

OUTPUT

DATA

Control Unit

INFORMATION

Figure 1.1 Data and Information

ALU

Input Unit

“A Computer is an electronic device that
takes raw data (unprocessed) as an input
from the user and processes it under the
control of a set of instructions (called
program), produces a result (output), and
saves it for future use.”

Internal
Memory

Output Unit
Data Path
Control Path

Main Memory
Secondary Storage

Figure 1.3 components of a computer
1.5.1 Input Unit

1.5 Components of a Computer

Input unit is used to feed any form
of data to the computer, which can be
stored in the memory unit for further
processing. Example: Keyboard, mouse,
etc.

The computer is the combination of
hardware and software. Hardware is the
physical component of a computer like
motherboard, memory devices, monitor,
keyboard etc., while software is the set of
4
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1.5.2 Central Processing Unit

to temporarily store the programs and
data when the instructions are ready to
execute. The secondary memory is used
to store the data permanently.

CPU is the major component
which interprets and executes software
instructions. It also control the operation
of all other components such as memory,
input and output units. It accepts binary
data as input, process the data according
to the instructions and provide the result
as output.

The Primary Memory is volatile, that
is, the content is lost when the power supply
is switched off. The Random Access Memory
(RAM) is an example of a main memory. The
Secondary memory is non volatile, that is,
the content is available even after the power
supply is switched off. Hard disk, CD-ROM
and DVD ROM are examples of secondary
memory.

The CPU has three components
which are Control unit, Arithmetic and
logic unit (ALU) and Memory unit.
1.5.2.1 Arithmetic and Logic Unit

1.5.5. Input and Output Devices

The ALU is a part of the CPU
where various computing functions are
performed on data. The ALU performs
arithmetic operations such as addition,
subtraction, multiplication, division
and logical operations. The result of an
operation is stored in internal memory
of CPU. The logical operations of ALU
promote the decision-making ability of a
computer.

Input Devices:
(1) Keyboard: Keyboard (wired /
wireless, virtual) is the most common input
device used today. The individual keys for
letters, numbers and special characters
are collectively known as character keys.
This keyboard layout is derived from the
keyboard of original typewriter. The data
and instructions are given as input to
the computer by typing on the keyboard.
Apart from alphabet and numeric keys,
it also has Function keys for performing
different functions. There are different set
of keys available in the keyboard such as
character keys, modifier keys, system and
GUI keys, enter and editing keys, function
keys, navigation keys, numeric keypad
and lock keys.

1.5.2.2 Control Unit
The control unit controls the flow of
data between the CPU, memory and
I/O devices. It also controls the entire
operation of a computer.
1.5.3. Output Unit
An Output Unit is any hardware
component that conveys information to
users in an understandable form. Example:
Monitor, Printer etc.
1.5.4. Memory Unit
The Memory Unit is of two types
which are primary memory and secondary
memory. The primary memory is used

Figure 1.4 Keyboard
(2) Mouse: Mouse (wired/wireless)
is a pointing device used to control the
5
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Fingerprint Reader / Scanner is a very safe
and
convenient
device for security
instead of using
passwords, which
is vulnerable to
fraud and is hard
Figure 1.6 Fingerprint
to remember.
Scanner
(5) Track Ball:
Track ball is similar to
the upside- down design
of the mouse. The user
moves the ball directly,
while the device itself
Figure 1.7 Track
remains stationary. The
Ball
user spins the ball in
various directions to navigate the screen
movements.

movement of the cursor on the display
screen. It can be used to select icons,
menus, command buttons or activate
something on a computer. Some mouse
actions are move, click, double click, right
click, drag and drop.
Different types of mouse available
are: Mechanical Mouse, Optical, Laser
Mouse, Air Mouse, 3D Mouse, Tactile
Mouse, Ergonomic Mouse and Gaming
Mouse.
Who invented
Mouse?
The
computer
mouse as we know it
today was
invented
and
developed
by
Douglas Engelbart, with
the assistance of Bill
English, during the 1960's
and was patented on November 17, 1970.

(6) Retinal Scanner: This performs
a retinal scan which is a biometric
technique that uses unique patterns on a
person's retinal blood vessels.

(3) Scanner: Scanners are used to
enter the information directly into the
c o m p u t e r ’s
memory.
This
device works like
a Xerox machine.
The
scanner
converts
any
Figure 1.5 Scanner
type of printed
or
written
information
including
photographs into a digital format, which
can be manipulated by the computer.

Figure 1.8 Retinal Scanner
(7) Light Pen: A light pen is a
pointing
device
shaped like a pen
and is connected
to a monitor. The
tip of the light
pen contains a
l i g h t - s e n s i t i v e Figure 1.9 Light Pen
element which detects the light from the
screen enabling the computer to identify the
location of the pen on the screen. Light pens

(4)Fingerprint Scanner: Finger
print Scanner is a fingerprint recognition
device used for computer security,
equipped with the fingerprint recognition
feature that uses biometric technology.
6
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have the advantage of ‘drawing’ directly onto
the screen, but this becomes hard to use, and
is also not accurate.

new approach to input information into
the Computer.
(11) Digital Camera: It captures
images
/
videos
directly in the digital
form. It uses a CCD
(Charge
Coupled
Device)
electronic
chip. When light falls
on the chip through
Figure 1.13
the lens, it converts
light rays into digital Digital Camera
format.

(8) Optical Character Reader: It is
a device which
detects characters
printed or written
on a paper with
OCR, a user can
scan a page from a
book. The Computer
will recognise the Figure 1.10 Optical
characters in the Character Reader
page as letters and punctuation marks and
stores. The Scanned document can be
edited using a wordprocessor.
(9) Bar Code / QR Code Reader: A
Bar code is a pattern printed in lines of
different thickness. The Bar code reader
scans the information on the bar codes
transmits to the
Computer
for
further processing.
The system gives
fast and error free
entry
of
information into Figure 1.11 Bar code
the computer.
Reader
QR (Quick response) Code: The
QR code is the two dimension bar code
which can be read by a camera and
processed to interpert the image.

(12) Touch Screen: A touch screen
is a display device that allows the user to
interact with a computer by using the
finger. It can be quite useful as an
alternative to a mouse or keyboard for
navigating a Graphical
User Interface (GUI).
Touch screens are used
on a wide variety of
devices
such
as
computers,
laptops,
monitors,
smart
phones, tablets, cash
registers
and
information kiosks. Figure 1.14 Touch
Screen
Some touch screens
use a grid of infrared beams to sense the
presence of a finger instead of utilizing
touch-sensitive input.

(10) Voice Input Systems:
Microphone serves as
a voice Input device.
It captures the voice
data and send it to
the Computer. Using
the
microphone
along with speech
Figure 1.12 Voice
recognition software
input System
can offer a completely

(13) Keyer : A Keyer is a device for
signaling by hand,
by way of pressing
one
or
more
switches. Modern
keyers have a
large
number
of switches but Figure 1.15 Keyer
not as many as a full size keyboard.
7
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Typically, this number is between 4 and
50. A keyer differs from a keyboard, which
has "no board", but the keys are arranged
in a cluster.
Output Devices:
(1) Monitor: Monitor is the most
commonly used output
device to display the
information. It looks
like a TV. Pictures on
a monitor are formed
with picture elements
called
PIXELS.
Monitors may either
be
Monochrome
which display textFigure 1.16 Monitor
or images in Black
and White or can be color, which display
results in multiple colors. There are
many types of monitors available such as
CRT (Cathode Ray Tube), LCD (Liquid
Crystal Display) and LED (Light Emitting
Diodes). The monitor works with the
VGA (Video Graphics Array) card. The
video graphics card helps the keyboard
to communicate with the screen. It acts
as an interface between the computer
and display monitor. Usually the recent
motherboards incorporate built-in video
card.

Figure 1.17 Plotter
(3) Printers: Printers are used to
print the information on papers. Printers
are divided into two main categories:
• Impact Printers
• Non Impact printers
Impact Printers
These printers print with striking
of hammers or
pins on ribbon.
These
printers
can
print
on
multi-part (using
carbon papers) by
using mechanical
pressure.
For Figure 1.18 Impact
Printer
example,
Dot
Matrix printers and Line matrix printers
are impact printers.
A Dot matrix printer that prints using
a fixed number of pins or wires. Each dot is
produced by a tiny metal rod, also called a
“wire” or “pin”, which works by the power
of a tiny electromagnet or solenoid, either
directly or through a set of small levers. It
generally prints one line of text at a time. The
printing speed of these printers varies from
30 to 1550 CPS (Character Per Second).

The first computer monitor was part of
the Xerox Alto computer system, which
was released on March 1, 1973.
(2) Plotter: Plotter is an output
device that is used to produce graphical
output on papers. It uses single color or
multi color pens to draw pictures.

Line matrix printers use a fixed
print head for printing. Basically, it prints
a page-wide line of dots. But it builds up a
line of text by printing lines of dots. Line
8
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printers are capable of printing much more
than 1000 Lines Per Minute, resulting
in thousands of pages per hour. These
printers also uses mechanical pressure to
print on multi-part (using carbon papers).
Non-Impact Printers

Figure 1.20 Inkjet Printer

These printers do not use striking
mechanism for printing. They use
electrostatic or laser technology. Quality
and speed of these printers are better than
Impact printers. For example, Laser printers
and Inkjet printers are non-impact printers.

They use the technology of firing
ink by heating it so that it explodes towards
the paper in bubbles or by using
piezoelectricity in which tiny electric
currents controlled by electronic circuits
are used inside the printer to spread ink in
jet speed. An Inkjet printer can spread
millions of dots of ink at the paper every
single second.

Laser Printers
Laser printers mostly work with
similar technology used by photocopiers.
It makes a laser beam scan back and
forth across a drum inside the printer,
building up a pattern. It can produce very
good quality of graphic images. One of
the chief characteristics of laser printer
is their resolution – how many Dots per
inch(DPI). The available resolution range
around 1200 dpi. Approximately it can
print 100 pages per minute(PPM)

Speakers: Speakers
produce
voice
output
(audio)
. Using speaker
along
with
speech synthesise Figure 1.21 Speakers
software, the computer can provide voice
output. This has become very common in
places like airlines, schools, banks, railway
stations, etc.
Multimedia Projectors:
Multimedia projectors are used to
produce computer output on a big screen.
These are used to display presentations in
meeting halls or in classrooms.

Figure 1.19 Laser Printer
Inkjet Printers:
Inkjet Printers use colour cartridges
which combined Magenta, Yellow and Cyan
inks to create color tones. A black cartridge
is also used for monochrome output. Inkjet
printers work by spraying ionised ink at a
sheet of paper. The speed of Inkjet printers
generaly range from 1-20 PPM (Page Per
Minute).

Figure 1.22 Multimedia Projector
9
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1.6 Booting of computer

Points to Remember:

An Operating system (OS) is a
basic software that makes the computer
to work. When a computer is switched
on, there is no information in its RAM.At
the same time, in ROM, the pre-written
program called POST (Power on Self
Test) will be executed first. This program
checks if the devices like RAM, keyboard,
etc., are connected properly and ready to
operate. If these devices are ready, then
the BIOS (Basic Input Output System) gets
executed. This process is called Booting.
Thereafter, a program called “Bootstrap
Loader” transfers OS from hard disk into
main memory. Now the OS gets loaded
(Windows/Linux, etc.,) and will get
executed. Booting process is of two types.

• Computers are seen everywhere around
us, in all spheres of life.
• It is an electronic device that processes
the input according to the set of
instructions
provided to it and
gives the desired output at a very fast
rate.
• Based on various stages of development,
computers can be divided into six
different generations.
• The computer is the combination of
hardware and software.
• Hardware is the physical component of
a computer.
• Input unit is used to feed any form of
data to the computer.
• CPU interprets and executes software
instructions.
• The ALU is a part of the CPU where
various computing functions are
performed on data.
• The control unit controls the flow of
data between the CPU, memory and
I/O devices.
• An Output Unit is any hardware
component that conveys information
to one or more people in user
understandable
form.
• The Memory Unit is of two kinds which
are primary memory and secondary
memory.

1) Cold Booting
2) Warm Booting
Cold Booting: When the system
starts from initial state i.e. it is switched
on, we call it cold booting or Hard Booting.
When the user presses the Power button,
the instructions are read from the ROM to
initiate the booting process.
Warm Booting: When the system
restarts or when Reset button is pressed,
we call it Warm Booting or Soft Booting.
The system does not start from initial state
and so all diagnostic tests need not be
carried out in this case. There are chances
of data loss and system damage as the data
might not have been stored properly.

Activity

STUDENT ACTIVITY
1. Explain the classification of computers.
2. Give the details of motherboard names,
RAM capacity used in the years 1993,
1995, 2005, 2008, 2016.
3. Mention two new input and output
devices that are not given in this
chapter.
10
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8.

Evaluation
PART – I
Choose the correct answer:
1.
First generation
computers used

9.

10.

(c) Integrated circuits
(d) Microprocessors
Name the volatile memory
(a) ROM 		

(b) PROM

(c) RAM		

(d) EPROM

(b) Second

(c) Third 		

(d) Fourth

(c) Dot matrix

What is a computer?
Distinguish between data and
information.
3.
What are the components of a CPU?
4.
What is the function of an ALU?
5.
Write the functions of control unit.
6.
What is the function of memory?
7.
Differentiate Input and output unit.
8.
Distinguish Primary and Secondary
memor y.
PART – III
Short Answers

(d) inkjet printer

1.

Identify the input device
(a) Printer 		

(b) Mouse

(c) Plotter 		

(d) Projector

…....… Output device is used for
printing building plan.
(b) Plotter

7.

(a) First 		

1.
2.

(b) Memory

(a) Thermal printer

6.

Which generation of computer used
IC’s?

Very Short Answers

(c) Monitor (d) Mouse

5.

(d) Hard disk

PART – II

Identify the output device
(a) Keyboard

4.

(b) RAM

(c) Flash drive

(b) Transistors

3.

(a) Post on self Test
(b) Power on Software Test
(c) Power on Self Test
(d) Power on Self Text
Which one of the following is the
main memory?
(a) ROM

(a) Vacuum tubes

2.

Expand POST

Which one of the following is used
to in ATM machines
(a) Touch Screen

(b) speaker

(c) Monitor 		

(d) Printer

2.
3.
4.
5.

When a system restarts which type
of booting is used.
(a) Warm booting

6.
7.

(b) Cold booting
(c) Touch boot

8.

(d) Real boot.

What are the characteristics of a
computer?
Write the applications of computer.
What is an input device? Give two
e x ampl e s .
Name any three output devices.
Differentiate optical and Laser
mouse
Write shortnote on impact printer
Write the characteristics of sixth
generation.
Write the significant features of
m o n i t o r.

11
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Explain in detail
1.
2.
3.

PART – IV

Explain the basic components of a computer with a neat diagram.
Discuss the various generations of computers.
Explain the following
a. Inkjet Printer
b. Multimedia projector c. Bar code / QR code Reader
References

(1)

Fundamentals of Computers – V. Rajaraman – PHI Publications

(2)

Computer Science text book – NCERT, New Delhi
Internet Resources

(1)
(2)

www.wikipedia.org
https://www.computerhope.com/jargon/c/computer.html

Prepare a comparative study of various computers of past and present with respect
to speed, memory, size, power consumption and other features
Computer

It is an electronic device that processes the
input according to the set of instructions
provided to it and gives the desired output at a very fast rate.

Vacuum tube

Vacuum tubes contain electrodes for controlling electron flow
and were used in early computers as a switch or an amplifier.

Transistors

The transistor ("transfer resistance") is made up of semiconductors. It is a component used to control the amount of
current or voltage used for amplification/modulation of an
electronic signal.

Punched cards

Punch cards also known as Hollerith cards are paper cards
containing several punched or perforated holes that were
punched by hand or machine to represent data.

Machine Language

Machine language is a collection of binary digits or bits that the
computer reads and interprets.

Assembly language

An assembly language is a low-level programming language.

12
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Integrated Circuits

The IC is a package containing many circuits, pathways,
transistors, and other electronic components all working
together to perform a particular function or a series of functions.

Microcomputer

Micro computer is used to describe a standard personal
computer.

High-level languages

A high-level language is a computer programming language
that isn't limited by the computer, designed for a specific job,
and is easier to understand.

Natural Language
Processing (NLP)

Natural Language Processing is a method used in artificial
intelligence to process and derive meaning from the human
language.

Robotics

Robot is a term coined by Karel Capek in the 1921 to play
RUR (Rossum's Universal Robots). It is used to describe a
computerized machine designed to respond to input received
manually or from its surroundings.

Nanotechnology

Nanotechnology is an engineering, science, and technology that
develops machines or works with one atom or one molecule
that is 100 nanometers or smaller.

Bioengineering

A discipline that applies engineering principles of design and
analysis to biological systems and biomedical technologies

13
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Unit I

Fundamentals of Computers

CHAPTER

2

Number Systems
Learning Objectives

2.2 Data Representations

• To know how the computer interprets
and stores data in the memory.
• To learn various data representations
and binary arithmetic.
• To learn conversion between various
Number Systems.

Computer handles data in the form
of ‘0’(Zero) and ‘1’ (One). Any kind of data
like number, alphabet, special character
should be converted to ‘0’ or ‘1’ which can
be understood by the Computer. ‘0’ and
‘1’ that the Computer can understand is
called Machine language. ‘0’ or ‘1’ are
called ‘Binary Digits’(BIT). Therefore,
the study of data representation in the
computer is important.
• A bit is the short form of Binary digit
which can be ‘0’ or ‘1’. It is the basic
unit of data in computers.
• A nibble is a collection of 4 bits (Binary
digits).
• A collection of 8 bits is called Byte.
A byte is considered as the basic unit
of measuring the memory size in the
computer.
• Word length refers to the number of
bits processed by a Computer’s CPU.
For example, a word length can have 8
bits, 16 bits, 32 bits and 64 bits (Present
day Computers use 32 bits or 64 bits)

2.1 Introduction

The term data comes from the
word datum, which means a raw fact. The
data is a fact about people, places or some
objects.
Example:
Let ‘Name’, ‘Age’, ‘Class’, ‘Marks’
and ‘Subject’ be some defined variables.
Now, let us assign a value to each of these
variables.
Name 		
Age		
Class		
Mark		
Subject

=
=
=
=
=

Rajesh
16
XI
65
Computer Science

Figure 2.1 Example for Data

Bit
(0 or 1)

In the above example, the values
assigned to the five different variables
are called data. When the above data is
processed, we get an information “Rajesh
is 16 years old, studying in Class XI, has
scored 65 marks in Computer Science
subject”.

Nibble (4 bits)
Byte (8 bits)
KiloByte (1024 bytes)
MegaByte (1024 KB)
GigaByte (1024 MB)
TeraByte (1024 GB)

Figure 2.2 Data Representation
14
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represents 1000, that is , 103. In binary
Computer memory (Main Memory
system, 1 KiloByte represents 1024 bytes
and Secondary Storage)is normally
that is 210. The following table represents
represented in terms of KiloByte (KB) or
the various memory sizes:
MegaByte (MB). In decimal system, 1 Kilo
Table 2.1 Memory Size (Read 2^10 as 2 power 10)
Name Abbr.

Size

Kilo

K

2^10 = 1,024

Mega

M

2^20 = 1,048,576

Giga

G

2^30 = 1,073,741,824

Tera

T

2^40 = 1,099,511,627,776

Peta

P

2^50 = 1,125,899,906,842,624

Exa

E

2^60 = 1,152,921,504,606,846,976

Zetta

Z

2^70 = 1,180,591,620,717,411,303,424

Yotta

Y

2^80 = 1,208,925,819,614,629,174,706,173

Bytes are used to represent characters in a text. Different types of coding schemes
are used to represent the character set and numbers. The most commonly used coding
scheme is the American Standard Code for Information Interchange (ASCII). Each
binary value between 0 and 127 is used to represent a specific character. The ASCII value
for (blank space) is 32 and the ASCII value of numeric 0 is 48. The range of ASCII values
for lower case alphabets is from 97 to 122 and the range of ASCII values for the upper case
alphabets is 65 to 90.
The speed of a computer depends on the number of bits it can process at once. For
example, a 64- bit computer can process 64-bit numbers in one operation, while a
32-bit computer break 64-bit numbers down into smaller pieces, making it slower.

2.3 Different Types of Number Systems
Number Systems
Decimal
Base value
10

(0,1,2,3,4,5,6,7,8,9)

Binary

Octal

Base value
2

Hexadecimal

Base value
8

(0,1)

(0,1,2,3,4,5,6,7)

Base value
16

(0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F)

Figure 2.3. Number Systems
15
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Example

A numbering system is a way
of representing numbers. The most
commonly used numbering system in
real life is Decimal number system.
Other number systems are Binary, Octal,
Hexadecimal number system. Each
number system is uniquely identified by
its base value or radix. Radix or base is the
count of number of digits in each number
system. Radix or base is the general idea
behind positional numbering system.

The binary sequence (1101)2 has
the decimal equivalent:
(1101)2 = 1 × 23 + 1 × 22 + 0 × 21 + 1 × 20
		
=8+4+0+1
		
= (13)10

2.3.3 Octal Number System
Octal number system uses digits
0,1,2,3,4,5,6 and 7 (8 digits). Each octal
digit has its own positional value or weight
as a power of 8.

2.3.1 Decimal Number System
It consists of 0,1,2,3,4,5,6,7,8,9(10
digits). It is the oldest and most popular
number system used in our day to day life.
In the positional number system, each
decimal digit is weighed relative to its
position in the number. This means that
each digit in the number is multiplied by
10 raised to a power corresponding to that
digit’s position.

Example
The Octal sequence (547)8 has the
decimal
equivalent:
(547)8
		
		
		

Example
(123)10 = 1x102 + 2x101 + 3x100
		 = 100 + 20 + 3
		 = (123)10

2.3.4 Hexadecimal Number System

2.3.2 Binary Number System

A
hexadecimal
number
is
represented using base 16. Hexadecimal
or Hex numbers are used as a shorthand
form of binary sequence. This system is
used to represent data in a more compact
manner. Since 16 symbols are used, 0 to
F, the notation is called hexadecimal. The
first 10 symbols are the same as in the
decimal system, 0 to 9 and the remaining
6 symbols are taken from the first 6 letters
of the alphabet sequence, A to F, where A
represents 10, B is 11, C is 12, D is 13, E is
14 and F is 15.

There are only two digits in the
Binary system, namely, 0 and 1. The
numbers in the binary system are
represented to the base 2 and the positional
multipliers are the powers of 2. The left
most bit in the binary number is called as
the Most Significant Bit (MSB) and it has
the largest positional weight. The right
most bit is the Least Significant Bit (LSB)
and has the smallest positional weight.
1
MSB

1

0

= 5×82 + 4×81 + 7×80
= 5×64 + 4×8 + 7×1
= 320 + 32 + 7
= (359)10

1
LSB
16
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Example
The hexadecimal sequence (25)16
has the decimal equivalent:

Table 2.2 Binary, Octal, Hexadecimal
equivalent of Decimal Numbers
Decimal Binary Octal Hexadecimal
0
0000
000
0000
1
0001
001
0001
2
0010
002
0002
3
0011
003
0003
4
0100
004
0004
5
0101
005
0005
6
0110
006
0006
7
0111
007
0007
8
1000
010
0008
9
1001
011
0009
10
1010
012
A
11
1011
013
B
12
1100
014
C
13
1101
015
D
14
1110
016
E
15
1111
017
F

(25)16 = 2×161 + 5×160
		 = 32+5
		 = (37)10
Workshop
1. Identify the number system for the
following numbers
S. No. Number Number system
1

(1010)10

2

(1010)2

3

(989)16

4

(750)8

5

(926)10

Decimal Number
system

2. State whether the following numbers are valid or not. If invalid, give reason.
S.No.

Statement

1.

786 is an Octal number

2.

101 is a Binary number

3.

Radix of Octal number is 7

Yes / No

Reason (If invalid)

decimal system, we will obtain a quotient
N1 and a remainder R1, where R1 can
have a value of either 0 or 1. The process
is repeated until the quotient becomes 0
or 1. When the quotient is ‘0’ or ‘1’, it
is the final remainder value. Write the
final answer starting from final remainder
value obtained to the first remainder value
obtained.

2.4 Number System Conversions
2.4.1 Decimal to Binary Conversion
Generally two methods followed.
Method 1: To convert Decimal to Binary
“Repeated Division by 2” method can be
used. Any Decimal number divided by 2
will leave a remainder of 0 or 1. Repeated
division by 2 will leave a sequence of 0s
and 1s that become the binary equivalent
of the decimal number. Suppose it is
required to convert the decimal number N
into binary form, dividing N by 2 in the

Example
Convert (65)10 into its equivalent
binary number

17
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2 65
2 32 - 1

LSB

2 16 - 0
2

8-0

2

4-0

2

2-0

MSB

1-0

Given Number : 65

Remainder

Equivalent or value less than power of 2
is : 64

Note :
65/2 = 32 + 1
32/2 = 16 + 0
16/2 = 8 + 0
8/2 = 4 + 0
4/2 = 2 + 0
2/2 = 1 + 0

(1) 65 - 64 = 1
(2) 1 - 1= 0
Power’s of 2 64 32 16 8

4

2

1

Binary
Number

0

0

1

0

0

0

6510 = (1000001)2

2.4.2 Decimal to Octal Conversion

(65)10 = (1 0 0 0 0 0 1)2

To convert Decimal to Octal,
“Repeated Division by 8” method can be
used. The method is the same we have
learnt in 2.4.1, but in this method, we
have to divide the given number by 8.
Example
Convert (65)10 into its equivalent
Octal number

Method 2 : Sum of Powers of 2.
A decimal number can be converted
into a binary number by adding up the
powers of 2 and then adding bits as needed
to obtain the total value of the number.
a) Find the largest power of 2 that is
smaller than or equal to 65.

8 65

6510 > 6410

8 8-1
1-0
MSB

b) S et the 64’s bit to 1 and subtract 64
from the original number
65-64=1
c) 32 is greater than the remaining total.
Therefore, set the 32’s bit to 0.
d) 16 is greater than the remaining total.
Therefore, set the 16’s bit to 0.
e) 8 is greater than the remaining total.
Therefore, set the 8’s bit to 0.
f) 4 is greater than the remaining total.
Therefore, set the 4’s bit to 0.
g) 2 is greater than the remaining total.
Therefore, set the 2’s bit to 0.
h) As the remaining value is equivalent to
1’s bit, set it to 1.
1-1=0
Conversion is complete
Example

1

LSB

(65)10 = (1 0 1)8
2.4.3 Decimal to Hexadecimal
Conversion
To convert Decimal to Hexadecimal,
“Repeated division by 16” method can be
used. The method is the same as we have
learnt in 2.4.1, but in this method, we have
to divide the given number by 16.
Example
Convert (31)10 into its equivalent
hexadecimal number.
16

6510 = (1000001)2

MSB

The conversion steps can be given as
follows:

31
1 - 15

LSB

(16)10 = (1F)16(Refer Table 2.2 F=15)
18
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2.4.4 Conversion of fractional Decimal
to Binary
The
method
of
repeated
multiplication by 2 has to be used to
convert such kind of decimal fractions.
The steps involved in the method of
repeated multiplication by 2:
Step 1: Multiply the decimal fraction by
2 and note the integer part. The
integer part is either 0 or 1.
Step 2: Discard the integer part of the
previous product. Multiply the
fractional part of the previous
product by 2. Repeat Step 1
until the same fraction repeats
or terminates (0).
Step 3: The resulting integer part forms
a sequence of 0s and 1s that
become the binary equivalent of
decimal fraction.
Step 4: The final answer is to be written
from first integer part obtained
till the last integer part obtained.

Workshop
3. Convert the following Decimal
numbers to its equivalent Binary, Octal,
Hexadecimal.
1) 1920

0

0.4 × 2 = 0.8

0

0.8 × 2 = 1.6

1

0.6 × 2 = 1.2

1

0.2 × 2 = 0.4

0

3)126

2.4.5 Binary to Decimal Conversion
To convert Binary to Decimal we
can use positional notation method.
Step 1: Write down the Binary digits and
list the powers of 2 from right to
left(Positional Notation)
Step 2: For each positional notation
written for the digit, now write
the equivalent weight.
Step 3: Multiply each digit with its
corresponding weight
Step 4: Add all the values.
Table 2.3 Positional Notation and Weight
Positional Weight
Notation

Integer part
0.2 × 2 = 0.4

2) 255		

(first integer part obtained)

Positional Weight
Notation

20

1

26

64

21

2

27

128

22

4

28

256

23

8

29

512

24

16

210

1024

25

32

Example

(last integer part obtained)

Convert
(111011)2
equivalent decimal number.

Note: Fraction repeats, the product is the
same as in the first step.
Write the integer parts from
top to bottom to obtain the equivalent
fractional
binary
number.
Hence
(0.2)10=(0.00110011…)2 = (0.00110011)2

Weight
Positional
Notation
Given
number

into

its

32

16

8

4

2

1

25

24

23

22

21

20

1

1

1

0

1

1

19
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2.4.7. Binary to Hexadecimal Conversion

= (59)10
= (59)10

Step 1: Group the given number into 4
bits from right to left.
Step 2: You can add preceding 0’s to make
a group of 4 bits if the left most
group has less than 4 bits.

2.4.6 Binary to Octal Conversion
Step 1: Group the given binary number
into 3 bits from right to left.
Step 2: You can add preceding 0 to make
a group of 3 bits if the left most
group has less than 3 bits.
Step 3: Convert equivalent octal value
using "2's power positional weight
method"
Table 2.4 Octal numbers and their Binary
equivalent

110

7

111

Convert
(1111010110)2
Hexadecimal number

0011

{

The left most groups have less
than 3 bits, so 0 is added to its left
to make a group of 3 bits.
Step-2: Find Octal equivalent of each
group

{

Note:

{

0011

1101

0110

2.4.8 C onversion of fractional Binary to
Decimal equivalent
Follow the steps to convert
fractional Binary number to its Decimal
equivalent.
Step 1: Convert integral part of Binary
to Decimal equivalent using
positional
notation
method
(Procedure is same as discussed in
2.4.5)
Step 2: To convert the fractional part of
binary to its decimal equivalent.
Step 2.1: Write down the Binary
digits in the fractional part
Step 2.2: For all the digits write
powers of 2 from left to right
starting from 2-1, 2-2, 2-3...... 2-n,
now write the equivalent weight.

011 010 110

110

0110

3
D
6
(1111010110)2 = (3D6)16

Step 1: Group the given number into 3
bits from right to left.

010

1101

Note: 0’s are added to the left most group
to make it a group of 4 bits

Example
Convert (11010110)2 into octal
equivalent number

011

into

Step 1: Group the given number into 4
bits from right to left.

{

6

Example

{

0
1
2
3
4
5

Binary
Equivalent
000
001
010
011
100
101

Octal

Step 3: Convert equivalent Hexadecimal
value using "2's power positional
weight method"

{

32+16+8+0+2+1		
(111011)2		

3
2
6
(11010110)2 = (326)8
20
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Step 2.3: Multiply each digit with
its corresponding weight
Step 2.4: Add all the values which
you obtained in Step 2.3
Table 2.5 Positional notation and weight
Positional
Weight
notation
-1
2 (1/2)
0.5
-2
2 (1/4)
0.25
-3
2 (1/8)
0.125
2-4 (1/16) 0.0625
2-5 (1/32)
0.03125
-6
2 (1/64) 0.015625
2-7 (1/128) 0.0078125
Step 3: To get final answer write the
integral part (after conversion),
followed by a decimal point(.) and
the answer arrived at Step 2.4
Example
Convert the given Binary number
(11.011)2 into its decimal equivalent
Integer part (11)2 = 3 (Refer table 2.2)
21
1

20		 2-1
1

.

0

2-2
1

2. For each positional notation of the
digit write the equivalent weight.
3. Multiply each digit
corresponding weight

with

its

4. Add all the values
Example
Convert (1265)8
Decimal number

to

equivalent

Weight

512

64

8

1

Positional
Notation

83

82

81

80

Given
number

1

2

6

5

(1265)8 = 512 ×1 + 64×2 + 8×6 +1×5
= 512 + 128 + 48 + 5
(1265)8 = (693)10
2.4.10 Octal to Binary Conversion
For each Octal digit in the given
number write its 3 digits binary equivalent
using positional notation.

2-3

Example

1

Convert (6213)8
Binary number

3 + . (0×0.5 + 1×0.25 + 1×0.125)
		
= 3. 375
(11.011)2
= (3.375)10

to

equivalent

6

2

1

3

110

010

001

011

Workshop
4. Convert the given Binary number
into its equivalent Decimal, Octal and
Hexadecimal number.

(6213)8=(110010001011)2

1) 101110101 2) 1011010 3) 101011111

Workshop

2.4.9. Octal to Decimal Conversion
To convert Octal to Decimal, we
can use positional notation method.
1. Write down the Octal digits and list the
powers of 8 from right to left(Positional
Notation)

5. Convert the following Octal numbers
into Binary numbers.
(A) 472
(B) 145
(C) 347
(D) 6247
(E) 645

21
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2.4.11 
Hexadecimal
to
Decimal
Conversion
To convert Hexadecimal to Decimal
we can use positional notation method.
1. Write down the Hexadecimal digits
and list the powers of 16 from right to
left(Positional Notation)
2. For each positional notation written
for the digit, now write the equivalent
weight.
3. Multiply each digit with its
corresponding weight
4. Add all the values to get one final
value.
Example
Convert (25F)16 into its equivalent
Decimal number.
Weight

256

16

1

Positional
Notation

162

161

160

Given
number

2

Workshop
6. Convert the following Hexadecimal
numbers to Binary numbers
(A) A6
(B) BE
(C) 9BC8
(D) BC9
2.5 Binary Representation for Signed
Numbers
Computers can handle both positive
(unsigned) and negative (signed) numbers.
The simplest method to represent
negative binary numbers is called Signed
Magnitude. In signed magnitude method,
the left most bit is Most Significant Bit
(MSB), is called sign bit or parity bit.
The numbers are represented in
computers in different ways:
• Signed Magnitude representation
• 1’s Complement

5

• 2’s Complement

F(15)

2.5.1 Signed Magnitude representation

(25F)16 = 2×256 + 5×16 + 15×1
= 512 + 80 +15
		(25F)16 = (607)10

The value of the whole numbers can
be determined by the sign used before it. If
the number has ‘+’ sign or no sign it will be
considered as positive. If the number has
‘–’ sign it will be considered as negative.

2.4.12 Hexadecimal to Binary Conversion
Write 4 bits Binary equivalent
for each Hexadecimal digit for the given
number using positional notation method.
Example
Convert (8BC)16 into equivalent
Binary number
8

B

C

1000

1011

1100

Example:
+43 or 43 is a positive number
–43 is a negative number
In signed binary representation,
the left most bit is considered as sign bit.
If this bit is 0, it is a positive number and
if it 1, it is a negative number. Therefore
a signed binary number has 8 bits, only 7
bits used for storing values (magnitude)
and the 1 bit is used for sign.

(8BC)16 = (100010111100)2
22
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+43 is represented in memory as follows:
Sign bit
Magnitude (Value)
0

0

1

0

1

0

1

1

Least Significant Bit (LSB)
(‘0’ represent that the number is positive)

0

1

0

1

0

b.

Add 1 to the result to the Least
Significant Bit (LSB).
2’s Complement represent of (-24)10

-43 can be represented in memory as
follows.
Sign bit
Magnitude (Value)
1

Invert all the bits in the binary
sequence (i.e., change every 0 to1 and
every 1 to 0 ie.,1’s complement)

Example

Most Significant Bit (MSB )

1

a.

Binary equivalent of +24:
8bit format:
1’s complement:
Add 1 to LSB:
2’s complement of -24:

1

Least Significant Bit (LSB)
Most Significant Bit (MSB )

Workshop

(‘1’ represent that the number is negative)

2.5.2 1’s Complement representation

7. Write the 1’s complement number and
2’s complement number for the following
decimal numbers:
(A) 22 (B) -13 (C) -65 (D) -46

This is an easier approach to
represent signed numbers. This is for
negative numbers only i.e. the number
whose MSB is 1.

2.6 Binary Arithmetic

The steps to be followed to find 1’s
complement of a number:
Step 1:

Convert given Decimal number
into Binary

Step 2:

Check if the binary number
contains 8 bits , if less add 0 at the
left most bit, to make it as 8 bits.

Step 3:

As decimal numbers, the binary
numbers also permit computations like
addition, subtraction, multiplication and
division. The following session deals only
with binary addition and subtraction.
2.6.1 Binary Addition
The following table is useful when
adding two binary numbers.

Invert all bits (i.e. Change 1 as 0
and 0 as 1)

A
0
0
1
1

Example
Find 1’s complement for (–24)10
Given
Number

Binary
Number

1’s Compliment

(-24)10

00011000

11100111

11000
00011000
11100111
+1
11101000

B
0
1
0
1

SUM (A + B) Carry
0
1
1
0
1

In 1 + 1 = 10, is considered as sum
0 and the 1 as carry bit. This carry bit is
added with the previous position of the bit
pattern.

2.5.3 2’s Complement representation
The 2’s-complement method for
negative number is as follows:
23
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Example Add: 10112 + 10012
(Carry 		1
Bit)→
1

}

1

0

1

1

+

1

0

0

1

1

0

1

0

0

Significant Bit is 0, you must borrow from a
more significant bit that contains 1 and replace
it with 0 and 0s upto that point become 1s.
Example Substract 10010102 – 101002

10

10112 + 10012 = 101002

1
1

2310 = 0

1

1

0

0

1

0

1

0

1

0

1

0

0

1

0

1

1

0

2’s power
16 8 4
Binary Number 1 0 1
2110 = 000101012

1
0

2
0

1
1

510
2’s power
4 2
Binary Number 1 0
510 = 000001012

0

0

1

0

1

1

1

1210 = 0 0

0

0

1

1

0

0

3510 = 0 0

1

0

0

0

1

1

1
1

Step 2:
2110
1’s Compliment
2’s Compliment

2.6.2 Binary Substraction

0 0 0 1 0 1 0 1
1 1 1 0 1 0 1 0
1 1 1 0 1 0 1 1

Step 3:
Binary Addition of –21 and 5 :

The table for Binary Substraction is
as follows:
A

1

2110

Step 2: Binary addition of 23 and 12:
1

10

Step 1: Change -21 and 5 into binary form

1210

Carry Bit →

0

Example Perform binary addition for the
following: (–21)10 + (5)10

2310

2’s power
8 4 2
Binary Number 1 1 0
1210 = 000011002

10

1

Step 1: Convert 23 and 12 into binary form
2
1

1

(-)

Example Perform Binary addition for the
following: 2310 + 1210

2’s power
16 8 4
Binary Number 1 0 1
2310 = 000101112

0

Carry bit

B

Difference Borrow
(A-B)
0
0
0
0
1
0
1
0
1
1
0
0
0
1
1
1
When substracting 1 from 0, borrow
1 from the next Most Significant Bit, when
borrowing from the next Most Significant
Bit, if it is 1, replace it with 0. If the next Most

1 1 1 1

-2110

1 1 1 0 1 0 1 1

510

0 0 0 0 0 1 0 1

-1610 (Result)

1 1 1 1 0 0 0 0
Workshop

8. Perform the following binary
computations:
(A) 1010 + 1510
(B) –1210 + 510
(C) 1410 – 1210
(D) (–210) – (–610)
24
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2.7 Representing Characters in Memory

The ASCII code equivalent to
the uppercase letter ‘A’ is 65. The binary
representation of ASCII (7 bit) value is
1000001. Also 01000001 in ASCII-8 bit.

As represented in introduction,
all the input data given to the computer
should be in understandable format. In
general, 26 uppercase letters, 26 lowercase
letters, 0 to 9 digits and special characters
are used in a computer, which is called
character set. All these character set
are denoted through numbers only. All
Characters in the character set needs
a common encoding system. There
are several encoding systems used for
computer. They are
• BCD – Binary Coded Decimal
• EBCDIC – Extended Binary Coded
Decimal Interchange Code
• ASCII – American Standard Code for
Information Interchange
• Unicode
• ISCII - Indian Standard Code for
Information Interchange

2.7.3 
E xtended Binary Coded Decimal
Interchange Code (EBCDIC)
This is similar to ASCII Code with
8 bit representation. This coding system
is formulated by International Business
Machine(IBM). The coding system can
handle 256 characters. The input code
in ASCII can be converted to EBCDIC
system and vice - versa.
2.7.4 
Indian
Standard
Code
for
Information Interchange (ISCII)
ISCII is the system of handling
the character of Indian local languages.
This as a 8-bit coding system. Therefore
it can handle 256 (28) characters. This
system is formulated by the department
of Electronics in India in the year 198688 and recognized by Bureau of Indian
Standards (BIS). Now this coding system
is integrated with Unicode.

2.7.1 Binary Coded Decimal (BCD)
This encoding system is not in the
practice right now. This is 26 bit encoding
system. This can handle 26 = 64 characters
only.

2.7.5 Unicode
This coding system is used in most of
the modern computers. The popular coding
scheme after ASCII is Unicode. ASCII can
represent only 256 characters. Therefore
English and European Languages alone can
be handled by ASCII. Particularly there was
a situation, when the languages like Tamil,
Malayalam, Kannada and Telugu could
not be represented by ASCII. Hence, the
Unicode was generated to handle all the
coding system of Universal languages. This is
16 bit code and can handle 65536 characters.

2.7.2 
American Standard Code for
Information Interchange (ASCII)
This is the most popular encoding
system recognized by United States.
Most of the computers use this system.
Remember this encoding system can
handle English characters only. This can
handle 27 bit which means 128 characters.
In this system, each character has
individual number (Refer Appendix).

Unicode scheme is denoted by
hexadecimal numbers. The Unicode table
of Tamil, Malayalam, Telugu and Kannada
is shown in Table 2.6

The new edition (version) ASCII -8,
8
has 2 bits and can handle 256 characters are
represented from 0 to 255 unique numbers.
25
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Table 2.6
Unicode Table of Tamil
0B8

0B9

0BA

ஐ

0

0BB

1

$ஂ ஒ
0B82

3

0

ற

$
ு

௱

1

ல ூ
$

௲

2

௳

3

ழ

௴

4

அ க

வ

௵

5

ஆ

ஶ

இ

ஷ

0B85

0BA4

0BB6

0BB7

0B87

ஈ

ந ஸ

0BA8

0B88

9

0B99

0BA9

ஊ ச

ப

0B8A

0B9A

௨ ௸

8

௩ ௹

9

$ொ

௪ ௺

A

$ோ

௫

B

ஜ
0B9C

$ௌ

௬

C

$்

௭

D

0BCC

D

0BCD

E

0BE7

0BE8

0BEA

$ி

௯

F

0B8F

0B9F

0BAF

0BBF

0D15

0D16

0D17

0D18

0D19

0D44

0D25

൴
0D74

0D54

൵

ൕ

0D75

0D55

0D35

0D73

0D26

0D36

0D46

0D56

0D66

0D76

0D27

0D37

0D28

0D38

0D47

0D29

0D57

0D67

0D77

$ൈ ൘ ൨ ൸

0D48

0D58

0D68

0D78

൙ ൩ ൹
0D59

0D39

0D69

0D79

0D1A

0D2A

0D3A

0D4A

0D5A

0D6A

0D7A

ഋ ഛ ഫ $഻ $ോ ൛ ൫ ൻ
0D1B

0D2B

0D3B

0D4B

0D5B

0D6B

0D7B

ഌ ജ ബ $഼ $ൌ ൜ ൬ ർ
0D1C

0D2C

ഝ ഭ

0D2D

0D3C

ഽ

0D3D

0D4C

0D5C

0D6C

0D7C

$് ൝ ൭ ൽ
0D4D

0D5D

0D6D

0D7D

എ ഞ മ $ാ ൎ ൞ ൮ ൾ
0D0E

0D1E

0D2E

0D3E

0D4E

0D5E

0D6E

0D7E

ഏ ട യ $ി  ൟ ൯ ൿ
0D0F

0BEF

0D34

0D72

ഊ ച പ ഺ $ൊ ൚ ൪ ൺ

0D1D

ஏ ட ய

0D63

0D43

ഉ ങ ഩ ഹ

0BED

0BEE

0D24

ഈഘ ന സ

0D0C

0BEC

0D33

0D62

0D42

0D71

ഇ ഗ ധ ഷ $ േ $ൗ ൧ ൷

0D0B

0BEB

0D23

0D32

0D61

0D41

0D70

ആ ഖ ദ ശ $െ ൖ ൦ ൶

0D0A

0BFA

E

0BBE

0D13

0D22

0D31

0D60

0D40

അ ക ഥ വ

0D09

0BF9

௮

0BAE

0D12

0D30

ഔ ത ഴ $ൄ ൔ

0D08

0BF8

$ா

0B9E

$ൣ ൳

0D07

0BF7

எ ஞ ம
0B8E

F

0BD7

0BE9

0BCB

C

$ഃ ഓ ണ ള $ ൃ

0D06

$ை

0BC8

0BCA

B

6

0BF6

7

0BB9

0BAA

௦ ௶

0BE6

0D7

$ൢ ൲

0D05

$ே $ௗ ௧ ௷

0BC7

உ ங ன ஹ
0B89

A

0BB8

$ெ

0BC6

0D6

$ം ഒ ഢ ല $ൂ

0D20

0D21

0D14

0BF5

0D5

ൡ ൱

0BF4

0BB5

0B95

0B86

8

0BB4

0D4

ഡ റ $ു

0D03

0BF3

0D3

$ഁ
0D02

0BF2

ஔ த
0B94

7

0BC2

0D2

ൠ ൰

0D10

0D01

0BF1

0BC1

0D1

$ഀ ഐ ഠ ര $ീ
0D00

0BF0

0BB3

4

6

0BD0

0BA3

0B83

5

0BC0

ஃ ஓ ண ள
0B93

0D0

0BF

௰

0BB2

0B92

0BE

$ீ ௐ

0BB1

2

0BD

ர

0BB0

0B90

0BC

Unicode Table of Malayalam

0D1F

0D2F

0D3F

0D4F

0D5F

0D6F

0D7F
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Table 2.6
Unicode Table of Telugu
0C0
0

$ం ఒ ఢ ల $ూ

$ౢ

2

$ః ఓ ణ ళ $ృ

$ౣ

0C12

0C13

3

0C24

0C34

0C15

0C25

5

0C55

0C16

0C17

0C26

0C27

0C36

0C37

0C46

0C56

0C66

౧
0C67

0C47

0C18

0C28

ఉ ఙ

0C38

0C48

హ

0C58

0C68

ౙ ౩

8

౹

9

ఊ చ ప

$ొ ౚ ౪ ౺

A

ఋ ఛ ఫ

$ో

౫ ౻

B

ఌ జ బ

$ౌ

౬ ౼

C

౭ ౽

D

ఎ ఞ మ $ా

౮ ౾

E

ఏ ట య $ి

౯ ౿

F

0C0C

0C1A

0C1B

0C1C

0C59

0C39

0C19

0C4A

0C2A

0C4B

0C2B

0C4C

0C2C

ఝ భ ఽ $్

D

0C1D

0C0E

0C0F

0C1E

0C1F

0C2D

0C2E

0C2F

0C3D

0C3E

0C3F

0C4D

0C5A

0C69

0C6A

0C6B

0C6C

0C6D

0C6E

0C6F

0C93

0CA3

0CB3

0CC4

ಅ

ಕ

ಥ ವ

0C85

0C95

0CA5

ಆ ಖ ದ
0CA6

0CE2

$ೣ
0CE3

0CD5

ಶ $ೆ $ೖ ೦
0CB6

0CC6

0C96

ಇ

ಗ ಧ ಷ $ೇ

0C87

0C97

0CD6

0CE6

೧

0CB7

0CC7

0CE7

ಈ ಘ ನ

ಸ

$ೈ

೨

0CA8

0CB8

0CC8

0CE8

0C98

ಉ ಙ

ಹ

೩

0C99

0CB9

0CE9

ಊ ಚ ಪ
0C9A

0CAA

ಋ ಛ ಫ
0C9B

0CAB

$ೊ

೪

0CCA

0CEA

$ೋ

೫

0CCB

0CEB

ಌ ಜ ಬ $಼ $ೌ
0C9C

0CAC

0CBC

೬

0CCC

0CEC

ಝ ಭ ಽ $್
0CAD

0CBD

ಎ ಞ ಮ $ಾ
0C8E

0C9E

0CAE

0CBE

೭
0CED

0CCD

ೞ ೮
0CDE

0CEE

ಏ ಟ ಯ $ಿ

೯

0CBF

0CEF

0C8F

0C9F

0CAF

0CF2

$ೕ

0CB5

0C86

0CA7

0CF1

$ೢ ೲ

0CC3

$ೄ

0C9D

0C7F

0CE1

0CC2

ತ

0C7D

0C7E

0CB2

0CA4

0C8C

0C7C

0CA2

0C94

0C8B

0C7B

ೡ ೱ

0CC1

ಔ

0C8A

0C7A

0C92

0CF

0CE0

$ಃ ಓ ಣ ಳ $ೃ

0C89

0C79

0CB1

0CE

ೠ

0CC0

$ಂ ಒ ಢ ಲ $ೂ

0C88

0C78

0CD

ರ $ೀ
0CB0

0CA1

4

$ౕ

0CA0

0CC

ಡ ಱ $ು

0C44

0C35

0C90

0CB

0C81

0C83

0C63

ఈ ఘ న స $ై ౘ ౨ ౸

0C0B

F

0C43

0CA

$ಁ
0C82

0C62

7

0C0A

E

0C42

ఇ గ ధ ష $ే

0C09

C

0C33

0C61

6

0C08

B

0C32

0C41

0C9

ಀ ಐ ಠ
0C80

0C60

ఆ ఖ ద శ $ె $ౖ ౦
0C07

A

0C23

0C31

0C40

అ క థ వ
0C06

9

0C22

0C30

ఔ త  $ౄ
0C05

8

0C8

0C7

1

0C20

0C21

0C14

7

0C6

ౡ

4

6

0C5

డ ఱ $ు

$ఁ

0C03

5

0C4

0

0C02

3

0C3

ౠ

0C10

0C01

2

0C2

$ఀ ఐ ఠ ర $ీ
0C00

1

0C1

Unicode Table of Kannada
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Alphabets

Appendix
American Standard Code for Information Interchange (ASCII)
(Few specific characters only)

Alphabets
A
B
C
D
E
F
G
H
I
J
K
L
M
N
O
P
Q
R
S
T
U
V
W
X
Y
Z
a
b
c
d
e

Decimal
number
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
97
98
99
100
101

Binary number
(8 bit)
01000001
01000010
01000011
01000100
01000101
01000110
01000111
01001000
01001001
01001010
01001011
01001100
01001101
01001110
01001111
01010000
01010001
01010010
01010011
01010100
01010101
01010110
01010111
01011000
01011001
01011010
01100001
01100010
01100011
01100100
01100101

Octal
number
101
102
103
104
105
106
107
110
111
112
113
114
115
116
117
120
121
122
123
124
125
126
127
130
131
132
141
142
143
144
145

Hexadecimal
number
41
42
43
44
45
46
47
48
49
4A
4B
4C
4D
4E
4F
50
51
52
53
54
55
56
57
58
59
5A
61
62
63
64
65
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f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z

102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122

01100110
01100111
01101000
01101001
01101010
01101011
01101100
01101101
01101110
01101111
01110000
01110001
01110010
01110011
01110100
01110101
01110110
01110111
01111000
01111001
01111010

146
147
150
151
152
153
154
155
156
157
160
161
162
163
164
165
166
167
170
171
172

66
67
68
69
6A
6B
6C
6D
6E
6F
70
71
72
73
74
75
76
77
78
79
7A

Decimal
number
48
49
50
51
52
53
54
55
56
57

Binary number
(8 bit)
00110000
00110001
00110010
00110011
00110100
00110101
00110110
00110111
00111000
00111001

Octal
number
60
61
62
63
64
65
66
67
70
71

Hexadecimal
number
30
31
32
33
34
35
36
37
38
39

Numerals
Alphabets
0
1
2
3
4
5
6
7
8
9
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Special Characters
Special
symbols
Blank
!
"
#
$
%
&
'
(
)
*
+
,
.
/
:
;
<
=
>
?
@
[
\
]
^
_
`
{
|
}
~

Decimal
number
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
58
59
60
61
62
63
64
91
92
93
94
95
96
123
124
125
126

Binary number
(8 bit)
00100000
00100001
00100010
00100011
00100100
00100101
00100110
00100111
00101000
00101001
00101010
00101011
00101100
00101101
00101110
00101111
00111010
00111011
00111100
00111101
00111110
00111111
01000000
01011011
01011100
01011101
01011110
01011111
01100000
01111011
01111100
01111101
01111110

Octal
number
40
41
42
43
44
45
46
47
50
51
52
53
54
55
56
57
72
73
74
75
76
77
100
133
134
135
136
137
140
173
174
175
176

Hexadecimal
number
20
21
22
23
24
25
26
27
28
29
2A
2B
2C
2D
2E
2F
3A
3B
3C
3D
3E
3F
40
5B
5C
5D
5E
5F
60
7B
7C
7D
7E
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Evaluation
Part-I

8.	Which amongst this is not an Octal
nu mb e r ?
A) 645			B) 234
C) 876			D) 123

 hoose the correct answer
C
1.	
Which refers to
the number of bits
processed by a
computer’s CPU?
A) Byte		
B) Nibble
C) Word length
D) Bit
2.	
How many bytes does 1 KiloByte
contain?
A) 1000		
B) 8
C) 4			D) 1024
3.
Expansion for ASCII
A) 
American School Code for
Information
Interchange
B) 
American Standard Code for
Information
Interchange
C) All Standard Code for Information
Interchange
D) 
American Society Code for
Information
Interchange
4.
2^50 is referred as
A) Kilo		
B) Tera
C) Peta		
D) Zetta
5.	How many characters can be handled
in Binary Coded Decimal System?
A) 64			B) 255
C) 256			D) 128
6.	For 11012 the equalent Hexadecimal
equivalent is?
A) F			B) E
C) D			D) B
7.	
What is the 1’s complement of
00100110?
A) 00100110		
B) 11011001
C) 11010001		
D) 00101001

Part-II
Very Short Answers
1.
What is data?
2.
Write the 1’s complement procedure.
3.
Convert (46)10 into Binary number
4.	We cannot find 1’s complement for
(28)10. State reason.
5.	
List the encoding systems that
represents characters in memory.
Part-III
Short Answers 			
1.	What is radix of a number system?
Give example
2.
Write note on binary number system.
3.	Convert (150)10 into Binary, then
convert that Binary number to Octal
4.
Write short note on ISCII
5.	Add a) -2210+1510 b) 2010+2510
Part-IV
Explain in Detail
1.
a) 
Write the procedure to convert
fractional Decimal to Binary
b) Convert (98.46)10 to Binary
2. 	
Find 1’s Complement and 2’s
Complement for the following
Decimal
number
a) -98		
b) -135
3.
a) Add 11010102+1011012
b) Subtract 11010112 - 1110102
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Unit I

Fundamentals of Computers

CHAPTER

3

Computer Organisation
Learning Objectives
•

engineering considerations involved in
designing a computer. On the other hand,
Computer Organisation deals with the
hardware components that are transparent
to the programmer.

To
know
the
organisation
of
the
computer
components and their
interconnections.

3.2. Basics of Microprocessors
The CPU is the major component of
a computer, which performs all tasks. This
is realized by the microprocessor which
is an Integrated Circuit. Microprocessors
were first introduced in early 1970s. The
first general purpose microprocessor,
4004 was developed by Intel Inc.

• To
know
the
processors and their characteristics.
• To know the importance of memory
devices and their roles in a computer.
• To explore RAM, ROM
differentiate each of them.

and

The
microprocessor
is
a
programmable multipurpose silicon chip.
It is driven by clock pulses. It accepts input
as a binary data and after processing,
it provides the output data as per the
instructions stored in the memory. A
block diagram of a microprocessor based
system is shown in Figure 3.1.

• To know about cache memory and
how it improves the performance of
a computer
• To know the secondary devices and
their usage
• To know about the ports and
interfaces so that external devices
can be connected

Input

3.1 Introduction
Computer organisation deals with
the hardware components of a computer
system. It includes Input / Output devices,
the Central Processing Unit, storage devices
and primary memory. It is concerned with
how the various components of computer
hardware operate. It also deals with how
they are interconnected to implement
an architectural specification. The term
computer organisation looks similar to
the term computer architecture. But,
computer architecture deals with the

Microprocessor

Output

Memory

Figure 3.1 A Microprocessor - Based System
The microprocessor is made up of 3
main units. They are:
• Arithmetic and Logic unit (ALU):
To perform arithmetic and logical
instructions based on computer
instructions.
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• Control unit: To control the overall
operations of the computer through
signals.

Every microprocessor has an
internal clock that regulates the speed at
which it executes instructions. The speed
at which the microprocessor executes
instructions is called the clock speed.
Clock speed is measured in MHz (Mega
Hertz) or in GHz (Giga Hertz).

• Registers (Internal Memory): They are
used to hold the instruction and data
for the execution of the processor.

Characteristics of Microprocessors

b) Instruction Set

A Microprocessor’s performance
depends on the following characteristics:

A command which is given to
a computer to perform an operation
on data is called an instruction. Basic
set of machine level instructions that a
microprocessor is designed to execute
is called as an instruction set. This

a) Clock speed
b) Instruction set
c) Word size
a) Clock Speed

Speed Measurement
Hertz – abbreviated as Hz is the standard unit of measurement used for measuring
frequency. Since frequency is measured in cycles per second, one hertz equals one
cycle per second.
Hertz is commonly used to measure wave frequencies, such as sound waves, light waves,
and radio waves. For example, the average human ear can detect sound waves between 20 and
20,000 Hz. Sound waves close to 20 Hz have a low pitch and are called "bass" frequencies.
Sound waves above 5,000 Hz have a high pitch and are called "treble" frequencies.
While hertz can be used to measure wave frequencies, it is also used to measure the
speed of computer processors. For example, each CPU is rated at a specific clock speed. This
number indicates how many instruction cycles the processor can perform in every second.
Since modern processors can perform millions or even billions of instructions per second,
clock speeds are typically measured in megahertz or gigahertz.
instruction set carries out the following
types of operations:
• Data transfer

is called its word size. Word size
determines the amount of RAM that
can be accessed by a microprocessor.

• Arithmetic operations

3.3 Data communication between
CPU and memory

• Logical operations

The Central Processing Unit(CPU)
has a Memory Data Register (MDR) and
a Memory Address Register (MAR). The
Memory Data Register (MDR) keeps the data
which is transferred between the Memory
and the CPU. The Program Counter (PC)
is a special register in the CPU which always
keeps the address of the next instruction to be

• Control flow
• Input/output
c) Word Size
• The number of bits that can be processed
by a processor in a single instruction
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executed. The Arithmetic and Logic unit of
CPU places the address of the memory to be
fetched, into the Memory Address Register.

follows:
• 8-bit microprocessor

A bus is a collection of wires used
for communication between the internal
components of a computer.

• 16-bit microprocessor
• 32-bit microprocessor

The word in the RAM has the same
size (no. of bits) as the Memory Data
Register (MDR). If the processor is an
8-bit processor like Intel 8085, its MDR
and the word in the RAM both have 8 bits.

• 64-bit microprocessor
3.4.2 Classification of Microprocessors
based on Instruction Set
The

size of the instruction set
is
important consideration while
categorizing microprocessors.There are
two types of microprocessors based on
their instruction sets.

The read operation transfers the
data(bits) from word to Memory Data
Register. The write operation transfers the
data(bits) from Memory Data Register to
word.

•	
Reduced Instruction Set Computers
(RISC)

If 5V is applied at one end of
a wire, the other end also can
receive 5V. In the same way,
the buses are wires, and the
binary data are voltages (5V as 1 and
0V as 0), and these buses can simply
pass the data as voltages from one end
to other.

•	
Complex Instruction Set Computers
(CISC)
Examples of RISC processors are
Pentium IV, Intel P6, AMD K6 and K7.
Examples of CISC processors are Intel
386 & 486, Pentium, Pentium II and III,
and Motorola 68000.

3.4 Types of Microprocessors
Microprocessors can be classified
based on the following criteria:

3.5 Memory Devices

• The width of data that can be processed

A memory is just like a human
brain. It is used to store data and
instructions. Computer memory is the
storage space in the computer, where data
and instructions are stored. There are two
types of accessing methods to access (read
or write) the memory. They are sequential
access and random access. In sequential
access, the memory is accessed in an

• The instruction set
3.4.1 Classification of Microprocessors
based on the Data Width
Depending
on
the
data
width,
microprocessors can process instructions.
The microprocessors can be classified as
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Cache
Memory

technology they use to hold data. Dynamic
RAM being a common type needs to be
refreshed frequently. Static RAM needs
to be refreshed less often, which makes
it faster. Hence, Static RAM is more
expensive than Dynamic RAM.
3.5.3 Read Only Memory (ROM)
Read Only Memory refers to special
memory in a computer with pre-recorded
data at manufacturing time which cannot
be modified. The stored programs that start
the computer and perform diagnostics are
available in ROMs. ROM stores critical
programs such as the program that boots
the computer. Once the data has been
written onto a ROM chip, it cannot be
modified or removed and can only be
read. ROM retains its contents even when
the computer is turned off. So, ROM is
called as a non-volatile memory.
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orderly manner from starting to end. But,
in random access, any byte of memory can
be accessed directly without navigating
through previous bytes.
Different
memory devices are arranged according
to the capacity, speed and cost as shown in
Figure 3.6.

Main Memory
Hard Disk

Figure 3.6 Memory Hierarchy
3.5.1 Random-Access Memory (RAM)
The main memory is otherwise
called as Random Access Memory. This
is available in computers in the form of
Integrated Circuits (ICs). It is the place in
a computer where the Operating System,
Application Programs and the data in
current use are kept temporarily so that
they can be accessed by the computer’s
processor. The smallest unit of information
that can be stored in the memory is called
as a bit. The memory can be accessed by
a collection of 8 bits which is called as a
byte.
RAM is a volatile memory, which
means that the information stored in it is
not permanent. As soon as the power is
turned off, whatever data that resides in
RAM is lost. It allows both read and write
operations.
3.5.2 Types of RAM
There are two basic types of RAM
• Dynamic RAM (DRAM)
• Static RAM (SRAM)
These two types differ in the

3.5.3.1 Programmable Read Only Memory
(PROM)
Programmable read only memory is
also a non-volatile memory on which data
can be written only once. Once a program
has been written onto a PROM, it remains
there forever. Unlike the main memory,
PROMs retain their contents even when
the computer is turned off.
The PROM differs from ROM.
PROM is manufactured as a blank
memory, whereas a ROM is programmed
during the manufacturing process itself.
PROM programmer or a PROM burner is
used to write data to a PROM chip. The
process of programming a PROM is called
burning the PROM.
3.5.3.2 Erasable Programmable Read
Only Memory (EPROM)
Erasable Programmable Read Only
Memory is a special type of memory which
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serves as a PROM, but the content can
be erased using ultraviolet rays. EPROM
retains its contents until it is exposed to
ultraviolet light. The ultraviolet light
clears its contents, making it possible to
reprogram the memory.
An EPROM differs from a PROM,
PROM can be written only once and
cannot be erased. EPROMs are used
widely in personal computers because
they enable the manufacturer to change
the contents of the PROM to replace with
updated versions or erase the contents
before the computer is delivered.

up the memory retrieval process. Due to its
higher cost, the CPU comes with a smaller
size of cache memory compared with the size
of the main memory. Without cache memory,
every time the CPU requests the data, it has to
be fetched from the main memory which will
consume more time. The idea of introducing
a cache is that, this extremely fast memory
would store data that is frequently accessed
and if possible, the data that is closer to it.
This helps to achieve the fast response time,
Where response Time, (Access Time) refers
to how quickly the memory can respond to
a read / write request. Figure 3.8 shows the
arrangement of cache memory between the
CPU and the main memory.
Cache

CPU
Fast

Slow

Main
Memory

Figure 3.8 Cache Memory Arrangement

Figure 3.7 Erasable Programmable Read
Only Memory

3.6 Secondary Storage Devices

Most of the EPROM chips
have a transparent area at the
top surface which is covered
by stickers. If it gets removed, the
ultraviolet light in the sunlight may
erase the contents.

A computer generally has limited amount of
main memory which is expensive and volatile.
To store data and programs permanently,
secondary storage devices are used. Secondary
storage devices serve as a supportive storage
to main memory and they are non-volatile
in nature, secondary storage is also called as
Backup storage
3.6.1 Hard Disk
Hard disk is a magnetic disk on which
you can store data. The hard disk has the
stacked arrangement of disks accessed by a
pair of heads for each of the disks. The hard
disks come with a single or double sided disk.
3.6.2 Compact Disc (CD)
A CD or CD-ROM is made from 1.2
millimeters thick, polycarbonate plastic
material. A thin layer of aluminium or
gold is applied to the surface. CD data is
represented as tiny indentations known as

3.5.3.3 Electrically Erasable Programmable
Read Only Memory (EEPROM)
Electrically Erasable Programmable
Read Only Memory is a special type of
PROM that can be erased by exposing it
to an electrical charge. Like other types of
PROM, EEPROM retains its contents even
when the power is turned off. Comparing
with all other types of ROM, EEPROM is
slower in performance.
3.5.4 Cache Memory
The cache memory is a very high speed
and expensive memory, which is used to speed
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"pits", encoded in a spiral track moulded
into the top of the polycarbonate layer. The
areas between pits are known as "lands".
A motor within the CD player rotates the
disk. The capacity of an ordinary CDROM is 700MB.

players, digital cameras and mobile phones.
Flash memory oﬀers fast access times. The
time taken to read or write a character in
memory is called access time. The capacity
of the flash memories vary from 1 Gigabytes
(GB) to 2 Terabytes (TB). A sample of flash
memory is shown in Figure 3.11.

Fig 3.9 Compact Disc

Figure 3.11 Flash Memory
3.6.5 Blu-Ray Disc
Blu-Ray Disc is a high-density optical
disc similar to DVD. Blu-ray is the type
of disc used for PlayStation games and for
playing High-Definition (HD) movies. A
double-layer Blu-Ray disc can store up to
50GB (gigabytes) of data. DVD uses a red
laser to read and write data. But, Blu-ray uses
a blue-violet laser to write. Hence, it is called
as Blu-Ray.

3.6.3 Digital Versatile Disc (DVD)
A DVD (Digital Versatile Disc or
Digital Video Disc) is an optical disc capable
of storing up to 4.7 GB of data, more than six
times what a CD can hold. DVDs are often
used to store movies at a better quality. Like
CDs, DVDs are read with a laser.
The disc can have one or two sides,
and one or two layers of data per side; the
number of sides and layers determines how
much it can hold. Double-layered sides are
usually gold-coloured, while single-layered
sides are usually silver-coloured, like a CD.

Fig 3.12 Blu- Ray Disc

Fig 3.10 Digital Versatile Disc
3.6.4 Flash Memory Devices
Flash memory is an electronic
(solid-state) non-volatile computer storage
medium that can be electrically erased and
reprogrammed. They are either EEPROM or
EPROM. Examples for Flash memories are
pendrives, memory cards etc. Flash memories
can be used in personal computers, Personal
Digital Assistants (PDA), digital audio

3.7 Ports and Interfaces
The Motherboard of a computer
has many I/O sockets that are connected
to the ports and interfaces found on the
rear side of a computer (Figure 3.13). The
external devices can be connected to the
ports and interfaces. The various types of
ports are given below:
37

Chapter 3 Page 051-063.indd 37

3/20/2020 10:51:01 AM

Serial Port: To connect the external
devices, found in old computers.

USB Port
Network Port
Mouse Port

Parallel Port: To connect the printers,
found in old computers.
USB Ports: To connect external devices
like cameras, scanners, mobile phones,
external hard disks and printers to the
computer.

VGA
Port

Serial
Port

Power Supply

Keyboard Port
HDMI Port

USB 3.0 is the third major version of the
Universal Serial Bus (USB) standard to
connect computers with other electronic
gadgets as shown in Figure 3.13. USB 3.0
can transfer data up to 5 Giga byte/second.
USB3.1 and USB 3.2 are also released.

Fig 3.14 Ports and Interfaces
High Definition Multimedia Interface
(HDMI)
High-Definition
Multimedia
Interface is an audio/video interface
which transfers the uncompressed video
and audio data from a video controller,
to a compatible computer monitor, LCD
projector, digital television etc.

Micro HDMI

HDMI

Figure 3.15 HDMI Ports

Figure 3.13 USB 3.0 Ports

Activity
VGA Connector: To connect a monitor or
any display device like LCD projector.

Student Activity
• Identify the components of a computer

Audio Plugs: To connect sound speakers,
microphone and headphones.

• Connecting external
printer/LCD projector.

PS/2 Port: To connect mouse and
keyboard to PC.

devices

like

Teacher Activity
• Show the components of a computer

SCSI Port: To connect the hard disk
drives and network connectors.

• Display different ROM ICs
• Display the flash memory
• Demonstrate various ports and their
usage
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Evaluation
7.

Part – I

Choose the correct answer
1.

2.

Which of the following is sadi to be
the brain of a computer?
(a) Input devices
(b) Output devices
(c) Memory device
(d) Microprocessor
Which of the following is not the
part of a microprocessor unit?
(a) ALU

8.

(b) Control unit

9.

(c) Cache memory (d) register
3.

(c) 256 		

(d) 8000

What is the capacity of 12cm
diameter DVD with single sided
and single layer?
(a) 4.7 GB 		

(b) 5.5 GB

(c) 7.8GB		

(d) 2.2 GB

What is the smallest size of data
represented in a CD?
(b) sectors

(a) 8

(c) pits 		

(d) tracks

10.

(d) 
determined by the processor
used.
Which of the following device
identifies the location when address
is placed in the memory address
register?
(a) Locator		
(b) encoder
(c) decoder		

6.

(b) 1024

(a) blocks		

(c) 32

5.

(a) 28 			

How many bits constitute a word?
(b) 16

4.

How many memory locations are
identified by a processor with 8 bits
address bus at a time?

Display devices are connected to
the computer through.
(a) USB port		

(b) Ps/2 port

(c) SCSI port		

(d) VGA
connector

Part – II
Very Short Answers
(1)	
What are the parameters which
influence the characteristics of a
microprocessor?

(d) multiplexer

Which of the following is a CISC
processor?

(2)

What is an instruction?

(a) Intel P6 		

(b) AMD K6

(3)

What is a program counter?

(c) Pentium III

(d) Pentium IV

(4)

What is HDMI?

(5)	Which source is used to erase the
content of a EPROM?

Which is the fastest memory?
(a) Hard disk

Part-III

(b) Main memory

Short Answers
(1)	Differentiate
Organisation
Architecture.

(c) Cache memory
(d) Blue-Ray disc

from

Computer
Computer
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Part-IV

(2)	Classify the microprocessor based
on the size of the data.

Explain in Detail

(3)	
Write down the classifications
of microprocessors based on the
instruction set.
(4)

(1)
Explain the characteristics of a
microprocessor.
(2)
How the read and write operations
are performed by a processor? Explain.

Differentiate PROM and EPROM.

(5)	Write down the interfaces and ports
available in a computer.
(6)

(3)
Arrange the memory devices in
ascending order based on the access time.

Differentiate CD and DVD

(4)

(7)	How will you differentiate a flash
memory and an EEPROM?

Computer
hardware

Explain the types of ROM.

Multipurpose

The physical parts or components of a computer, such as the CPU,
mother board, monitor, keyboard, etc.
Intel Corporation is an American multinational corporation
and technology company involving in hardware manufacturing,
especially mother board and processors
Silicon chip is an integrated , set of electronic circuits on one small
flat piece of semiconductor material, silicon.
Multipurpose is several purpose

Address bus

Address bus is a collection of wires that carry the address as bits

Data bus

Data bus is a collection of wires to carry data in bits

Intel
Silicon chip

Control bus
Arithmetic
operations
Data Transfer
Logical
operations

Control bus is a control line/collection of wires to control the
operations/functions
Arithmetic operations are the mathematical operations on data like
add, subtract etc

Bidirectional

Data Transfer means moving data from one component to another
Logical operations are the operations on binary/Boolean data like
AND, OR , NOT
Bidirectional means both the directions/ways

Unidirectional

Unidirectional means only one direction

Access time

Access time is the time delay or latency between a request to an
electronic system, and the access being completed or the requested
data returned
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Unit I

Fundamentals of Computers

CHAPTER

4

Theoretical concepts of Operating System
Learning objectives

This controls input, output and
other peripheral devices such as disk
drives, printers and electronic gadgets.
The functions of an Operating System
include file management, memory
management, process management and
device management and many more.

 To know the concept of Operating
Systems and their types.
 To acquire the basic Knowledge of
Operating Systems and its functions.

4.1 Introduction to Software

A software is set of instructions that
perform specific task. It interacts basically with
the hardware to generate the desired output.
4.1.1 Types of Software
Software is classified into two types:
1)

Application Software

2)

System Software

Monitor

Hard drive
APPS
Operating
System

Application Software:
Application software
is a set of programs to
perform specific task.
For example MS-word is an application
software to create text document and VLC
player is familiar application software to
play audio, video files and many more.
System Software:
System software is a type of
computer program that is designed to run
the computer’s hardware and application
programs. Example Operating System and
Language Processor

Printer

Mo
use

Keyboard

Figure: 4.1 Operating System
Without an Operating System, a
computer cannot eﬀectively manage all the
resources. When a computer is switched
on, the operating system is loaded in to the
memory automatically.

4.2 Introduction to Operating
System (OS)

Some of the popular Operating
Systems used in personal computers and
laptops are Windows, UNIX and Linux.
The mobile devices mostly use Android
and ioS as mobile OS.

An Operating System (OS) is
a system software which serves as an
interface between a user and a computer.
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4.3.2 Multi-user Operating Systems

Application
Software

.

User

Hardware

4.4 Key features of the Operating
System

Figure: 4.2 Interaction of Operating system
and user

Uses of Operating Systems

The various key features are given below

The following are few uses of Operating
System

User
ace
Interf

The main use of Operating System is
S
Ma ecur
nag ity
em
ent

 to ensure that a computer can be used
to extract what the user wants it do.

ess t
oc men
r
P ge
a
an
M

 Starting
computer
operation
automatically when power is turned
on (Booting).
 Controlling Input and Output Devices
 Manage the utilisation of
memory.

main

Memory
Management

 Easy interaction between the users
and computers.

Key
Features of
Operating
System

M
an File
ag
em
en
t

t
Faul ce
ran
Tole

Operating
System

It is used in computers and laptops
that allow same data and applications to
be accessed by multiple users at the same
time. The users can also communicate with
each other. Windows, Linux and UNIX
are examples for multi-user Operating
System.

Figure: 4.3 Key Features of the Operating
System

 Providing security to user programs.

4.3 Types of Operating System

4.4.1 User Interface (UI)

Operating System are classified into
the following types depending on their
processing capabilities.

User interface is one of the
significant feature in Operating System.
The only way that user can make
interaction with a computer. This is a main
reason for key success of GUI (Graphical
User Interface) based Operating System.
The GUI is a window based system with a
pointing device to direct I/O, choose from
menus, make selections and a keyboard
to enter text.Its vibrant colours attract the
user very easily.

4.3.1 Single User Operating Systems
An operating system allows only a
single user to perform a task at a time. It
is called as a Single user and single Task
operating system.MS-DOS is an example
for a single user and single task Operating
System.
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Now Linux distribution is also
available as GUI based Operating System.
The following points are considered
when User Interface is designed for an
application.
1. The user interface should enable the
user to retain this expertise for a
longer time.
2. The user interface should also satisfy
the customer based on their needs.

•

Keeping track of which portion of
memory are currently being used and
who is using them.

•

Determining which processes (or
parts of processes) and data to move
in and out of memory.

•

Allocation and de-allocation of
memory blocks as needed by the
program in main memory. (Garbage
Collection)

4.4.3 Process management

3.The user interface should save user’s
precious time.

Process management is function
that includes creating and deleting
processes(program)
and
providing
mechanisms for processes to communicate
and synchronize with each other.

4. The ultimate aim of any product is to
satisfy the customer. The User Interface
is also to satisfy the customer.
5. The user interface should reduce number
of errors committed by the user

. A system task, such as sending
output to a printer or screen, can also be
called as a Process.

4.4.2 Memory Management
Memory Management is the
process of controlling and coordinating
computer’s main memory and assigning
memory block (space) to various running
programs to optimize overall computer
performance. The Memory management
involves the allocation of specific memory
blocks to individual programs based on
user demands.

A computer consists of a collection
of processes, they are classified as two
categories:
•

Operating System processes which is
executed by system code

•

User Processes which is execute by
user code

All these processes can potentially
execute concurrently on a single CPU.

The
objective
of
Memory
Management process is to improve both
the utilization of the CPU and the speed
of the computer’s response to its users
via main memory. For these reasons the
computers must keep several programs in
main memory that associates with many
different Memory Management schemes.

The following algorithms are
mainly used to allocate the job (process)
to the processor.
1. FIFO

2. SJF

3. Round Robin

4. Based on Priority
FIFO (First In First Out)Scheduling

The Operating System is responsible
for the following activities in connection
with memory management:

This algorithm is based on queuing
technique. Assume that a student is
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standing in a queue (Row) to get grade
sheet from his/her teacher. The other
student who stands first in the queue gets
his/her grade sheet first and leaves from
the queue (Row). Followed by the next
student in the queue gets it corrected and
so on. This is the basic logic of the FIFO
algorithm.

Job B is assigned to the processor
before job A.
4.4.4 Security Management
The major challenge in computer
and software industry is to protect
user’s legitimate data from hackers. The
Operating System provides three levels of
securities to the user end. They are

Technically, the process that enters
the queue first is executed first by the
CPU, followed by the next and so on. The
processes are executed in the order of the
queue (row).

(1) File access level
(2) System level

SJF (Shortest Job First)Scheduling

(3) Network level

This algorithm works based on the
size of the job being executed by the CPU.

In order to access the files created
by other people, you should have the
access permission. Permissions can either
be granted by the creator of the file or
bythe administrator of the system.

Consider two jobs A and B.
1) A = 6 kilo bytes

2) B = 9 kilo bytes

First the job “A” will be assigned
and then job “B” gets its turn.

System level security is offered by
the password in a multi-user environment.

Round RobinScheduling

Both windows and Linux offer the
password facility.

The Round Robin (RR) scheduling
algorithm is designed especially for time
sharing systems. Jobs (processes) are
assigned and processor time in a circular
method. For example take three jobs A, B,
C. First the job A is assigned to CPU then
job B and job C and then again A, B and C
and so on.

Network security is an indefinable
one. So people from all over the world try
to provide such a security.
All the above levels of security
features are provided only by the Operating
System.
4.4.5 Fault Tolerance

Based On Priority

The Operating Systems should be
robust. When there is a fault, the Operating
System should not crash, instead the
Operating System have fault tolerance
capabilities and retain the existing state of
system.

The given job (process) is assigned
based on a Priority. The job which has
higher priority is more important than
other jobs. Take two jobs A and B. Let the
priority of A be 5 and priority B be 7.
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4.4.6 File Management

respectively. If the process P1 completes
within 20 minutes then processor takes
the next process P2 for the execution. If
the process P2 could not complete within
40 minutes, then the current process P2
will be paused and switch over to the next
process P3.

File management is an important
function of OS which handles the data
storage techniques. The operating
System manages the files, folders and
directory systems on a computer.The
FAT(File Allocation Table) stores general
information about files like filename, type
(text or binary), size, starting address
and access mode.The file manager of the
operating system helps to create, edit,
copy, allocate memory to the files and
also updates the FAT. There are few other
file management techniques available like
Next Generation File System (NTFS) and
ext2(Linux).

4.4.9 Distributed Operating Systems
The Distributed Operating System
is used to access shared data and files
that reside in any machine around the
world using internet/intranet.The users
can access as if it is available on their own
computer.
The advantages of distributed
Operating System are as follows:

4.4.7 Multi-Processing
This is a one of the features of
Operating System. It has two or more
processors for a single running process
(job). Processing takes place in parallel
is known as parallel processing.Since
the execution takes place in parallel, this
feature is used for high speed execution
which increases the power of computing.
4.4.8 Time-sharing

•

A user at one location can make use of
all the resources available at another
location over the network.

•

Many computer resources can be
added easily in the network

•

Improves the interaction with the
customers and clients.

•

Reduces the load on the host computer.

This is a one of the features of
Operating Systems. It allows execution of
multiple tasks or processes concurrently.
For each task a fixed time is allocated. This
division of time is called Time- sharing.
The processor switches rapidly between
various processes after a time is elapsed or
the process is completed.
For example assume that there are
three processes called P1, P2, P3 and time
allocated for each process 30, 40, 50 minutes

Figure: 4.4 Distributed Operating Systems
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4.5 Prominent Operating Systems

Evaluation

Prominent OS are as follows:

Part – I

• UNIX

Choose the correct answer

• Microsoft Windows

1)

• Linux
• iOS
• Android
Modern operating systems use a
Graphical User Interface(GUI). A GUI lets
use to your mouse to click icons, buttons,
menus and everything, is clearly displayed
on the screen using a combination of
graphics and text elements.

2)

Operating system is a
A)Application
Software
B) Hardware
C)System Software
D)Component
Identify the usage of
Operating Systems
A) Easy interaction between the
human and computer

Student Activity

B) Controlling
Devices

Activity 1: Draw a line between the
operating system logo and the correct
description.

input

&

output

C) Managing use of main memory
D) All the above

A command-line operating
system is an example of Open
Source software development
and Free Operating System
A popular Operating System
for mobile phone technology
which is not linked with
Apple products.

3)

4)

Used with Apple computers
and works well with cloud
computing.
Designed to be used for the
Apple iPhone

5)

Is an Operating System that is
very popular in universities,
companies, big enterprises etc

6)

The most popular GUI
Operating System for personal
computers.

Which of the following is not a
function of an Operating System?
A)Process Management
B)Memory Management
C)Security management
D)Complier Environment
Which of the following OS is a
Commercially licensed Operating
system?
A)Windows

B)UBUNTU

C)FEDORA

D)REDHAT

Which of the following Operating
systems support Mobile Devices?
A)Windows 7

B)Linux

C)BOSS

D)iOS

File Management manages
A) Files
B) Folders
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		 C) Directory systems

Part-III

		 D) All the Above
7)		
Interactive
provides

Operating

Short Answers
1) What are the advantages and
disadvantages
of
Time-sharing
features?

System

		 A)Graphics User Interface (GUI)
		 B)Data Distribution

2) List out the key features of Operating
system

		 C)Security Management

3) Write a note on Multiprocessing

		 D)Real Time Processing

Part-IV
Explain in Detail
1) Explain the concept of a Distributed
Operating System along with its
advantages.

8) An example for single task operating
system is
		A)Linux
		 B) Windows
		 D) Unix

2) List out the points to be noted while
creating a user interface for an
Operating system.

9)		The File management system used
by Linux is

3) Explain the process manangement
algorithms in Operating System.

		C)MS-DOS

		 A) ext2
		 B) NTFS

References

		 C) FAT

1) Silberschatz, galvin gagne, Operating
System concepts – john wiley&sons,inc
2) Andrew s. Tanenbaum, modern
Operating Systems – pearson
publication
3) Andrew s. Tanenbaum , Operating
Systems design and implementation,
prentice 		
hall publication
4) Tom anderson, Operating Systems:
principles and practice, recursive
books
5) Thomas w. Doeppner, Operating
Systems in depth: design and
programming, john wiley & sons, inc

		 D) NFTS
Part – II
Very Short Answers
1) List out any two uses of Operating
System?
2) What is multi-user Operating System?
3) What is a GUI?
4) What are the security management
features available in Operating System ?
5) What is multi-processing?
6) What are the different Operating
Systems used in computer?
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Unit I

Fundamentals of Computers

CHAPTER

5

Working with Windows Operating
System
Learning Objectives
After learning the concepts in this
chapter, the students will be able
• To know the concepts of Operating
Sy ste m .
• To know the versions of the windows
operating system.
• To know the concepts like desktop
and the elements of window.
• To explore the document window.
• To compare the different types of icons.
• To explore the windows directory
structure.
• To practice creating files and folders
in specific drives.
• To manage the files
and
folders.
• To know the procedure
to start and shutdown
the computer.

•

Memory Management

•

Process Management

•

Device Management

•

File Management

•

Security Management

•

Control overall system performance
User 1

Software

User 2

User n

System
Softwares

Application
Softwares

Operating System
Hardware

CPU

RAM

I/O

Figure 5.1. Overview of an Operating
System
5.2. Introduction to Windows Operating
System
Every computer needs an Operating
System to function. Microsoft Windows is
one of the most popular Graphical User
Interface (GUI). Multiple applications can
execute simultaneously in Windows, and
this is known as “Multitasking”.

5.1. Introduction to
Operating
System
An Operating System (OS) is
a system software (Figure 5.1) that
enables the hardware to communicate
and operate with other software. It also
acts as an interface between the user and
the hardware and controls the overall
execution of the computer.

Windows Operating System uses
both Keyboard and mouse as input
devices. Mouse is used to interact with
Windows by clicking its icons. Keyboard
is used to enter alphabets, numerals and
special characters.

Following are some of the important
functions of an Operating System as
discussed in the previous chapter:
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Some of the functions of Windows
Operating System are:
• Access applications (programs) on the
computer (word processing, games,
spread sheets, calculators and so on).
• Load any new program on the computer.
• Manage hardware such as printers,
scanners, mouse, digital cameras etc.,
• File management activities (For
example creating, modifying, saving,
deleting files and folders).

•

Change computer settings such as
colour scheme, screen savers of your
monitor, etc.

With reference to the Table 5.1, let us see the
versions of Windows Operating System.
5.4. Handling the mouse
Before learning Window Operating System,
you should know more about mouse and its
actions.

5.3. Various versions of Windows
Versions

Logo

Year

Specific features

• Introduction of GUI in 16 - bit. processor
• Mouse was introduced as an input device.

Windows
1.x

1985

Windows
2.x

• Supports to minimize or maximize windows.
1987 • Control panel feature was introduced with various
system settings and customising options.

Windows
3.x

• Introduced the concept of multitasking.
1992 • Supported 256 colours which brought a more modern,
colourful look to the interface.

Windows
95

Windows
98

• Introduced Start button, the taskbar, Windows Explorer
and Start menu.
1995
• Introduced 32 - bit processor and focused more on
multitasking.
• Integration of the Web browser (Internet Explorer) with
the Operating System.
1998 • DOS gaming began to disappear as Windows based
games improved.
• Plug and play feature was introduced.

Windows
NT
Windows
Me

• Designed to act as servers in network.
2000

• It introduced automated system
recovery tools.

diagnostics and
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Windows
2000

• Served as an Operating System for business desktop and
laptop systems.
• Four versions of Windows 2000 were released: Professional
2000 (for business desktop and laptop systems), Server (both a
Web server and an office server), Advanced Server (for
line-of-business applications) and Data Centre Server
(for high-traffic computer networks).

Windows
XP

• Introduced 64-bit Processor.
2001 • Improved Windows appearance with themes and
offered a stable version.

Windows
Vista

2006 • Updated the look and feel of Windows.

Windows
7

Windows
8

Windows
10

• Booting time was improved, introduced new user
2009 interfaces like Aero Peek, pinning programs to taskbar,
handwriting recognition etc. and Internet Explorer 8.
• Windows 8 is faster than previous versions of Windows.
• Start button was removed.
• Windows 8 takes better advantage of multi-core
2012
processing, solid state drives (SSD), touch screens and
other alternate input methods.
• Served as common platform for mobile and computer.
• Start Button was added again.
• Multiple desktop.
2015 • Central Notification Center for App notification and
quick actions.
• Cortana voice activated personal assistant.
Table 5.1 Versions of Windows Operating System.
The following are the mouse actions:
Right Click
Action

Reaction

Point to Move the mouse pointer over the
an item item.
Point to the item on the screen,
press and release the left mouse
button.
Point to the item on the screen,
press and release the right mouse
Right
button. Clicking the right mouse
click
button displays a pop up menu
with various options.
Point to the item on the screen,
Doublequickly press twice the left mouse
click
button.
Click

Left Click

Figure 5.2.Mouse actions
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files, folders, shortcuts etc., Icons play a
vital role in GUI based applications.

Point to an item then hold the left
mouse button as you move the
Drag and
pointer press and you have reached
drop
the desired position, release the
mouse button.

5.5.1.1.Standard Icons
The icons which are available
on desktop by default while installing
Windows OS are called standard icons. The
standard icons available in all Windows
OS are My Computer, Documents and
Recycle Bin.

5.5. Windows Desktop
The opening screen of Windows is
called
“Desktop”.
The desktop of your computer may
look different from what is seen in Figure 5.3.
This is because Windows allows you
to change the appearance of the desktop.
In Figure 5.3, the desktop shows
the Start button, Taskbar, Notification
Area and date and time.

Aero peek button
Figure 5.4. Aero peek button
5.5.1.2. Shortcut Icons:
Shortcut icons can be created for
any application or file or folder. By double
clicking the icon, the related application
or file or folder will open.

Gadgets

Icons

(Figure5.5)
Application Icon

Task bar

Start Button
Notification Area
Figure 5.3. Microsoft Windows 7 Desktop
Folder Icon

5.5.1. The Icons
Icon is a graphic symbol
representing the window elements like

Figure 5.5.The types of Icons

Various Disk drive
icons

Hard disk drives with
total and remaining
space available

Removable Storage (pen drive)
Figure 5.6.Disk drive Icons
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5.5.1.3. Disk drive icons:

Note

The disk drive icons graphically
represent five disk drive options. (i) Hard
disk (ii) CD-ROM/DVD Drive (iii) Pen
drive (iv) Other removable storage such
as mobile, smart phone, tablet etc., (v)
Network drives if your system is connected
with other system.

When
you
open
any
application, such as OpenOffice Writer,
OpenOffice Impress or OpenOffice Calc
etc., you will find two Windows on the
screen. The larger Window is called
the Application Window. This Window
helps the user to communicate with
the Application program. The smaller
window, which is inside the Application
Window, is called the Document
window. This Window is used for typing,
editing, drawing, and formatting the text
and graphics.

You can move to the Desktop
any time by pressing the Winkey
+ D or using Aero Peek while
working in any application.
You can see Figure 5.4 to know where
Aero peek lies in the Taskbar.

Title bar with title of the document

5.6. The Window

5.7. Application Window

Menu bar

It is an area on a computer screen
with defined boundaries, and within which
information is displayed. Such windows
can be resized, maximised, minimised,
placed side by side, overlap, and so on.

t i on
Applica

An Application Window contains
an open application i.e. current application
such as Word or Paint. When two or more
windows are opened, only one of them is
active and the rest are inactive. Figures 5.6
and 5.7 display the Application Window
of OpenOffice Writer and the appearance
of the Multiple Windows opened
(overlapped) in the Desktop.

Tools bar

re a
w or k a
Scroll bars

Window Control buttons

Window is a typical rectangular area
in an application or a document. It is an area
on the screen that displays information for a
specific program.

Figure 5.6. Application Window

5.8. Document Window
A document window is a section of
the screen used to display the contents of
a document. Figure 5.8 is an example of a
document window.

Figure 5.7. Multiple Windows
opened in Desktop
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In Windows 7, in the absence of the
menu bar, click Organise and from the
drop down menu, click the Layout option
and select the desired item from that list.

Application Window
Document window
Ruler
Document Area

Figure 5.8.Document Window
5.9. Elements of a window
Figure 5.9 helps to understand the
elements of a window.

Figure 5.10. To display Menu Bar

5.9.1. Title Bar – The title bar will display
the name of the application and the name
of the document opened. It will also contain
minimize, maximize and close button.
Corners

Borders

Title Bar

Figure 5.10 helps to understand how to
make menu bar visible in its absence.
5.9.3. The Workspace
The workspace is the area in the
document window to enter or type the text
of your document. Figure 5.10 Shows the
workspace area in the document window.

Corners

Menu Bar

Borders

5.9.4. Scroll bars - The scroll bars are used
to scroll the workspace horizontally or
vertically. Figure 5.9 shows the Scroll bars.

Scroll Bar

5.9.5. Corners and borders
Workspace

Corners

Borders

The corners and borders of the window
helps to drag and resize the windows. The
mouse pointer changes to a double headed
arrow when positioned over a border or a
corner. Drag the border or corner in the
direction indicated by the double headed
arrow to the desired size as shown in Figure
5.9. The window canbe resized by dragging
the corners diagonally across the screen.

Corners

Figure 5.9 The elements of a window.
5.9.2 Menu Bar
The menu bar is seen under the title bar.
Menus in the menu bar can be accessed by
pressing Alt key and the letter that appears
underlined in the menu title. Additionally,
pressing Alt or F10 brings the focus on the
first menu of the menu bar.
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5.10.1. Start Menu
In the lower left-hand corner of the windows screen is the Start button. When you
click on the button, the Start menu will appear. Using the start menu, you can start any
application.
This symbol
indicates
Sub menu is
attached to this
option
Modify system
Settings
View a list of
installed
Programs

Add / Modify
devices and
Printer settings
Get Help

Search Box
Log off / Restart /
Shutdown

Start
Button
Figure 5.11 - Start Menu
Taskbar

At the bottom of the screen is a horizontal bar called the taskbar. This bar contains
(from left to right) the Start button, shortcuts to various programs, minimised programs
and in the extreme right corner you can see the system tray which consist of volume
control, network, date and time etc. Next to the Start button is the quick Launch Toolbar
which contains task for frequently used applications.
5.10.2. Computer Icon
By clicking this icon, the user can see the disk drivers mounted in the system. In
windows XP, Vista, this icon is called "My computer" in Windows 8 and 10, it is called "This
PC". The functionality of computer icon remains the same in all versions of windows as shown
in Figure 5.13.
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Start Button

Minimised program /
Folders
show
hidden icons

Network
icon

Default
Language

Figure 5.12.Taskbar

Volume
Adjustment

Aero peek
Time and button
Date

Figure 5.13. Computer icon in versions of Windows OS
5.10.3. Starting and Closing Applications

3. You can also open an application by
clicking Run on the Start menu, and the
name of the application. (Figure 5.15)

Most of the applications installed
on your computer are available through
the start menu. Depending on the system
setup, the applications in the Start menu
varies. To start an application:
1. Click the Start
button and then
point
to
All
Programs.
The
Program menu
appears.(Figure
5.14)

Figure 5.15.Starting a program using Run
option
4. To quit an application, click the Close
button in the upper right corner of the
application window. (Figure 5.16)
Workshop

2. Point to the group
that contains the
application you
want to start, and
then click the Figure 5. 14.Starting
application name. a applicatioin using
Start menu

1. 
Start the application Wordpad
using Start menu and Run option.

Close the Wordpad application
using File menu.
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There are two ways in which you can
create a new folder:

Close button

Method I:
Step 1: Open Computer Icon.
Step 2: Open any drive where you want to
create a new folder. (For example
select D:)
Step 3: Click on File → New → Folder.
Step 4: A new folder is created with the
default name “New folder”. (Figure
5.19)
Step 5: Type in the folder name and press
Enter key. (Figure 5.20 shows the
newly created Folder named “Test
Folder ").

Exit Option

Figure 5.16. Closing the application using
Close button and Exit option
5. You can also quit an application by
clicking on File → Exit and File → Close
option in Windows 7. (Figure 5.16)
5.11. Managing Files and Folders
In Windows 7, you can Organise
your documents and programs in the
form of files and folders. You can move,
copy, rename, delete and search the files
and folders.
5.11.1. Creating files and Folders
5.11.1.1 Creating Folders
You can store your files in many
locations – on the hard disk or in other
devices. To better organise your files, you
can store them in folders.

Figure 5.17. Creating a Folder using File
menu

Figure 5.18. New Folder created with the default name
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Figure 5.19. Renaming the new Folder
Method II:
In order to create a folder in the
desktop:
Step 1: In the Desktop, right click → New
→ Folder. (Figure 5.20 Shown the
procedure)
Step 2: A Folder appears with the default
name “New folder” and it will be
highlighted as shown in the Figure
5.22.
Step 3: Type the name you want and press
Enter Key.

2.

Type the contents in the workspace
and save the file using File → Save or
Ctrl + S.

3.

Save As dialog box will be opened.

4.

In the dialog box, select the location
where you want to save the file by
using look in drop down list box.

5.

Type the name of the file in the file
name text box.

6.

Click save button.

Step 4: The name of the folder will change.
Workshop
2. Create a Folder in My Documents
with your name using any one of the
methods discussed.
5.11.1.2 Creating Files (Wordpad)
Wordpad is an in-built word processor
application in Windows OS to create and
manipulate text documents.
In order to create files in wordpad
you need to follow the steps given below.
1.

Figure 5.20. Creating a folder
in the desktop

Click Start → All Programs →
Accessories → Wordpad or Run →
type Wordpad, click OK. Wordpad
window will be opened as shown in
Figure 5.22.

Workshop
3. Open the Wordpad application and
save it under a folder created with
your name in My Documents.
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click that file, it will directly open
that file or the folder.

Figure 5.22. Wordpad - Word Processor
application
4.

There is another option called “See
more results” which appears above
the search box.

5.

If you click it, it will lead you to a
Search Results dialog box where you
can click and open that file or the
folder.

Searching Files or folders using
Computer icon
1. Click Computer Icon from desktop or
from Start menu.

Figure 5.21 New folder icon on the dektop
5.11.2. Finding Files and Folders

2. The Computer disk drive screen will
appear and at the
top right corner of
that screen, there
is a search box
option. (Figure
5.24)

You can use the search box on the
Start menu to quickly search a particular
folder or file in the computer or in a
specific drive.
To find a file or folder:
1.

Click the Start button, the search
box appears at the bottom of the
start menu.

2.

Type the name of the file or the
folder you want to search. Even if
you give the part of the file or folder
name, it will display the list of files
or folders starting with the specified
name. (Figure 5.23)

3.

The files or the folders with the
specified names will appear, if you

3. Type the name
of the file or the
folder you want
to search. Even
if you give the
part of the file or
folder name, it
will display the list
of files or folders Figure 5.23. Finding
starting with the a File/Folder using
specified name.
Start button
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Figure 5.24. Finding a File/Folder in the Computer icon screen
4. Just click and open that file or the
folder.
Workshop

or folders. You can rename using the File
menu, left mouse button or right mouse
button.
Method 1

4. Find the file created in Workshop-3
using the above procedure

Using the FILE Menu
1. Select the File or Folder you wish to
Rename.

5.11.3. Opening existing Files or Folders
The most common way of opening a file
or a Folder is to double click on it.

2. Click File→ Rename.
3. Type in the new name.

5.11.4. Renaming Files or Folders

4. To finalise the renaming operation,
press Enter as in Figure 5.25.

There are number of ways to rename files

Figure 5.26.Folder renamed
Figure 5.26, you can see that the folder is
renamed as SCERT-DPI from SCERT.
Method 2
Using the Right Mouse Button
1. Select the file or folder you wish to
rename.
2. Click the right mouse button over the
file or folder. (Figure 5.27)

Figure 5.25. Renaming File/Folders using
the File menu

3. Select Rename from the pop-up menu.
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4. Type in the new name.

2. Press F2 or click over the file or folder.
A surrounding rectangle will appear
around the name.

5. To finalise the renaming operation,
press Enter.

3. Type in the new name.

6. Figure 5.29. Shows that the folder "New
Folder" is renamed as C++.

4. To finalise the renaming operation,
press Enter.
Workshop
5. Rename the file created by you using
the File menu, left mouse button or
right mouse button.
5.11.5. Moving/Copying
Folders

Files

and

You can move your files or folders to other
areas using variety of methods.
Moving Files and Folders
Method I-CUT and PASTE
To move a file or folder, first select the
file or folder and then choose one of
the following:
• Click on the Edit → Cut or Ctrl + X
Or right click → cut from the pop-up
menu.
• To move the file(s) or folder(s) in the
new location, navigate to the new
location and paste it using Click Edit
→ Paste from edit menu or Ctrl + V
using keyboard.

Figure 5.27. Renaming File/Folders using
the Right Mouse Button

• Or Right click → Paste from the popup menu. The file will be pasted in the
new location.
Method II – Drag and Drop
In the disk drive window, we have two
panes called left and right panes. In
the left pane, the files or folders are
displayed like a tree structure. In the
right pane, the files inside the specific
folders in the left pane are displayed
with various options.

Figure 5.28. New Folder is renamed as C++
Method 3
Using the Left Mouse Button
1. Select the file or folder you wish to rename.
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• In the right pane of the Disk drive
window, select the file or folder you
want to move.

• To paste the file(s) or folder(s) in the
new location, navigate to the target
location then do one of the following:

• Click and drag the selected file or folder
from the right pane, to the folder list
on the left pane.

• Click Edit → Paste or Ctrl + V.
• Or Right click → Paste from the
pop-up menu.

• Release the mouse button when the
target folder is highlighted (active).

Method II – Drag and Drop

• Your file or folder will now appear in
the new area. Figrue 5.29 shows how
to move files or folders using drag and
drop method.

• In the RIGHT pane, select the file or
folder you want to copy.
• Click and drag the selected file and/or
folder to the folder list on the left, and
drop it where you want to copy the file
and/or folder.
• Your file(s) and folder(s) will now
appear in the new area.
Note
If you want to select multiple files
or folders, use Ctrl + Click.
5.11.6. Copying Files and Folders to
removable disk
There are several methods of
transferring files to or from a removable
disk.

Figure 5.29.Moving the File/
Folder using drag and drop

• Copy and Paste

Copying Files and Folders

• Send To

There are variety of ways to copy files
and folders:

METHOD I - Copy and Paste
• Plug the USB flash drive directly into
an available USB port.

Method I - COPY and PASTE
To copy a file or folder, first select the
file or folder and then choose one of
the following:

• If the USB flash drive or external drive
folder does NOT open automatically,
follow these steps:
• Click Start→Computer. (Figure 5.31)

• Click Edit → Copy or Ctrl + C or right
click→ Copy from the pop-up menu.
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Figure 5.32. Copying File using right click
• Return to the Removable Disk window,
right-click within the window, then
select Paste. (Figure 5.33)
Figure 5.30. Selecting Computer
option from Start menu
• Double-click on the Removable Disk
associated with the USB flash drive.
(Figure 5.31)

Figure 5.33. Pasting File using right click

METHOD II - Send To
• Plug the USB flash drive directly into an
available USB port.
• Navigate to the folders in your computer
containing files you want to transfer.

Figure 5.31. Double Clicking
Removable Disk

• Right-click on the file you want to
transfer to your removable disk.

• Navigate to the folders in your
computer containing files you want to
transfer.

• Click Send To and select the Removable
Disk associated with the USB flash drive.
(Figure 5.34)

Right-click on the file you want to copy,
then select Copy. (Figure 5.32)
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Workshop

Workshop

7. Delete the file created by you after
duplicating the same under My
D o c uments.

6.  Move the file created by you in My
Documents to Drive D.
 Copy the file created by you from
drive D: to a removable disk.

Note
To permanently delete a file or folder
(i.e. to avoid sending a file or folder to
the Recycle Bin), hold down the SHIFT
key, and press delete on the keyboard.

5.11.7. Deleting Files and Folders
• When you delete a file or folder, it will

Recycle Bin
Recycle bin is a special folder to keep
the files or folders deleted by the user, which
means you still have an opportunity to recover
them. The user cannot access the files or folders
available in the Recycle bin without restoring
it. To restore file or folder from the Recycle Bin

move into the Recycle Bin.
To delete a file or folder:
Select the file or folder you wish to delete.

• Open Recycle bin.
• Right click on a file or folder to be
restored and select Restore option from
the pop-up menu.
• To restore multiple files or folders, select
Restore all items.
• To delete all files in the Recycle bin, select
Empty the Recycle Bin.
5.12. Creating Shortcuts on the Desktop
Shortcuts to your most often used
folders and files may be created and placed
on the Desktop to help automate your work.

Removable disk

Figure 5.34. Copying File using Send to

• Select the file or folder that you wish to
have as a shortcut on the Desktop.

option

• Right click on the file or folder.

1. Right- click the file or folder, select
Click File → Delete or press Delete key

• Select Send to from the shortcut menu,
then select Desktop (create shortcut)
from the sub-menu.

from the keyboard.

•

Delete option from the po-pup menu or

2. The file will be deleted and moved to the
Recycle bin.

A shortcut for the file or folder will now
appear on your desktop and you can
open it from the desktop in the same
way as any other icon. Figure 5.36.
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Figure 5.35 Creating Shortcut
5.13. Shutting down or Logging off a Computer
Once you have closed all open applications, you can either log off your computer or shut down
the computer.
Log Off
To Log off/Shut down the computer:

Figure 5.36. Log off option
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•
•

•

•

•
•

•

•

Click start → log off (click the arrow
next to Shut down) or Start →
Shutdown
(Figure 5.37)
If you have any open programs, then
you will be asked to close them or
windows will Force shut down, you
will lose any un-saved information if
you do this.
Switch User: Switch to another user
account on the computer without
closing your open programs and
Windows
processes.
Log Off: Switch to another user
account on the computer after closing
all your open programs and Windows
processes.
Lock: Lock the computer while you're
away from it.
Restart: Reboot the computer. (This
option is often required as part of
installing new software or Windows
update.)
Sleep: Puts the computer into a lowpower mode that retains all running
programs and open Windows in
computer memory for a super-quick
restart.
Hibernate (found only on laptop
computers): Puts the computer
into a low-power mode after saving
all running programs and open
Wwindows on the machine's hard
drive for a quick restart.

Evaluation
Part – I

Choose the correct answer
1.

From the options
given below, choose
the
operations
managed by the
operating
system.
a. Memory
b. Processes
c. Disks and I/O devices
d. all of the above

2.

Which is the default folder for many
Windows Applications to save your
file?
a. My Document			
b. My Pictures
c. Documents and Settings		
d. My Computer

3.

Under which of the following
OS, the option Shift + Delete –
permanently deletes a file or folder?
a. Windows 7		
b. MS-DOS
c. Linux		
d. Android OS

4.

What is the meaning of "Hibernate"
in Windows XP/Windows 7?
a. 
Restart the Computer in safe
mode
b. Restart the Computer in hibernate
mode
c. 
Shutdown
the
Computer
terminating all the running
applications
d. Shutdown the Computer without
closing the running applications
The shortcut key used to rename a
file in windows
a. F2		
b.F4
c.F5		
d. F6

Activity
Student Activity
1. Create files and folders using Windows
and Ubuntu and compare them.
2. Create a File/Folder in Windows 7,
Windows 8 and Windows 10. Prepare
a report on the differences you face
while creating the same.

5.
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2.
3.

Part – II
Very Short Answers
1.
2.
3.
4.
5.

What is known as Multitasking?
What are called standard icons
Differentiate Files and Folders.
Differentiate Save and save As
option.
How will you Rename a File?

4.
5.

Part-IV
Explain in Detail
1.

Explain the versions of Windows
Operating
System.
2.
Explain the different ways of finding
a file or Folder
3.		
Write the procedure to create
shortcut
in
Windows OS.

Part-III
Short Answers
1.

Write a note on Recycle bin.
Write a note on the elements of a
w i n d o w.
Write the two ways to create a new
folder.
Differentiate copy and move

What are the functions of Windows
Operating system.

Operating System (OS)

System software that enables the harware to communicate
and operate with other software.

Mouse

Handheld hardware input device that control a cursor
in a GUI and can move and slect text, icons, files, and
folders.

Windows

Familer operating system developed by Microsoft corpn.

Desktop

Opening screen of windows operating system.

Icon

Tiny image represent a command.

Folder

Container of files

Linux

An operating system.
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Unit II

Office Automation Tools

CHAPTER

6

Part - I : Introduction to Word Processor
Learning Objectives

Table 6.1 - Proprietary Software & Open
Source Software

• To understand the
importance of a word
pro c e s s or.

Proprietary source Word processing software

• To understand this
application in Open
Office.
• To understand working of OpenOffice
writer in Windows OS.

Package

Developer

Microsoft Word

Microsoft Corporation

WPS Word

Kingsoft

WordPro

Lotus Corporation

Open Source Word processing software

• To know the editing options in
OpenOffice
writer.
• To know the text formatting and page
formatting options in OpenOffice
writer.
• To know the use of spell check features
of OpenOffice writer.

Package

Developer

OpenOffice Writer

Apache

LibreOffice Writer

The document
foundation

Abiword

Abisource

Tamil Word Processors
Tamil openoffice writer, Tamil
LibreOffice
Writer,
Kamban
3.0,
Mentamizh2017 – These are familiar
word processors exclusively for Tamil
Language. Microsoft also provides full
Tamil interface for all office suits.

6.1 Introduction to Word Processor
Word processor is a computer
software to create, edit, manipulate,
transmit, store and retrieve a text
document. The above said activities are
called as “Word Processing”. In other words,
Word processing is an activity carried out
by a computer with suitable software to
create, edit, manipulate, transmit, store and
retrieve text documents.

In this chapter, you are going to learn
about an word processor (OpenOffice
Writter).

6.2 An Introduction to OpenOffice
Writer

There are many word processing
software available as proprietary source
as well as open source. The familiar
word processing packages are given in the
following Table.

OpenOffice is the leading opensource office software suite for word
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processing, spreadsheets, presentations,
graphics, databases and much more. It is
available in many languages and works
on all computers. It stores all data in an
International open standard format and
can also read and write files from common
office software packages. OpenOffice is
easy to learn.

• Change tracking during revisions.
• Database integration, including a
bibliography database.
• Export to PDF.
6.2.1 Download and Install openoffice
Download and Install the latest
version of OpenOffice suite from http://
www.openoffice.org/download at free of
cost.
6.2.2 Creating a new document in
OpenOffice Writer
A
new
OpenOffice
Writer
document can be created by various
methods. From Windows, select
Start → All Programs → OpenOffice →
OpenOffice Writer
(or)

OpenOffice is a productive office suite
with a collection of different software
packages such as
• OpenOffice Writer - Word Processor to
create text documents
• OpenOffice Calc - Spreadsheet to create
worksheets
• OpenOffice Base - Database
• OpenOffice Impress - Presentation
s oftware

From Star Center (Welcome Screen):
• Double-click on “OpenOffice” icon on
the desktop
• Now, a welcome screen appears as
shown in Figure 6.1

• OpenOffice Draw Drawing Software
• OpenOffice Formula Create formula and equations
OpenOffice Writer is the word
processor component of OpenOffice. In
addition to the usual features of a word
processor (spelling check, thesaurus,
hyphenation, autocorrect, find and
replace, automatic generation of table of
contents and indexes, mail merge and
others), Writer provides these important
features:

Figure 6.1 Opening Screen (Star Center) of
OpenOffice

• Templates and styles.
• Page layout methods, including frames,
columns, and tables.
• Embedding or linking of graphics,
spreadsheets, and other objects.
• Built-in drawing tools.
• Master documents-to group a collection
of documents into a single document.

The opening screen is called as “Star
Center”. Writer is one of the components
of OpenOffice. So, it may be invoked from
the “Star Center” by simply clicking on the
“Text Document” icon. (or)
A new text document can also
be created by selecting File → New →
Text Document from any OpenOffice
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Control Buttons:
of the document and its application. By
default, the document is given the name
as Untitled1.
At the right corner of title bar the
control buttons available: (1) minimize,
(2) maximize/restore and (3) close shown
in Figure 6.4

Application. Ctrl + N keyboard short
cut can also be used to open a new text
document as shown in the Figure 6.2

1

2

3

Figure 6.4 Control Buttons
(1) Minimize button:

Figure 6.2 A new OpenOffice Writer Window

6.2.3 Parts of Writer Window:

Click here to Minimize

The Figure 6.3 displays the contents
of OpenOffice Writer window such as
Title bar, Menu bar, Standard Toolbar,
Formatting Tool bar, Ruler, Work space
and Status bar. The components of a
OpenOffice Writer window are explained
below in Figure 6.3.
Title bar with document name Menu bar

Tool bar

Control buttons

Figure 6.5 - Window Showing Minimize
button
Insertion Point

When you click minimize button,
it shrinks your document window smaller
in size and shows it as a small button on
the task bar. To restore it in its original
size, place your mouse pointer on the
OpenOffice button which is available in
the Taskbar, you can view your document
as miniature and when you click on the
button, your document is restored to its
original size.

Ruler

Scroll bars
Status bar

Figure 6.3 Components of Writer Window

Title Bar
The title bar is displayed at the top
of the window, which displays the name

Figure 6.6 - Minature Window of Open
Office Document
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(2) Maximize button :

such as: New, Open, Close, Save, Save As,
Print, Export etc.

When you click maximize button,
your document window is displayed in
full screen. When it is in full screen, the
maximize button is changed to “Restore”.

Edit –The Edit menu contains cut,
copy, paste, Undo, Redo etc.
View –The View menu contains
the options that used to modify the
environment of Writer such as display
of toolbars, web layout, print layout,
navigator etc.

Restore

Figure 6.7 - Sizing Buttons
When you click restore button, the
document window regains to its original
size.

Insert – The Insert menu contains
commands for inserting various elements
such as pictures, tables, charts, comments,
headers, footers, special characters etc.

(3) Close button :
This button is called as “Close”
button, when you click this button, the
application is closed and OpenOffice
returns back to the desktop. The red
colored close button may also be called as
“Exit” or “Quit”.

Format – The Format menu
contains the options of various text and
page formatting features like page size,
layout, font characteristics, bullets and
numbering etc.
Tables– The Tables menu contains
various tools to manage and manipulate
tables such as to create a table, insert rows,
insert columns, split cells, merge cells etc.

Exit / Close openoffice

Tools – The Tools menu contains
various tools and functions such as spell
check, macros, mail merge, end notes/
footnotes etc.

Close document

Figure 6.8 - Close Button
There is another X mark on the
right most corner of the menu bar. This
is actually used to close your document.
When you click this X mark, your
document will be closed, OpenOffice will
continue to be in open condition.

Window – The window menu shows
display options such as New Window,
Close Windows, Split and Freeze.

Menu Bar

Under the menu bar, there are two
toolbars available by default. They are:

Help – The Help menu displays the
inbuilt help features in OpenOffice.
Tool Bar:

The menu bar is below the title
bar which comprises of various menus
consisting of various options.

(1) Standard Toolbar
(2) Formatting Toolbar
Standard Tool Bar– This tool bar
is just below the menu bar which consists
of shortcut icons for frequently performed

Figure 6.9 - Menu Bar
File – The File menu contains
various options for file management tasks
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tasks. There are many shortcut icons like cut, copy, paste, undo etc…

Figure 6.10- Standard Toolbar
Formatting Tool Bar– The formatting tool bar is below the standard tool bar which
consists of icons used for formatting the text like bold, underline, italics, font type, font
color etc.

Figure 6.11- Formatting Toolbar
Ruler
The ruler is a scale below the formatting tool bar which shows the margins.There
are two set of rulers (1) Horizontal ruler and (2) Vertical ruler. Horizontal ruler is used to
set left and right margins of a page and vertical ruler for top and bottom setting.
Figure 6.12 - Ruler
Work Space

The Enter key must not be pressed at the
end of the each line. The Enter key should
be pressed only at the end of a paragraph
or when a blank line is to be inserted.
When a page is filled up, OpenOffice
Writer automatically creates a new page.

The work space is the blank area
which is used to type the content of the
file.A flashing vertical bar that appears at
the beginning of the screen which is called
as “Insertion pointer”.
Status Bar

6.2.5 Moving within a document

The status bar is at the bottom of the
window which shows the current status of
the document such as number of pages,
current page number, default language etc.

There are different ways of moving
within a document. The shortcut keys
given in Table 6.2 are used to move easily
within a document.

6.2.4 Entering the Text

Table 6.2 Keyboard shortcut Keys

Once a new document is opened,
the text can be typed in the blank area of
the screen. As the text is typed they appear
on the screen and the flashing vertical bar
called the insertion pointer moves to the
right. When the text reaches the end of the
line, the word is automatically wrapped
to the next line. This feature in any word
processor is known as “Word Wrap”.

KEY

ACTION

→

To move a character right

←

To move a character left

↑

To move one line up

↓

To move one line down

Ctrl + →

One word right

Ctrl + ←

One word left
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Ctrl + ↑

One paragraph up

Ctrl + ↓

One paragraph down

Home

To the beginning of line

End

To the end of line

Ctrl +
Home

To the beginning of
document

Ctrl + End

To the end of document

Tab

To move one cell to right

Shift + Tab

To move one cell to left

• Select location to store your document.
The default location to store all
documents is “Documents” folder in
Windows.
• Type your document name in the File
Name box.
• All documents in OpenOffice Writer
will be stored with .odt extension. You
can store your OpenOffice document
as Microsoft Word document or pdf. To
do so, select file type from Save as type
list box. This list box shows variety of
formats to be saved.

Pg up(Page To scroll one screen up
Up)
Pg
To scroll one screen down
Down(Page
Down)

• Finally, Click “Save” button.

6.2.6 Saving the Document

• Once the file is saved, your document
name will be displayed on the title bar.

The first time the document is
saved, OpenOffice Writer prompts for a
name. Naming the file enables the user
to find and open that file again. One can
select the drive and folder where the file
will be stored. To save a document for a
first time, the following steps are used:

Saving with password
Enter Your Password here

• Click File → Save → (or) File → Save
As (or) Ctrl + S
• The “Save As” dialog box appears as on
Figure 6.13.
Click Ok to Finalise

Enter the same Password once again
Figure 6.14 – Password dialog box

In OpenOffice Writer, a document
can be protected with a password. You can
set a password to protect your document

Figure 6.13 Save As dialog box
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the “Save” button, it proceeds to save the
file. If you are not willing to save the file,
then click “Discard”, or if you want to
cancel this warning and continue working
in the same document, click “Cancel”.

while saving a file. To save a file with
password, click on “Save with Password”
check box in Figure 6.1.3 and then click
“Save” button. Immediately it shows “Set
Password” dialog box as shown in the
Figure 6.14.

6.2.8 Opening an existing document

In this dialog box, Enter a password
in “Enter Password to open” text box and
retype the same password in “Confirm
Password” box for confirmation. Finally
click “OK” button.

Once a document is saved, it can be
opened at any time. To open an existing
document, Click on the File → Open or
Ctrl + O, the Open dialog box appears,
enter the name of the file in the File Name
text box and click the OPEN button as in
Figure 6.16.

“More Options” button in Figure
6.14 provides some more features to your
protected document such as “Read only”
and change password.
6.2.7 Closing a Document
After your document is saved, it is
still open. So, you can continue typing your
document. When the work is finished, you
should save the document and then close
document using File → Close command
(or) Press Ctrl + W.

Figure 6.16 – Open dialog box

6.3 Tamil Typing Interface

Closing Unsaved Document:

Typing in Tamil has different methods.

When you close an unsaved file
using the close control button, Writer
shows a warning message as shown in
Figure 6.15.

•

Using Tamil Font

•

Using Tamil Interface.

In the first method specific Tamil fonts are
available which has to be downloaded and
installed and should be included in the
font folder of the control panel. But this
method has some drawbacks:
• The user must be aware of Tamil typing.
• The particular font must be available in
the system.

Figure 6.15 Alert Message box

• It does not support other languages
including English.

If you accept the warning message,
click the “Save” button. When you click
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• The computer accepts characters as
symbols not as language.

to the right of the insertion pointer
To insert a text in between if
something is left out, the insertion can be
made by taking the insertion pointer to
the current location and Press the Insert
key the newly typed text is inserted, so that
the existing text moves to the right. This is
Insert mode. Press the Insert key again,
the text is over written on the existing text.
This is called Type over mode. You can
toggle between the insert mode and type
over mode by pressing the Insert key.

• It is not portable, i.e. if the document
is sent to another computer, if the same
font is not available, it is recognized as
symbols not as original characters.
To overcome the drawbacks in the first
method, the interface method provides
the following advantages:
• It follows Unicode technique. Hence
knowledge of Tamil typing is not
necessary.

6.5 Select, Move and Copy text

• It is easy to type documents in Tamil in
any word processor.

6.5.1 Selecting Text

• Some of the Unicode fonts like “Arial
Unicode” supports all Indian languages
including Tamil and English using
respective language interface.

In any word processor, the text has to
be selected for performing any operations
like copying, moving, formatting etc. The
text selection can be done in two methods:

6.3.1 Download and Install Tamil Typing
Interface

i) Selecting the continuous text.
ii) Selecting the non continuous text.

Many Tamil Typing Interfaces are available
as open source such as “Murasu”(it is
exclusively for Tamil), “NHM Writer”(It is
universal to all Indian languages) etc.

Selecting the continuous text
To select the text continously move the
insertion pointer to the begining of the
text.

To download and install:
• “Murasu” use the link : http://anjal.net/
download

• hold the SHIFT key and drag the mouse
across until the required text is selected
and then release the SHIFT key.

• “NHM writer” use the link : http://
software.nhm.in

• The selected text can be used for any
operation.

6.4 Editing a document
Once a document is typed, it can
be edited in many ways. If there is some
insertions or deletions, it can be done while
typing or after typing also. Corrections
can be made in two different ways :

Selecting the non continuous text
To select the text not continuous, move
the insertion pointer to the begining of
the text,
• hold the CTRL key and drag across the
required text to be selected and release
the CTRL key

Backspace Key: Deletes the
character to the left of the insertion
p o i n t e r.

• The required text is selected and can be
used for any operation

Delete Key : Deletes the character
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Selection using other methods:

• Click Ctrl + V or Paste Icon
→ Paste

Selection using Mouse:
To select the text using mouse:

or Edit

The required text is moved to the new
location.

i) Move the insertion pointer to the
begining of the text

Coping text

ii) Hold down the Left mouse button and
drag it across the text

To copy a text from one location to
another

iii) Release the mouse button when the
required portion of text is selected

• select the text to be copied
• Click Ctrl + C or Copy Icon
Edit → Copy

iv) The selected text will be highlighted.
Selection using Keyboard:+

or

To select the text using keyboard:

• A duplicate copy of the text is made and
sent to the clipboard

i)Move the insertion pointer to the
begining of the text

• Take the insertion pointer to the new
location to be copied and

ii) Hold the Shift key and use the
movement keys to drag across the
required
portion.

• Click Ctrl + V or Paste Icon
Edit→ Paste

The required text is copied to the new
location.

iii) when the required portion is selected
release the Shift key

The Editing shortcut keys are as given in
Table 6.3

iv) The selected text will be highlighted.
Selection using Shortcut keys:

Table 6.3 - Cut, Copy and Paste Icons
and Shortcuts

Shortcut keys help to select the text quickly
and easily.
• To select a word - Double click on the
word

Operation
CUT

• To select the entire document - Press
Ctrl + A

COPY

6.5.2 Moving and Coping text
Moving text
To move
an ot h e r

a text from one location to

PASTE

• Select the text to be moved
• Click Ctrl + X or Cut Icon
Edit →Cut

or

or
UNDO

• The text is removed from the source
location and placed in the clipboard
• Take the insertion pointer to the new
location to be moved and

Action
Cuts the
selected text
To make a
duplication
of the text.
To paste
the text to a
new location
after cut
or copy
process.
Cancels the
previous
operation
that was
performed

Icons

Shortcut
Key
Ctrl +X
Ctrl +C

Ctrl +V

Ctrl +Z
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6.5.3 Paste Special

6.6 Help System in Writer

When you move or copy selected
text, the Paste option is used to send the
information as a whole. But, to move or
copy only some aspects of the data, like
only its formatting or only value, the
Paste Special option is used.

Open Office Writer provides several
forms of help. By pressing F1 or select Help
from the menu bar the help window appears
as shown in Figure 6.18.

To use Paste special option, select
the text and apply move or copy, then at
the destination location,
• Click Edit → Paste Special (or) press
Ctrl+Shift+V, or Alt+E+S the Paste
Special dialog box opens as shown in
Figure 6.17.
• The Paste Special menu varies depending
upon the origin and formatting of the
text (or object) to be pasted.

Figure 6.18 – Help window

• Select DDE (Dynamic Data Exchange)
link from the Paste special dialog box.

• To activate tooltips, extended tips, and
the help Agent, click Tools → Options
→ OpenOffice
• For a more detailed explanation, select
Help → What’s This? and hold the
mouse pointer over the icon where you
want more help. Figure 6.19 shows the
General settings window

Figure 6.17 - Paste Special dialog box
• Select the type of application and click
the OK button.

Tips

• The copied data is pasted into the
document with a link.
Note

Extended tips

Dynamic Data Exchange(DDE) is a
mechanism whereby the source data
can be pasted into the destination as
a linked, 'live' copy of the original.

Figure 6.19 - General settings window

Any changes made in the source
will immediately reflect in the
destination.
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Workshop
6.1
• Open a new document in Open office writer.
• Type the following paragraph.
“The ignited minds of the youth is the most powerful resource on the earth. The power
of the youth, if properly directed, will bring about transformed humanity by meeting
its challenges and bring peace and prosperity.”
• Save and close the document.
• Exit from Open Office Writer.
6.2
• Open the document created in Workshop-6.1.
• Append the following paragraph.
“We are as young as our faith and as old as our doubts. We are also as young as our selfconfidence and as old as our fears. We are as young as our hopes and as old as our despairs".
• Save the document
• Using Delete or Backspace key remove the last line of the first paragraph.
• Type the following lines after the second paragraph and create it as a new paragraph.
“It doesn’t matter who you are, if you have a and determination to achieve that vision,
you will certainly do so.”
• In the third paragraph insert the word “vision” between “a” and “and ”.
6.3
• Open the document created in workshop-6.1.
• Copy and paste the following words into a new document either using keyboard
or mouse shortcuts. (i) Ignited (ii) powerful (iii) humanity (iv) challenges (v)
prosperity
• Save the new document
• In the first document, move the following words either using keyboard or mouse
shortcuts. (i) Ignited (ii) Challenges (iii) Prosperity
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Part - II : Formatting Text and Paragraph
The default font color is black and
the font color can be changed by clicking
on the Font colour icon
which shows
the color palette from which the required
color can be selected.

6.7 Text formatting
A text without any special
formatting
gives
a
monotonous
appearance. OpenOffice Writer offers a
number of choices for formatting such as
Bold, Italics and defining the font type,
and font size. Bold, Italic, underlined are
the most common types of text formatting.
Almost all the formatting options are
available under the Format menu.

Besides the regular formatting
Bold, Italics and underline, many other
formatting can be done by using the
dialog box shown in Figure 6.20. The
other formatting options can be selected
by using Format → Character. The
Character dialog box is displayed as
shown in the Figure 6.20 using which all
the formatting can be done at a single
stretch with a preview options.

6.7.1 Changing font style, size and colour
A font is a set of characters in a
particular style. Changing the default
appearance of the text like changing the
font type , size, color, style etc., are called
as Text formatting. To make the text
attractive and more appealing, various
formatting like bold, italic and underline
can be done by using the following text
formatting shortcuts shown in Table 6.4

Font Tab
Preview window

Table 6.4 Text formatting shortcuts
ICON

SHORTCUT
KEY

OPERATION

ACTION

BOLD

Makes the
text bold

Ctrl + B

ITALICS

Italicizes the
text

Ctrl +I

6.7.2 Changing Case

UNDERLINE

Underlines
the text

Ctrl +U

Normally any text can be typed
in upper or lower case. The text can be
changed to different cases like:

Figure 6.20 – Character dialog box

The default font type is Times
New Roman and the type of font can be
changed by clicking on the Font Type icon

• Uppercase (Capital letters)
• toggle case (reverse case),
• sentence case (first letter of each
sentence in capital),

The default size of font is 12 points
which can be changed by clicking on the
Font Size icon

• Capitalize every word (first letter of
each word in capital),
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• lower case. (Small letters)

the appearance of individual paragraphs.
There are four types of alignment available
in Open Office Writer - left - alignment,
Right - alignment, Center - alignment,
and Justify - alignment.

This can be done by:
• Select the required text to change case
• Select Format → Change case.
• Select the required options

Left-alignment - A paragraph's
text is LEFT aligned when it is aligned
evenly along the left margin and uneven
along the right margin. This is the default
alignment when a paragraph is typed.

6.7.3 Highlighting text
Highlighting is used to draw
attention to important information in text.
Highlighting is beneficial because it first
asks the reader to pick out the important
parts, and then gives an effective way to
review that information later.

Right-alignment - A paragraph's
text is RIGHT aligned when it is aligned
evenly along the right margin and uneven
along the left margin.

Highlighting can be applied by
selecting the text and click Highlighting
icon
, the color palette is displayed,
select the required color, and the text is
highlighted. Highlighting can be removed
by selecting the text and click No Fill from
the color palette.

Center-alignment- All the lines in
the paragraph are aligned to the center of
the page size.
Justified-alignment - All the lines
in the paragraph, are arranged evenly
both on the left and right margins. This
is achieved in Writer by automatically
inserting additional space between the
words.

Highlighting is to draw attention
to important or key points in a
document for easy reference by
marking it in a different color.

Paragraph formatting can be
applied by Format → Paragraph, the
paragraph dialog box appears as displayed
in Figure 6.21.

6.7.4 Clearing the formatting
the

To clear the formatting applied to
text

• Select the entire document by Ctrl + A
or Edit →Select All
• Clear applied formatting by Ctrl + M
6.8 Paragraph formatting
6.8.1 Paragraph Alignment
A paragraph is any text that ends
with a hard return. A hard return is
accomplished anytime you press the
Enter
key. Paragraph Alignment or
justification refers to the way in which
the lines of a paragraph are aligned.
Paragraph alignment lets you to control

Figure 6.21 – Paragraph dialog box
79

Chapter 6.indd 79

3/20/2020 11:34:22 AM

The paragraph formatting can also be done by icons using the formatting tool bar
as shown in Figure 6.22 and shortcut keys as shown in Table 6.5

Figure 6.22 Formatting toolbar
Table 6.5 Paragraph Alignment Icons and shortcut Keys
ALIGNMENT

ACTION

ICON

SHORT CUT KEY

LEFT

Align the paragraph with respect to
the left margin

Ctrl + L

RIGHT

Align the paragraph with respect to
the right margin

Ctrl + R

CENTER

Align the paragraph with respect to
the center of the page

Ctrl + E

JUSTIFIED

Align the paragraph with respect to
both the left and right margin

Ctrl + J

An example showing all the four paragraph alignment:
Left Alignment
All power is with in you take up one idea, make that one idea your life. Think
of it dream of it, live on that idea let the brain, muscles, nerves, every part
of your body be full of that idea, and just leave every other idea alone. This is the
way to success.
Right Alignment
All power is with in you take up one idea, make that one idea your life.
Think of it dream of it, live on that idea let the brain, muscles, nerves, every part
of your body be full of that idea, and just leave every other idea alone.
This is the way to success.
Center Alignment
All power is with in you take up one idea, make that one idea your life.
Think of it dream of it, live on that idea let the brain, muscles, nerves,
every part of your body be full of that idea, and just leave every other
idea alone. This is the way to success.
Justified Alignment
All power is with in you take up one idea, make that one idea your life. Think of it
dream of it, live on that idea let the brain, muscles, nerves, every part of your body
be full of that idea, and just leave every other idea alone. This is the way to success.
Example 6.1 Paragraph Alignment
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6.8.2 Line Spacing:

line of text can be created by moving the
insertion pointer to the begining of the line
and pressing the tab key on the keyboard.
There are four types of intentations:

Line spacing determines the amount
of vertical space between lines of text in a
paragraph. By default, the lines are singlespaced, that is the spacing accommodates
the largest font in that line, plus a small
amount of extra space. In Open Office,
setting line spacing is quite easy through
the context menu, select the line or word
or phrase, right-click → line spacing,
select the type single, 1.5 or double. There
are seven different types of line spacing
as shown in the dialog box given below in
Fig.6.23.

• Left Indent
• Right Indent		
• First Line Indent
• Hanging Indent.
Left indent - The Left indent
controls the space between the paragraph
and the left margin. This is the default
indent. Each click on the Increase indent
icon moves the paragraph ½ inch away
from the left margin.

• Select the entire document by Edit →
Select All

The left indent can also be applied
by Format → Paragraph → Indents &
Spacing tab, enter a value in the “Before
text” spin box as shown Figure 6.23. This
results in left indent.

• Format → paragraph
• The paragraph dialog box appears, click
Indents & Spacing tab
• In the line spacing option, select the
type and click OK button.

Right Indent - The Right indent
controls the space between the paragraph
and the right margin. Each click on the
decrease indent icon removes the indent
applied by the Increase indent. The Right
indent can be applied by using dialog box as
shown in Figure 6.23.
Select Format → Paragraph →
Indents & Spacing tab, enter a value in
“after text” spin box. This results in right
indent.
First Line Indent - This First-Line
indentation indents the first line of the
paragraph. It is the most common way to
start a new paragraph.

Figure 6.23 Paragraph dialog box
6.8.3 Indenting text
Indent is the distance from the left
and right margin of a paragraph. It is used
to improve the efficiency and readability
of the paragraph and makes the paragraph
look more attractive. In paragraphs,
an easy way to apply indent for the first

This indent can be applied by
Format → Paragraph → Indents &
Spacing tab, select First line option in the
Figure 6.23, enter a positive value which
results in first line indent.
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Hanging indent -This is a special
kind of indent where the first line of the
paragraph alone hangs outside leaving the
rest of the text. To apply Hanging indent, a
negative value is given in the “First line”
option of the paragraph dialog box as
shown in Figure 6.23.

6.8.5 Style of Bullets and Numbering

6.8.4 Bullets and Numbering

• Format → Bullets and Numbering

The default type of bullet is ( . ) and
the default type of numbering is (1, 2, 3
……). The style of bullets and numbering
can be changed by applying the following
steps:
• Select the text to be bulleted

Bullets and numbering are used
to emphasize list of things and make the
list easy to read and follow. It provides
an excellent way to segregate, list and
organize information to the reader. You
can control the appearance, or format a
bulleted or numbered list.

• Select Bullets Tab

Bullets – This is a paragraph level
attribute that applies a bullet character
to the start of the paragraph. In bulleted
lists, each paragraph begins with a bullet
character. This is suitable when the
text has to be presented as a list of items
preceded by a bullet symbol and no
sequence has to be followed. Bullets are
quickly created by clicking on the Bullet
icon

The bullets and numbering dialog
box with the bullets tab is displayed in
Figure 6.24.

• The Bullets and Numbering dialog box
appears where different styles of bullets
are displayed
• Click on the required style
• Click Ok button
• The selected text is bulleted.

Numbering – This attribute applies
a numeral to the start of the paragraph.
Numbering is more suitable when the
text has to be presented as a sequence. In
numbered list, each paragraph begins with
an expression that includes a number or
letter and a separator such as a period or
parenthesis. The numbers in a numbered
list are updated automatically when you
add or remove paragraphs in the list.
Numbering is quickly created by clicking
on the Numbering icon.

Figure 6.24 Bullets and Numbering dialog
box
Note
If the text is not typed, then apply the
steps above and then type the text, the
newly entered text will appear in bulleted
form.
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To apply Numbering
1. Select the text to be numbered
2. Format → Bullets and Numbering
3. Select Numbering Type Tab
4. The Bullets and Numbering dialog
box appears where different styles of
numbering are displayed
5. Click on the particular style
6. Click Ok button
7. The selected text is numbered.
The bullets and numbering dialog
box with the numbering type tab is
displayed in Figure 6.25.

Figure 6.25 Bullet and Numbering dialog
box

Bullets and numbered lists
provide an excellent way to
segregate, list and organize
information to the reader. You
can control the appearance or format, of a
bulleted or numbered list.

The most important thing in a
word processor is how to format the page
elements such as margins, numbering, page
layout, headers and footers. Formatting
your page makes it look more attractive
and make it easier to read.

6.9 Page formatting

6.9.1 Setting the page size and margins

Note

Changing page size

If the text is not typed, then apply the
steps above and then type the text,
the newly entered text will appear in
numbered form.

The default page size in Writer is
8.5 x 11”, the same as that of a standard
A4 printing paper. However, for different
types of documents, you may need to
change the page size. To change the paper
size:

Turning off Bullets and Numbering
As you can quickly add bullets or
numbers to existing text by clicking on
the icons, the bullets and numbers can be
removed easily.

• Select the page to be resizized
• Select Format → Page, the page style
dialog box appears as shown in Figure
6.26.

• Select the text where the bullets and
numbers are to be removed.
• Click on the Bullets icon
remove bullets.
• Click on the Numbering icon
to remove numbering.

• Select Page Tab

again to

• In the paper format group, select the
format like A4, legal etc.

again

• Or the width and height option can be
used to set the page size.
Changing page margins
Page margins are the white space
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around the top, bottom, left, and right of
your document. Margins let Writer know
where to start placing the text at the top of
a document, when to move on to the next
page at the bottom, where to start typing
text on the left side, and where to stop and
move to the next line on the right.

dialog box
1. Right-click anywhere on the page and
select Page from the popup menu and
select page tab of Page Style dialog box
as shown in Figure 6.26.
2. In the Margins group, specify the values
for left , right , top and bottom margins.
3. Click ok button.
6.9.2 Orientation
Page orientation refers to how the
document will be displayed on screen
and printed. There are two different
or ient at ions:
Landscape - The width of the
document is more than the height. This
is best suited for displaying professional
photos, invitations, albums, tables etc.

Figure 6.26 Page style dialog box
Changing or setting page margins
in OpenOffice Writer can be done in two
ways:

Landscape

1. Using the Rulers - quick and easy, but
does not have precise values.

Portrait – This is the most common
and default orientation . Here, the height
of the document is more than the width.
Normally books, newspapers will be
displayed in this format.

2. Using the Page Style dialog box - can
specify precise values for the margins.
1. Changing page margins - using Ruler
1. The shaded sections of the rulers are
the margins.
2. Hold the mouse pointer over the line
between the gray and white sections.
3. The mouse pointer turns into a doubleheaded arrow.

Portrait

4. Hold down the left mouse button and
drag the mouse to move the margin and
release it at the required point.
5. The new margin is set.			

To change the orientation:

2. Using the Page Style dialog box

• Select the page whose orientation is to
be changed

To change margins using the Page Style
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• In the Page Style dialog box, under the
Orientation group,
• Select Portrait or Landscape button.
• Click ok button.
6.9.3 Page colour and borders
Changing the page color is not quite
common. To do so, in the Page Style dialog
box, select Background tab, In As option
click on color and select the “color” from the
color palette or select “graphic” to apply
an image as a page background, as shown
in Figure 6.27.

Figure 6.28 Page style dialog box - Borders

6.10 Working with Headers and
Footers
The Header is a section of the
document that appears in the top margin,
which displays the title or chapter name ,
author name of a document.
The Footer is a section of the
document that appears in the bottom
margin of the page which displays the
page number, date, time etc. which gets
displayed on all the pages automatically.
6.10.1 Inserting Header and Footer

Figure 6.27 Background color

• Select from the main menu Insert →
Header → Default

Borders can be applied to an entire
document, an entire page, paragraph, or
just to certain sections of the document.
From the Page Style dialog box, select
the Borders tab, the User-defined area
helps to define the area of borders, the
line style of borders, color of borders can
be selected. The dialog box in Figure 6.28
shows the borders setting in the Page Style
dialog box.

• The header text area is separated from
the normal text area.
• In the header area, enter the text that
is to be repeated in all pages or Select
Insert → Fields →Title.
Similarly to insert a Footer, the steps are as
given below:
• Select from the main menu Insert →
Footer → Default
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• Place the insertion pointer in the footer
area of the page.

• Position the insertion pointer where the
page number has to appear

• Select Insert → Fields → Date to insert
date in all the pages.

• Select Format → page, which will
display the Page Style dialog box as in
Figure 6.29.

Once the Headers and Footers
are given in the first page, the same text
appears in all the pages.

• Select Page Tab
• In the Layout settings, select the Format
drop down combo box

6.10.2 Inserting and Formatting page
numbers

• Select the desired style and click OK
button.

Once the Header / Footer area are
created, the page numbers can be inserted
by performing the following steps:
• Place the insertion pointer where you
want to insert the page number
• choose Insert → Fields → Page
Number
• The page number appears with a gray
background
Normally, the page numbers appear
as 1,2,3….., To change the numbering
style, the following sequence of steps can
be performed:

Figure 6.29 Page Style dialog box
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Workshop
6.4
1. Open a new document in OpenOffice writer.
• Type the following paragraph
“Learning gives creativity, creativity leads to thinking, thinking provides knowledge,
and knowledge makes you great”
• Save the document
• Perform text formatting features like Bold, Italics, Underline, Change font, change
Size, Color and change case (Upper case to lower case, lower to upper) for the words.
(in the paragraph and make the paragraph more appealing to read.
• Highlight the text “ Knowledge makes you great”
• Undo all formatting options using keyboard shortcut.
6.5
• Open the document created in the workshop 6.1
• Type the following lines below the first paragraph
“ When one door closes, another opens, but we often look so long and so regretfully
upon the closed door that we do not see the one that has opened for us – Alexander
Grahambell ”
• Using any one of the paragraph alignment icons or keyboard shortcuts (left, right,
center, or justified) align the first paragraph.
• Change the line spacing of second paragraph to any one of the type.
• Create bullets for the first paragraph and numbering for the second paragraph using
icon or menu choice.
• Save and close this documents.
6.6
• Open the document created in workshop-6.2.
• Change page size, margin and orientation, change border and background color.
• Apply suitable header and footer for the table.
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Part - III : Find & Replace and Spell check
3. To replace text, click Replace button.

6.11 Find & Replace

The highlighted word is replaced with the
word given in the Replace with box.

OpenOffice Writer has a Find and
Replace feature that helps to locate for a
text inside a document and replace it with
another word. In addition to finding and
replacing words and phrases, you can also
use wildcards and regular expressions to
perform advanced search. To search a word

4. Click Find All, Writer selects all
instances of the search text in the
document.
All occurances of Bombay are highlighted.
5. Click Replace All button, Writer
replaces all matches.

• Click Edit → Find & Replace (or)
Ctrl + F

This will replace all occurances of
"Bombay"
with
"Mumbai".

• The Find & Replace dialog box appears as
shown in Figure 6.30

6. Enable Match case to perform the search
case sensitively so that uppercase and
lower cases are distinguished separately.

Steps to find & replace a text
1. Type the text you want to find in the
Search for box

7. Enable Whole Words only to make
the search more specific to words. For
example, if you search for the word
"Image", the command will only find
"Image" not "Imaging", "Images" etc.

For Example : To search a word "Bombay" in
a document and replace with "Mumbai",
enter the word "Bombay" in the Search
for box.

6.12 Spell Check

2. To replace the text with different text,
type the new text in the Replace with box

The documents prepared using word
processing software should be without
any spelling mistake. For this purpose
OpenOffice Writer includes a dictionary
and a spell check program. OpenOffice
Writer can identify the spelling mistakes
as the document is typed or after the entire
document is typed.

Enter the word " Mumbai" in the Replace
with box and Click Find button , to start
the search , the found word is highlighted
and the first occurrence of "Bombay" is
highlighted.

6.12.1 AutoSpellCheck

Bombay

AutoSpellCheck option checks each
word as it is typed and displays a wavy
red line under any misspelled word. Once
the word is corrected, the red wavy line
disappears. This can be done byclicking
the AutoSpellCheck icon

Mumbai

• Right-click on a word with a wavy
underline, to open a powerful context
menu. Correct words can be selected

Figure 6.30 Find & Replace dialog box
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6.12.2 Automatic correction

from the suggested words on the menu.
The selection will replace the misspelled
word with correct word.

Auto Correct feature has the facility
to correct the common misspellings and
typing errors, automatically. For example,
“hte” will be changed to “the”, which can
be done through the menu option, Tools
→ AutoCorrect to open the AutoCorrect
dialog box as shown in the Figure 6.32
which provides the chance to change the
misspelled word with the correct word.

To perform a separate spelling
check on the document (or a text selection)
click the Spelling and Grammar icon
. This checks the document or selection
and opens the Spelling dialog box (Figure
6.31) if any misspelled words are found.
This can also be achieved by pressing F7
key

To make an AutoCorrect entry
•
•
•
•
•
•

Select Tools → AutoCorrect
AutoCorrect dialog box appears
Click Replace Tab
In replace box, type the misspelt word
In with box, the correct word
Click New

Fig: 6.31 The Spelling dialog box
Here are some more features of the spelling
command:
• Not in Dictionary text area displays
the misspelled word Suggestions
boxdisplays alternate spellings. Ignore
once button is to skip the word once,
Ignore All button skip occurances of
the word. Change button will change
only that particular occurance. Change
All button will change all occurances of
the word.

Figure 6.32 AutoCorrect wizard
AutoCorrect is automatically
turned on. To turn it off, uncheck
Format → Autocorrect →
While Typing.

• The text language can be changed (for
example, Spanish, French, or German)
from the Spelling dialog box.

AutoCorrect can be used as a quick way to
insert special characters. For example, (c)
will be autocorrected to ©. You can add
your own special characters.

C The new words can be added to a
dictionary. Click Add in the Spelling
dialog box and pick the dictionary to
add it to.
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Activity 1:
Do the necessary steps to correct
the word “comupter” into “computer”
au t o m at i c a l l y
1. Goto Tools → AutoCorrect Options
AutoCorrect dialog box appears as shown
in Figure 6.34
2. Click the Replace tab and type “comupter”
in Replace text box and “computer” in with
textbox. then Click New and then OK
3. The word “Comupter” is replaced with
“Computer” and displayed in the list.
4. After entering this, when you type
“comupter” in the document, it will be
automatically changed to the correct
spelling
“computer”.

Figure 6.35 Auto correct list

Workshop
• Open a new document and type the
following paragraph
• “All birds find shelter during a rain.
But Egles avoid rain by flying above
the clouds. Problems are common,
but attitude make the difference.”
• Apply spelling check and find the
word “Egles” and replace it with
“Eagles”.
• Save the document with password.

Figure 6.33 Auto correct menu

Figure 6.34 Autocorrect dialog box
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Part - IV : Working with Tables
6.13 Inserting Tables
A table is a grid with a specified
number of rows and columns. Tables
can often be used as an alternative to
spreadsheet to organize materials. A
well-designed table can help readers to
understand better what you are trying to
convey.

Figure 6.36 Insert Table Dialog Box

6.13.1 
Different techniques to insert
tables

• Select the number of rows and columns
of the table

To insert a new table, position the
insertion pointer where you want the table
to appear, then use any of the following
methods to open the Insert Table dialog
box as shown in Figure 6.36.

• Give a Name to the table in the Name
Text box
• Select the Heading check box to define
the first row in the table as the heading
• Select the Repeat heading check box
to repeat the heading row if the table
spans more than one page

There are two methods to create a table :
Method 1. Table Icon
To insert a table quickly from the
standard tool bar:

• Select the Don't split table check box
to prevent the table from spanning
more than one page

1. Place the insertion pointer where you
want the table to appear.

• Select the Border check box to display
table with grid.

2. Click the down arrow to the right side
of the Table icon
.

• Click ok

3. In the drop down grid, select the
number of rows and columns for the
table.

The AutoFormat button at the bottom
of the Insert table dialog box opens the
AutoFormat dialog box as shown in
Figure 6.37.

4. The table will appear at the location of
the insertion pointer.

From here, it is possible to choose
among different predefined formats.

Method 2. Insert table dialog box
To insert a table with more control
over the settings and properties, use the
Insert Table dialog box.

If none of the predefined auto
formats have the desired characteristics
for your table, you can tune the format
of the table or a particular cell with the
contextual Table toolbar. Open the toolbar
by placing the insertion pointer inside a
table cell or

To open the dialog box: Select Table →
Insert →Table or Ctrl +F12 or left-click
the Table icon. From this dialog box, you
can:
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select View → Toolbars → Table. This will
bring the table formatting toolbar which
helps to format the table in the desired
format.

3. Click OK to close the dialog box.

6.14 Formatting table
Formatting a table involves
formatting of the table layout, formatting
the table text, adjusting the size of the
table, its position on the page, adding or
removing rows or columns, merging and
splitting cells, changing borders and the
background.

Figure 6.39 Insert Row Dialog Box
6.14.2 Deleting rows and columns
To delete rows or columns inside a table:
1. Place the insertion pointer in the row
or column to be deleted and right-click.
2. Choose Row → Delete to delete a row
or Column → Delete to delete a column.
3. The selected row / column is deleted.
6.14.3 Merging and Splitting cells
To merge a group of cells:
1. Select the cells to merge.
2. Right click and choose Cell → Merge or
choose Table → Merge Cells from the
menu bar.
To split a cell:
1. Place the insertion pointer inside the
cell.
2. Right click and choose Cell → Split, or
choose Table → Split Cells from the
menu bar.
3. Select the direction of the split,
horizontally (for rows), or vertically (for
columns), as well as the total number of
cells to create.

Figure 6.37 Auto format Dialog Box

Figure 6.38 Table Formatting Toolbar
6.14.1 Inserting rows and columns
To insert rows or columns inside a table:
1. Place the insertion pointer in the row
or in the column where you would like
to add new rows or columns and rightclick.
2. Choose Row →Insert – to insert a new
row or Column → Insert – to insert a
new column. A dialog box will appear,
from which you can select the number
of rows or columns to insert. You can
also set the position of the new rows or
columns to Before or After as shown in
Figure - 6.39.
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Workshop
6.7
• Open a new document.
• Using icon or table menu create the given table with required of 5 rows and6 columns
with the labels S.No., Name, Maths, Phy, Che and Total
• After the sixth row add a new row and type suitable data for the new row.
• Delete the second row using icon or command.
• Using icon or command after the second column add a new column and type
suitable data for the new column.
• Delete any one column using icon or command.
• Save and close the document.
6.8
• Open the document created in workshop-6.7.
• Do the following options :
• Change the border style and border line width for one table.
• Change height and width for the row and column respectively.
• Save and close the document.
• Create a new document.
• Create a 4 x 4 table using icons in toolbars or using commands.
• Split any one row/ column in one given table into more than one cell using icon or
command.
• Merge any two or more row / column in the given table using icon or command.
6.9
• Open the document created in workshop-6.8.
• Delete the table contents.
• Perform all table formatting options for this table.
• Add two more rows and columns and also delete the rows and columns.
• Save and close the document.
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Part - V : Enhancing and Printing a document
6.15 Enhancing a Document

in mathematical equations. To insert such
characters, the procedure given below is
followed:

6.15.1 Inserting pictures
OpenOffice Writer has the ability
to insert and edit images in a more simple
way. The picture gallery of the Writer
consists of a collection of images from
which the desired image can be selected
and inserted into the document. To insert
an image from a file, the steps are as
follows:

• Place the insertion pointer in your
document where you want the character
to appear
• Click on Insert → Special Characters
• The Special Characters dialog box
appears as shown in Figure 6.41 from
which the desired symbol can be
selected by clicking on the character.

• Place the insertion pointer where you
want the image to appear

• As you select each character, it is shown
on the lower right, along with the
numerical code for that character

• Select Insert → Picture → From file

• If you do not find a particular special
character you want, try changing the
font selection.

• The insert picture dialog box appears
where the picture gallery opens from
which the desired picture can be
selected.

• Click the OK button and the character
is inserted at the current location.

• If the picture is not in the gallery, then
browse the pictures from the folder,
choose the desired picture.

The insert special characters dialog
box is displayed in Figure 6.40.

• Click on the Open button
• The selected picture is inserted into the
document
6.15.2 Inserting Special Characters
Many symbols which are used in
a mathematical equation like alpha(∞),
beta(β), pi(π) etc., are not available on the
standard keyboard. However, representing
these characters are very much essential

Figure 6.40 Insert Symbol Dialog box
6.15.3 Inserting Shapes
OpenOffice Writer uses the drawing
tools, to create various shapes by using
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the Drawing toolbar. To use the drawing tools repeatedly, you can move this toolbar to a
convenient place on the window. The drawing tool bar can be obtained by clicking View
→ Toolbars → Drawing as displayed on Figure 6.41.

Figure 6.41 Drawing toolbar
To use a drawing tool, the steps are as
press F3. You can also save a formatted
given below:
Tip as AutoText and then insert a copy by
typing "tip" and pressing F3.
• Click in the document where you want
the drawing to be displayed.

To assign AutoText shortcut to
some text, the steps are as follows :

• Select the tool from the Drawing
toolbar as shown in Figure 6.44 The
mouse pointer changes to a cross-hair
pointer.

1. Type the text into your document.
2. Select the text so that it is highlighted.
3. Select Edit → AutoText (or press
Ctrl+F3).

• Move the cross-hair pointer to the
place in the document where you want
the drawing to appear and then clickand-drag to create the drawing object.

4. Enter a name for your shortcut. Writer
will suggest a one-letter shortcut, which
you can change.

• Release the mouse button. The selected
drawing function remains active, so you
can draw another object of the same
type.

5. Click on the inverted arrow of the
AutoText button on the right and select
New (text only) from the menu.
6. Click Close to return to your document.

• To cancel the selected drawing function,
press the Esc key or click on the Select
icon on the Drawing toolbar.

7. Once the entry is created, to insert the
auto text into the document, place the
cursor where the text is to be inserted
and click Ctrl+F3,

• You can now change the properties
(fill color, line type and width, change
Anchor, and others) of the drawing
object using either the Drawing Object
Properties toolbar or the choices in the
dialog box.

8. Select the name from the list of entries
and click Insert button.
9. The auto text is inserted into your text.
Note
If the only option under the
AutoText button is Import, either
you have not entered a name for your
AutoText or there is no text selected in
the document.

6.15.4 Inserting AutoText
AutoText allows you to assign text,
tables, graphics and other items to a key or
key combination. For example, rather than
typing "TamilNadu" every time you use
that phrase, you might just type "tn" and
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6.16 Page Preview , Setting the
printer and Printing a document
6.16.1 Preview the document to be
pr i n te d
It is a good practice to preview the
document before taking the print out.
The steps to be followed to preview the
document :
1.

2.

3.

Click File → Page Preview, or click
the Page Preview icon. The Writer
displays the Page Preview toolbar

Figure 6.42 Print Dialog box

In the page preview tool bar click
Multiple Pages icon to display
multiple
pages.

Click General Tab.

3.

Select the required printer from the
list of printers.

4.

Under Range and copies section :
select All Pages option to print all
pages, select Pages option to specify
the particular page or page range.

5.

Specify Number of Copies using spin
arrows.

6.

Click Print button.

To close the preview click the Close
Preview button.

6.16.2 Setting the Printer and Printing
The following are the steps to
change the printer setting :
1.

2.

Click File → Print or Ctrl +
P or Print File Icon which
opens the Print dialog box as
shown in Figure 6.42.
Activity

Student Activity
1.

Make the students prepare a invitation for school annual day.

2.

Let the students prepare their class timetable in table format and format it in an attractive
manner.

3.

Make the students create a greeting card in landscape format with a picture and a birthday
message and distribute to students on their birthday.

Teacher Activity
1.

To show a demo to the students how to type a question paper by using formulas and
special characters, changing the margins and printing in the practical session.

2.

To show the students a demo of inserting a picture and applying crop , color changes,
background and others features to modify it and make more attractive.
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Workshop
6.10

6.12

• Open the document created in
Part-1 workshop-6.1

• Open the document created in
workshop-6.2

• Download images related to Dr.
A.P.J ABDUL KALAM From
net and insert the images in the
document at required place using
command or icon.

• Using Autotext command or
keyboard shortcut create shortcut
for
• “Vital Information Under Seize” as
“VIRUS” and make it appear in one
document.

• Open the document in Part-III –
workshop-1 , download images
related to the content from net
and insert the images at required
place.

• Using Print icon change printing
attributes, preview and print the
document.

• Save the document and close.

6.13
• Open the document created in
workshop-6.4

6.11
• Open a new document.

• Insert suitable picture of a circle.

• Using the commands to insert
special characters, special symbols

• Type
the
formula
for
the
circumference of a circle using insert
special character option.

• Type the following equations (i)
Aα+Br+cβ (ii) πr2h.
•

• Using drawing tools draw
following in the document.

Using drawing toolbar insert
various drawings/ shapes in your
document

the

• Print the document using print
command.

• Save and close the document.

p
Im

re s

s

Writer

Database

Calc
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Annexure 1
Shortcut Key

Function

Ctrl+A

Select the whole document.

Ctrl+B

Makes text bold.

Ctrl+C

Copy the text.

Ctrl+D

Double Underline text.

Ctrl+E

Text is center aligned.

Ctrl+F

Find and Replace.

Ctrl+I

Makes text Italics.

Ctrl+J

Text is Justifed.

Ctrl+L

Text is left aligned.

Ctrl+R

Text is right aligned.

Ctrl+U

Underlines text.

Ctrl+V

Paste the text.

Ctrl+X

Move the text.

Ctrl+Y

Redo last action.

Ctrl+Z

Undo last action.

Left Arrow

Move cursor one character left.

Right Arrow

Move cursor one character right.

UpArrow

Move cursor one line up.

DownArrow

Move cursor one line down.

Shift+ LeftArrow

Move cursor with selection to the left.

Shift+ RightArrow

Move cursor with selection to the right.

Ctrl+ LeftArrow

Go to beginning of word.

Ctrl+ RightArrow

Go to end of word.

Home

Go to beginning of line.

End

Go to end of line.

Ctrl+Home

Go to start of document.

Ctrl+End

Go to end of document.

Shift+Home

Go and select from the beginning of line.

Shift+End

Go and select till end of line.

Insert

Insert mode on/off.

Page Up

Move one screen up.

Page Down

Move one screen down.

Ctrl+Shift+B

Subscript.

Ctrl+Shift+P

Superscript.
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Annexure 2
Unicode Tamil Keyboard Typing Chart
a
aa
i
ii
u
uu
e
ee
ai
o
oo
au
q

j
ஜ்
sh
ஷ்

ja
ஜ
sha
ஷ

jaa
ஜா
shaa
ஷா

அ
ஆ
இ
ஈ
உ
ஊ
எ
ஏ
ஐ
ஒ
ஓ
ஔ
ஃ

k
ng
s
nj
d/t
N
w
th
p
m
y
r
l
v
z
L
R
n

je
ஜெ
she
ஷெ

க்
ங்
ச்
ஞ்
ட்
ண்
ந்
த்
ப்
ம்
ய்
ர்
ல்
வ்
ழ்
ள்
ற்
ன்
jee
ஜே
shee
ஷே

ka
nga
sa
nja
da / ta
Na
wa
tha
pa
ma
ya
ra
la
va
za
La
Ra
na

க
ங
ச
ஞ
ட
ண
ந
த
ப
ம
ய
ர
ல
வ
ழ
ள
ற
ன

jo
joo
ஜ�ொ ஜ�ோ
sho
shoo
ஷ�ொ ஷ�ோ

ke
kee
ko
koo
kau

கே
கே
க�ொ
க�ோ
க�ௌ

we
wee
wo
woo
wau

நெ
நே
ந�ொ
ந�ோ
ந�ௌ

ji
ஜி
shi
ஷி

jii
ஜீ
shii
ஷீ

ju
ஜு
shu
ஷு

juu
ஜூ
shuu
ஷூ

WorkShop -6.14 : Type the following content in Tamil using any interface (Murasu / NHM / Azhagi).
kaNNan - கண்ணன்
sennai – சென்னை
thamiznaadu – தமிழ்நாடு
thaajmahaal – தாஜ்மஹால்
shaajakaan – ஷாஜகான்

joothpur – ஜ�ோத்பூர்
juulai – ஜூலை
shiiradi – ஷீரடி
hamadu – ஹமது
vaashingtan - வாஷிங்டன்

சென்னையில் உள்ள மாநகராட்சிப் பள்ளிகள் சென்னைப்பள்ளிகள் (Chennai Schools)
என்று அழைக்கப்படுகிறது. இந்த பள்ளிகளை நிர்வகிக்க சென்னை மாநகராட்சியில் கல்வித்துறை

(Education Department) இயங்கி வருகின்றது. ஒரு இந்திய ஆட்சிப்பணி (IAS) அதிகாரி, ஒரு கல்வி
அலுவலர் (Educational Officer) மற்றும் 10 துணைகல்வி அலுவலர்களுடன் (Assistant Educational
Officers – AEO) இத்துறை செயல்படுகிறது.
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Evaluation
Part – I

Choose the correct answer
1. Which is the opening screen of OpenOffice?
a. Star desktop

b. Star center

c. Star screen

d. Star window

2. Which option allows you to assign text, tables, graphics and other items to a key or key
combination?
a. Autoformat

b. Automatic

c. Auto text

d. Autographics

3. Which menu contains the Numbering option?
a. File		

b. Edit

c. Tools

d. Format

4. Which is displayed at the top part of the window?
a. Menu bar

b. Tool bar

c. Title bar d. Format bar

5. What is changing the default appearance of the text called?
a. Text formatting b. Page formatting c. Special formatting d. Paragraph formatting
6. Find & Replace option is available in which menu?
a. File		

b. Edit

c. Format d. Tools

7. Which button selects all instances of the search text in the document?
a. Find

b. Find All

c. Replace d. Replace All

8. What is the shortcut key to go to the start of the document?
a. Ctrl + Home

b. Ctrl + End

c. Home

d. End

9. What is the shortcut key for finding and replacing text in a document?
a. Ctrl + F1

b. Ctrl + F4

c. Ctrl + F5

d. Ctrl +F7

10. What is the short cut key for Undo?
a. Ctrl +E

b. Ctrl + U

c. Ctrl + Z d. Ctrl + n
Part – II

Very Short Answers
1. How do you insert pictures in to your document?
2. What are the different packages in OpenOffice Writer?
3. What is auto text in Writer?
4. How do you merge cells in a table?
5. State the differences between proprietary software and open source software.
Part-III
Short Answers
1. What is the difference between moving and copying text?
2. What are the different types of orientation?
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3. How do you insert rows and columns?
4. What are the different ways to save a document?
5. Write the steps to change the line spacing of text.
Explain in Detail
1.
2.
3.
4.

Part-IV

What are the different methods to change margin in Writer?
What is Header and Footer? How do you insert page numbers in footer area?
Write the steps to Find and Replace a word with another word in OpenOffice Writer?
Explain Page formatting in Writer.

WORD

OpenOffice writer

MEANING
A software used to create, edit, view, manipulate, transmit, store,
print and retrieve a text document.
A word processor component of OpenOffice.

Proprietary

Owner or ownership.

Word processor

Embedding

To surround tightly or firmly.
Highlighting is used to draw attention to important information
Highlighting
in a text.
Indents is the distance from the margin that is used to improve
Indents
the efficiency and readability of the paragraph.
Dynamic Data Exchange – a mechanism where source data can
DDE
be pasted into a destination with a link of the original.
The PasteSpecial option is used when only some aspects of the
Paste Special
data, like only its formatting or only value is send while moving
or copying.
This is the section at the top of the page where any references
Headers
like title, chapter name , author name can be given which gets
repeated on all pages.
This is the section at the bottom of the page where any references
Footers
like page number can be given which gets repeated on all pages.
This helps to assign shortcuts to some text which are frequently
AutoText
used.
This feature automatically checks the spelling while typing and
Auto spell check
underlines the misspelt words with wavy lines which can be
corrected later.
This feature automatically corrects the common misspellings
Automatic Correction
and typing errors automatically.
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Unit II

Office Automation Tools

CHAPTER

7

Part – I Working with OpenOffice Calc
7.1 Introduction to spreadsheet

Daniel Singer "Dan" Bricklin
The Father of Spreadsheet

Spreadsheet is a very useful office
automation tool to organise, analyse and
store data in a tabular form. Spreadsheet
was developed as computerized equivalent
to paper-based accounting worksheets.

Daniel
Singer
"Dan"
Bricklin (born 16 July
1951), often referred
to as “The Father of
the
Spreadsheet”,
is
the American co-creator, with Bob
Frankston, of the VisiCalc spreadsheet.
He also founded Software Garden, Inc.,
of which he is currently President of
Trellix Corporation, which is currently
owned by Web.com. He currently
serves as the Chief Technology Officer
of Alpha Software.

Spreadsheet users can adjust any
of the stored values and can observe the
effects on the calculated values. This
is called "What if " analysis. Modern
spreadsheet can have multiple interacting
sheets and can display data either as text
or numerals or in a graphical form.
7.1.1 Evolution of Spreadsheet

OpenOffice Calc is a popular open
source spreadsheet application maintained
by Apache Foundation. StarOffice calc
was the parent application of OpenOffice
Calc which was developed by a German
Company namely, Star Division in 1985.

Daniel Bricklin and Bob Frankston
developed the first spreadsheet called
“VisiCalc” in 1979 for Apple II. In 1982,
Lotus Corporation introduced “Lotus
1-2-3”; Lotus 1-2-3 was the first to
introduce cell names and macros. In 1987,
Microsoft Corporation introduced Excel.
Excel implemented a Graphical User
Interface (GUI) and the ability to point
and click using a mouse. There are lots of
other spreadsheet applications; Microsoft
Excel continues to be the most popular
spreadsheet software.

7.2 Working with OpenOffice Calc
Calc is the spreadsheet component
of OpenOffice. You can enter any kind of
data in a spreadsheet and then manipulate
this data to produce certain results.
Alternatively, you can enter data and
then use Calc in a ‘What If...’ manner by
changing some of the data and observing
the results without having to retype the
entire spreadsheet.
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• Functions: which can be used to
create formula to perform complex
calculations on data

First Spreadsheet

• Database functions: to arrange, store,
and filter data
7.3 Creating a new worksheet
A new spreadsheet can be created
through various methods. From windows,
select

VisiCalc ("Visible Calculator") was
the first spreadsheet for personal
computers, originally released for the
Apple II by VisiCorp. It is considered
that VisiCalc turned the microcomputer
from a hobby for computer enthusiasts
into a serious business tool, prompting
IBM to introduce the IBM PC, two
years later. It was sold over 700,000
copies in six years, and as many as 1
million copies over its history.

Start → All Programs → OpenOffice →
OpenOffice Calc (or)
From Star Center (Welcome Screen):
Double-click on “OpenOffice” icon the
desktop
Now, a welcome screen appears as shown
in Figure 7.1.
This open screen is called as “Star
Center”. Calc is one of the component of
OpenOffice. So, it may be invoked from
the “Star Center” by simply clicking on
the “Spreadsheet” icon. (or)

7.2.1 Features of OpenOffice Calc:
• Connecting with Excel - Ability to
open, edit, and save Microsoft Excel
spreadsheets

A new spreadsheet can also be
created by selecting File → New →
Spreadsheet from any OpenOffice
Application. After using any one of the
above said methods, OpenOffice Calc
window appears as shown in Figure 7.2.
The outline of the window is very similar to
other application windows of OpenOffice.
The main area of the Calc window is called
as “Work area” or “Worksheet”.

• AutoSum - helps you to add the
contents of a cluster of adjacent cells.
• List AutoFill - automatically extends
cell formatting when a new item is
added to the end of a list.
• AutoFill - allows you to quickly fill cells
with repetitive or sequential data such
as chronological dates or numbers, and
repeated text. AutoFill can also be used
to copy functions. You can also alter
text and numbers with this feature.

A worksheet is a grid of cells with a
programmable calculator attached to each
cell. When you open a new spreadsheet,
there are three worksheets available by
default. You can include more sheets and
organize them.

• Charts - helps you in presenting a
grvaphical representation of your data
in the form of Pie, Bar, Line charts and
more.
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Figure 7.1 Opening Screen (Star Center) of OpenOffice
3

1

5

6

7

2

4

8

11

10

9

Fig 7.2 OpenOffice Calc Window
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1. Title Bar
3. Menu Bar
5. Name Box /
Address Box
7. Formula Bar /
Input Line
9. Zoom

the current file, Save a file, Save a file in
another name, print file, Export file etc.

2. Control Buttons
4. Tools Bar
6. Quick Function
Wizard
8. Formatting
Properties
10. Scroll bar
11. Status Bar

Edit - menu contains the editing
commands like, cut, copy, paste, Undo,
Redo, Fill etc., Most of the menu items are
similar to Writer Edit menu. But, for Calc,
some special editing options are available
under this menu.

7.3.1 Parts of the OpenOffice Calc
Wi n d o w

View - menu contains the
commends which are used to modify the
environment of calc.

Appearance of the Calc window is
very similar to that of the Writer window.
The workspace of writer is a big blank
area. But, in calc, the grid of cells is the
workspace.

Insert – menu contains commands
for inserting various calc elements such
as cells, columns, rows, functions, charts
etc.,

7.3.1.1 Title Bar

Format – menu contains the
commands of various text and cell
formatting features.

Top of the window is called the
“Title Bar”. It is used to show the name
of the file and name of the application.
In OpenOffice calc, the default name for
the first unsaved worksheet is “Untitled1”.
When you save the file, Untitled will
change to the name in which you saved.

Tools – menu contains various tools
and functions such as spell check, protect
document, insert pictures, macros, etc.,
Data – menu contains the
commands to manipulate data in a
spreadsheet such as sort, filter, subtotal,
validity etc.,

7.3.1.2 Control Buttons:
In the right corner of title bar, (1)
minimize, (2) maximize / restore and (3)
close control buttons are available.

Window – menu shows display
options such as New Window, Close
Windows, Split and Freeze.

7.3.1.3 Menu Bar
Below the title bar is menu bar.
Most of the menus are very similar to
what you learnt in OpenOffice Writer.

Help – menu lists in-built help
features available with OpenOffice.

File - menu contains the commands
of all file management tasks like, Create
a new file, Open an existing file, Close

Under the menu bar, there are three
toolbars available by default. They are:

7.3.1.4 Tools Bar
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(1) Standard Toolbar

(2) Formatting Toolbar

(3) Formula bar

Standard Toolbar

Formula bar

Formatting Toolbar

Fig. 7.3 OpenOffice Calc Toolsbar
Standard Toolbar – contains
frequently used File, Edit and Data menu
commands as icons such as New Open
Save, Send, print, print preview, Cut,
Copy, Paste, Sorting, inserting chart etc.,

Name box / Address Box

Function
Wizard

Formatting Toolbar – contains
frequently used text and cell formatting
commands as such as changing font style,
font size, font colour, alignments, cell
formatting etc.,

Sum button

Input Line

Function
button

Fig. 7.4 Calc Formula bar

Formula bar – This is a very
important element in a spreadsheet. It
contains Name box, Function Wizard,
Sum button, Function button and Input
line (Refer Figure 7.4).

7.3.1.5 Scroll bar

Name box : It display the current
cell address

7.5)

Function Wizard : It is used to
insert function

screen up and down.

Sum button : It is used to quickly
insert sum function.

the screen left and right.

Spreadsheet window also has two
sets of scrolling bars (1) Vertical Scrollbar
and (2) Horizontal Scrollbar (Refer Figure

Vertical Scroll bar : It is used to move the
Horizontal Scroll bar : It is used move
Scroll buttons : used to move the screen

Input Line : This is used to show
the contents of the current cell. It always
shows actually what you typed in a cell. It
is also used to edit the contents.

to the relative distance.

106
Chapter 7.indd 106

3/20/2020 11:37:09 AM

Upward
Scroll arrow
Scroll button

Scroll button

Downward
Scroll arrow

Left Scroll
arrow

Right Scroll
arrow

Scroll button

Fig. 7.5 Calc Scrolling bar

7.3.1.6 Row, Column, Cell and Cell
Pointer

Cell address is the combination of
column heading and row number. For
example, the intersection of column B
and row 4 makes a cell B4. (Figure 7.7).
Every cell is thus identified by its unique
cell address.

Below the formula bar contains the
worksheet of work area which consit of
grid cells The worksheet has number of
rows and columns, where each column is
labelled as A, B, C, D ….. AA, AB, AC …..
and the rows are numbered from 1, 2, 3
…. (Figure 7.6).

Cell pointer is a rectangle box which
can be moved around the worksheet. The
cell in which the cell pointer is currently
located is known as “Active cell”. When
you type anycontent, it will appear in the
active cell. The address of the active cell
is displayed in the Name box / Address
box. Active cell’s column name and row
number will be highlighted. Using this
visual clue, one can easily identify an
active cell. Moreover, the contents of an
active cell will be displayed in the formula
bar.

OpenOffice Calc version 4.1.5
contains 1024 columns and 10,48,576
rows. Column heading starts from A and
end with AMJ. In the case of Microsoft
Excel 2016, there are 16,384 columns (A
to XFD) and 10,48,576 rows available.
Cell
Intersection of each row and
column makes a box which is called as
“Cell”. Each cell has its unique address.
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Row numbers

Column Heading

Cell Pointer
of
Grid

Cells

Fig. 7.6 Calc Rows, Columns, Cells
Current Cell Address

Highlighted Column Heading

Active all
Highlighted lighted Row
Number

Fig. 7.7 Cells, Rows and Columns
7.3.1.7 Worksheet tabs:
Active Sheet

Sheet Count
Sheet Navigation buttons

Fig. 7.8 Calc Sheet Tab
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At the bottom of the grid of cells
are the sheet tabs. By default there are 3
sheets “Sheet1”, “Sheet2” and “Sheet3”,
(Figure 7.8). When you open a new
worksheet, sheet1 is the default active
sheet. Active sheet tab will appear in white
colour. If you click on another sheet, it
will become active and its colour will turn
white. Multiple sheets can also be selected
by clicking the sheet and press the Ctrl
button (Ctrl + Click). Selected sheets will
turn to white colour.

Figure. 7.10 Rename Sheet dialog box
It shows the current name; delete
or overwrite the existing name and type
a new name; click OK button. New name
will be displayed on the sheet.

On the left of the sheet tab, four
navigation buttons are used to move
between worksheets (Figure 7.9).

7.3.1.8 Status bar
Below the sheet tabs and horizontal
scrolling bar is the “Status Bar”. It shows
the current status of the worksheet (Refer
Figure 7.11).

3

1

2

Sheets count: Displays current
serial number of the sheet / total number
of sheets available.

4

(1) Move to the First sheet

Page Style: Displays the page style
of the current sheet. To make changes, just
double-click on “Default” and it will show
you the “Page Style” dialog box, which is
used to change the margin, orientation,
paper size, inserting header, footer, border
style etc.,

(2) Move to the previous sheet
(3) Move to Next sheet
(4) Move to the Last sheet
Fig. 7.9 Calc Sheet tab and Navigation
buttons
Left corner of status bar shows the
total count of sheets and the present active
sheet number. For example, if the status
bar shows sheet 3/12; 3 refers to the serial
number of the current sheet and 12 refers
to the total number of sheets available.

Selection Mode: Displays the
selection mode of the current sheet. There
are three modes available to select the cells
of a worksheet. They are, Standard (STD),
Extend (EXT) and Add (ADD).
Unsaved Changes: An asterisk ( * )
symbol indicates the changes made in the
worksheet but not yet saved. If you have
saved your changes, it will disappear.

Every sheet name can be renamed.
To rename a sheet, just double-click on
the sheet, which will show a small box as
shown in Figure 7.10.
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Sheets count

Zoom

Selection Mode

Page Style

Unsaved Changes

Fig. 7.11 Calc Status bar

7.4 Working with Data

cell information

it has numbers and symbols. In general,
data types are classified as:

When you open a new spreadsheet,
the cell pointer is located in cell A1. So,
the Cell A1 is known as “Home Cell”. Cell
pointer can be moved anywhere in the
spreadsheet using the direction keys.

Alphabetic data type – consists
of alphabets only Numeric data type –
consists only of numbers (whole number
or fractional numbers) Alphanumeric
data types – consists of a combination of
alphabets and numerals Date data type
– consists only of date Time data type –
consists only time

“Tab key” is used to move the cell
pointer towards the right side or forward
direction. “Shift+Tab” is used to move
backward i.e. from right to left in a row.
“Enter” key is also used to move the cell
pointer. Enter moves the cell pointer to a
cell below the current cell i.e. downwards.
Four “direction keys” are used to move the
cell pointer anywhere in the worksheet.

7.4.1.1 Entering Numbers:
Any numeric data can be entered
in a spreadsheet. Entered numbers are
aligned to the right side within the cell
by default. Negative numbers may be
entered with a minus sign or within
brackets (Refer Figure 7.12). If you enter
any number within the bracket, it will be
changed as negative number i.e., number
prefixed with minus. If any number starts
with 0 (zero); Calc will drop the leading
zero.

7.4.1 Entering Data:
Any data can be typed directly in any cell
of the worksheet. But, the cell in which
you type data should be an active cell.
So, move the cell pointer to a particular
cell to make it active cell; or click any
cell to make it active cell. Then, start
typing any data. When you type data,
spreadsheet recognises the type of data
entered in cells.
Data types:
Data are in different types. Data
are made up of alphabets, numbers, Date
and time is another data type even though

Figure 7.12 Entering data
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7.4.1.2 Entering Text:

(Figure 7.14). This is a visual clue to know
whether the date is accepted or not.

Unlike numbers, any character can
be entered as data in Calc. Entered text will
be aligned to the left side within the cell
by default. When you enter any numeric
value, if it has aligned left, it is understood
that the entered content is not a number.
If there is any number that starts with a
single quote, calc converts that number to
text (Refer Figure 7.13).

A Date format can be changed to any
other valid form using “Cell Formatting”
dialog box, and it will be discussed later.

Fig. 7.14 Entering Date
Like dates, for entering time, calc
follows the general format HH:MM:SS.
where HH, MM and SS represent hours,
minutes and seconds respectively.
Different Date Formats
Figure 7.13 Entering Text

Order styles

7.4.1.3 Entering Date and Time:
Before entering date, ensure the
format of your system date. Calc accepts
date as per the system date format. If your
system has American date format i.e.
month-date-year; you should enter dates
in Calc spreadsheet as mm/dd/yy. If your
system follows the Indian date format,
date should be entered as dd/mm/yy form
in Calc. Only the correct form of date is
accepted by Calc as a date.v

DD/MM/YYYY

YYYY/MM/DD

MM/DD/YYYY
DD/MM/YYYY
and
MM/DD/YYYY

For example: If your system has
American Date format, 18th December
2017 should be entered as 12/18/17. As
soon as the date is typed in the correct
form, the entered date will be aligned on the
right side within the cell, and if you place
the cell pointer in that cell, the formula
bar shows your date as “12/18/2017”

DD/MM/YYYY
and
YYYY/MM/DD

Countries
Asia (Central, SE,
West), Australia, New
Zealand, parts of Europe,
Latin America, North
Africa, India, Indonesia,
Bangladesh and Russia
Bhutan, Canada, China,
Koreas, Taiwan, Hungary,
Iran, Japan, Lithuania,
Mongolia.
United States, Federated
States of Micronesia,
Marshall Islands
Malaysia, Nigeria,
Philippines, Saudi Arabia,
Somalia
Afghanistan, Albania,
Austria, Czech Republic,
Germany, Kenya, Macau,
Maldives, Montenegro,
Namibia, Nepal,
Singapore, South Africa,
Sri Lanka, Sweden.
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Value in
Column B

Value in
Column C

Formula
in
Column D

Result in
Column D
Operator

In Calc, you can enter
formulas in two methods, either
directly into the cell or at the
input line. Formula in Calc may
start with equal (=) or plus(+)
or minus(–) sign followed
by a combination of values,
operators and cell references.
But, as a general practice, all
formulas should start with an
equal sign. If any formula starts
with a + or –, the values will
be considered as positive or
negative respectively.

Arithmetic operators are symbols for
performing simple arithmetic operations such as
addition, subtraction, multiplication, division etc.,
These operators return a numerical result.

Name

After entering the data
in worksheet, you can perform
calculations on the data in the
worksheet. In order to create
formulae, you first need to
know the syntax that describes
the format for specifying a
formula.

7.5.1.1 Arithmetic Operators

Operator

7.5 Creating Formulae

+
*
/
^
%

Addition
Subtraction
Multiplication
Division
Exponent
Percent

98
125
25
90
25
600

25
25
5
10
2

= B3 + C3
= B3 – C3
= B3 * C3
= B3 / C3
= B3 ^ C3
= B3 * 35%

123
100
125
9
625
72

Percentage (%) operator shows percentage of the content.

Table 7.1 List of Arithmetic Operators
Formula bar shows the formula what the user
had entered. But, the cell shows the resulted value
(Figure 7.15).
Formula Entered

7.5.1 Operators
Operators are symbols
for doing some mathematical,
statistical
and
logical
calculations.
Combination
of values, operators and
cell references is called as
“Expression”. Calc supports a
variety of operators which are
categorized as:
(1)

Arithmetic Opertors

2)

Relational Operators

(3)
(4)

Reference
Operators
Text Operator

Figure 7.15 Percentage Operator
7.5.1.2 Relational Operators
Relational operators are symbols used for
comparing two values such as greater than, less than,
equal to etc. The relational operators are also called
as "Comparative operators". These operators return
either a True or a False.
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Formula in
Column D

Result in
Column D

98

100 =B3>C3

FALSE

85

72

Value in
Column B
Value in
Column C

Name

Operator

Greater
than
Greater
than
>=
or equal
to
>

Reference operators are used to
refer cell ranges. A continuous group
of cells is called as “Range”. There are
three types of reference operators that
are used to refer cells in calc; they are
(1) Range Reference Operator, (2) Range
Concatenation (3) Intersection Operator.

=B3>=C3 TRUE

Range Reference Operator

< Less than 54

24

=B3<C3

Less than
<= or equal 55
to

55

=B3<=C3 TRUE

=

12

=B3=C3 TRUE

45

=B3<>C3 TRUE

Equal to 12
Not equal
<>
54
to

7.5.1.3 Reference Operator

FALSE

Colon (:) is the range reference
operator. It is used to group a range of
cells. An expression using a range operator
has the following syntax:
reference left : reference right
where reference left is the starting cell
address of a linear group of cells or upper
left corner address of a rectangular group

Table 7.2 List of Relational Operators of
cells.

Reference right is the last cell address of a
linear group or lower right corner address
of a rectangular group of cell.

Figure 7.16 Entering Relational Operator
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Example:
(i)

Linear group of cells A1, A2,A3,A4,A5 is referred as A1:A5

(ii) Rectangular group of cells A2, A3, A4, ….. B2, B3, B4,….D5, D6 is referred as
A2:D6 (Refer Figure 7.17)
Highlighted Columns (Selected)

Highlighted Row (Selected)

Range of Cells

Figure 7.17 Range of selected cells
Name box shows the reference A2:D6 corresponding to the cells included in the
drag operation with the mouse to highlight the range.
Reference concatenation operator:
Concatenation means joining together. Tilde (~) symbol is used as a concatenation
operator in calc. An expression using a concatenation operator has the following syntax:
reference left ~ reference right
Example:
If you want to find the sum of the values from A1 to A6 and C3 to F3. The formula
is =SUM(A1:A6 ~ C3:F3)
SUM is a function to find the sum of a group of values.
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Intersection Operator:
Intersection operator is used to join two set of groups. It is very similar to Range
concatenation operator. The intersection operator is represented by an exclamation
reference left ! reference right
Example: (A2:D3 ! B2:E4)
Range 2 B2:E4

Range - 1 A2 : D3
A

B

C

D

E

F

1

A1

B1

C1

D1

E1

F1

2

A2

B2

C2

D2

E2

F2

3

A3

B3

C3

D3

E3

F3

4

A4

B4

C4

D4

E4

F4

Intersection of
Range 1 and
Range 2

B2:D3

Figure 7.19 Intersection operator
The result of (A2:D3 ! B2:E4) is referred by the range B2:D3, because these cells are
both inside A2:D3 and B2:E4 (Refer Figure 7.19 and 7.20).

Figure 7.20 Worksheet with Intersection operator
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7.5.1.4 Text Operator:
In Calc, “&” is a text operator which is used to combine two or more text. Joining two
different texts is also known as “Text Concatenation” (Refer Figure 7.23). An expression
using the text operator has the following syntax:
text reference1 & text reference2

Figure 7.21 Text operator
When arithmetic operators are used in a formula, Calc calculates the results using
the rule of precedence followed in Mathematics. The order is:
I.

Exponentiation ( ^ )			

II.

Negation ( - )

III.

Multiplication and Division ( *, /)

IV.

Addition and Subtraction (+, -)

Here is an example to illustrate how to create a formula:
Illustration 1:
Create a Marks worksheet with the following data:
Reg. No
12001
12002
12003
12004
12005
12006
12007
12008
12009
12010

Name
Jayashree J
Kowsalya T
Muskan S
Ashia Stephy R
Vennila T P
Deepika M
Tharani J
Thulasi A
Ayisha B
Jenifer A

Tam
147
156
149
168
199
187
165
143
120
145

Eng
136
148
165
144
198
141
102
169
138
135

CS
105
149
123
146
150
98
100
88
109
95

Com
163
147
168
192
200
130
192
176
182
180

Acc
162
179
179
167
200
178
192
173
167
185

After completing the data entry, your worksheet will look as shown in Figure 7.22.
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Small red triangle indicates the column width
is not enough to display the entire text

Figure 7.22 Worksheet Illustration
7.5.2 Construction of formula
To construct a formula, follow the steps below:
•

Cell pointer should be in the cell in which you want to display the result.

•

Formula should begin with an = sign.

•

In a formula, use only cell reference (cell addresses) instead of the actual values within
the cells.

•

While constructing a formula, BODMAS rule should be kept in mind.

•

General Syntax of constructing a formula is: = cell reference1 <operator> cell
reference2 <operator> ……………….

•

Cell references are of two types (i) Relative cell reference (ii) Absolute Cell reference.

•

If you refer cell addresses directly while constructing formulae, it is called as “Relative
Cell reference”.

•

Examples of Relative Cell references:
Adding values of A1, B1, C1, D1

=A1+B1+C1+D1

Subtract E4 from H3

= H3 – E4

Multiply A5 and B5

= A5 * B5

Average of G1, G2, G3, G4

=(G1+G2+G3+G4)/4
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•

In the above table, all cell references are “Relative cell references”.

•

While writing a formula, if you use the $ symbol in front of a column name and row
number, it will become an “Absolute Cell reference”.

•

•

Examples of Absolute cell references:
Adding values of A1, B1, C1, D1

=$A$1+$B$1+$C$1+$D$1

Subtract E4 from H3

= $H$3 – $E$4

Multiply A5 and B5

= $A$5 * B5

Average of G1, G2, G3, G4

=($G$1+G2+$G$3+G4)/4

In an expression, all cells need not necessarily be relative or absolute. You can mix
both type of references.

•

The following section explains the use of relative cell reference. About “Absolute cell
reference”, you will be learn later in this chapter.

Finding Total to the above Illustration:
•

Move the cell pointer to H2 (Total column)

•

Type the following formula; after entering the formula, press “Enter” key
= C2+D2+E2+F2+G2 (Refere Figure 7.25)

•

Now, you will get the sum of all the values of C2, D2, E2, F2 and G2

•

The above-mentioned formula clearly stated that, how worksheets are working with
cells.

•

While referring to the cell addresses in a formula, the spreadsheet reads the value
inside the cell that you refer. This is a good practice of constructing a formula. Because,
if you change any value, the spreadsheet recalculates with that new value.
After entering a formula the result is display as in Figure 7.23
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Figure 7.23 Constructing formula in Worksheet

7.6 Save, Close and Open the Worksheet:
7.6.1 Saving Worksheet
The process of saving a worksheet is very similar to saving a document. Steps to
save a worksheet are as follows:
Step 1: File → Save (or) Ctrl + S (or) Click “Save” icon on the standard tool bar.
Step 2: If the spreadsheet has not been saved previously, the Save As dialog box will
appear.
Step 3: Type the name in “File Name” list box. OpenOffice Calc Spreadsheets are stored
with extension .ods by default.
Step 4: Click “Save” button.
After clicking the save button, the given file name is displayed in the title bar as shown in Figure 7.24

File Extension:
A file extension or file name extension helps to identify the type of file.
Following table gives the file extension of commonly used files.
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Familiar File Type

Extension

Text Files

.txt

Microsoft Word Documents

.doc / .docx

OpenOffice Documents

.odt

Microsoft Excel

.xls / .xlsx

OpenOffice Calc

.ods

Microsoft PowerPoint

.ppt / .pptx

OpenOffice Impress

.odp

Executable Files / Applications

.exe

Web Pages

.htm / .html

Portable Document Format

.pdf

Photos

.jpg / .jpeg (Joint Photographic Experts Group)

Animated Images

.gif (Graphical Image Format)

Audio

.mp3

Audio / Video

.mp4
File Name

Application Name

Figure 7.24 Saved Spreadsheet
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Note: The saved file is stored in the

7.6.3 Closing a Worksheet

"Document folder" by default.

After saving the worksheet; it
remains open. So, you can continue to
work with the spreadsheet. When the work
is finished, you should save using File →
Save (or) Click “Save” icon (or) Ctrl + S
and then to close the worksheet using File
→ Close command (or) Press Ctrl + W.

What is save?
Technically saving is a process of
transferring or shifting contents
from primary memory (RAM) to
Secondary storage medium such as
Hard disk, Pen drive, memory chip
etc.

7.6.4 Opening an existing worksheet
7.6.4.1 Using Open dialog box

7.6.2 Auto Save:

To reopen an existing worksheet,
the File → Open command (or) “Open”
icon (or) Ctrl + O can be used. An Open
dialog box appears as shown in Figure 7.25
that is similar to “Save As” dialog box.

The OpenOffice saves a file at
regular intervals. This is called as “Auto
Save” feature. The default time interval
is 15 minutes. It can be reduced even to
one minute. If any unexpected shutdown
occurs, this feature will recover your
file.

The name of the file to be opened
can be chosen from the list or folder in
which worksheet has been saved.

Default location

Available Files
and Folders

Read only
Option

Figure 7.25 Open Dialog box
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7.6.4.2 Using Recent documents
OpenOffice keeps a list of recently
opened files. File → Recent Documents
option can be used to open an existing
worksheet from the list as shown in
Figure 7.26

•

Move the cell pointer to the cell in
which you want to paste.

•

Select Edit → Paste or Click “Paste”
icon or Press Ctrl + V

7.7.2 Cut and Paste Data
•

Select the cell or cells you want to cut

•

Select Edit → Cut or Click “Cut”
icon from the standard toolbar or
Press Ctrl + X

•

Move the cell pointer to the cell in
which you want to paste.

•

Select Edit → Paste or Click “Paste”
icon or Press Ctrl + V

List of recently used files

Figure 7.26 List of Recent Documents
7.7 Copy, Cut and Paste

7.7.3 Copy and Paste Formula
•

The process of Copy and Paste data is
used for copying formula.

•

When you copy a formula from one
cell to another cell, the address of the
pasted formula will change according
to its row. This is called “Relative Cell
Reference” (Refer Figure 7.27).

•

Example:

7.7.1 Copy and Paste Data
•

Select the cell or cells you want to
copy

•

Select Edit → Copy or Click “Copy”
icon from the standard toolbar or
Press Ctrl + C

While pasted it becomes = B3* C3

Row number
Originally typed formula = B2*C2
Figure 7.27 Copy and Paste formula to multiple cells
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7.7.4 Copy a formula from one cell and paste it in multiple cells:
(For illustration 1 - Refer 7.23)
Step 1: Copy the formula from H2 using Ctrl + C or Edit → Copy (or) click “Copy” icon.

Figure 7.28 Copy and Paste forumla to Multiple cells
Step 2: Select all cells (i.e. H3 to H11) in which you want to paste this addition formula.
Step 3: Paste the copied formula using Ctrl + V or Edit → Paste (or) Click “Paste” icon.
Self Practice:
1.

Open the spreadsheet which was created in Illustration 1.

2.

Add one more column heading “Average” in I1

3.

Create a formula to find the average of all marks in I2.

4.

Apply the formula to the remaining cells.

5.

Save the changes and close the file

7.8 Auto Fill Feature:
You have learnt how to copy and paste a formula from one cell to other cells in the
previous section. The process of Copy and paste can be replaced by a click and drag and it is
called as “Auto Fill”. This is an alternate way to copy and paste.
Auto Fill feature fills the contents from one cell to all the dragged cells. The content may
be a data or formula. If you fill a relative formula, all the addresses of filled formulae will be
changed.
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Drag
fill handle

Drag Fill Handle

Drag Cells

Figure 7.29 Drag fill handle
Cell pointer’s “Drag fill handle” is
used to auto fill. Just click and drag this

Generated series

handle to fill the contents. It can be dragged
towards right or down. Same can be achieved
by Edit →Fill → Down (or) Edit → Fill →

Figure 7.30 AutoFill series

Right.

7.8.2 Generating series using command

7.8.1 Auto Fill Series:

Edit → Fill → Series Command is used
to generate different set of series. Before
using this feature, a set of cells should be
selected. Using Fill Series feature, you can fill
series of values at any direction. (Remember
that, auto fill only fills either right or down).
Refer Figure 7.31

Auto Fill is also used to generate a
series of values. For example, if you want to
generate 1,2,3……. up to some length; it can
be done by a simple click and dragging over.
Generating whole number series:

Direction : Down / Right / Up / Left
(Selected cell direction will be default)

(Refer Figure 7.30)
Step 1:In cell A1, type as 1 (one) and press

Series type :

enter

Linear : To generate a sequence of series
(Example 2,4,6,8,10…….)

Step 2:click A1 to place the cell pointer

Growth : To generate multiplication series
(Example 2,4,8,16,32,64……)

Step 3:Click “Drag Fill Handle” of cell
pointer; now the mouse pointer becomes a

Date : To generate date series (when you
select date as series type; time unit section
gets enabled)

small +
Step 4:Drag over the cells; while dragging,
the generated values will be displayed.

AutoFill : To generate a continuous series
of values (1,2,3,…….). When you select
“AutoFill”, Time unit section, End value and
Increment text boxes become disabled.

Step 5:Release the mouse pointer. Selected
cells will be filled with series of values.
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Time Unit: (Enabled only when you select the series type as “Date”
Day

: To generate date series day-wise

Weekday : To generate date series weekday-wise
Month

: To generate date series month-wise

Year

: To generate date series year-wise

Start Value:
•

Initial value of the series should be typed

End Value:
•

End value of the series should be typed

•

If you fail to specify the end value, series will be generated upto the selected cells.

Figure 7.31 Fill series dialog box
•

If your selection is less than the specified end value, series will be generated only upto the
selected cells.

Increment:
•

It is a middle value between the first and second value of your series. So, the next value
(Third value) of the series will be generated based on this value.

•

If you want to generate a decreasing order series, negative value should be specified as an
increment value.
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Self Practice:
(i) Generate Even number series from 2 to 20
(ii) Generate a series of 5, 10, 15, 20 ……. upto selected cells.
(iii) Generate a series of 2,4,8,16,……… 2048
(iv) Generate a series of 33, 30, 27 …… upto 3
(v) Assume, today is Friday and generate next 25 Fridays (Date series).
7.8.3 Date Arithmetic:
Manual date calculations can be tricky because you have to keep track of the number
of days in a month. In spreadsheets, date calculations become very simple. Here you can
add a number to a date and arrive at a new date, find the difference between two dates
and use a wide variety of function and formats to get what you want.
For example, enter a date 02/26/2018 in a cell, say A2. Suppose you want to calculate
the date 80 days after this date. To do so, enter the formula, = A2 + 80, in another cell, say
A4.
The date 05/17/18 appears in the cell.
Find out how many days you were born?
•
•
•

Type today’s date in first cell.
Type your birth date in second cell.
Type the following formula in third cell = first_cell_reference – second_cell_
refernce
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Part – II Editing and Formatting Worksheet
7.9 Inserting Columns, Rows and Cells
In Calc, Columns, rows and cells can be inserted individually or in groups.
7.9.1 Inserting a Column:
When you insert a new column, it is inserted to the left of the current column. The
location of the cell pointer present, is the Current column. In Calc, you can insert a new
column anywhere in the worksheet.
Step 1: Select the column where a new column should be inserted.
Step 2: Right-click on the selected column name that you selected. A pop-up menu
appears.
Step 3: click the “Insert Columns” option from the menu.
Now, a new column will be inserted to the left of the current column.
To insert column click
Right Click here

Pop - up Menue appears
Figure 7.32 Insert Column pop-up menu
A new column can also be inserted using Insert →
(Refer Figure 7.32)

Columns command.
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Click "Insert" menu
Select "columns" option

Figure 7.33 Insert Column menu bar
Practical Practice:
1.
2.
3.
4.
5.
6.

Open the spreadsheet which was created in Illustration 1.
Insert a new column between column E and F
Give the heading as “Eco” and Enter the Economics marks for all the students
Insert one more column between the columns, Name and Tamil marks.
Give the heading as “Date of Birth” and Enter the date of birth for all the students.
Save the changes and close the file.

7.9.2 Inserting Rows
When you insert a new row, it is inserted above the current row. The location of the
cell pointer present is the current row. In Calc, you can insert a new row anywhere in the
worksheet.
Step 1: Select the row where a new row to be inserted.
Step 2: Right-click on the row number, a pop-up menu appears
Step 3: click “Insert Rows” option from the menu.
Now, a new row will be inserted to above the current row.
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Right Click here to select the row as well as get popup menu

Select "Insert Rows"

Figure 7.34 Insert Rows popup menu

Insert → Rows command is used to insert a new row. Refer Figure 7.35
Click "Insert" menu

Select "Rows" option

A new "Row"
inserted
above the
selected row

Figure 7.35 Insert Rows menu bar
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Self Practice:
1.

Open the spreadsheet which was created in Illustration 1.

2.

Insert 8 rows one by one, then insert the following student details

3.

Save the changes and close the file.

Reg. No
12101
12102
12103
12104
12105
12106
12107
12108

Name
Sarika S
Jewees Celcya J
Yuvarani T
Meharunisha I
Priya W
Vijaya Vasavi K
Deepika B
Viji V

Date of Birth
26/05/2001
11/04/2001
27/06/1999
30/05/2001
07/03/2000
03/06/2001
14/03/2001
19/04/2001

Tam
145
102
172
132
130
198
120
137

Eng
135
165
130
146
172
175
182
173

CS
145
134
107
112
100
149
103
128

Eco
125
95
155
185
92
148
144
148

Com
180
180
162
192
162
158
107
125

Acc
196
134
130
176
155
135
186
177

7.9.3 Inserting Cells
•

To insert a new cell between two existing cells, just right-click on any existing cell

•

From the pop-up menu, select “Insert” option Figure 7.36 Insert cells

•

The “Insert Cells” dialog box appear with four options
i) Shift cells down

ii) Shift cells right

iii) Entire row

iv) Entire Column

•

Any one of the four options is selected.

•

Selecting “Shift cells down”, inserts a new cell in the present location and the existing
cells are shifted downwards.

•

Selecting “Shift cells right”, inserts a new cell in the present location and the existing
cells are shifted towards right.

•

Selecting the “Entire Row” or “Entire Column” option, inserts a new row or a new
column.v

Figure 7.36 Insert cells
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7.9.4 Inserting multiple columns or rows

Inserting a new Column or
row is really possible in a
Spreadsheet?

Multiple columns or rows can be inserted
at once rather than inserting one at a time.
•

All spreadsheets have some
specific number of rows and columns,

Select multiple rows or columns for

then how can you insert an additional

insertion.
•

row or column. Is this possible?

Follow steps as in 7.9.1 and 7.9.2

Technically this is NOT POSSIBLE.

7.9.5 Inserting Columns, Rows and Cells

Additional column, row or
even cell cannot be inserted in any
spreadsheet. When you insert a
column or row, the contents within
the column or row will be shifted to
the next column or row. But visually
it is felt that a new column or row has
been inserted.

using “Insert Cells” Toolbar
•

Insert Cells floating toolbar is also
used to insert cells, rows and columns

•

Click View → Toolbars → Insert Cell

•

A tiny floating toolbar appears on the
screen with four icons. Using these

7.10.1 Delete single column or row

icons, you can insert cells, rows and

A single column or row can be
deleted by using the mouse:

columns. Refer Figure 7.37

Insert Rows
Insert
Columns

•

Select the column or row to be deleted.

•

Choose Edit →Delete Cells from the
menu bar.
(Or)

Insert cell right
Insert cell down
Figure 7.37 Insert cell tool bar

7.10 Deleting columns and rows

•

Right-click on the column or row
header.

•

Choose Delete Columns or Delete
Rows from the pop-up menu.

7.10.2 Delete multiple columns or rows
A single or multiple columns or

Multiple columns or rows can be
deleted at a time. Refer Figure 7.38

rows can be deleted.
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•

Select the required columns or rows

Deleting Column or Row is
not Possible

for deletion.
•

Right-click on the selected columns

Same as inserting column or
row, Deleting a column or row is
also not possible. No one can delete
any column or row in a spreadsheet.
When you delete a column or row, all
the contents will be removed from
the column or row. Actually, this is
also another kind of deleting contents
from a column or row.

or row.
•

Choose Delete Columns or Delete
Rows from the pop-up menu or Edit
→ Delete Cells.

Practical Practice:
1.
2.

Open the spreadsheet which was
created in Illustration 1.

7.11 Formatting Worksheet

Delete the details of any 3
students. Save the changes and
close the file.

Formatting Data in a cell gives
additional effect to the text. Additional
effect includes changing the font style,
font size, automatic wrapping, bold,
underline, italic etc. The data in Calc
can be formatted in several ways. Using
formatting icons can be used.

Selected columns

To Delete Selected
columns; click
here

Figure 7.38 Delete multiple columns
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7.11.1 Text Formatting
Making the cell contents as bold, italics, underlined, changing font style, size,
colour etc., comes under text formatting. All text formatting options are available as icons
in Formatting toolbar learnt in OpenOffice Writer. Figure 7.39(a) Text Formatting Toolbar
Bold Italic

Moving handle
Styles

Font Styles

Align Justify
Center Align
Figure 7.39(a) Text Formatting Toolbar

Font style

Used to change
Font style

Font size

Used to change
Font size

Bold

Ctrl + B

Used to make
the data as
Bold

Italic

Ctrl + I

Used to
italicize data

Underline

Ctrl + U

Used to
underline the
data

Left Align

Ctrl + L

Left Align data
within a cell

Ctrl + R

Right Align
data t within a
cell

Ctrl + E

Center the
data within a
cell

Ctrl + J

Align the data
evenly both on
left and right
side of a cell

Center Align

Justify

Merge cell

Underline

Fond Size

7.11.2 Number formatting

Formatting Keyboard Description
Option
Shortcut

Right Align

Merge
Cells

Number formatting options are
used to visually change the format of
a numeric content. These formatting
changes are only for visual as, it does not
change its original value. For example, To
display a number as currency form use
Number format: Currency.
Number format: Currency will be used as
shown Figure 7.39(b).
Percentage

Delete
Decimal

Add
Decimal
Standard
Figure 7.39(b) Formatting toolbar

Currency

Number
Format

Keyboard
Shortcuts

Currency Symbol
Ctrl+Shift+4
Percent
Ctrl+Shift+5
Standard
Ctrl+Shift+6
Add Decimal Place
Delete Decimal Place

Makes selected
cells as a single
cell
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Practical Practice:
1.

Open the spreadsheet which was created in Illustration 1.

2.

Align all headings as center and make them bold.

3.

Align all Register numbers and marks in center

4.

Apply different font styles to the entire worksheet.

5.

Save the changes and close the file

Part – III Working with Functions and Chart
= SUM (range 1; range 2; range 3……
range n)

7.12 Functions

If you want to know the sum of the
values in A1, A2, A3, A4 and in A5, Place
your cell pointer in A5 and directly type
the formulae as follows.

OpenOffice Calc has more than 350
functions under 11 categories. Functions
are predefined formulae already available
with Calc. They are used to perform
several frequently done calculations.
Every function has a unique name and
a prototype. Functions are categorized
according to their functionality. For
example, the functions such as Sum,
Average, Sin, Cos etc., are categorized as
“Mathematical Functions”.
7.12.1
Inserting
Worksheet:

Functions

= SUM (A1:A4)
While inserting a function the
following points should be kept in mind.

into

A function can be inserted by
(i) Direct Insert Method or (ii) Using
Function Wizard method.

1.

A function should begin with an equal
sign.

2.

Use proper name for the function to
be used.

3.

Arguments should be given within
the brackets as per the syntax. Each
function has a unique argument list.

4.

Press “Enter” key after typing the
function.
Funciton name
Funciton arguments

7.12.1.1 Direct Insert method:
If you know the function name and
its syntax, it can be directly typed in any
cell of the worksheet.

= Sum (A1 : A4)
Equal
Sign

For example, SUM is the most
frequently used function to add a set of
values. The syntax of the SUM ( ) is

First
Cell

Last
Cell

Figure 7.40 Function Syntax
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Self Practice:
1.

Open the spreadsheet which was created in Illustration 1.

2.

Delete all the formula in Total column.

3.

Use SUM function to add all the marks of each student.

4.

Save the changes and close the file

7.12.1.2 Using Function Wizard method
A function can inserted using Function Wizard in Calc. Function Wizard is a dialog
box provides the step-by-step procedure to insert a function. Function wizard can be
invoked by clicking the Function Wizard icon on the Formula bar (or) Insert → Function
(or) Ctrl + F2. Refer Figure 7.41
Function category drop down list box:
Function Wizard has two tabs viz. Functions and Shortcuts. In Functions Tab, the
list of categories is available in Category drop down list box. In Calc, the functions are
categorized into 11 types. They are,
1. Database
5. Logical
9. Spreadsheet

2. Date and Time
6. Mathematical
10. Text

3. Financial
7. Array
11. Add-in

4.
8.

Information
Statistical

Function Category List box

Function Name
with arguments

List of Functions

Short description
about the Function

Figure 7.41 Function wizard
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About POWER ( ) function:

If you select any particular category, the
Functions list box shows the functions
which belongs to the selected category. If
“All” is selected under category all functions
in calc is displayed in alphabetical order.
Refer Figure 7.42

POWER ( ) is a function which is
used to calculate power of an exponent
value of a number. This function is
categorized as a Mathematical function.
There are two inputs needed to find the
power value of a number. They are, Base
value and exponent value. For example,
to find the value of 25 to the power of 2
(252) where 25 is the base value, 2 is the
exponent value.

Selected Category

List of Functions

The syntax of POWER( ) is = POWER
(Base ; Exponent)
Both Base and Exponent are
arguments. In Calc, arguments are
separated by a semicolon.
Inserting POWER( ) in a worksheet:
Step 1: In cell A2 type the base value 25
Step 2: In cell B2 type the exponent value
2

Figure 7.42 Function wizard – Function
Category list box

Step 3: Move the cell pointer to C2; in
which you want display result.

Function Description
When you select a function, the
function wizard shows the function name,
syntax and a small description about the
function on the right side of the dialog
box. Refer Figure 7.43

Step 4: Click fx icon from Formula bar
(or) choose Insert → Functions
(or) Press Ctrl + F2.
Step 5: Pull down category list box, Choose
“Mathematical”

Inserting a function using Function
Wizard: (with Cell Reference)

All function under Mathematical
category is displayed in the
“Functions” list box

The following steps explains to insert
POWER( ) function in a cell.
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Step 6: Scroll the “Functions” list box and select “POWER( )”. The function wizard shows the
description about the selected function on the right corner of the dialog box
Step 7: Click “Next” command button. Now, Function wizard appears as shown in the Figure
7.44.
Selected Category
Function
Name

Function
Syntax

Description about
Function

Selected
Function

Figure 7.43 Function wizard dialog box

.

Step 8: Click on the cell which is contains the base value (A2).
Now, the minimized wizard shows the cell address you have selected (A2). Refer Figure 7.45

Function button
(Nesting of Functions

Select Cell
button
Select Function

Figure 7.44 Function wizard
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Function name in input box

Maximize

Shrinked Function wizard
with Function name

Selected Cell

Figure 7.45 Function wizard
Step 9: Click “Maximize” button to display full wizard. Now, Function wizard appears as
shown in Figure 7.46

Cell address with
contains Base

Formula for finding
Power

Figure 7.46 Function wizard

Base box shows the cell address which contain base value.
Step 10: Directly type the cell address which contains exponent, in Exponent box; or
repeat steps 7, 8 and 9.
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After entering Base and Exponent cell references, the function wizard appears as shown
in Figure 7.47

Result to the
Function
Base value cell
address
Exponent value cell
address
Formula

Result to the
formula

Figure 7.47 Function wizard
The formula box displays the syntax of the function with input values and Result box
displays the result value.
Step 11:

If the result is correct, click “OK” button else click “Back” button to display the
previous page of this wizard.

Inserting a function using Function Wizard: (with direct values)
In the previous example, Cell addresses are used for Base and Exponent values. In Calc,
direct values can be used instead of using cell reference (i.e. cell address) to find the same
result.
In this case, type base and exponent value instead of cell address. Function wizard
displays the result in the current cell. Refer Figure 7.48 shown below.
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Vaues typed

Function Formula bar
with values

Result of the function

No more steps

Figure 7.48 Function Wizard (with Direct values)
Self Practice:
1.

Open a new worksheet.

2.

In cell A1 type as “Value”

3.

In cell A2 type as “Square root”

4.

In cell B1 type any value

5.

In cell B2 insert the function to find the square root of the value in B1

6.

After getting square root, change the value in B1, observe changes in result.

7.

Use the same function in another sheet directly i.e. without using function wizard.
7.13 Working with Chart

7.13 Working with Chart
One of the most important features of spreadsheet is the ability to create charts
based on numeric data. The charts are used to present data in an easy manner. Creating
charts is the key factor for the of success of spreadsheet. OpenOffice Calc provides a
“chart wizard” to create and manipulate charts.
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7.13.1 Chart Wizard
Chart wizard is used to insert charts in Calc. Chart wizard can be invoked by
clicking “chart” icon from standard toolbar or choosing Insert → Chart command. A
"Chart wizard" appear as shown in Figure 7.49
Chart wizard dialog box has 4 steps viz. (1) Chart type (2) Data Range (3) Data
Series and (4) Chart Elements. The “Next” button is used to move from one step to another
step.
Step 1: Chart type
The first step of “Chart wizard” is used to select Chart type. All available chart
types are listed under the “Choose a chart type” list box. On the right side of the list box
shows style of the selected chart; each chart type has different styles.

Figure 7.49 Chart Wizard – Step 1: Chart type
For example, Column chart has three styles viz. Normal, Stacked and Percent
Stacked. Refer Figure 7.49
"3D Look" check box helps to display the selected chart type in an attractive form.
3D Look is applied only for Column, Bar, Pie and Area chart type. Refer Figure 7.50
Click, “Next” button to move to the second step.
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Column Chart

3D Cylinder shape

Chart styles
List of 3D
shapes

3D look
Checkbox

Figure 7.50 Chart Wizard – Step 1: Chart type with 3D Look
Step 2: Data Range
In this step, specify the range of data for which the chart should be created in “Data
range” text box or click “Select data range” button which is at the end of the textbox to minimize
the wizard.
If the user had selected the data before invoking "chart wizard", the selected range will
appear automatically in the textbox as shown in Figure 7.51.
There are two checkboxes used to set the first row or first column or both, as X and Y
axis labels to the chart.
Click "Next" button to move to the third step.

Figure 7.51 Chart Wizard – Step 2: Data Range
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Step 3: Data Series
In this step, the user can fine tune the data to be included in the chart. If you don’t
want to include any column, click the column names listed in “Data Series” box and click
on “Remove” button or if you want to add some more columns click “Add” button. Refer
Figure 7.52. This is useful only if you have very specific requirements for data in your
chart. Otherwise simply click “Next” button to move the last step.
Step 4: Chart Element
This step is used to insert or change titles and legend. In “Title” box, type the title
for the chart, to add a subtitle type it in the “Subtitle” box. Refer Figure 7.53. For example,
A chart for showing the highest mark holder in you class, you may enter as “Highest Mark
holder” as title and “Class XII F” as subtitle.

Figure 7.52 Chart Wizard – Step 3: Data Series

Figure 7.53 Chart Wizard – Step 3: Chart Elements
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User can add or modify the labels of X and Y axis.
To create a chart click “Finish” button.
7.13.2 Demo for creating a chart
Type the following data in a new worksheet as in Figure 7.54. The following steps
is followed to create a chart for the given data.
Step 1 – Select Data:
•

Select the data from A1 to F11.

Step 2 – To open the chart wizard:
•

Click “Chart” icon from Standard toolbar (or) choose Insert → Chart.

Step 3 – Selecting Chart type and shape: (Refer Figure 7.55)

Figure 7.54 Rainfall (in mm) data of ten districts in 2010

Figure 7.55 Chart Wizard – Step 1 Chart Type
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•

Select “Chart type” as Column and style as Normal

•

Check “3D Look” and click “Cylinder shape”

•

Click “Next” button.

•

If the user wants change any other type or shape, click on the style image. Preview of
the chart displayed on the backgroup of the chart wizard. So, you can view the chart
at every stage of design.

Step 4 – Defining Data range: (Refer Figure 7.56)
•

In this case, the data has been selected earlier. So, the selected data range is displayed
in the “Data range” box.

•

Other settings are by default. Click “Next” to move to step 5.

Figure 7.56 Chart Wizard – Step 2 Data Range
Step 5 – Adding or Removing Data series: (Refer Figure 7.57)
•

“Data Series” list box shows all the columns to be included in the chart.

•

Click on the “Total” in the data series box and click “Remove” button to remove the
column.

•

If you don’t want to add or remove anyother column click “Next” button to move to
the last step.
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Figure 7.57 Chart Wizard – Step 3 Data Series
Step 6 – Adding Title, Subtitle, Name of X and Y axis: (Refer Figure 7.58)
•

Type the title and subtitle of the chart in “Title” and “Subtitle” box

•

Type the name of the X and Y-axis in the respective boxes.

•

The Display legent text box is selected to the right which is the default.

•

Click “Finish” button.
Now the chart will be displayed as in Figure 7.59.

7.13.3 Editing Chart elements:
After inserting a chart any element of the chart can be modified. To modify the
element
(i) Double click on the element
(ii) Right click on the selected element
(iii) Select Format from the popup menu.
For example, To change the display pattern of the X-axis, double-click on the X-axis
and then right-click on it. A pop-up menu appears as shown in the Figure 7.60.
•

In this popup menu, click “Format Axis…” option.
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Figure 7.58 Chart Wizard – Step 4 Chart Elements
Now the chart will be displayed as given below

Rain Fall Details
600

During 2010

RainFall in mm

500
Sep

400
300

Oct
Nov

200

Dec

100
0
Theni
Coimbatore
Tiruvallur
Dharmapuri Kanchipuram
Chennai
Erode
Cuddalore
Madurai
Tirunelveli

District
Figure 7.59 Chart
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RainFall in mm

1200

Rain Fall Details
During 2010
Sep

1000
800

Oct
Nov

600
400
200
0

Dec
Dec
Coimbatore Dharmapuri Kanchipuram
Chennai
Cuddalore
Erode

Theni

Tiruvallur

Districts

Figure 7.60 Chart element formatting pop-up menu
•

Now, a Format Axis dialog box appears as shown in Figure 7.61

Figure 7.61 Chart Element Properties dialog box
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Rain Fall Details
During 2010

Tiruvallur

Tirunelveli

Theni

Madurai

Kanchipuram

Erode

Dharmapuri

Cuddalore

Coimbatore

Chennai

Rain Fall in mm

1200
1000
800
600
400
200
0

Sep
Oct
Nov
Dec
Total

Districts

Figure 7.62 Completed Chart
Select “Label” tab.
•

In Text Orientation spinbox, type as 90 degree or click and drag the Text direction animated
handle.

•

Click “OK” button.

•

Now, the chart will be as in Figure 7.62

Self Practice:
1.

Open the spreadsheet which was created in Illustration 1.

2.

Create a column chart with 3D “cone” shape showing the total marks of all students.
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Part – IV Sorting Filtering and Page setup
7.14 Advanced data analysis tools
A spreadsheet is a “Flat file database”. Thus, database operations such as sorting,
filtering can be done on spreadsheet. The “Data” menu of OpenOffice calc provides maximum
data analysis tools such as sorting, filtering, validity etc., In this part, the sorting and filtering
feature is to be learnt.
7.14.1 Database
A database is a repository of collections of related data or facts. It arranges them in a
specific structure. The table given below contains details of students in a class.
Sl.
No

Class

Group
Code

Student Name

Gender

Comm
Date of
Birth

Date of
Birth

Religion

1

XII - F1

302

GANDHIMATHI N

F

SC

02/10/2000

H

2

XII - H2

402

SANDHIYA D

F

SC

19/08/2000

H

3

XII - H2

402

SUMATHI P

F

BC

06/09/1999

H

4

XII - F1

302

JAYASREE J

F

BC

09/06/2001

H

5

XII - H1

402

JOTHIKA A

F

SC

07/04/2001

H

6

XII - H2

402

RAMYA T

F

MBC

23/11/2000

H

7

XII - F1

302

KOWSALYA T

F

SC

14/12/2000

H

8

XII - F1

302

ASHA A P

F

SCA

14/09/2000

H

9

XII - A

102

VENNILA T P

F

BC

14/02/2000

H

10

XII - F2

302

SANGEETHA G

F

MBC

14/01/2000

H

Table 7.14.1 Student Database
The entire collection or related data in one table is referred to as a File or a Table.
Each row in a table represents a Record, which is a set of data for each database entry.
Each table column represents a Field, which groups each piece or item of data among the
records into specific categories. (Refer Figure 7.63)
7.14.2 Sorting:
Sorting is the process of arranging data in ascending or descending order. There are
two types of sorting in OpenOffice Calc. They are,
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(1)

Simple Sorting

(2)

Multi Sorting

(3)

Sort by selection

(1) Simple Sorting
Arranging data using single column is known as simple sorting. For sorting the
data, calc provide two icons on the standard tool bar viz. (1) Sort Ascending (2) Sort
Descending.
•

Sort Ascending – Arrange data in alphabetical order (A to Z / Small to Large)

•

Sort Descending – Arrange data in reverse order (Z to A / Large to Small)
Field

Record
Figure 7.63 Spreadsheet Data Table
Sorting data
Step 1: Place cell pointer in the field (column) to be sorted
Step 2: Click Sort Ascending or Sort Descending icon
151
Chapter 7.indd 151

3/20/2020 11:37:14 AM

OpenOffice Calc, sort the data of selected column and its corresponding values
present in other columns are also arranged simultaneously. Refer Figure 7.65

Sort Ascending

Sort Descending

Figure 7.64 Standard Tool Bar with Sort Ascending / Descending
Click "Sort Ascending" icon to arrange ascending order

Place the Cell pointer
anywhere in name column
				

Firgure 7.65 Sort Ascending

(2) Multi Sorting
Sorting data based on more than one field (column) is known as multi sorting. For
example, the worksheet containing data of 20 students belongs to different groups and
classes. To rearrange this data alphabetically by name and group code, multi sorting is
used. Refer Figure 7.66.
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Multi-sorting data
Step 1:

Select Data → Sort

Name are arranged in Ascending order According to names, other data also
rearranged
Step 2:

Sort dialog box appears. (Refer Figure 7.67)

Step 3:

Select the field name (Student name) in which you want to sort from the “sort
by” dropdown list box and then choose order of sorting i.e. Ascending or
Descending. Ascending is the default selection.

Step 4:

Select another field name (Group Code) from the “Then by” dropdown list box
and choose the order of sorting to this column.

Step 5:

Click “OK” button.
In OpenOffice Calc, multi sort can be done only for three fields.
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Select First column in which
the data arranged first

Select order of
arrangement

The selected the second and third column in which the
data to be arrange based on the first column
Fainally Click
"Ok"

Figure 7.67 Multi-sorting dialog box
(3) Sort by selection
In Calc sorting can be done on selected range. But this kind of sorting is generally not
recommended, because the other relevant data are also not sorted. Therefore, OpenOffice
Calc displays a warnning message for this type of sorting. Refer Figure 7.68.
Sorting data by selection:
Step 1:

Select any particular field in which you want sort.

Step 2:

Click required Sort icon from standard tool bar or Data → Sort command.
Calc, display a “Sort Range” warning message as shown in the Figure 7.68
“Sort Range” message box has two options, viz. (1) Extend selection (2) Current
selection.

Step 3:

“Extend Selection” – Sort all the data based on the selection.
“Current Selection” – Sort only the selected range of data, remaining data are not
sorted.
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7.14.3 Filtering
Filter is a way of limiting the information that appears on screen. Filters

Figure 7.68 Sort by selection
are a feature for displaying and browsing a selected list or subset of data from a worksheet.
The visible records satisfy the condition that the user sets. Those that do not satisfy the
condition are only hidden, but not removed.
OpenOffice Calc allows three types of filters. They are AutoFilter, Standard Filter
and Advanced Filter.
(1) Auto Filter:
Auto Filter applies a drop-down list box to each field (columns) filled with similar
data available in that field. Using the list box item, you can filter the data that matches the
criteria of the data concerned.
Using Auto Filter:
•

Click Auto Filter icon available on the “Standard tools bar” (or)
click Data → Filter → Auto Filter
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•

The list box contains similar data in the fields. Refer Figure 7.69 and 7.70

•

Each list box item will be considered as filter criteria.
Drop down list box

Figure 7.69 Spreadsheet table with Auto Filter

Figure 7.70 Auto Filter dropdown list box
•

Select the data item from the list box. Now, Calc shows only the records which are
satisfy the selected criteria.

Example:
If you want to apply an auto filter to the contents of the table 7.14.1, follow the
following two steps
Step 1: Place cell pointer anywhere in the table
Step 2: Click Auto Filter icon
Filter → Auto Filter

available on the “Standard tools bar” (or) Click Data →

In the above table, if you want to view only the students belongs to the Group code 402;
•

Click the dropdown list box’s drop arrow (a tiny triangle) to get the filter criteria.
(Refer Figure 7.70)
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•

Select group code 402 from the list

•

The spreadsheet displays only the student’s details those who are studing in group
code 402 (Refer Figure 7.71) and the remaining details are only hidden.

Figure 7.71 Filtered details

Figure 7.72 Standard Filter dialog box
Removing Auto Filter:
•

To remove auto filter, click “Auto filter” icon once again .

•

The original table is displayed without filter.

(2) Standard Filter: Auto filter is used only for single criteria on a data, whereas the
Standard filter is used for multiple critieria to filter.
Step 1:
•

Select Data → Filter → Standard Filter.
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•

Now, the entire data is selected and
"Standard Filter" dialog box dispalys
as shown in Figure 7.73.

7.14.1
Step 1: Select Data →Filter → Standard
Filter

Step 2:
•
•
•

•

Select the column heading from the
“Filed name” list box for first criteria.

Step 2: In “Standard Filter” dialog box,
select the first criteria;

Select conditional opeator such as >,
<, = etc., from “Condition” list box.
Type or select the value of critera in
the “Value” box.

Step 3:
•

•

•

Select Field name as Group code

•

Select Condition as =

•

Type or select Value as 402

Step 3: To select the second criteria;

Select the one of the logical operator
(And / Or) from “Operator” list box
to fix second criteria.
Follow the step 2, for the next criteria.

Step 4:
•

Now, “Standard Filter” dialog box
appears as in Figure 7.73

Click “OK” to finish.

•

Select Operator as “AND”

•

Select Field name as Class

•

Select Condition as =

•

Type or select Value as XII- H2

Example for Standard filter:
If you want to filter the records of “BC”
students of group code 402 from the table

Figure 7.73 Standard Filter
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Step 4: Click “OK”
•

Now, the table displays only the recods which are match for the given two criteria.
Refer Figure 7.74.

Remove Standard Filter:
•

Select Data → Filter → Remove Filter

Figure 7.74 Class XII student of group 402

Figure 11.75 Page Style dialogue box
•
•

“Header” tab is used to create header
“Footer” tab is used to create footer
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7.15 Setting the page size, Orientation and Margins
•

To set page size, select Format → Page

•

Page style dialoge box will appears as shown in figure 7.75.

•

“Page” tab is used to change page size, orientation and margin

•

“Header” tab is used to create header

•

“Footer” tab is used to create footer

Workshop 1
1. Create a worksheet with following data
Emp.
No

Name of Emp.

Basic

DA HRA CCA

MA

GPF

IT

HF

300

250

1002

Kannan K

20200

600

300

250

1003

Gowrishankar N V 24300

600

300

250

1004

Lenin K

23400

600

300

250

1005

Suryanarayanan T

24100

600

300

250

1006

Ramesh K

18500

600

300

1007

Govindasami A

13200

600

300

1008

Kannan S

20250

600

300

1009

Penchil Rao K

28300

600

300

250

1010

Logeswaran M

30200

600

300

250

1011

Arumugam E

12000

600

300

250

1012

Vasu G N

25000

600

300

250

%10 of Gross

600

12 % of Basic

25500

%15 of Basic and DA

Manivannan M

25 % of Basic

1001

250
250
250

Based on the above data,
(1) Calculate the Gross Salary, Total Deductions and Net Salary
(2) Insert “IT Cess” column and calcualte 3% of cess to all employees
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7.15
therecords
page size,
Orientation and
(3) Setting
Delete the
of “Govindasami”
andMargins
“Arumugam”.
•(4) To
set page
Format
Page
Insert
four size,
new select
rows and
enter→the
following employee details.
•(5) Page
style dialoge
box
will appears
shown
in figure 7.75.
Calculate
the Total
amount
of GPF,asIT
and Cess
•

“Page” tab is used to change page size, orientation and margin
Emp. No Name of Emp.
Basic DA HRA CCA MA GPF

IT HF

24750
• 2001
“Header”Murali
tab is G
used to create header
2002
Munirathnam A
23550
• “Footer” tab is used to create footer
2003
Ramakrishnan V G 25500
2004
Srinivasan R
Workshop 1

27500

Workshop: 2
1. Create a worksheet with following data

147
63
43
12
152
85

600

300

600

300

6005% 300
6005% 300
6003% 300
10%
6004% 300
6006% 300

1011 Arumugam E
12000
600
300
3. Calculate the following using formula or function
1012 Vasu G N
25000
600
300
(i) Amount of Discount, Selling price and Amount of sales for each product
Based on the above data,
(ii) Total amount of discount and Sales of the month
(1) Calculate the Gross Salary, Total Deductions and Net Salary
(iii) Closing stock of each product
(2) Insert “IT Cess” column and calcualte 3% of cess to all employees
4. Draw a Pie chart to show the highest selling product.

Closing Stock

Weight (gm)

%15 of Basic and DA

Dark Fantasy
1008102 Kannan
S
103 Nutri Choice
1009104 Penchil
Rao K
Lays potato chips
Oreo
1010105 Logeswaran
M

15
10
25
50
15
25

25 % of Basic

Milk Bikis A
1007101 Govindasami

18500345
120
85 106
13200
75 147
20250
250 98
28300
52 172
120
30200112

24100

300

Amount of Sale
%10 of Gross

Suryanarayanan T

600

12 % of BasicSelling price

1005

23400

300
Amount of
Discount

Lenin K

600
Rate of
Discount

1004

Cost price

Gowrishankar N V 24300

1006100 Ramesh
K
Marie Gold

20200

Opening stock

1003

Product Name

Kannan K

Code

1002

Sales in units

1. Create a new worksheet in OpenOffice Calc.
Emp.
Name of Emp.
Basic DA HRA CCA MA GPF IT
HF
No the following stock and sales details of “Chennai whole sale Marketing Pvt.
2. Enter
Ltd.”
during
the monthMof Jan-2018.
1001
Manivannan
25500
600
300
250
250
250
250
250
250
250
250
250
250
250
250
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Workshop: 3
1. Create a worksheet in OpenOffice Calc.

120 days

9.5%

2002

Kumar

175000

15/01/2018

150 days

9.5%

2003

Ibrahim

550000

16/01/2018

140 days

10.5%

2004

Valli

375000

21/01/2018

210 days

10%

2005

Charles

450000

28/01/2018

130 days

10.5%

Due date

02/01/2018

Total Amount

250000

Interest (Rs)

Amount of Loan

Senthil

Rate of Interest

Name

2001

Loan Sanction
date

AC No Emp. No

Duration of Loan

2. Enter the following details of loan sanctioned during the month of January 2018 of
“Tamil Finance Corporation”.

3. Create the formula to calculate
(i) Interest, Total amount and due date.
(ii) Grass total of amount of loan, interest and total amount.

03/02/2018
07/02/2018
10/02/2018
10/02/2018
26/02/2018

Due date

Loan Sanction
date

250000
375000
350000
450000
800000

Total Amount

Amount of Loan

Pari
Arul
Raman
Givind
Zeenath

Interest (Rs)

Name

3001
3002
3003
3004
3005

Rate of Interest

AC No

Duration of Loan

4. Insert 5 new rows between Kumar and Ibrahim and include the following details

125 days 9.5% 5%
155 days 9.5% 5%
130 days 10.5% 3%
100 days 10% 10%
90 days 10%
4%
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Points to Remember:

W
o

•

Spreadsheet is a very useful office automation tool for organization, analysis
and storage of data in a tabular form.

•

Daniel Bricklin and Bob Frankston developed the first spreadsheet software
called “VisiCalc” in 1979 for Apple II.

•

OpenOffice Calc is popular open source spreadsheet application software
presently maintained by Apache Foundation.

•

A worksheet is a grid of cells with a programmable calculator attached to each
cell.

•

OpenOffice Calc version 4.1.5 contains a total of 1024 columns and 10,48,576
rows.

•

Intersection of every row and column makes a box which is called as “Cell”.

•

Cell pointer is a rectangle element which can be moved around the worksheet.

•

The cell in which the cell pointer is currently located is known as “Active cell”.

•

All formula should start with an equal sign.

•

There are four types operators supported by calc.

•

The charts are used to present numerical data in an easy manner.
Activity

Student Activity
1.

Based on the concept of calculation using formula / functions, make the students to
create various worksheet data.

2.

Make the students prepare Charts and manipulate data using sorting and filtering
features.

Teacher Activity
1.

To show the demo of working with spread sheets using simple example in class room.
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Evaluation
Part – I

Choose the correct answer
1.

2.

3.

4.

5.

6.

7.

Which is the first electronic spreadsheet?
(A)Excel		

(B) Lotus 1-2-3

(C) Visicalc		

(D) OpenOffice Calc

Which of the following applications was the parent to OpenOffice Calc?
(A)Visicalc		

(B) LibreCalc

(C) Lotus 123		

(D) StarOffice Calc

Grid of cells with a programmable calculator:
(A)Spreadsheet		

(B) Database		

(C) Word processor		

(D) Linux

A column heading in Calc is represented using
(A)Number		

(B) Symbol

(C) Date		

(D) Alphabet

Which key is used to move the cell pointer in the forward direction within the worksheet?
(A)Enter		

(B) Tab

(C) Shift + Tab		

(D) Delete

A formula in calc may begin with
(A) =			

(B) +		

(C) -			

(D) All the above

What will be the result from the following formula (Assume A1=5, B2=2)? + A1^B2
(A) 7			

(B) 25

(C) 10			

(D) 52
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8.

9.

10.

What will be the result from the following expression (Assume H1=12, H2=12)? =
H1<>H2
(A) True		

(B) False

(C) 24			

(D) 1212

Which of the following symbol is used to make a cell address as an absolute reference?
(A) +			

(B) %		

(C) &			

(D) $

Which of the following key combinations is used to increase the width of the current
column?
(A)Alt + Right arrow				

(B) Ctrl + Right arrow

(B)Alt + Left arrow

(D) Ctrl + Left arrow

			

Part – II
Very Short Answers
1. What are the types of toolbars available in OpenOffice calc?
2.

What is a Cell pointer?

3.

Write about the text operator in OpenOffice Calc.

4.

Write the general syntax of constructing a formula in Calc.

5.

What are the keyboard shortcuts to cut, copy and paste?

6.

Can you edit the contents of a cell? If yes, explain any one of the method of editing the
cell content.

7.

What are the options available in “Insert Cells” dialog box?

8.

Match the following
A
(a) Cut, Copy and Paste
(b) Cell pointer
(c) Selection Mode
(d) $A5$

9.

B
(1) Absolute Cell
(2) Status bar
(3) Standard Toolbar
(4) Active cell

Define the following (i) Text Operator (ii) Rows and Columns of spreadsheet
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10.

Differentiate between Copy -Paste and Cut-Paste
Part-III

Short Answers
1. Write a short note on OpenOffice Calc.
2.

Write about inserting columns and rows in Calc.

3.

Differentiate Deleting data using Backspace and Delete

4.

Write any three formatting options.

5.

In cell A1=34 A2=65 A3=89 write the forumla to find the average.
Part-IV

Explain in Detail
1.

Explain about changing the column width in Calc.

2.

Write the steps to generate the following series. 5, 10, 20 ….. 2560

3.

Read the following table
1
2
3
4
5
6

A
Year
2012
2013
2014
2015
2016

B
Chennai
1500
1600
1900
1850
1950

C
Madurai
1250
1000
1320
1415
1240

D
Tiruchi
1000
950
750
820
920

E
Coimbatore
500
350
300
200
250

Above table shows the sales figures for “Air Cooler” sold in four major cities of Tamilnadu
from the year 2012 to 2016. Based on this data, write the formula to calculate the following.
(1)

Total sales in the year 2015.

(2)

Total sales in Coimbatore from 2012 to 2016.

(3)

Total sales in Madurai and Tiruchi during 2015 and 2016.

(4)

Average sales in Chennai from 2012 to 2016

(5)	In 2016, how many “Air Coolers” are sold in Chennai
compared to Coimbatore?
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Spreadsheet

Sheet of paper that shows accounting or other data
in rows and columns

What-if analysis

It is a process of changing the values in a cell to see
how those changes will affect output.

VisiCalc

The first electronic spreadsheet application

GUI

Graphical User Interface

Excel

Familiar spreadsheet application developed by Microsoft
Corporation.

Cell

Intersection of rows and column

Cell Pointer

A rectangular box, highlighting the cell in a spreadsheet.

Active cell

A cell in which the cell pointer is presently locating

Formula

A formula is an expression telling the computer what
mathematical operation to perform upon a specific value.

Operator

A symbol that usually represents an action or process

Range

Group / Collection of cells

BODMAS Rule

Order of mathematical calculation:
Brackets - Orders (powers or square roots) - Division –
Multiplication – Addition - Subtraction.

Drag fill handle

A small black box at the bottom right corner of the cell pointer.

Function

Predefined formula / A group of instructions to return a single
result or a set of results.

Chart

Graphical representation of data.

Database

A large quantity of indexed digital information.

Flat file database Single table, non relative database
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Annexure 2
Sl.
No

Function

Description

Syntax

1

Averageif

Averages the arguments that meet the Average (range; criteria;
condition
average_range)

2

Celling

Rounds a number up to the nearest
multiple of significance

Celling (number; significance;
[mode])

3

Countif

Count the argument which meet the
set conditions

Countif (range; criteria)

4

Fact

Calculates the factorial of a number.

Fact (number)

5

Floor

Rounds number down to the nearest
multiple of significance

Floor (number1; number2)

6

Product

Multiples the arguments

Product (number1; number2)

7

Quotient

Returns the integers portion of a
division

Quotient (numerator;
denominator)

8

Round

Rounds a number to a predefined
accuracy

Round (number; count)

9

SQRT

Returns the square root of a number

SQRT (number)

10 Sum

Returns the sum of all arguments

Sum (number1; number2;….)

11 Sumif

Totals the arguments that meet the
condition

Sumif (range; criteria; sumrange)

12 Sumsq

Returns the sum of the squares of the
arguments

Sumsq (number1;
number2;…)

13 DB

Returns the real depreciation of an
asset for a specified period using the
fixed-declining balance method

Db (cost; salvage; life;
period;[month])

14 N

Converts a value to a number

N (value)

15 Date

Provides an internal for the date
given

Date (year; month; day)
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16 Days

Calculates the number of days
between two dates

Days (date2; date1)

17 Days360

Calculate the number of days
between two dates based on a 360
days year

Days360 (date1; date;[type])

18 Average

Returns the average of a sample

Average (number1;
number2;…)

19 Count

Counts how many numbers are in the Count (value1; value2;…)
list of arguments

20 Concatenate Combines several text items into one

Concatenate (text1; text2;..)

21 Len

Calculates length of a text string

Len (text)

22 Lower

Converts text to lower case

Lower (text)

23 Mid

Returns a partial text strings of a text

Mid (text; start; number)

24 Proper

Capitalizes the first letters in all
words

Proper (text)

25 Upper

Converts text to upper case

Upper (text)
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Unit II

Office Automation Tools

CHAPTER

8

Presentation Basics
Learning Objectives

8.1 Presentation Software - Meaning

After learning this chapter, the students will
be able to
•

•

Know the open source presentation
s oft w a re

•

explore opening a new presentation
using Impress

•

create a new presentation using various
ways using Impress

•

Know parts of the main Impress
Window

•

differentiate five sections of Task pane

•

explain Window elements of Impress

•

differentiate various views in Workspace

•

explore drawing Objects & inserting
OLE

•

draw freeform shapes

•

rotate Objects

•

create animation in slides/objects

A presentation software is a computer
software package used to show
information, in the form of a slide
show.

It includes three major functions:
• an editor that allows the text to be
inserted and formatted,
• a method for inserting and
manipulating graphic images and
• a slide-show system to display the
content.
•

Presentation software is used to create
presentations, quizzes, e-learning
packages and multimedia products.

•

Most presentation software packages
will create your multimedia product
using a series of slides.

•

Text, images, video, animations, links
and sound can be combined on each
slide to create a final product.

The most commonly known
presentation programs are OpenOffice.
org Impress, Microsoft PowerPoint and
Apple's Keynote. In this chapter, we are
going to explore on OpenOffice.org’s
presentation Software Impress.
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8.2. Impress
Impress is OpenOffice.
org’s presentations (slide show)
module. You can create slides
using Impress. It contains
different elements like text,
bulleted and numbered lists,
tables, charts, clip art and a range
of graphic objects. Impress has
access to the spelling checker
and thesaurus. Also, it comes
with pre-packaged text styles,
background styles with online
help.
8.3. Opening a new presentation
You can start Impress in several
ways:
•

In order to open Impress
using Start button, click
Start button and select All
Programs → Open Office
→ OpenOffice Impress.
(Figure 8.1)

•

If it is already pinned in the
Start menu, just click and
open it. (Figure 8.2)

Figure 8.1 – Opening Impress using Start button
(using All Programs)

8.4. Creating a new presentation
You can create a presentation
by any one of the following
methods.
1.

By selecting an Empty
presentation

2.

By selecting From template
Figure 8.2 – Opening Impress using Start button
171

Chapter 8.indd 171

3/20/2020 11:37:23 AM

3. Choose a design under Select a slide

3.
By selecting from Open
existing presentation

design. The slide design section gives

8.4.1. Using Empty presentation

you two main choices: Presentation

1.

Select Empty presentation under Type.
It creates a presentation from scratch.

Backgrounds and Presentations.

2.

Click Next. The Presentation Wizard
step 2 appears. Figure 8.4 shows the
Wizard.

4.

Each one has a list of choices for slide
designs. If you want to use one of these
other than the <Original>, click it to

Figure 8.3 – Using the Presentation Wizard to choose the type of presentation

Figure 8.4 Wizard showing the main choices
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select it. The preview of the same will be
shown in the preview pane.
5.

6.
7.

for computer screen display, so select
Screen option. (Figure 8.6).

<Original> is an empty background.
You can also select among three
predefined Presentations: <Original>,
Introducing a New Product, and
Recommendation of a Strategy.
(Figure 8.6).

8.

Click Next. The Presentation Wizard
step 3 appears (Figure 8.7). In this
step, you can choose the desired slide
transition from the Effect drop-down
menu. Select the desired speed for
the transition between the different

Click an item to see a preview of the
slide design in the Preview window.

slides in the presentation from the
Speed drop-down menu. Medium is

Select how the presentation will be
used under Select an output medium.
Generally, presentations are created

a good choice. Click Create. A new
presentation is created. (Figure 8.8)

Figure 8.5 Selecting a slide design using Presentation Backgrounds
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Figure 8.6 Selecting a slide design using Presentations

Figure 8.7 Selecting a slide transition effect

174
Chapter 8.indd 174

3/20/2020 11:37:23 AM

8.4.2. Using Template
•

Choose the template that you want.
(Figure 8.9).

If you choose the option From
template, it uses a template design
already created as the basis for a new
presentation. The wizard changes
to show a list of available templates.

•

Introducing a New Product and
Recommendation of a Strategy are
pre-packaged presentation templates.

Figure 8.8 New presentation

Figure 8.9 Opening a new presentation using From template option
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8.4.3. Using Open existing presentation
•

•

If you choose the option Open existing
presentation, it helps in continuing
the work on a previously created
presentation.

You have to open a presentation
already prepared by clicking Open
button. The wizard changes to show
a list of existing presentations, from
which you can choose the one that
you want. (Figure 8.10).

Figure 8.10 Opening a new presentation using Open existing presentation option

Figure 8.11 Opening a new presentation using New icon
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toolbar and select Presentation from
the drop-down menu (Figure 8.11).

Tip Notes
First Spreadsheet
•

•

If you do not want the wizard
to start every time you start
Impress, select the Do not show
this wizard again checkbox.

3.

Or else, choose File → New →
Presentation.
(Figure
8.12).

8.5. Parts of the main Impress window

Leave the Preview checkbox
selected, so templates, slide
designs, and slide transitions
appear in the preview box as
you choose them.

The main Impress window (Figure
8.13) has three parts: the Slides pane,
the Workspace and the Task pane.
Additionally, several toolbars can
be displayed or hidden during the
creation of a presentation.

Various ways of Starting Impress:

Tip Notes

You can start Impress in various ways.
1.

You can select the presentation from
the system menu or the OpenOffice.
org Quickstarter.

2.

Or you can click the triangle to the
right of the New icon on the main

You can remove the Slides pane or
Tasks pane from view by clicking
the Close (X) option in the upper
right corner. You can also show or
hide these panes using View → Slide
Pane or View → Task Pane/Side bar.

Figure 8.12 Opening a new presentation using File menu
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Figure 8.13 Main window of Impress
8.5.1. Slides pane

•

Rename a slide.

•

The Slides pane contains thumbnail
pictures of the slides in your presentation,
in the order of our insertion of slides.

•

Copy or move the contents of one
slide to another (copy and paste, or
cut and paste, respectively).

•

Clicking a slide in this pane selects it
and places it in the Workspace. While
it is there, you can apply any changes
that are desired to that particular
slide.

It is also possible to perform the
following operations, other than using the
Slides pane.
•

Several additional operations can
be performed on one or more slides in the
Slides pane:

Change the slide transition following
the selected slide or after each slide in
a group of slides.

•

Change the sequence of slides in the
presentation.

•

Add new slides at any place within the
presentation after the first slide.

•

•

Mark a slide as hidden so that it will
not be shown as part of the slide show.

Change the slide design. (A window
opens allowing you to load your own
design.)

•

•

Delete a slide from the presentation if
it is no longer needed.

Change slide layout for a group of
slides simultaneously. (This requires
using the Layouts section of the Tasks
pane.)
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8.5.2. Tasks pane

8.5.2.2. Layout

The Tasks pane has five sections:

Pre-packaged layouts are shown.
You can choose the one that you want,
use it as it is or modify it to suit your own
requirements. At present, it is not possible
to create custom layouts. (Figure 8.15)

8.5.2.1. Master Pages
You define the page style for your
presentation using Master Pages. Impress
contains pre-packaged Master Pages (slide
masters). One of them by default is blank,
and the rest have a specific background.
(Figure 8.14)

Figure 8.15 Layout
8.5.2.3. Table Design
Standard table styles are provided
in this pane. You can further modify the
appearance of a table with the selections to
show or hide specific rows and columns,
or to apply a banded appearance to the
rows and columns. (Figure 8.16)

Figure 8.14 Master Pages
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8.5.2.4. Custom Animation
A variety of animations for
selected elements of a slide are listed
here. Animation can be added to selected
elements of a slide and it can also be
changed or removed later. (Figure 8.17)
8.5.2.5. Slide Transition
Transitions are available, including
No Transition. You can select the
transition speed (slow, medium, fast). You
can also choose between an automatic or
manual transition, and how long you want
the selected slide to be shown (automatic
transition only). (Figure 8.18)

Figure 8.16 Table Design

Figure 8.18 Slide Transition
Figure 8.17 Custom Animation
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8.6. Window elements of Impress

statistics about the file that you are
viewing. It is a good practice to check the
information shown there. In case you do
not need the information in the Status
Bar, you can hide it by selecting View →
Status Bar from the main menu.

Figure 8.19 shows the elements
of the Impress Window Open source
application.
The window elements of Impress
include Title Bar, Menu Bar, Tool Bar,
Ruler Bar and the Scroll Bar which are
similar to the elements in Open Office
writer.

8.6.3. Navigator
The Navigator (Figure 8.20) displays
all objects contained in a document. It
provides another convenient way to move
around a document and find items in it.
The Navigator button is located on the
Standard toolbar. You can also display the
Navigator by choosing Edit → Navigator
on the menu bar or pressing Ctrl+Shift+F5.

8.6.1. View Buttons:
The Workspace has five tabs:
Normal, Outline, Notes, Handout, and
Slide Sorter, as seen in Figure 8.19. These
five tabs are called View Buttons.

The Navigator is more useful if you
give your objects (pictures, spreadsheets,
and so on) meaningful names, instead of
Status Bar is present at the bottom
leaving them as the default “Object 1” and
of your window, which gives you some
“Picture 1” as shown in Figure 8.20.
Menu Bar Tool Bar
8.6.2. Status Bar:

View Button
Scroll Bar

Figure 8.19 Window elements of Impress
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you assemble the various parts of your
selected slide. Each view is designed to
ease the completion of certain tasks.
Normal view is the main view for
creating individual slides. Use this view to
format and design slides and to add text,
graphics and animation effects.
Outline view shows topic titles,
bulleted lists and numbered lists for each
slide in outline format. Use this view to
rearrange the order of slides, edit titles
and headings, rearrange the order of items
in a list and add new slides.
Notes view lets you add notes to each
slide that are not seen when the presentation
is shown.
Slide Sorter view shows a
thumbnail of each slide in order. Use
this view to rearrange the order of slides,
produce a timed slide show, or add
transitions between selected slides.
Handout view lets you print your
slides for a handout. You can choose one,
two, three, four, or six slides per page from
Tasks pane → Layouts. Thumbnails can
be re-arranged in this view by dragging
and dropping them.

Figure 8.20 Navigator
8.7. Workspace
The Workspace has five tabs:
Normal, Outline, Notes, Handout and
Slide Sorter, as seen in Figure 8.19. These
five tabs are called View Buttons. There
are many toolbars that can be used during
the slide creation; they are revealed by
selecting them with View → Toolbars.

8.7.1. Normal view
There are two ways to place a slide
in the Slide Design area of the Normal
view: clicking the slide thumbnail in the
Slides pane or using the Navigator.
To open the Navigator, click the
Navigator button in the Standard Toolbar
or press Ctrl+Shift+F5 and select a slide

The actual Workspace section is
below the View Buttons. This is where
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by scrolling down the Navigator list until
you find the one that you want and then
double-click it. (Figure 8.21)

or Move Down) on the Text Formatting
toolbar.
Change the outline level for any of
the paragraphs in a slide using the left and
right arrow buttons (Promote or Demote).

8.7.2. Outline view
Outline view contains all the slides
of the presentation in their numbered
sequence. Only the text in each slide is
shown. Slide names are not included.

Both move a paragraph and change
its outline level using a combination of
these four arrow buttons.

Outline view serves for two purposes.

2) Comparing the slides with your
outline (if you have prepared one in
advance). If you notice from your outline
that another slide is needed, you can create
it directly in the Outline view or you can
return to the Normal view to create it,
then return to review all the slides against
your outline in the Outline view.

1) Making changes in the text of a slide:
•
Add or delete text in a slide just as
in the Normal view.
•
Move the paragraphs of text in the
selected slide up or down by using the
up and down arrow buttons (Move Up

Figure 8.21 Presentation in Normal view
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8.7.3. Notes view

If a slide is not in the correct
sequence, you can move it to its proper
place:

Use the Notes view to add notes to a slide:
1) Click the Notes tab in the Workspace
(Figure 8.23).

a) Click the slide icon of the slide that
you wish to move, as indicated in
Figure 8.22.

2) Select the slide to which you will add
notes.

b) Drag and drop it where you want.

Figure 8.22 Presentation in Outline view

Figure 8.23 Presentation in Notes view
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• Double-click the slide in the Slide pane,
or

row,

• Double-click the slide’s name in the
Navigator.

Change the number of slides per
if desired:

1) Check View → Toolbars → Slide View to
show the Slide view toolbar (Figure
8.24 ).

3) In the text box below the slide, click
on the words Click to add notes and
begin typing.

2) Adjust the number of slides (up to a
maximum of 15).

You can resize the notes text box
using the green resizing handles and move
it by placing the pointer on the border,
then click and drag. To make changes in
the text style, press the F11 key to open
the Styles and Formatting window.

3) After you have adjusted the number of
slides per row, View → Toolbars → Slide
View will remove this toolbar from
view.

8.7.4. Slide Sorter view

of

The Slide Sorter view contains all
of the slide thumbnails (Figure 8.24).

•

Use this view to work with a group
of slides or with only one slide.

To select a group of slides, use one
these methods:
Use the Control (Ctrl) key: Click
on the first slide and, while pressing
Control, select the other desired
slides.

Figure 8.24 Presentation in Slide Sorter view
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•

Use the Shift key: Click on the first
slide, and while pressing the Shift
key, select the final slide in the group.
This selects all of the other slides in
between the first and the last.

•

Use the cursor: Click on the first slide
to be selected. Hold down the left
mouse button.

•

Drag the cursor to the last slide
thumbnail.

slides will go. You can work with slides in
the Slide Sorter view as in the Slide pane.
To make changes, right-click a slide
and do the following, using the pop-up
me nu:

A dashed outline of a rectangle forms
as you drag the cursor through the
slide thumbnails and a thick black
border is drawn around the selected
slides. Make sure that this rectangle
includes all the slides you want to
select. (Figure 8.25)

•

Add a new slide after the selected
slide.

•

Delete or rename the selected slide.

•

Change the Slide Layout.

•

Change the Slide Transition.

–

For one slide, click the slide to select
it. Then add the desired transition.

–

For more than one slide, select the
group of slides and add the desired
transition.

•

Mark a slide as hidden. Hidden slides
will not be shown in the slide show.

•

Copy or cut and paste a slide.

To move a group of slides:
1) Select the group of slides.
2) Drag and drop the group to their new
location. The same vertical black line
appears to show you where the group of

Figure 8.25 To move a slide in a presentation using the Slide Sorter
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8.7.5. Handout view

8.8. Formatting a presentation
8.8.1. Inserting, deleting and rearranging
slides

Handout view is for setting up the
layout of your slides for a printed handout.
Click the Handout tab in the workspace,
then choose Layout in the tasks pane
(Figure 8.26). You can then choose to
print one, two,three, four, or six slides per
page.

Tip Note: Remember to save frequently
while working on the presentation,
to prevent any loss of information.
You might also want to activate the
AutoRecovery function (Tools → Options
→ Load/Save → General). Make sure that
Save AutoRecovery information every
is selected and that you have entered a
suitable recovery frequency.

To print a handout:
1) Select the slides using the Slide Sorter.
(Use the steps listed in selecting a
group of slides.)

8.8.2. Creating the first slide

2) Select File Print or press Ctrl+P to
open the Print dialog box.

The first slide is normally a title
slide. Decide the layout as per its purpose
of presentation. You can use the prepackaged layouts available in the Layout
section of the Tasks pane. Suitable layouts
are Title Slide (which also contains a
section for a subtitle) or Title Only, Title
and Content, Title and two content and so
on.

3) Select Options in the bottom left
corner of the Print dialog box.
4) Check Handouts in the Contents
section, and then click OK.
5) Click OK to close the Print dialog
box.

Figure 8.26 Presentation in Handout view
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Tip Notes
If you do not know the names
for the pre-packaged layouts, you
can use the tooltip feature. Position
the cursor on an icon in the Layout
section (or on any toolbar icon)
and its name will be displayed in a
small rectangle. If the tooltips are
not enabled, you can enable them.
From the main menu, select Tools →
Options → OpenOffice.org → General
→ Help and mark the Tips checkbox.
If the Extended tips checkbox is
also marked, you will get more
detailed tooltip information, but the
tooltip names themselves will not be
provided.
•

•

Adjustments to the formatting of
the title can be done by pressing
the F11 key, right-clicking the Title
presentation style entry, and selecting
Modify from the pop-up menu.

•

If you are using the Title Slide layout,
click on “Click to add text” to add
a subtitle. Proceed as above to make
adjustments to the formatting if
required. (Figure 8.27)

8.8.3. Inserting additional slides
The steps for inserting additional
slides are basically the same as for selecting
the title page. It is a process that has to be
repeated for each slide.
Unless you are using more than
one slide master, your only concern is the
Layouts section of the Tasks pane (Figure
8.28).

Select a layout in the Layout section
of the Tasks pane by clicking on it: it
appears in the Workspace. To create
the title, click on Click to add title
(assuming the Blank Slide layout was
not used) and then type the title text.

First insert all the slides that are
needed as per your outline. Only after
this, you should begin adding special
effects such as custom animation and slide
transitions.

Figure 8.27 Creating the first slide
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Step 1: Insert a new slide. This
can be done in a variety of
ways.
•

Insert → Slide.

•

Right-click on the present
slide, and select Slide →
New Slide from the pop-up
menu. (Figure 8.28).

•

Click the empty space after
the last slide also to create
a new slide by right clicking
New Slide. (Figure 8.29)

•

Click the Slide icon in the
Presentation
toolbar.

Step 2: Select the layout slide
that best fits your
needs. (Figure 8.28).

Figure 8.28 Inserting a new slide using Right Clicking
on the previous slide

Step 3: Modify the elements of
the slide like removing
unneeded
elements,
adding needed elements
(such as pictures), and
inserting text.
8.8.4. Deleting a Slide
You can delete a slide at
any time using the following
procedure.
•

Select the slide you want to
delete

Figure 8.29 Inserting a new slide using Right Clicking
in the empty space after the last slide
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•

Click Edit Æ Delete slide (Refer
Figure
8.30)

Figure 8.31 Deleting a slide using Right
click
• Drag that slide to the desired position
by holding the mouse using left click.

Figure 8.30 Deleting a slide using Edit
menu
• Or else, right click the slide and
choose Delete slide from the pop-up
menu. (Figure 8.31)

•

Tip Notes
The same procedure can be
followed by using the Slide sorter
view also to delete a single slide or
multiple slides.

Tip Notes
the

8.8.5. Rearranging slides

The same can be done using
Slide sorter view.
8.9. Running the slide show

If you want to rearrange the slides ,
you need to follow the procedure below.
•

Release the mouse once you drag the
slide to the desired place. (Figure
8.32)

To run the slide show, do one of the
fol low ing:

Select the slide that you want to
rearrange.

•

Click Slide Show → Slide Show on the
main menu bar. (Figure 8.33).
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Figure 8.32 Rearranging the slide using

•

Click the Slide Show button on the
Presentation toolbar or the Slide
Sorter toolbar (Figure 8.34).

•

Press F5 or F9.

•

If the slide transition is Automatically
after x seconds, let the slide show run
by itself.

•

If the slide transition is On mouse
click, do one of the following to move
from one slide to the next.

•

Use the arrow keys on the keyboard
to go to the next slide or to go back to
the previous one.

•

Click the mouse button to advance to
the next slide.

•

Press the Spacebar on the keyboard to
advance to the next slide.

Figure 8.33 Running Slideshow using Slideshow menu

Figure 8.34 Running Slideshow using Slideshow button from the Toolbar
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•

When you advance past the
last slide, the message “Click
to exit presentation...”
appears. Click the mouse
or press any key to exit the
presentation.

•

To exit the slide show at
any time, including at the
end, press the Esc key.
8.10. Saving a Presentation

In order to save a presentation
Click File → Save (Figure 8.35)
Figure 8.36 Save dialog box.
•

After giving save option, Impress will open a
dialog box asking the name in which this file
should be saved (Figure 8.36)

•

The default file extension for Impress is .odp.
Tip Notes
You can also use Save As option
from the File menu. The difference
between Save and Save As is Save
option will save the presentation in
the folder specified by you. Save As
will save another copy of the same
file either in the same folder or in a
different folder specified by you.

Figure 8.35 Saving a
presentation using File menu

•

Type the name of the file you want to give in the
text box space after File Name in the dialog box.
(Figure 8.36).

•

You can save the presentation as a PPT
presentation
also.
(Figure
8.37)
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•

You can also export the presentation
directly as pdf. (Figure 8.38)

•

Figure 8.39 Shows exporting the
presentation directly as PDF.

A slide master has a defined set of
characteristics, including the background
color, graphic, or gradient; objects (such as
logos, decorative lines and other graphics)
in the background; headers and footers;
placement and size of text frames; and the
formatting of text.

8.11. Master slide
A slide master is a slide that is used
as the starting point for other slides. It is
similar to a page style in Writer: it controls
the basic formatting of all slides based on
it. A slide show can have more than one
slide master.

All of the characteristics of slide
masters are controlled by styles. The styles
of any new slide you create are inherited
from the slide master from which it was
created. In other words, the styles of the
slide master are available and applied to
all slides created from that slide master.
Changing a style in a slide master result in
changes to all the slides based on that slide
master; it is, however, possible to modify
each individual slide without affecting the
slide master.

Tip Notes
Three terms are used for this concept.
Master slide, slide master and master
page all refer to a slide which is used
to create other slides.

Figure 8.37 Saving a presentation under various File types
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Figure 8.38 Export the presentation directly as PDF
Tip Notes

presentation styles cannot be created.

Though it is highly recommended
to use the slide masters whenever
possible, there are occasions where
manual changes are needed for
a particular slide, for example to
enlarge the chart area when the text
and chart layout is used.

Figure 8.39 Shows the Slide Master.
•

Click View → Master → Slide Master

It is possible to view the Master slides in
two styles:

The pre-packaged presentation
styles can be modified, but new

1.

Slide Master

2.

Notes Master

Figure 8.39 Slide Master View
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•

A New Master slide can be created
either by using the Master View dialog
box or by right clicking slides in the
Slides pane. (Figure 8.41)

•

The renaming of the Master Slide is
also done by the same procedure.

•

Master Slide will be closed by using
the Close Master View in the Master
View dialog box .

Figure 8.40 Notes Master View

Figure 8.41 Creating New Master using Master View and right click option
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8. 12. Creating Graphic Objects
You can create your own graphics
using the drawing tools available in
Impress. Impress contains a number of
advanced drawing functions. To create
more advanced graphic objects, you can
use OpenOffice.org to draw and import
the graphic object created into an Impress
slide.
8.12.1.The Drawing toolbar
The Drawing toolbar contains tools
that are used to create graphic objects. If
this toolbar is not showing, select View
→Toolbars Drawing from the main menu
bar.
•

Select: selects objects. You can select
multiple objects by dragging the
m ou s e.

•

Line: draws a straight line.

•

Arrow: draws a straight line ending
with an arrowhead. The arrowhead
will be placed where you release the
mouse button.

•

Rectangle: draws a rectangle. Press
the Shift button to draw a square.

•

Ellipse: draws an ellipse. Press the
Shift button to draw a circle.

•

Text: creates a text box with the text
aligned
horizontally.

•

Vertical text: creates a text box with
the text aligned vertically.

•

Curve: draws a curve.

•

Connectors: draws a connector line
between two figures. Click the black
triangle for additional connectors.

8.13.Inserting images
In order to insert an image in
OpenOffice Impress, place the cursor in
the place where you want the image to
be inserted. Then, Click Insert → select
Picture → From File option from the
Insert menu. Figure 8.44.
OpenOffice Impress will display
the dialog box, where you can select the
image from the specific location and
select open. The image will be inserted in
the specified location. Figure 8.44.

Figure 8.42 The Drawing Tool Bar
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Figure 8.43 Inserting an image using insert menu

Figure 8.44 Selecting the image from a location
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8.14 Inserting audio and video
Open Office Impres will let
you insert audio files or movei
files. The audio and move files
can be inserted by clicking Insert
Movie and Sounds opetion from
the Insert menu. Figure 8.45
Same as inserting images here
also, a dialog box will be oepned.
Select the audio or movie file
form the specified location and
open. It will be opened in the
slide. Figure 8.46. The movie or
audio file inserted will be played
during the slide show by clicking
the mouse over it.
Figure 8.45 Inserting Movie and Sound

Figure 8.46 Selecting the Movie / Sound file
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Activity
Student Activity
1.

Create a presentation using

•

Empty presentation

•

Template

•

Open Existing Presentation

2.

Create a presentation using MS PowerPoint.

3.

Identify and write the differences between creating a presentation using Impress and
MS PowerPoint.

4.

Create a presentation of “My State” using all the types of slide layouts.

5.

Run the slideshow of “My State” by fixing durations of time for each slide.

Teacher Activity
This entire chapter can be taught with the help of the following methodology.
1.

Laboratory Activity – the teacher can make the entire class to go to the lab and can
explain the concept using a projector in the lab.

2.

Or else, the teacher can demonstrate the concept using a PC and a projector inside the
classroom.

3.

The teacher apart from this Open source software, can compare the elements of the
windows and creating presentations in MS PowerPoint also.
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Evaluation
Part – I

Choose the correct answer
1.

2.

Which is used to move quickly from one slide to another?
A)Compass 		

B)Navigator

C)Fill color		

D)Page border

Which is the shortcut key to view the slideshow?
A)F6 		

3.

B)F9			C)F5			D)F10

In Impress, which views shows thumbnail versions of all your slides arranged in
horizontal rows.
A)Notes		B)Outline		C)Handout		D)Slide Sorter

4.

Identify the default view in Impress.
A)Normal

5.

B)Slide Sorter

C)Handout		

D)Notes

Which menu contains the Slide Transition option?
A)Slide Show B)View		C)Tools		D)Format

6.

Identify the extension of the Impress presentation.
A) ,odp		

7.

8.

B) .ppt		

C) .odb		

d. ,ood

In presentation tools, the entry effect as one slide replaces another slide in a slide
show. Identify the option that suits after reading the statement.
A)Animation 				

B)Slide Transition		

C)Custom animation			

D)Rehearse Timing

Vanya has made a presentation on “Global Warming”. She wants to progress her slide
show automatically while speaks on the topic in the class. Which features of Impress
would she use?
A)Custom Animation			

B)Rehearse Timing

C)Slide Transition			

D)Either (a) or (b).
Part – II

Very Short Answers
1. What is the difference between a slide and a slide show?
2.

How many in-built slide layouts does impress consist of?
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3.

What do you understand by a presentation?

4.

Define a template in Impress.

5.

What do you understand by the slide layout?
Part-III

Short Answers
1. How many types of views are provided by Impress to its users?
2.

Who uses the presentation software and why?

3.

Define the Slide Sorter view and its significance.

4.

What is a Normal view? Explain.

5.

How are transition effects helpful in creating an effective presentation in Impress?
Part-IV

Explain in Detail
1.

Valarmathi’s teacher asks her to create a presentation in OpenOffice Impress. As
Valarmathi has never worked in Impress before, help her to perform the following
tasks:
a.

She wants that except for the first slide, all the slides should have the same design.
For this, what does she need to do?

b.

To easily communicate with her audience, she wants to provide them with a hard
copy of the slides of the presentation. What should she create for it?

c.

She wants to insert some pictures and movie files in some slides. How can she do
that?

d. Suggest her the view that would be the most suitable for showing the presentation
to the audience.
e.	To make her presentation more attractive, she wants to add some effects in it. How
can she do it? Suggest.
2.

Explain how a presentation can help a salesperson to promote his/her products.

3.

Sivabalan created a presentation to be shown at his school’s Annual Function. Just
5 minutes before the presentation, he noticed that he has misspelt the name of the
school, which is appearing in all the 30 slides of the presentation. How can he rectify
this mistake in all the slides in one-shot?

4.

List some advantages of using templates.
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Unit III

Web Page Development using
HTML and CSS

CHAPTER

9

Introduction to Internet and Email
Learning Objectives

Let us call this company Sri Mother
International Ltd. Imagine the amount
of information such as sales, inventory,
etc. required by the management of the
company to make everyday decisions. To get
this information they will need to call their
local offices. Their local offices will need
to mail or fax printed reports or even send
media (floppies!) through the postal service.
By the time the mail is received, the data is
already days old. Even if reports are faxed,
it will be a cumbersome task to consolidate
all reports. This task also increases chance of
human error since large numbers of reports
are manually collated. This is just one part of
the equation. You also need to consider the
information required by the local offices.
They also need various data from the head
office and other offices around the world.

To know the
• Necessity of Internet
in Commerce
• Types of Network available
• Services available in Internet
• Applications of Internet
• Difference between Internet, Intranet
and extranet
• Difference
Website

between

Webpage

and

• Difference between Static and Dynamic
Webpage
• Difference between Browser and Search
engine

Now consider the same company,
but in the present time with all their offices
interconnected. They would use a single
application around the world that takes
advantage of their global network. The data
from all offices would be instantly stored
at the central location and with a single
click, the management team can see data
from around the world in any format they
like. This data would also be real-time. This
means that they see it, as its happening. Since
the data is centralized, any office location
can see data pertaining to any location.

• Do’s and don’t of safe Surfing on Internet
9.1 Necessity of Internet
It is important to understand what a
network is and the importance of network.
Simply put, a network is a collection of
interconnected devices (such as computers,
printers, etc.). To understand the importance
of networks, let us look at how things worked
before networks were created. For this,
consider a large multinational company that
sells food products in a time when networks
did not exist.

As you can see, the cost, time and
effort involved in transferring data was
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much higher without networks. So networks decrease cost, time, and effort and thereby
increase productivity. They also help in resource optimization by helping to share resources. A
simple example of resource sharing is a printer, shared between many different computers in a
typical office.
9.2 INTERNET and WWW
Several networks, small and big all over the world, are connected together to form a
Global network called the internet. The internet uses TCP/IP(Transmission Control Protocol/
Internet Protocol ) to transmit data via various types of media. .The internet protocol (IP)
addressing system is used to keep track of the millions of users. Each computer on net is
called as host. The internet is the most cost-effective method of communications in the world.
Examples of few services available are:
Marketing
Internet

Marketing /
Purchasing

Internet

Extranet

The World

The World

Extranet

Intranet

IT - Dept.

Company
Only

Suppliers, Customers
Collaborators

Suppliers, Customers
Collaborators

Intranet

Figure 9.1

The Internet works by using a protocol called TCP/IP. TCP/IP allows one computer to
talk to another computer via the Internet through compiling packets of data and sending
them to right location.

An extranet is a private network that
uses Internet technology and the public
telecommunication system to securely share
part of a business's information or operations
with suppliers, vendors, partners, customers,
or other businesses.

An Intranet is a website used by
organizations to provide a place
where employees can access company
information (eg policies, procedures, staff,
directory, department info), tools (quick
links to common apps, forms etc.) and
(collaborate (to social sharing tools similar
facebook).
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• Email
• Web-enabled audio/video conferencing services
• Online movies and gaming
• Data transfer/file-sharing, often through File Transfer Protocol (FTP)
• Instant messaging
• Internet forums
• Social networking
• Online shopping
• Financial services
9.2.1 Domain Name
It is a name or an identity which become a online identity and can be access by the web
browser when connected to internet.
Table: 9.1
Generic Domain Name Description
.com

Commercial Organisation

.gov

Government institution

.org

Non-profit Organisation

.net

Network Support Group

.edu

Educational Institution

The heart of intranets and the internet is called as the Domain Name
System(DNS), the way computers can contact each other and do things such
as exchange electronic mail or display Web pages. The Internet Protocol (IP)
uses this Internet address information and the DNS to deliver mail and other
information from computer to computer
Table: 9.2
Country Level Domain Name

Description

.in

India

.au

Australia

.us

United States of America

.jp

Japan

.ru

Russia

.sg

Singapore
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9.2.2 What is URL?
Every server on the internet
has an IP number, a unique number
consisting of four parts separated by
dots. The IP number is the server’s
address
165.113.245.2
128.143.22.55
Figure 9.2
At times the number keeps
changing hence it is harder for people to remember number than to remember word
combinations. So, addresses are given “word-based” addresses called URL. The URL and the
IP number are one and the same.
A URL is an address that shows where a particular page can be found on the World
Wide Web. URL is an abbreviation for 'Uniform Resource Locator (URL)'.

9.2.3 Who Governs the Internet?
One of the most frequently
asked questions about the internet
is, “ Who runs it?” The truth is that
no centralized management of the
internet exists.

ICANN was created on September 18,
1998, and incorporated on September
30, 1998, in the US State of California.
It is headquartered in the Playa Vista
neighborhood of Los Angeles.

The internet as a whole does not have a single controller. But the internet society,
which is a voluntary membership organization, takes the responsibility to promote global
information exchange through the internet technology. Internet Corporation for Assigned
Names and Numbers( ICANN) administers the domain name registration. It helps to avoid a
name which is already registered.
9.3.4 What is W3C?
W3C stands for "World Wide Web Consortium." The W3C is an international
community that includes a full-time staff, industry experts, and several member organizations.
These groups work together to develop standards for the World Wide Web.
The World Wide Web Consortium (W3C) is an international organization committed
to improving the web. It is made up of several hundred member organizations from a variety
of related IT industries. W3C sets standards for the World Wide Web (WWW) to facilitate
better communication ability and cooperation among all web stakeholders. It was established
in 1994 by the creator of the WWW, Tim Berners-Lee.
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9.3 Types of Internet Service
Here are some common types of Internet service.
Wireless
Radio frequency bands are used in place of telephone or cable networks. One of the
greatest advantages of wireless Internet connections is the "always-on" connection that can be
accessed from any location that falls within network coverage. Wireless connections are made
possible through the use of a modem, which picks up Internet signals and sends them to other
devices.
Mobile
Many cell phone and smartphone providers offer voice plans with Internet access.
Mobile Internet connections provide good speeds and allow you to access the Internet.
Hotspots
Hotspots are sites that offer Internet access over a wireless local area network (WLAN)
by way of a router that then connects to an Internet service provider. Hotspots utilize WiFi technology, which allows electronic devices to connect to the Internet or exchange data
wirelessly through radio waves. Hotspots can be phone-based or free-standing, commercial or
free to the public.
Broadband
This high-speed Internet connection is provided through either cable or telephone
companies. One of the fastest options available, broadband Internet uses multiple data
channels to send large quantities of information. The term broadband is shorthand for broad
bandwidth. Broadband Internet connections such as DSL and cable are considered highbandwidth connections. Although many DSL connections can be considered broadband, not
all broadband connections are DSL.
DSL
DSL, which stands for Digital Subscriber Line, uses existing 2-wire copper telephone line
connected to one's home so service is delivered at the same time as landline telephone service.
Customers can still place calls while surfing the Internet.
Cable
Cable Internet connection is a form of broadband access. Through use of a cable modem,
users can access the Internet over cable TV lines. Cable modems can provide extremely fast
access to the Internet.
Satellite
In certain areas where broadband connection is not yet offered, a satellite Internet option may
be available. Similar to wireless access, satellite connection utilizes a modem.
ISDN
ISDN (Integrated Services Digital Network) allows users to send data, voice and video
content over digital telephone lines or standard telephone wires. The installation of an ISDN
adapter is required at both ends of the transmission—on the part of the user as well as the
Internet access provider.
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Dongles / Data Card
Today, many dongles provide wireless capabilities. For example, USB Wi-Fi adapters
are often called dongles. Since most computers now have built-in Wi-Fi chips, mobi data
adapters, such as 3G and 4G dongles, are more prevalent. These types of dongles allows to
connect to the Internet even when Wi-Fi is not available.
Comparison between Data Card and Dongle
Dongle

Data Card

Refers to any removable component used
for enabling extra security. USB Dongles
can be divided into
• WiFi Dongles
• BlueTooth Dongle
• Memory Dongle

It is a removable electronic card which
is used for storing for data. Types of
datacard are
• Expansion Card
• Memory Card or Flash Card
• Identification Card

9.3.1 Internet Connection and Access Methods
There are several ways or methods of connecting to the Internet.
There are two access methods direct and Indirect and these can be either fixed or
mobile.
9.3.1.1 Indirect Access
This is most common
method used in home and office
networks.
The device e.g. computer
connects to a network using
Ethernet or WiFi and the network
connects to the Internet using
Asymmetric digital subscriber
lineADSL( cable or fibre.)
9.3. 1.2 Direct Access
This is most common
method used when travelling.

Indirect Access

Direct Access
Public-Wifi
Dial up-(old method
Router

Wthernet or Wi-Fi
network
ADSL, Fibre or
3G/4G
Cable
Internet Connection Methods
Figure 9.3

The device e.g. smart phone
connects directly to the Internet using 3G/4G mobile networks or public Wi-Fi.
There are two ways to look for the information on the web.
1. If the URL of the website is known, enter it on the address bar.
2. If is the URL is not known, then “Search Engines” will help us to get the information.
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A search engine is a software system that is designed to search for information on the
World Wide Web.
Examples of popular search engines are Yahoo, Lycos, Altavista, Hotbot, Google and
Askjeeves.
1. A browser is used to access websites and web pages whereas a search engine isused to
search for particular information.
2. Internet Explorer, Chrome, Firefox, Safari, and are the most popular web browsers while
Google and Yahoo are the most popular search engines.
3. A browser is used to access the Internet whereas in order to open a search engine you need
a browser.
The list of content returned via a search engine to a user is known as a search engine
results page (SERP).
9.4 Internet Applications
1. Internet telephony using VoIP (Voice-over-Internet Protocol) Example Skype
2. Job search

:-Nowadays, many people search for their jobs online using naukri.
com,monster.com, recuritmentindia.com etc as it is quicker .

3. Online Shopping

:-The internet has also facilitated the introduction of a new market
concept consisting of virtual shops. For example amazon.com

4. Stock market updates :- Selling or buying shares sitting on computer through internet.
Several websites like ndtvprofit.com, moneypore.com, provide
information regarding investment
5. Travel

:- One can use internet to gather information about various tourist
place .it can be used for booking Holiday tours. Some of the web
sites providing this service are goibibo.com, makemytrip.com,
olacabs.com.

6. Research

:-Research papers are present online which helps in the researcher
doing a literature review

7. Video conferencing

:- It enables direct face-to-face communication across networks
via web cameras, microphones, and other communication tools.

8. e –commerce

:- e–commerce (electronic commerce or EC) is the buying and
selling of goods and services, or the transmitting of funds or data,
Largest e-commerce companies in India are Flipkart, Snapdeal,
Amazon India, Paytm.

9. Online payments

:- The rising boom of online payments in India has given way to
many new entrants in the industry such as Paytm etc who are
majorly wallet driven payment companies.
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10. Social Networking

:- 
Social networking is the use of internet-based social media
programs to make connections with friends, family etc. Examples
of social networking includes Facebook

11. Voicemail

:-Voicemail is a system of sending messages over the phone.

12. Chatting

:-On the Internet, chatting is talking to other people who are using
the Internet at the same time you are.

13. e-banking

:-e-banking (Online banking) , also known as internet banking, it
is an electronic payment system that enables customers of a bank
or other financial institution to conduct a range of financial
transactions through the financial institution's website. The
online banking system will typically connect to or be part of the
core banking system operated by a bank and is in contrast to
branch banking which was the traditional way customers accessed
banking services.

14. e-learning

:-e-Learning are courses that are specifically delivered via the internet
to somewhere other than the classroom where the professor is
teaching. It is not a course delivered via a DVD or CD-ROM, video
tape or over a television channel

e-learning is utilizing electronic technologies to access educational curriculum outside
of a traditional classroom. It is a program delivered completely online. E-learning is interactive
in that you can also communicate with teachers, professors or other students in a class. There
is always a teacher/ professor interacting/ communicating, grading participation, giving
assignments and conducting tests.
15. E-governance :- Electronic governance or e-governance is the application of information
and communication technology (ICT) for delivering government services.
Benefits of E-governance
•
•
•
•
•

Reduced corruption
High transparency
Increased convenience
Reduction in overall cost.
Expanded reach of government

9.5 Email

Electronic mail or email is
information stored on a computer
The first mail was sent by Ray Tomlinson in
that is exchanged between two
1971 as a test e-mailmessage containing the
users over telecommunications.
text like “QWERTYUIOP”
Email is a message that may
contain text, files, images or any other attachments sent through a network to a specified
individual or group of individuals
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Figure 9.4
9.5.1 Structure of email
Click the Compose button and then writing an e-mail contents
When sending an e-mail message, several fields are required to be filled:
• The To field is where you type the e-mail address of the person who is the recipient of your
message.
• The From field should contain your e-mail address.
• If you are replying to a message, the To and From fields are automatically filled out; if it's a
new message, you'll need to enter them manually.
• The Subject should consist of a few words describing the e-mail's contents. The Subject lets
the recipient see what the e-mail is about, without opening and reading the full e-mail. This
field is optional.
• The CC (Carbon Copy) field allows you to specify recipients who are not direct addressees
(listed in the "To" field). This field is optional.
• The BCC (Blind Carbon Copy) field is similar to CC, except the recipients are secret.
Each BCC recipient will receive the e-mail, but will not see who else received a copy. The
addressees (anyone listed in the "To" field) remain visible to all recipients. This field is
optional.
• Finally, the Message Body is the location you type your main message. It often contains
your signature at the bottom; similar to a hand-written letter.
9.5.2 Advantages of email
Some of the main advantages of email are listed below.
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• Free delivery - Sending an e-mail is virtually free, outside the cost of Internet service.
There is no need to buy a postage stamp to send a letter.
• Global delivery - E-mail can be sent to nearly anywhere around the world, to any country.
• Instant delivery - An e-mail can be instantly sent and received by the recipient over the
Internet.
• File attachment - An e-mail can include one or more file attachments, allowing a person
to send documents, pictures, or other files with an e-mail.
• Long-term storage - E-mails are stored electronically, which allows for storage and archival
over long periods of time.
• Environmentally friendly - Sending an e-mail does not require paper ( Paperless )),
cardboard, or packing tape, conserving paper resources.
9.5.3 What is sent in an email
In addition to text messages being sent over e-mail, it is also possible to attach a file or
other data in an e-mail. For example, an attachment could be a picture, PDF,word processor
document,, or any file stored on the computer.
9.6 Internet Threat
It’s a dangerous world out there in the World Wide Web. Just as your mother may
have told you to never talk to strangers, the same advice holds true for the virtual world. You
may know to be wary of giving strangers your business bank account details. But can you
be sure the website you’re logging into is that of your bank and not a forgery created by a
cybercriminal?Cybercriminals use many different methods to lure you into parting with your
confidential personal or business information. Hence you ought to be aware of the issues and
be extra vigilant when online and offline..
Computer virus: A computer virus is a small piece of software that can spread from one
infected computer to another. The virus could corrupt, steal, or delete data on your computer—
Malware: Malware is short for “malicious software.” Malware is used to mean a “variety of
forms of hostile, intrusive, or annoying software or program code.” Malware could be computer
viruses, worms, Trojan horses, dishonest spyware, and malicious rootkits—all of which are
defined below.
Trojan horse: Users can infect their computers with Trojan horse software simply by
downloading an application they thought was legitimate but was in fact malicious.
Malicious spyware: Malicious spyware is used to describe the Trojan application that was
created by cybercriminals to spy on their victims.
Computer worm: A computer worm is a software program that can copy itself from one
computer to another, without human interaction.
Botnet: A botnet is a group of computers connected to the Internet that have been compromised
by a hacker using a computer virus or Trojan horse. An individual computer in the group is
known as a “zombie“ computer.
Spam: Spam in the security context is primarily used to describe email spam. Unwanted
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messages in your email inbox. Spam, or electronic junk mail, is a nuisance as it can clutter
your mailbox as well as potentially take up space on your mail server.
Phishing: Phishing scams are fraudulent attempts by cybercriminals to obtain private
information. Phishing scams often appear in the guise of email messages designed to appear
as though they are from legitimate sources. For example, the message would try to lure you
into giving your personal information by pretending that your bank or email service provider
is updating its website and that you must click on the link in the email to verify your account
information and password details.
Rootkit: A rootkit is a collection of tools that are used to obtain administrator-level access to
a computer or a network of computers. A rootkit could be installed on your computer by a
cybercriminal exploiting a vulnerability or security hole in a legitimate application on your PC
and may contain spyware that monitors and records keystrokes.
9.7. Browsers
Looking for information on the internet is called surfing or browsing. To browse the
internet, a software called the web browser or browser is used.
E-commerce, social media, and many other things we take for granted today would
be impossible without internet browsers.Web browsers translates HTML documents of the
website and allows to view it on the screen.
9.8.1 Familiar Internet Browser
1. Google Chrome is a freeware familiar web browser developed by Google Inc. It is best for
its speed, simplicity, security, privacy and customization features. Google Chrome supports
on Android 4.0 or higher, iOS 6.0 or higher, Mac OSX 10.6 or higher and Windows (XP sp2
or higher) and Linux system.
2. Mozila Firefox is a free and open source web browser developed by Mozilla Foundationand
Mozilla Corporation. FireFox is default browser in Ubuntu . It supports Windows, Mac
OS X, Linux and Android system.
3. Internet Explorer commonly known as Microsoft Internet Explorer or Windows Internet
Explorer is the first or default browser for a Windows PC. It is developed by Microsoft.
4. Safari is a web browser developed by Apple Inc. and comes with OS X and iOS. Some
version of safari browser also supports in Windows Operating System. Exclusively used in
Apple Mac system.
9.8 Web Page Vs Web Site
Websites
A website is a collection of webpages. For example if there is a company that owns
sricompany.com then this website will have several Webpages like Home, About Us, Contact
Us, Testimonials, Products, Services, FAQ’s, and others. The first page of the website is called a
Home Page. All of these pages together make up a Website.
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Web Pages
A webpage is apage of a Website. A web page can be accessed by a URL in a browser and
that page can be copied and or send to a friend for review whereas websites are collections of
multiple page that must be navigated to view other content
A webpage is a page of a Website. Every page has a unique address called the Uniform
Resource Locator (URL). The URL locates the pages on the internet.
Difference between Webpage and Website
Webpage

Website

Consists of a Single document displayed by A collection of multiple documents
a browser
displayable by a browser
Shares a unique domain name

Has its own unique domain name

Makes up a website

Contains one or more webpages
9.9 Static and Dynamic Web Pages

Web pages are classified as Static and Dynamic Webpages
Web pages are called Static websites as they remain the same whenever it is visited.
Examples of static Websites are website owned by Small business organizations, School
websites etc.
Websites that displays marks of Public Examinations and Entrance Examinations
changes when different register numbers are given. Such websites are called as Dynamic
Websites. Eg,. Websites of Government and Entrance Exams.
Comparison of Static and Dynamic Web Pages
Static Web Page

Dynamic Web Page

The content and layout of a web page is fixed

The content and layout may change during
run time

Static Web pages never use databases

Databases is used to generate dynamic
content through queries

Static web pages directly run on the Dynamic web pages runs on the server
browser and do not require any server side side application programs and displays
application program
the results
Dynamic web page development requires
programming skills

Static Web pages are easy to develop

9.10 Safe Surfing on Internet
As a great reminder that Internet security is something that needs constant vigilance.
It’s also a great reminder that a lot of things can happen on the Internet if you don’t properly
take precautions against them. With that in mind, be sure to have a safe and happy Safer
Internet Day.
213

Chapter 9 Pages 1-27.indd 213

3/20/2020 11:37:50 AM

SAFER INTERNET DAY
Safer Internet Day (SID) 2018 iscelebrated around the world in February of every year
with a theme of "Create, connect and share respect: A better internet starts with you".
Following is the do’s and don’t of safe Surfing on Internet
1. Don’t give out your personal information – Don’t put personal details such as your home
address, telephone numbers or parent’s work address online as cybercriminals can use this
information to create a fake profile with your details
2. What goes online, stays online – Use privacy settings to make sure only your friends and
family can see photos you post. Avoid posting holiday plans as criminals have been known
to track your movements
3. Check your security and privacy settings – Make sure your social network privacy settings
are secured so only your friends can see your personal information and use your privacy
settings to restrict who can see your posts, videos and photos
4. Password safety – Sharing your password with your parents is a sensible idea, but avoid
sharing your password with your friends, even if they promise they won’t tell anyone! Also,
when setting your password, make sure it isn’t something people may guess such as your
pet’s name. Use a mixture of letters, numbers and upper and lower case characters
5. Always protect your mobile device – Make sure your mobile phone is pin-protected so all
your personal information stored on it is safe. Download a security app which allows you
to remotely wipe any personal data, should your mobile be lost or stolen
6. Don’t talk to strangers online or offline – Don’t meet up with strangers and let your parents
know if a stranger has tried to get in contact with you online.
7. Listen to the adults who know – Adults will always be worried about you. Help set their
mind at rest and avoid chatting online with strangers.
8. Be wary of unsecured or unknown websites – When shopping online, use reputable and
known retailers.
9. Be careful what links you click on – Avoid clicking links in an email, Instant Message or on
your social network unless you are sure the message is from someone you know.
Now that we have come to the end of this chapter, the next chapter introduces you to
create a web page using html tags.
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Points to Remember:
• The different type of network are LAN, MAN, WAN, PAN, CAN and WLAN
• Two things required for TCP/IP needed are
a) Message to transmit
b) Means to reliably transmit the message
• Each computer on net is called as host
• Internet Corporation for Assigned Names and Numbers ( ICANN) administers the
domain registration to avoid name already registered.
• W3C stands for world wide web consortium.
• Hotspots are sites that offer internet access over wireless local network.
• Video conferencing enables direct face-to-face communication across networks via
web cameras, microphones, and other communication tools.
• E–commerce (electronic commerce or EC) is the buying and selling of goods and
services, or the transmitting of funds or data, over an electronic network, primarily the
Internet.
• Social networking is the use of internet-based social media programs to make
connections with friends, family, classmates, customers and clients.
• Voicemail is a system of sending messages over the phone.
• Email is short for 'electronic mail' similar to a letter, it is sent via the internet to a
recipient
• An internet browser, also known as a web browser, is a software program that you can
use to access the internet and view web pages on your computer.
• A website is a collection of webpages.
• Dongle refers to removable component used for enabling software protection. E.g.
USB, WiFi
• A webpage is a page of a Website.
• E-commerce is the activity of buying or selling of products on online services or over
the Internet.
• Electronic governance or e-governance is the application of information and
communication technology (ICT) for delivering government services.
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Evaluation
Part – I

Choose the correct answer
1.

2.
3.
4.
5.

6.

7.
8.
9.
10.
11.

What is the expansion of WLAN?
a)Wireless Local Area Network		
c) Wireless Local Area Netware		

b) Wired local Area Network
d) Wireless Area Netbande

Range of Campus Network is
a) 10 KM		
b) 5 KM		

c) 25 KM		

d) 20 KM

Each computer on net is called
a) host			
b) server		

c) workstation

d) node

The internet is governed by
a) ICANM		
b) ICANN		

c) ICMA		

d) ICNNA

Expansion of W3C
a) World Wide Web Consortium		
c) World Web Wide Consortium		

b) Wide World Web Consortium
d) World Wide Web Consortum

W3C was established in 1994 by
a) Tim Berners-Lee				
c) Kim Berners				

b) Tim Burnard Lee
d) Kim Bernard Lee

Hotspot uses which type of network services?
a) LAN		
b) PAN		
c) WLAN		

d) CAN

USB WiFi adapters are often called as
a) Data Card		
b) Pen Drive		

d) Memory Card

c) Dongles		

Looking for information on the internet is called
a) Surfing		
b) Searching		
c) Finding		

d) glancing

Safari web browser was developed by
a) Google		
b) Apple		

d) Linux Corpn.

c) Microsoft		

How many types of websites are available?
a) 3		
b) 2		
c) 4		
d) 6
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3. Differentiate Data Card and Dongles.
4. Write a note on two access methods of
connecting to internet.
5. Differentiate browser and a search engine
with suitable examples.
6. Differentiate Website and Webpage.
7. What is the difference between Static and
dynamic web page.
8. What are Advantages of email.

Part – II
Very Short Answers
1.	Name the two important protocols for
internet?
2. What is a network?
3. What is the role of ICANN ?
4. What is a search engine?
5. What is a browser?
6.	
What are the components of url
addressing
?
7. What is a website?
8. What is CC and BCC in an email?
9. What is a Static web Page?
10. What is a Dynamic web page?
11. What are the benefits of e-governance?
12. What is Phishing ?
Part-III

Part-IV
Explain in Detail
1. Explain any five types of internet services.
2. Explain any five internet applications
with suitable examples.
3. Write a note on any five Internet browsers
other than that given in the book.an
4. Explain the do’s and don’t of safe surfing
on internet.

Short Answers
1. What is TCP/IP ?
2.	Write a note on Hotspot internet service.

Activity
Student Activity
Explain the different types of network.
Mention a few internet services you know.
Mention a few Internet Applications other than that is given in the textbook
List some browsers not given in the text book
Teacher Activity
Students is taught to develop Static and Dynamic Websites as workshop.

GLOSSARY
Acronym

Description

VSNL

Videsh Sanchar Nigam Ltd

TCP

Transmission Control Protocol

IP

Internet Protocol

Host

A host is a computer connected to a computer network
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ICANN
W3C

Internet Corporation for Assigned Names and Numbers
World Wide Web Consortium

WWW

World Wide Web

Tim Berners-Lee Creator of WWW
DSL

Digital Subscriber Line

ISDN

Integrated Services Digital Network

URL

Uniform Resource Locator

Dongle

A sbmall device able to be connected to and used with a computer,
allowing access to wireless broadband or use of protected software.

ADSL

Asymmetric Digital Subscriber Line

Browser
Search Engine

A browseris software that is used to access the internet Eg. Chrome,
FireFox
A search engine is a web-based tool that enables users to locate
information on WWW. Eg. Google

SERP.

The list of content returned via a search engine to a user is known as
a search engine results page.

Phishing

Phishing scams are fraudulent attempts by cybercriminals to obtain
private information

WebSite

Collection of Webpages

WebPage

It is page of Website.

EDI

Electronic Data Interchange

Voice mail

System of sending messages over the phone.

e-commerce

Electronic Commerce, Buying and selling goods and services over an
electronic network.

e-governance

Electronic governance. Application of information and communication
technology for delivering government services.

Internet

Several networks, small and big all over the world, are connected
together to form a Global network called the internet.

Intranet
Extranet

It is a website used by organizations to provide a place where
employees can access company related information.
It is a private network using internet technology to share part of
business information with suppliers partners and customers.

References:
1. Mastering HTML, CSS & JavaScript Web Publishing – Laura Lemay, Rafe Colburn, Jennifer
Kyrnin – BPB Publications.
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Unit III

Web Page Development using
HTML, and CSS

CHAPTER

10

HTML - Structural Tags

Learning Objectives:

HTML was originally
derived from SGML
(Standard Generalized
Markup Language) a
larger, complicated document
processing language. To learn
HTML, no need to know about
SGML.

The students will learn the following:
• How to create web pages using HTML.
• What are the various structural tags
available to create an HTML document.
• What are the various page formatting
tags available and how to use them.

10.1 Introduction to HTML

10.2 Writing HTML document

In the previous sections you learnt
about Internet and web pages, whatever you
have seen on the web is a document written
in HTML (Hyper Text Markup Language).
HTML is a special markup language used
to create web pages. This language tells the
browsers, how to display the text, images,
animations and other contents of a hypertext
document on the screen. The language also
tells how to make a document interactive
through special hyper links.

HTML is a markup language. Writing
in a markup language is very simple, directly
you start the text of your web document
and add special tags around words and
paragraphs. The tags are coded by HTML
commands or keywords that indicate how
web browser should format and display the
content.
HTML is made up of tags and its
attributes. Tags are known as elements of
HTML. Additional information such as
colour, alignment etc., can be included with
an HTML tag is known as attribute. Attributes
are used to improve the appearance of an
HTML document. You cannot create your
own tags to create a new style or feature.

HTML is not a word processing
tool or a programming language. It is only
a markup or page layout and hyperlink
specification language. It describes the
structure of a document.
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All HTML tags should be specified within angle brackets (< >). For example,
<HTML> is a tag. HTML is not case sensitive that means you can write an HTML tag in lower
case or in upper case (Small letter or Capital letter). Browser treats both of them in the same
manner. For example, you can write <HTML> as <html>; both are same.
10.2.1 HTML Document Structure
An HTML document contains the text of the page itself and HTML tags, which defined
the structure and appearance of the document. It also contains hyperlinks to other pages or to
include multimedia elements such as audio, video, animations etc. Entire HTML document is
bounded within a pair of <html> and </html> tags.
All HTML documents should follow this general format

<html>
<head>
<title> My First Web Page </title>
</head>
<body>
This is my First Web Page
</body>
</html>
HTML tags are generally have an opening and closing tag surrounding the text they
affect. Opening tag turn-on a feature such as heading, bold, center etc., and closing tag turn-off
its features. Opening and closing tags are the same name, but closing tag name preceded by a
slash ( / ). For example, <html> is an opening tag, </html> is a closing tab.
Every web document has two sections viz. Heading Section and Body Section. The
heading section is used to show the title of a webpage in title bar or tab heading in browser.
The head section should begins with <head> tag and end with </head> tag. The tag <title> is
used to specify the title of the webpage.
The body section is used to display the main content on the browser window. The
body section should defined within <body> and </body> tags. Whatever the text you specify
between these tags will display on the browser window. (Refer Figure 10.1)

220

Chapter 10 Pages 28-53.indd 220

3/20/2020 11:39:10 AM

Head Section

Body Section

Figure 10.1 – Internet Explorer with my first web page
10.2.2. Structural Tags of HTML:
<html>, <head>, <title> and <body> these four tags are known as structural tags. These
tags are basic essential elements to construct a web page.
Table: 10.1
Opening Tag Closing Tag
<html>

</html>

<head>

</head>

<title>

</title>

<body>

</body>

Description
The <html> tag identified the document as an HTML
document.
All HTML documents should begins with <html> and
end with </html>.
The <head> tag contains information about the
document, including its title, scripts used, style
definition and document descriptions.
The <title> tag contains the title of the document. The
title specified between opening and closing tags appears
in the title bar / page tab of the browser.
<title> tag should be placed within <head> tag.
The <body> tag encloses all the tags, attributes and
information to be displayed in the web page.
<body> tag should be entered below the </head> tag.

10.2.3. HTML Writing Tools
To get started writing HTML, there is no need of web server, web hosting or even
internet connection. You can write, test and link web pages without a network. To create and
testing a HTML document i.e. web page need an application (text editor) to write HTML code
and a browser to view them. Using a simple text editor (Notepad for Windows or getit for
Linux) is a good way to learn HTML coding.
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10.2.3.1 Creating a Webpage
Step 1: Open a text editor
Windows7 : Start → All Programs
→Accessories → Notepad
Step 2: In the appearing Note pad / Text Editor,
type the HTML document.
(Refer Figure 10.2)
Step 3: Save the file as HTML
• Click File → Save (or) Press Ctrl + S

Figure 10.2 – Notepad with HTML code
• Save as dialog box appears as shown in the Figure 10.3
• In “File Name” text box, type a file name with .htm or .html extension.
• Select “All Files” from “Save as type” list box.
• Click “Save” button.

Save in Location

File name with
.htm or. html

Select "All Files"

Figure 10.3 Save As dialog box
10.2.3.2. Viewing Webpage in a Browser:
Step 1: Open a Browser (Internet Explorer / Mozilla Firefox or any)
Step 2: Click File → Open File (or) Press Ctrl + O
Step 3: From the “Open” dialog box, browse the folder in which the HTML document is saved.
Choose the File name and click “Open” button. (Refer Figure 10.5)
Now, your web page is displayed in the browser.
10.2.3.3 Viewing Source file
Source file is an HTML document, what you actually type in text editor (Notepad or
getit). You can view your original source file in the browser. The following steps are to be
followed to view a source file.
• Right click on the browser
• Select View Page Source (Firefox and Chrome) / View Source (Internet Explorer) or
Press Ctrl + U (all browser)
• Source file will be displayed.
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• In Internet Explorer, View → Source is also used to open source file.
Remember that, you cannot edit the source file opened using the methods you learnt above.
10.2.3.4 Edit and Reload the source file
Source file can be edit only through the text editor. So, to edit the source file, open the
source file with a text editor. When you edit a source file, no need to close browser in which
displaying the HTML document. The following steps are to be followed to open a source file.
• Go to the folder in which your source files are located.
• According to you default browser, your source file icon is displayed. (Refer Figure 10.7)
Internet Explorer

Mozilla Firefox

Google Chorme

Figure 10.5 Source files in different browsers
• Right click on the source file that you want to edit
• From the pop-up menu, select Open With → Notepad
• Source file will be opened in text editor
• Make the changes and save the file using File → Save or Ctrl + S.
Reload / Refresh the changes:
• After modify and save the source file, minimize your source file.
• Go to the browser.
• Click Refresh (Internet Explorer) / Reload Current Page (Firefox) / Reload this page
(Chrome) icons on the address bar.
• Press Ctrl + R or F5 will be used to refresh / reload the modifications.
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10.3 HTML Attributes
Attributes are special words used inside a tag to specify additional information to a
tag. Attributes should be placed within the opening tag. Most of the tags support specialized
attributes and there are also a few global elements that can be used with any tag. Global
elements are common to all HTML elements; they can be used on all elements.
10.3.1 Attributes for Structural Tags
1. Attributes of <html> tag
The <html> tag is used to specify the beginning and closing of an HTML document.
This tag does not have any effect on appearance of document. This is only used to make
browsers and other programs, known that this is an HTML document.
<html> tag has two attributes viz. dir and lang to specify the text direction and
language setting respectively.
attribute Value to be set to attribute Description
dir attribute specifies the direction of the text to
be aligned within the entire document. It is global
ltr (align left-to-right)
dir
attribute.
rtl (align right-to-left)
• ltr is the default value
• rtl is used for Arabian languages.
lang attribute specify the language used with in
Predefined language code
the document. Predefined language code will be
English – en
lang
used for this purpose.
Tamil – ta
Malayalam – ml; Kannada – kn; Hindi – hi;
Telugu – te
French – fr; German – de;
2. Attributes of <body> tag
The <body> tag defines the document’s body. The contents of an HTML page reside
within the <body> tag. <body> tag contains several attributes.
(i) Background Colour: bgcolor = color
`
By default all the browsers display the text on white background. However, the
background color of the browser can be changed by using bgcolor tag.
The tag to change background colour:
<body bgcolor = color_name/color_code>
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Illustration 10.1 – HTML code to change background colour of a browser
<html>
<head>
<title> Background Colour change </title>
</head>
<body bgcolor = yellow>
		
This is my browser with different colour
</body>
</html>
In the above HTML code,
colour name has been used to
change the background colour
of the browser’s body section.
Generally colors in HTML are
represented as six digit hexadecimal
values. Colour name can be used
for only few colors. But, color code
(hexadecimal value) will be more
flexible to handle colors.

D:\CS_TestBook_Final\HTML\

File

Edit View Favorites

Tools

Background Colour change
Help

This is my browser with different colour

File

Edit Format

bgcolor - Notepad

View Help

<html>
		<head>
			<title> Background Colour
change </title>
		</head>
		
<body bgcolor = yellow>
			
This is my browser with
different colour
		</body>
The Colour of the
</html>
browser turns in yellow

Figure 10.5 Internet Explorer with
The six digit hexadecimal
Yellow background
value is the combinations of three,
two digit number sequence represent a color. First two digits represent Red, next two digits for
Green and last two digits for Blue (RGB) in the range of 00 – FF. For example, 000000 is black
and FFFFFF is white. FF0000 is bright red. You can try out different combinations of these
values to get variety of colors.
You can use some basic color names or color code to handle colors in HTML elements.
Modern browsers support nearly 140 colors. Color code should be prefixed with #. The
following table shows some basic colors with their hexadecimal code.
Table 10.2 – Some basic Color names with code
Color Name Hexadecimal value
Red
#FF0000
Blue
#0000FF

Color Name
Olive

Hexadecimal value
#808000

White

#FFFFFF

Green

#008000

Black

#000000

Yellow

#FFFF00
#00FF00
#800080
#C0C0C0

Maroon
Grey
Aqua
Brown

#800000
#808080
#00FFFF
#A52A2A

Lime
Purple
Silver
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To know the complete color code visit:
https://www.w3schools.com/tags/ref_colornames.asp
The above illustration 10.1 can be re-written as follows to get the result
<html>

<head>
		
<title> Background Colour change </title>
</head>
<body bgcolor = #FFFF00>
		
This is my browser with different colour
</body>
</html>

(ii) Body text Colour: text = color
The default text colour of body section is “black”, it is often called as automatic color.
text attribute within body tag is used to change the text colour.
The tag to change body text colour:
<body text = color_name/color_code>
Illustration 10.2 – HTML code to change background and text color of
a browser’s body
<html>
<head>
		

<title> Background Colour change </title>

</head>
<body bgcolor = #FFFF00>
		

This is my browser with different colour

</body>
</html>

To the above code, text will be displayed in Red color on yellow background. You can also use
colour code instead of colour name.
(iii) Background image: background=image
An image or picture can be applied as background to a webpage. When you insert an
image as background, the text will be displayed on top of the image. Background images can
be a texture or bitmap or even a photo.
When you insert a small image, the browser takes the image and repeats it across and
down to fill browser window. Inserting animated images (GIF images) creates more interesting.
The tag to apply an image as background:
<body background = “image_name_with_extenstion”>
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Illustration 10.3 – HTML code to apply an image as background
<html>
<head>
<title> Image as background </title>
</head>
<body background = “flower01.gif ”>
This is my browser with an image as background
</body>
</html>

While including an image as
background, the image file name is
not required to be in double quotes.
The code <body background =
flower01.gif> can also produce the
same result.
If your image file name is long
or split as two more words or along
with path, should be specify within
double quotes.

Inserting an image as
background

Remember that, if the image
Figure 10.6 Internet Explorer with an
file and HTML source are located
image as background
in different locations i.e. in different
folder or drive, file path should be clearly specified along with image file name. In the above
case, image file and HTML source file both are located within the same folder. So, path name
is not mentioned.
For example, If the image file is somewhere in a folder (say Images folder in E: drive),
you must specify its full path within double quotes as given below.
<body background = “E:\Images\ flower01.gif ">
(iv) Setting Margins: margin = value
The margin refers the blank area from left or top edge of the browser window. Generally
there is no default margin setting in any browser. If you want to leave some space as margin to
left or top; leftmargin or topmargin attributes will be used respectively.
The tag to specify the left and top margin:
<body leftmargin = value topmargin = value>
		

The Value is referred as pixels (72 pixels to an inch)
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Illustration 10.4 – HTML code to set left and top margins
<html>
<head>
<title> Setting Margins </title>
</head>
<body leftmargin = 50 topmargin = 50>
This is my Web page with top and left margin
</body>
</html>

The statement <body leftmargin = 50 topmargin = 50> will intent the body text 50
pixels away from the left as well as from top edge of the browser.
Illustration 10.5 – Create a web page (HTML document) to the following specification.
• Title: My First Web Page
• Text to be display: Welcome to Computer Applications
• Background color: Lime
• Body text color: Blue
• Margin: from left and top 1 inch
<html>
<head>
		
<title> My First Web Page </title>
</head>
<body bgcolor = Lime text = blue leftmargin = 72 topmargin = 72>
		
Welcome to Computer Applications
</body>
</html>
Remember that, when you use more than one attribute within an HTML element (Tag)
space is used as separator.

10.4 Headings
Headings are used to include titles to sections of a web page. HTML has six levels of
headings viz. <h1> to <h6>. The number with h indicates the level of heading. Header tags are
display the body text as bolder and larger in size according to its level.
The syntax of heading tags:
<h…> Heading text </h…>
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Illustration 10.6 – HTML code with Headings
<html>

<head>
		
<title> Heading </title>
</head>
<body>
<h1> Welcome to Computer Application</h1>
<h2> Welcome to Computer Application</h2>
<h3> Welcome to Computer Application</h3>
<h4> Welcome to Computer Application</h4>
<h5> Welcome to Computer Application</h5>
<h6> Welcome to Computer Application</h6>
</body>
</html>

<H1>
<H2>
<H3>
<H4>
<H5>
<H6>

Figure10.7 – Different levels of Headings
10.4.1 Attribute of Headings tag
Align is an attribute to set right, center and justify alignment to headings. Left if the
default alignment, so that it is not supported in latest version of HTML. Justify alignment is
not supported by older browsers.
The tag is to specify the alignment to headings:
<h# align = value>
Where # is the level number, value may be Right, Center or Justify. Justify alignment
only used for paragraphs. The meaning of alignment is similar what you learnt from Word
processor.
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Illustration 10.7 – HTML code with Heading and align attributes
<html>
<head>
		

<title> Heading </title>

</head>
<body>
<h1 align=center> Welcome to Computer Application </h1>
<h2 align=right> Welcome to Computer Application </h2>
</body>
</html>

10.5 Line Breaks and Paragraphs
Browser applications are having some special rules for displaying text. They do not
recognize returns, tabs or even more than one space between words. If you create an HTML
document with multiple lines of text, browser will display it as a single line. (Refer Figure 10.8)

Browser display
multiple lines as a
single statement.
Because, the browser
does not recongnize
returns

}

Multiple lines

Figure 10.8 Multiline statement displayed as Single line
The <br> tag is used for line break. The <br> is an empty tag, does not have close tag
and attribute. It should be placed at the end of a line. (Refer Figure 10.9)
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}

Multiple lines
with <br> tag

Multiple lines
without <br> tag

}

}

Figure 10.9 Usage of <br> tag
In HTML, paragraphs are created using the <p> tag. The content what you type
between <p> and </p> is identified as a paragraph and display as a paragraph by the browser.
Because, the browser does not recognize returns (Pressing “Enter” Key). Remember that in
word processors, pressing “Enter” key is identifying a paragraph.
Illustration 10.8 HTML code to create a paragraph

<html>
<head>
		
<title> Paragraph </title>
</head>
<body>
<h1 align=center> Business </h1>
<p> Business may be defined as any activity in which a man is
very much interested and these activities bring him profit, money,
prestige and power. </p> <p> In economic sense, the term business
means works, efforts and acts of people, which are connected with
the production of wealth and activities, which are directed with
the object of making profit.</p> <p> Production and distribution
of goods to consumers for a profit constitute business. </p>
</body>
</html>
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In the above illustration, the contents specified between <p> and </p> considered as
paragraph. Each paragraph displayed separately (Refer Figure 10.10).

Figure 10.10 Browser with Paragraphs
Changing Paragraph alignment
You know already that the types of paragraph alignments in Word processor. In HTML
documents more are four paragraph alignments viz. Left, Right, Center and Justify. The text
that you type between <p> and </p> is by default aligned to left. To change the alignment of a
paragraph align attribute can be used with <p> tag.
The tag to specify the alignment to paragraphs:
		

<p align = alignment>

Where alignment can either be Right, Center or Justify. Remember that, left is the
default alignment.
Remember that, the keyboard shortcut to change paragraph alignment in word
processor is not working in HTML.

10.6 Comments
Comments are used to describe the page or provide some kind of indication of the
status of the page. The tag <!> is used to create comments. In HTML, the text what you type
within this tag is considered as comments and it is ignored by the browser. Comments never
show up onscreen. Comments can be placed anywhere in HTML document.
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The general form of comments:
		<! comments >

10.7 Container and Empty Elements
The HTML elements (Tags) can be classified as two types – (1) Container elements (2)
Empty elements.
Container Elements:
• The tags which are required opening and closing is known as container elements or tags.
For example: <html>, <body>, <title>, <p> etc.,
Empty Elements:
• The tags which are required only opening tag is known as empty elements or tags. For
example: <br>
Points to Remember:
• HTML (Hyper Text Markup Language) is a special markup language used to create
web pages
• HTML is not a word processing tool or a programming language.
• HTML is made up of tags and its attributes.
• Tags are known as elements of HTML.
• Attribute is special word used inside tag to specify additional information to the tag
such as color, alignment etc.
• Every web document has two sections viz. Heading Section and Body Section.
• <html>, <head>, <title> and <body> these four tags are known as structural tags
• List of HTML tags from Section-I
Table 10.3
Opening Closing
Tag
Tag
<html>

<head>

<title>

Type

Function

Attributes

Contains

Used
inside

</html> Container

Delimits a
complete
HTML
document

Dir, Lang

<head>, <body>

</head> Container

Defines the
function
header

--

<title>

<html>

</title>

Defines the
document
title

--

Text

<head>

Container
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<body>

</body> Container

Defines the
document
body

All tags that
Background,
controls
the
Bgcolor, Text,
appearance of <html>
Leftmargin,
body of the web
Topmargin
page

</h1>,
< h 1 > ,
Defines one
</h2>,
<h2>….
Container of six levels of
…… </
<h6>
headings
h6>

Align

Text

<body>

Align

Text

<body>

---

Text

<p>

</p>

Defines a
Container paragraph of
text

<br>

--

Empty

Insert a line
break

---

Workshop - 1
Type the following code in a text editor, save it as an html file and open in a browser.
Observe and study their functions by viewing them in your browser. Then, make the required
changes and look what happens.
<html>
<body>
<h1> Thai Pongal </h1>
<p> Pongal is a harvest festival dedicated to the Sun. It is a fourday festival which according to the Tamil calendar is usually
celebrated from 14 January to 17 January. </p>
<p> Thai Pongal is one of the most important festivals celebrated
by Tamil people in Tamil Nadu, Puducherry and the country
of Sri Lanka, as well as Tamils worldwide, including those in
Malaysia, Mauritius, South Africa, the United States, Singapore,
Canada, Myanmar (Burma) and the UK. </p>
<p> Thai Pongal corresponds to Makara Sankranthi, the harvest
festival celebrated throughout India. </p>
</body>
</html>

Carry over the following changes:
(a)

Add a suitable title

(b)

Center the heading

(c)

Change the different alignment setting for each paragraph
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Evaluation
Part – I

Choose the correct answer
1.

HTML is acronym for
(a) Hyper Transfer Markup Language
(c) Hyper Transfer Makeup Language

(b) Hyper Text Markup Language
(d) Hyper Text Makeup Language

2.

The coded HTML keywords that indicates how web browser should format and display
the content is called…….
(a) Tags		
(b) Attributes		
(c) Headings		
(d) Body

3.

Which of the following is a special word used inside tag to specify additional information
to the tag?
(a) Tags		
(b) Attributes		
(c) Headings		
(d) Body

4.

HTML tags should be specified within:
(a) [ ]			
(b) { }			

(c) ( )			

(d) < >

5.

An HTML document is bounded within a pair of ….. tags
(a) <body> ……. </body>			
(b) <title> ……. </title>
(c) <html> ……. </html>			
(d) <head> …… </head>

6.

Which of the following symbol is used to define a closing tag?
(a) < >			(b) %			(c) /			(d) \

7.

Which section of the browser window displays the main contents?
(a) Head		
(b) Body		
(c) Title		
(d) Heading

8.

Which of the following tag is a structural tag?
(a) <html>		
(b) <h1>		
(c) <br>		

9.

In HTML, colours are represented as
(a) Binary values
(b) Octal values

(d) <p>

(c) Decimal values (d) Hexadecimal values

10.		 Which of the following symbol is used to prefix with hexadecimal value representing
colour in HTML?
(a) %			(b) #			(c) @			(d) &
11.

Which of the following attribute is used to change text colour within body tag?
(a) bgcolor		
(c) background
(c) text		
(d) color

12.

Within body section, which of the following attribute is used to set top margin?
(a) margin		(b) top			(c) topmargin		(d) leftmargin
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13.

How many levels of heading tags available in HTML?
(a) 6			(b) 4			(c) 8			(d) 3

14.

The tag used to insert a line break:
(a) <h1>		
(b) <br>		

15.

(c) <html>		

The tag used to define a paragraph in HTML:
(a) <para>		
(b) <p>		
(c) <q>		

(d) <p>
(d) <br>

Part – II
Very Short Answers
1

Sandhiya is creating a webpage. She is entering HTML code on her computer. In between,
she keeps pressing “Refersh” / “Reload” button on her browser. What is the purpose?

2.

Explain with the help of an example the difference between container and empty elements
of HTML.

3.

What is the wrong in the following coding?
<html>
<my web page>
<title> Welcome to my web page
</head>
</title>

4.

How do you define comments in HTML?

5.

How do you include an image as your web page background?
Part-III

Short Answers
1.

Explain the attributes available with <body> tag.

2.

What are the attributes available in <html> tags?

3.

How do you view the source file?

4.

How do you save a file as HTML file?
Part-IV

Explain in Detail
1.

Write a HTML program to display your school name and address using various
geading level tags.

2.

Write the basic structure of a HTML program.
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GLOSSARY
HTML

– Hyper Text Markup Language used to create web pages.

Tag

– A coded HTML command. It is also called as element.

Attribute

– Special word, carrying special meaning used inside on HTML tag.

Heading Section

– Refers title bar of a browser.

Body Section

– Refers main client area of a browser.

Browser

– An application to view web pages or web sites.

Web Page

– An Online page contains hypertext.

Hypertext

– Text which contains links to other texts.

Text Editor

–

Word Processor

– An application used to create and manipulate text documents.

Notepad

– A default text editor available with Windows.

Getit

– A default text editor available with Linux.

Windows

– Familiar GUI Operating system developed by Microsoft.

Linux

– Familiar Open Source operating system.

An application used to type and modifies text contents, but it is not a
word processor.

Internet Explorer – A browser available with Windows.
A default browser available with Linux. Open Source Third party
browser can be installed in windows.

Mozilla Firefox

–

Chrome

– A familiar web browser developed by Google.

References:
1. Mastering HTML, CSS & JavaScript Web Publishing – Laura Lemay, Rafe Colburn, Jennifer
Kyrnin – BPB Publications.
2. Informatics Practices, A text book for CBSE class XII – Sumita Arora – Dhanpat Rai & Co.
3. Computer Application (Commerce) – Text book of XII – Department of Education –
SCERT, Kerala.
4. https://www.w3schools.com/html/default.asp
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Unit III

Web Page Development using
HTML and CSS

CHAPTER

11

HTML - Formatting text, Creating Tables, List and Links
Learning Objectives:
The students will learn the following:
• How to formatting text contents of an HTML document with
variety of tags and attributes.
• How to create and manipulate tables in HTML.
• How to create different types of List.
• What is Link and how to create internal and external links.
In the previous section you learn how to create a web page with basic elements. In this
section, you are going to learn about how to format the text such making bold, italic, underline,
changing font style, font size, font color and more. Formatting text is very important as well
as interesting task in creating web pages. Formatting is purely based on your imagination and
creativity.

11.1 Text Formatting Tags of HTML
In the previous chapter you learnt how to create a web page with basic elements.
In this section, you are going to learn about how to format the text such as making bold,
italic, underline, changing font style, font size, font color and more. Formatting text is very
important as well as interesting task in creating web pages. Formatting is purely based on your
imagination and creativity.
11.1.1 Bold, Italics, Underline
<b>, <i>, <u> are the tags to make the text as bold, italic and underline. These are all
container tags. You know well about container tags. All container tags required a closing tag.
These tags are otherwise known as “Physical Style” tags.
Table 11.1 Physical Style Tags
Opening Tag Closing Tag
<b>
</b>
<i>
</i>
<u>
</u>
<tt>
</tt>

Description
Text will be bold
Text will be italics
Text will be Underlined
Text will be old type writer style i.e. fixed width font
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Illustration 11.1 Text Formatting
<html>
<head>
<title> Text Formatting </title>
</head>
<body>
<h1 align = center> Kancheepuram </h1>
<b> Kanchipuram is part of Tondaimandalam </b> <br>
<i> Kanchipuram is 72 km away from Chennai </i> <br>
<u> It is the administrative headquarters of Kancheepuram District. </u>
<br>
<b><i> Kanchipuram is well-connected by road and rail. </i> </b>
<p> Chennai <b> International Airport </b> is the nearest domestic and
international airport to the town, which is located at Tirusulam in Kanchipuram
district. </p>
</body>
</html>
Output will be:

11.1.2 <strong> and <em> tags
In addition to bold and italic tags i.e. <b> and <i>, HTML provides <strong>, <em> tags to
make the text as bold and italics. These tags are container tags.
<strong> Important text
The <strong> tag is a phrase tag. It is used to define important text. This tag displays the text
as bold.
<em> - Emphasized text
The <em> tag is used to emphasize the text. That means, when you use this tag, the text
will be in italics.
Visually these two tags display the contents as very similar as <b> and <i> respectively.
But, technically the meaning of <strong> and <em> is “Important” not just bold and italics.
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Illustration 11.2 Usage of <strong> and <em> tags
<html>
<head>
		
<title> Additional Text Formatting Tags </title>
</head>
<body>
		<strong> Welcome to Tamilnadu </strong> <br>
		<em> Welcome to Tamilnadu </em>
</body>
</html>
11.1.3 <big> and <small> tags
The <big> tag is used to define the text bigger in size than the normal size. It is often
used to call attention a text.
The <small> tag is used to define the text smaller than the current size.
These two tags are container tags.
Illustration 11.3 Usage of <big> and <small>
<html>
<head>
<title> Small and Big tags </title>
</head>
<body>
Govenment of Tamilnadu <br>
<big> Madurai Corporation welcomes you </big> <br>
<small> Thank you! Visit again </small>
</body>
</html>

11.1.4 Highlighting text
Highlighting is an important formatting feature is used to call attention to the reader.
The <mark> tag is used to highlight the text in HTML. This is also a container tag. Whatever
the text given between <mark> and </mark> will be displayed as highlighting with default
color (mostly yellow).
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Illustration 11.4 Usage of <mark>
<html>
<head>
<title> Highlighting text </title>
</head>
<body>
A Computer is an <mark> electronic </mark> device
</body>
</html>

Output will be:

11.1.5 Subscript and Superscript
A Subscript is a way to display a character or a number below the normal line of type.
For example: The scientific notation for water is H2O. It should be written as H2O. Here, 2 is
appearing below the normal line. This is called subscript.
A Superscript is also a way to show a character or a number above the normal line
of type. For example: The familiar algebra equation “a plus b the whole square” should be
written as (a+b)2. Here, the square value 2 is appearing above the normal line. This is called
superscript.
Usually, the subscript and the superscript character or number is smaller than the rest
of the text.
In HTML, the <sub> and <sup> tags are used to create subscript and superscripts
respectively. As like as other formatting tags, this is also a container tag.
The text or number given between <sub> and </sub> will be displayed as subscript.
Same as subscript, the text or number given between <sup> and </sup> will be displayed as
superscript.
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Illustration: 11.5 Usage of <sub> and <sup>
<html>
<head>
<title> Subscript and Superscript </title>
</head>
<body>
The scientific notation of Water is H<sub>2</sub>O <br>
(a+b)<sup>2</sup> = a<sup>2</sup> + 2ab + b<sup>2</sup>
</body>
</html>

The output will be:

The Scientific notation of Water is H<Sub>2</Sub>0

(a+b)<Sup>2</sup>=a<sup>+2ab+b<sup>2</sup>
11.1.6 Inserting and Deleting
The text what you see on browser cannot delete or insert. But you can show a text as
deleted or inserted. <del> and <ins> tags are used to markup a segment of text as deleted or
inserted respectively. These two tags are container tags.
The text what you specify between <del> and </del> will be displayed as strike through.
The text you specify between <ins> and </ins> will be shown as underlined.
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Illustration: 11.6 Usage of <del> and <ins>
<html>
<head>
<title> Inserting and Deleting text </title>
</head>
<body>
		

I am coming from <del> Madras</del> <ins> Chennai </ins>

</body>
</html>

11.1.7 Strike through:
To display a text as wrong text, the <s> tag can be used to show the text as strike through
style. The <s> and <del> tags are display the text in similar way. This is also a container tag.
The text you specify between <s> and </s> will be display in strike through style.
11.1.8 Comparison of tags:
A few tags do the same things you have learned so far. For example, <b> and <strong>,
<i> and <em>, <u> and <ins> and so on. These tags may be shows the same output, but the
usage of tags are varying. The following table shows the usage of this kind of tags.
Table: 11.2
Tag

Usage

<b> To show the text in bold
<i>

To show the text as italics

Tag

Usage
To show important
<strong>
text
<em>
To Call attention

Final Output
Bold
Italics

<u> To show the text as underlined <ins>

To insert a text

Underline

<s>

To replaced or
deleted text

Strike through

To show the wrong text

<del>

While writing HTML document, you should use the appropriate tags according to its
usage. If you want show a text as underlined use <u> instead of <ins>.
11.1.9 The Center Tag
Paragraphs can be centered with Align attribute with <p> tag. But for non-paragraph
text contents can be centered with <center> tag. The <center> tag is used to centralize a segment
of text. It is a container tag. That means, what you type between <center> and </center> will
be displayed in the center of the browser.
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Illustration 11.7 Center the text
<html>
<head>
		

<title> Center the text </title>

</head>
<body>
		

<h1 align = center> Thiruvallur </h1>

<center> Thiruvallur was originally known as Thiruvallur which specifies the
sleeping position of the holy lord <b> "Balaji" <b>, in the
<b> <u> Veeraragava swamy temple of Thiruvallur. </b> </u> </center>
</body>
</html>
Output will be

11.2 Changing font style, size and color
The <font> tag is used to change the style, size and color of text. It is also a container
tag. It is generally used for changing the appearance of a short segment of text. Before using
<font>, you should have the knowledge about fonts.
A font is a named set of certain style of character and number. Each font looks different
from other fonts. Generally some fonts are used for specific purpose. For example, Times New
Roman is a style of font usually used for preparing office documents. Arial is another font style
which is used for publishing work. Variety of fonts available in internet at free of cost.
Generally, a browser shows the contents as default system font setting. Every system has
different font setting with another system.
The general form of <font> tag with attributes:
<font face= “font_name” size=value color=color_name / color_code>
		

Text to be displayed

</font>
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• The face is an attribute to set different font style. The name of a font has multiple words it
should be specified within double quote.
• The size attribute is used to set size of the text. The size can have an absolute value from 1
to 7. These predefined sizes are known as virtual size. Each virtual size is successively 20%
larger than the previous one.
• The color attribute is used to set the color to the text. As you leant earlier color name or
color code in hexadecimal may be used.
Illustration 11.8 HTML code to change font properties
<html>
<head>
<title> Changing Font Properties </title>
</head>
<body>
<font face="Arial Black" size=1 color=red> Font Size 1 </font> <br>
<font face="Arial Black" size=2 color=blue> Font Size 2 </font> <br>
<font face="Arial Black" size=3 color=green> Font Size 3 </font> <br>
<font face="Arial Black" size=4 color=yellow> Font Size 4 </font> <br>
<font face="Arial Black" size=5 color=pink> Font Size 5 </font> <br>
<font face="Arial Black" size=6 color=red> Font Size 6 </font> <br>
<font face="Arial Black" size=7 color=blue> Font Size 7 </font> <br>
</body>
</html>
The output will be:

Note: The <font> tag is not supported by HTML5.
Multiple fonts with face attribute:
As you learnt already, the face attribute of font tag is used to change font style of a
segment of text. In face attribute, you can assign more than one font-name at a time within
double quotes with comma. For example,
<font face = "Bookman old style1, Broadway1, Forte, Arial">
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Welcome to HTML
</font>
Browser first tries to find out whether the font-name in the list is supported or not. If
the first font is not supported by the browser, then it displays the text in second font, otherwise
it will display next one. If no font in the list is supported, then the browser display the in the
default font.
In the above code, consider the font names “Bookman old style1” and “Broadway1” are
not supported by any browser. (Because, the names has been changed). So, the text “Welcome
to HTML” will be displayed in “Forte” style. If your browser not supported “Forte” font, the
text will be displayed in “Arial” font, otherwise the browser shows the text as in default font
setting. In the case of Internet explorer, the “Times New Roman” is the default font to display
the contents.

11.3 Section Break
The <hr> (Horizontal Rules) tag, which is known as “Thematic Breaks” separate
sections of an HTML document visually. It produces a horizontal line spread across the width
of the browser. This is an empty tag, which means the tag has no closing tag.
Illustration 11.9 An HTML code to demonstrate Horizontal rules tag - <hr>
<html>
<head>
		
<title> Horizontal Tag </title>
<head>
<body>
<h1 align=center> Tamil Language </h1>
<font face = "Arial Black" size = 5 color="Red">
Tamil is a Dravidian language predominantly spoken by the Tamil people of
</font>
<hr>
<font face = "Copperplate Gothic Bold" size = 6 color="Blue">
		
India, Sri Lanka, Singapore, Malaysia, Mauritius and South Africa
</font>
<hr>
<font face = "Verdana" size = 6 color="Green">
		
Tamil is an official language of India (Tamilnadu and Puducherry),
		
Sri Lanka and Singapore.
</body>
</html>
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The output will be:

Attributes of <hr> tag
The <hr> tag having four attributes viz. size, width, noshade and color. These attributes
are used to set size, width, 3D appearance and color to the horizontal line respectively.
The general syntax of <hr> tag with attributes:
<hr size=value width=value noshade, color=color_name/code>
Size:
Thickness of the horizontal line can be changed with size attribute. The size is given in
terms of pixels. A pixel is one of the tiny dots that make up the display on computer. Generally,
72 pixels equal to an inch. Pixel is usually referred as points. For example: The code <hr size =
72> display a horizontal line with 1 inch thickness. The default size is 3 pixels.
Width:
The width attribute specifies the horizontal width of the rule line. The default rule is
drawn across the full width of the browser. The value of the width attribute may be the exact
width of the rule in pixel or a certain percentage. Usually, the value of the width is specified as
percentage. 100% is the default width.
For example:
<hr width = 50%> display an half of a horizontal rule line on the browser window.
Noshade:
The default view of a horizontal rule line is 3D. So, no need to specify the term “noshade”
as an attribute with <hr> tag. If you specify the attribute “noshade” turn off 3D view, turns on
2D view. Noshade is a Boolean type attribute.
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Color:
The horizontal line is displayed in gray color by default. The color attribute is used to
change is default color to desired color. As you leant already, the value of color either is a color
name or color code.
Note: All attributes of <hr> tag is not supported by HTML5
Illustration 11.10: An HTML code to demonstrate Horizontal rules with Attributes.
<html>
<head>
<title> Horizontal Line Attributes </title>
</head>
<body>
Rule with size 72pixels
<hr size = 72>
Rule with size 36pixels, 50% width
<hr size = 36 width=50%>
Rule with size 18pixels, 30% width, in 2D
<hr size = 18 width=30% noshade>
Rule with size 9pixels, 50% width, 2D, in Green color
<hr size = 9 width = 50% noshade color=Green>
</body>
</html>

The output will be

11.4 Tables in HTML
Table is grid of rows and columns. Remember, what you learnt about tables in
OpenOffice Writer. Creating a table in HTML is not as easy as created in OpenOffice writer.
The tables were officially introduced with HTML 3.2. Tables are useful for the general display
of tabular data. Representing table in HTML is heavy on tags.
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11.4.1 Tags to create table elements
There are five core tags are used to create a table in HTML. They are,
• <table> tag is used to create a table.
• <tr> tag defines table rows
• <th> tag defined table columns
• <td> tag is used to specify the data in a cell
• <caption> tag defines title for the table
•

Apart from these five core tags, <tbody>, <thead> and <tfoot> tags are also used to
define and control whole sections of table. All the above tags are container tags.

11.4.2 Creating Table
With the following illustration, you can learn how to create a table in HTML.
Illustration 11.11: An HTML code to Table tags
<html>
<head>

</head>

<TR>

</TR>
<TR>

</TR>
<TR>

</TR>
<TR>

<title> Creating Table </title>
<body bgcolor="PaleGoldenRod">
<Table border=1>
<Caption> Books and Authors </Caption>
<TH> Book </TH>
<TH> Author </TH>
<TH> Publisher </TH>
<TD> Foxpro 2.5 </TD>
<TD> R.K. Taxali </TD>
<TD> BPB Publications </TD>
<TD> Visual Basic .NET </TD>
<TD> Jeffrey R. Shapiro </TD>
<TD> Tata McGraw Hill </TD>
<TD> Core Java Vol 1 </TD>
<TD> Horstmann Cornell </TD>
<TD> Pearson </TD>

</TR>
</Table>
</body>
<html>

In the above HTML code, the <Table border=1> tag creates a table structure with
border. The code <Caption> Books and Authors </Caption> display the text specified
between <Caption> as title to the table.
249

Chapter 11 Pages 54-92.indd 249

3/20/2020 11:42:46 AM

The above code contains four set of <tr> blocks. First block of <tr> creates a table row
with three column headings with the help of <th> tag. When you use <th> tag, the column
heading were aligned center and text becomes bold by default.
Rest of the <tr> blocks display the contents what you specify within <td> tags. All the
tags used with table were container tags. So, each and every tag should be closed with their
closing tag. The following Figure is more useful to understand the same code given above.
The output will be:

Row 2
Row 3
Row 4

Table Block

Row 1

Table heading
<Table border=1>
<Caption> Books and Authors </Caption>
<TR> <TH> Book </TH>
<TH> Author </TH>
Column heading
<TH> Publisher </TH>
</TR>

{
{
{
{

<TR> <TD> Foxpro 2.5 </TD>
</TR>

Row 2 - Data

<TD> R.K. Taxali </TD>
<TD> BPB Publications </TD>

<TR> <TD> Visual Basic .NET </TD>

</TR>
<TR>

</TR>

Row 3 - Data

<TD> Jeffrey R. Shapiro </TD>
<TD> Tata McGraw Hill </TD>

<TD> Core Java Vol 1 </TD>
<TD> Horstmann Cornell </TD>
<TD> Pearson </TD>

Row 4 - Data

</Table>
<Table border=1>

<TR>

TD>
</TR>

<Caption>Books and Authors</Caption>

<TD>Foxpro 2.5</TD>
<TD>R.K. Taxali</TD>
<TD>BPB Publications</

<TR>

TH>
</TR>

<TH>Book</TH>
<TH>Author</TH>
<TH>Publisher</

11.4.3 Attributes of table
The <table> is a container tag. There are several attributes to improve the layout of the
table. They are listed below:
1. Cellspacing
It is used to set the space between cells in a table. The value should be in pixels
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2. Cellpadding
It is used to set the space between the contents of a cell and its border. the value should
be in pixels.
3. Border:
Border attribute with <table> tag is used to specify the thickness of the border lines
around the table. The value of the border attribute should be a non zero value in pixels. If its
value is zero, HTML displays the table without border. The default value is Zero in most the
browsers.
4. Bordercolor:
It is used to apply the colour to the border lines.
5. Align:
It is used to set the position of the table within the browser window. Left is the default
position. Right or center may be the value of align attribute.
6. BGcolor
It is used to apply background colour to the table.
7. Height and Width
These two attributes are used to specify the height and width of a table in terms of pixels
or percentage.
Illustration 11.12: An HTML code to demonstrate the attributes of Table
<html>
<head>
<title> Table with Attribute </title>
</head>
<body>
<table cellspacing=5 cellpadding=15 border=4 bordercolor=blue align=center
bgcolor=yellow>
<TR>
<TH> Class </TH>
<TH> Boys </TH>
<TH> Girls </TH>
</TR>
The output will be:
<TR>
<TD> VI </TD>
<TD> 150 </TD>
<TD> 165 </TD>
</TR>
<TR>
<TD> VII </TD>
<TD> 146 </TD>
<TD> 151 </TD>
</TR>
<TR>
<TD> VIII </TD>
<TD> 107 </TD>
<TD> 110 </TD>
</TR>
</table>
</body>
</html>
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Attributes of <TD>, <TH> and <TR> tags:
1. Align
Used to specify the horizontal alignment of content within a cell. Left is the default
alignment. Possible values are Right and Center.
2. VAlign
Used to specify the vertical alignment of the contents within a cell. Bottom is the default
alignment. Possible values are Top and Middle
3. Width
Used to specify the width of a cell in terms of pixels or percentage.
4. BGcolor and Background
Bgcolor attribute is used to apply a particular colour to the background of a cell.
Background attribute is used to apply an image or picture as background of a cell.
5. Rowspan and Colspan
Rowspan attribute is used to merge two or more cells in a row as a single cell.
Colspan attribute is used to merge to two or more cells in a column as a single cell.
Illustration 11.13: An HTML code to demonstrate the attributes of <td>, <th> and
<td> tags.
<html>
<head>
<title> Attributes of td, tr and th tags </title>
</head>
<body>
<table border align=center>
<Caption> Govt. Hr. Sec. School, Mullai Nagar, Thiruvallur
<tr>
<th colspan=6> Boys and Girls Strength during 2016-17 and 2017-18 </th>
</tr>
<tr align=center>
<th rowspan=2> Class </th>
<th rowspan=2> Group </th>
<th colspan=2 bgcolor=silver> 2016 - 17 </th>
<th colspan=2 bgcolor=gray> 2017 - 18 </th>
</tr>
<tr>
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<th bgcolor=yellow> Boys </th>
<th bgcolor=pink> Girls </th>
<th bgcolor=yellow> Boys </th>
<th bgcolor=pink> Girls </th>
</tr>
<tr align=center>
<th rowspan=2> XI </th>
<th> Science </th>
<td> 75 </td>
<td> 82 </td>
<td> 65</td>
<td> 96 </td>
</tr>
<tr align=center>
<th> Commerce </th>
<td> 125 </td>
<td> 147 </td>
<td> 118 </td>
<td> 163 </td>
</tr>
<tr align=center>
<th rowspan=2> XII </th>
<th> Science </th>
<td> 86</td>
<td> 97 </td>
<td> 71</td>
<td> 106 </td>
</tr>
<tr align=center>
<th> Commerce </th>
<td> 145 </td>
<td> 186 </td>
<td> 130 </td>
<td> 198 </td>
</tr>
</table>
</body>
</html>

The output will be:

Lists in HTML
HTML supports three types of lists viz. numbered, unnumbered and definition. These
lists are called as Ordered List, Unordered List and Definition List respectively.
1. Numbered List / Ordered List
Numbered list is created within the tag pair <OL> ….. </OL> tag. The tag <LI> is used
to present the list item in the list. Ordered list displays items in a numerical or alphabetical
order. Both <OL> and <LI> tags are container tags. But the usual the practice, closing tag
</LI> never be used.
253

Chapter 11 Pages 54-92.indd 253

3/20/2020 11:42:47 AM

Illustration 11.14: An HTML code to demonstrate Numbered list
<html>
<head>
<title> Number List </title>
</head>
<body>
<OL>
<LI> Tamil
<LI> Telugu
<LI> English
<LI> Computer Application
<LI> Commerce
<LI> Accountancy
<LI> Economics
</OL>
</body>
</html>

The output will be:

Attributes of Ordered List:
There are two attributes can be used to customize ordered list, they are
(1) Type - changing numbering style
(2) Start - changing numbering order.
Type – is used to change the number style. The default number style is standard Arabic
numerals (1,2,3,…………).
Table: 11.3
Type value
Numbering style
1
Standard Arabic Numerals 1,2,3,4,……………….
a
Lowercase letters a, b, c, d, …………
A

Uppercase letter A, B, C, D ………..

i
I

Lowercase Roman numerals i, ii, iii, iv, v ……………
Uppercase Roman numerals I, II, III, IV, V ………..

Start – is used to specify the number of letter with which start the list. The default starting point
is 1. The value of the start attribute should be a decimal number, regardless of the numbering
style being used.
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Illustration 11.15: An HTML code to demonstrate attribute of OL tag
<html>
<head>
<title> Attribute of OL tag </title>
</head>

The output will be:

<body>
<OL type=i start=5>
		<LI> Physics
		<LI> Chemistry
		<LI> Biology
		<LI> Botany
		<LI> Zoology
</OL>
</body>
</html>
2. Un-numbered List / Unordered List

Unordered lists are often referred as bulleted lists. Instead of numbers, each element in
the list has prefixed with a special bullet symbol. Unordered list is surrounded within <UL>
……… </UL> tags. As discussed above, each list element is defined by <LI> tag.
Illustration 11.16: An HTML code to demonstrate Unordered list
<html>
<head>
<title> Unordered List </title>
</head>
<body>
<UL>
		
<LI> Chennai G Hr. Sec. School, Rotler Street, Chennai 600 112.
		
<LI> Karnakata Sanga Hr. Sec. School, T. Nagar, Chennai 600 017.
		
<LI> S.M.B. Jain Hr. Sec. School, T. Nagar, Chennai 600 017.
		
<LI> Chennai G Hr. Sec. School, Nungambakkam, Chennai 600 034.
		
<LI> Chennai G Hr. Sec. School, Saidapet West, Chennai 600 015
		
<LI> Santhome Hr. Sec. School, Mylapore, Chennai 600 004.
</UL>
</body>
</html>
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The output will be:

Attribute of Unordered List:
Like ordered list, type attribute is used to customize bullet style for the list of elements.
By default, a solid circle is used as bullets.
Table: 11.4
Type value
Disc
Square

Numbering style
• A solid circle
A solid square

Circle

oAn unfilled circle

Illustration 11.17: An HTML code to demonstrate Unordered list
<html>
<head>
<title> Attribute of UL tag </title>
</head>
<body>
<UL>
		
<LI> Chennai G Hr. Sec. School, Rotler Street, Chennai 600 112.
		
<LI> Karnakata Sanga Hr. Sec. School, T. Nagar, Chennai 600 017.
</UL>
<UL type=square>
		
<LI> S.M.B. Jain Hr. Sec. School, T. Nagar, Chennai 600 017.
		
<LI> Chennai G Hr. Sec. School, Nungambakkam, Chennai 600 034.
</UL>
<UL type=circle>
		
<LI> Chennai G Hr. Sec. School, Saidapet West, Chennai 600 015
		
<LI> Santhome Hr. Sec. School, Mylapore, Chennai 600 004.
</UL>
</body>
</html>
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The output will be:

3. Definition List
Definition list is different from other two types of list. No bullet or number is provided
for the list items. In this list type, the list element has two parts.
(1) A definition term
(2) The definition description
Definition list is surrounded within <DL> ……. </DL> tags.
Definition term is presented in between <DT> ….. </DT> tag and
Definition description should be surrounded within <DD> ………… </DD> tag.
Illustration 11.18: An HTML code to demonstrate Definition list

<html>
<head>
<title> Definition List </title>
</head>
<body>
<DL>
<DT> HTML: </DT>
		<DD> Hyper Text Markup Language </DD>
<DT> Webpage:
<DD> A web page is a document that is suitable for the World Wide Web and
web browsers. A web browser displays a web page on a monitor or mobile device.
</DD>
</DL>
</body>
<html>
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The output will be:
Definition List

Nested Lists:
A list block can be defined inside another list is called as nested list.
Illustration 11.19: An HTML code to demonstrate Nested lists
<html>
<head>
<title> Nested List </title>
</head>
<body>
<OL>
<LI> Districts of Tamilnadu
<UL type=A>
		<LI> Chennai
		<LI> Madurai
		<LI> Coimbatore
</UL>
<LI> District of Kerala
<UL type=A>
		
<LI> Thiruvananthapuram
		<LI> Palakkad
		<LI> Idukki
<UL>
</OL>
<body>
<html>

The output will be:

Links:
Link is an important feature of HTML to connect web resources. Link in HTML is used
to create hyperlinks to web content. Web content may be an HTML document or an external
webpage or any multimedia content such as an image, video, audio, animation etc., or even a
part of the current document.
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There are two important things needs to create a link in HTML,
(1) The name of the file or URL to which you want to link
(2) The text that will serve as the clickable link.
The anchor tag <A> is used to create links along with HREF attribute. HREF is
abbreviated as “Hypertext Reference”.
Structure of an anchor tag with href:
<A href = “ Web content path / URL “> Text – Clickable link </A>
Example:

Clickable text
<A href = "http://tnscert.org/index.html">SCERT </A>
URL to load

The above link code creates the target of the hyperlink to the website http://thscert.org/
index.html. At the time the user clicks the link, the browser opens the home page of the URL.
Internal Links:
Creating a link to a particular section of the same document is known as Internal Link. To
create an internal like, the attribute Name is used along with <A> tag. The Name attribute of
<A> tag establish the link to the content within the document.
Illustration 11.20: An HTML code to demonstrate Internal Linking:
<html>
<head>
<title> South India </title>
</head>
<body>
<h1 align = center> South India </h1>
<p> South India is the area encompassing the Indian states of
<A href = #AP> Andhra Pradesh, </A>
<A href = #KR> Karnataka, </A>
<A href = #KL> Kerala, </A>
<A href = #TN> Tamil Nadu </A> and Telangana as well as the union territories of
Lakshadweep, Andaman and Nicobar Islands and Puducherry, occupying 19% of India's
area (635,780 km2 or 245,480 sq mi). </p>
<A Name = AP><B> Andhra Pradesh </B> </A>
<p> Andhra Pradesh is one of the 29 states of India. Situated in the south-east of the country,
it is the eighth-largest state in India. The largest city in Andhra Pradesh is Visakhapatnam.
</p>
<A Name = KR> <B> Karnataka </B> </A>
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<p> Karnataka is a state in the south western region of India. It was formed on 1 November
1956, with the passage of the States Reorganisation Act. Originally known as the State
of Mysore, it was renamed Karnataka in 1973. The capital and largest city is Bangalore
(Bengaluru). </p>
<A Name = KL> <B> Kerala </B> </A>
<p> Kerala is a state in South India on the Malabar Coast. It was formed on 1 November
1956 following the States Reorganisation Act by combining Malayalam-speaking regions. It
is divided into 14 districts with the capital being Thiruvananthapuram.</p>
<A Name = TN> <B> Tamilnadu </B> </A>
<p> Tamil Nadu literally 'The Land of Tamils' or 'Tamil Country' is one of the 29 states of
India. Its capital and largest city is Chennai (formerly known as Madras). </p>
</body>
</html>

HTML Link Colors
A link will appear in all browsers by default as in the following colour:
• An unvisited link is underlined and blue
• A visited link is underlined and purple
• An active link is underlined and red
We can change the default colours, by using CSS will be discussed later.
External Link:
Establish link with an external web page in known as external linking. It is made possible
by providing the URL of the external file in the HREF attribute of <A> tag of the current page.
Illustration 11.21: An HTML code to demonstrate Linking with an external website/
webpage
<html>
<head>
<title> Links </title>
</head>
<body>
<h1 align=center>
		
Welcome to <br>
		
<A href = "http://www.tnscert.org">
		
State Council of Educational Research and Training, Tamilnadu </A>
</h1>
</body>
</html>
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Illustration 11.22: An HTML code to demonstrate Linking with multiple pages:
<! Master.htm >
<html>
<head>
<title> Linking two pages </title>
</head>
<body>
<h2> Applications of OpenOffice </h2>
		<ul>
			

<LI> <A href=writer.htm> OpenOffice Writer </A>

			

<LI> <A href=calc.htm> OpenOffice Calc </A>

			
<LI> <A href=impress.htm> OpenOffice Impress </A>
			</ul>
</body>
</html>
-----------------------------------------------<! Writer.htm>
<html>
<head>
<title> OpenOffice Writer </title>
</head>
<body>
<h2> OpenOffice Writer </h2>
<p> Writer has everything you would expect from a modern, fully equipped word
processor. </p>
<p> It is simple enough for a quick memo, yet powerful enough to create complete
books with contents, diagrams, indexes, etc. You're free to concentrate on your ideas
while Writer makes them look great. </p>
<A href=master.htm> Back to Home </A>
</body>
</html>
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-----------------------------------------------<! calc.htm>
<html>
<head>
<title> OpenOffice Calc </title>
</head>
<body>
<h2> OpenOffice Calc </h2>
<p> Calc is the spreadsheet application you've always wanted.
Newcomers find it intuitive and easy to learn; professional data miners and number
crunchers will appreciate the comprehensive range of advanced functions. </p>
<p> DataPilot is an advanced technology that makes it easy to pull in raw data from
corporate databases; cross-tabulate, summarize, and convert it into meaningful
information. </p>
<A href=master.htm> Back to Home </A>
</body>
</html>
-----------------------------------------------<! Impress.htm>
<html>
<head>
<title> OpenOffice Impress</title>
</head>
<body>
<h2> OpenOffice Impress </h2>
<p> Impress is a truly outstanding tool for creating effective multimedia presentations.
Your presentations will stand out with 2D and 3D clip art, special effects, animation,
and high-impact drawing tools.</p>
<A href=master.htm> Back to Home </A>
</body>
</html>
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Points to Remember:
• <b>, <i>, <u> are the tags to make the text as bold, italic and underline. These tags
are otherwise known as “Physical Style” tags.
• Highlighting is an important formatting feature is used to call attention to the reader.
The <mark> tag is used to highlight the text in HTML.
• The <sub> and <sup> tags are used to create subscript and superscripts respectively.
• The <font> tag is used to change the style, size and color of text.
• A font is a named set of certain style of character and number.
• The <hr> (Horizontal Rules) tag, which is known as “Thematic Breaks” separate
sections of an HTML document visually.
• Table is grid of rows and columns.
• The tables were officially introduced with HTML 3.2.
• There are five core tags are used to create a table in HTML.
• HTML supports three types of lists viz. numbered, unnumbered and definition.
These lists are called as Ordered List, Unordered List and Definition List respectively.
• Link is an important feature of HTML to connect web resources. Link in HTML is
used to create hyperlinks to web content.
• Hyperlinks are considered either Internal or External links depends on their target.
Workshop:
1. Write an HTML code for a webpage of your school with the following specifications:
o A heading followed by a paragraph about your school in 10 lines using text formatting
tags and attributes.
o Include an ordered list with the subjects taught your school.
2. Write an HTML code for a webpage of your district with the following details and features:
o A heading followed by a paragraph of 15 sentences about the district using text
formatting tags and attributes.
o A list of the tourist places in the district. (Use Unordered list)
3. Write an HTML code to show the following table in a webpage:
Students studying Computer Subjects
SN
School
No. of Students
Comp.
Comp.
Comp.
Science Application Technology
1 Govt. HSS, M.K.B. Nagar, Chennai 39
25
62
-2 Chennai G HSS, M.H. Road, Chennai 11
123
141
87
3 Dr. GMTTV HSS, Amman Koil St., Chennai
45
76
23
79
4 Chennai G HSS, Rotler St, Chennai 112
18
63
43
5 Chennai B HSS, G.Koil St., Chennai 84
31
52
15
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4.

Write HTML codes to create four web pages about Population of Tamilnadu with the
following description.
o In main page write about “Population” (Refer XI Economics text book, Page No: 228229. Para 11.5) and create list with the following terms:
o “Density”, “Urbanisation” and “Sex ratio”.
o Write separate pages for “Density”, “Urbanisation” and “Sex ratio” (For contents, refer
XI Economics text book, Page No: 229. Para 11.5.1, 11.5.2 and 11.5.3).
o In main page, create link with respective pages to the list items.

Evaluation
Part – I

Choose the correct answer
1. Which of the following tags are called as physical style tags?
(A) <html>, <b>, <br>

B) <b>, <br>, <u>

(C) <A>, <b>, <i>		

(D) <b>, <i>, <u>

2. Which feature is used to call attention to the reader?
(A) Highlight

(B) Bold

(C) Italics

(D) Underline

3. The tags <sub> and <sup> used for:
(A) Subject and Super

(B) Subscript and Super

(C) Subject and Superscript

(D) Subscript and Superscript

4. A named set of certain style of character and number is:
(A) Style

(B) Character

(C) Font

(D) List

(B) <th>

(C) <dh>

(D) <td>

(a) tfoot

-

(1) Order list

(b) start

-

(2) Hyperlink

(c) href

-

(3) Highlight

(d) mark

-

(4) Table

(a)

(b)

5. Pick odd one from the list
(A) <tr>
6. Match the following:

		

(c)

(d)
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(A)

4

1

2 3

(B)

1

4

3 2

(C)

4

3

2 1

(D)

1

2

4 3

(C) 3

(D) 2

7. Definition list has how many parts?
(A) 5

(B) 4

8. A list block can be defined inside another list is:
(A) Inner List

(B) Nested List

(C) Outer List

(D) Listing List

9. Read the following statement and choose the correct statement(s):
(I) Link in HTML is used to create hyperlinks to web content.
(II) HREF is abbreviated as Hypertext Markup File
(A) I is correct		

(B) II is correct

(C) I and II is correct		

(D) Both are wrong

10. To create internal link, which of the following attribute should be used?
(A) link

(B) name

(C) local		 (D) Inter
Part – II

Very Short Answers
1. Write a short note on (i) <strong> (ii) <em>
2. What is the use of <mark> tag?
3.	Write the following equation as HTML notation:
Pd = 2s – Q2
4. Write about any two attributes of font tag.
5. What is thematic break?
6. What is pixel?
7. What are the types of list in HTML?
8. How will you define numbered list?
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Part-III
Short Answers
1. Write an HTML code to display the following text in exactly the same way as given below.
I am studying Computer Science Application.
2.

Briefly explain the attributes of <hr> tag.

3.

What are the core tags used to create table in HTML?

4.

Write an HTML code to provide hyperlink to https://www.w3schools.com

5.

Difference between <UL> and <OL> tags.

6.

Write HTML code to produce the following table:
A

B
C
Part-IV

Explain in Detail
1.

Write an HTML code the show the following text:
MODERN ATOMIC THEORY
The findings of modern atomic theory are given as follows:
• An atom is the smallest particle which takes part in chemical reaction.
• An atom is considered to be a divisible particle.
• The atoms of the same element may not be similar in all respects.
eg: Isotopes (17Cl35, 17Cl37)
• The atoms of different elements may be similar in some respects.
eg. Isobars (18Ar40, 20Ca40)

2.

Explain the attributes used with <table> tag in HTML.

3.

Explain the types of list with suitable HTML code.

4.

What is Link and explain the types of links.

5.

Write HTML code to create the following table:
A

C

D

B
F

E

G
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GLOSSARY
Text Formatting

–

Showing text with different style and colour.

Font

–

Named set of certain style of character and numbers.

Table

–

A Structure of rows and columns or grid of cells.

Cell

–

An individual box in a table.

Border

–

A line surrounded by cells.

Column

–

Vertical structure of a table.

Row

–

Horizontal structure of a table.

Ordered List

–

Indents lists having numbers or letters in front of every list
item.

Unordered List

–

Indents lists having a bullet symbol in front of every list item.

Definition List

–

Lists showing definition terms and definition descriptions.

Link

–

Make connection with a part of content of same document or
an external document.

Hyperlink

–

A link from a hypertext document.

Internal Link

–

Connecting with another part of the same document.

Local Link

–

Internal Link

External Link

–

Connection with another hypertext document.

References:
1. Mastering HTML, CSS & JavaScript Web Publishing – Laura Lemay, Rafe Colburn, Jennifer
Kyrnin – BPB Publications.
2. Informatics Practices, A text book for CBSE class XII – Sumita Arora – Dhanpat Rai & Co.
3. Computer Application (Commerce) – Text book of XII – Department of Education –
SCERT, Kerala.
4. https://www.w3schools.com/html/default.asp
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Unit III

Web Page Development
using HTML and CSS

CHAPTER

12

HTML - Adding multimedia elements and Forms
Learning Objectives:
The students will learn the following:
• How to insert images with HTML document.
• How to insert music and movies in web pages.
• What is Forms and how to create forms and controls within an HTML document

12.1 Inserting Images
Images are essential element to make an HTML presentation as more attractive manner.
Moreover images are used to depict many complex concepts in simple way. To make more
attractive and communicative web pages, images should be added in the appropriate places.
Images displayed on the web page should be converted to universally supported format.
Most of the browsers supports, GIF, JPEG and PNG images formats. HTML-5 introduces
SVG images. One format of image can be converted to another format by using Image editing
applications such as Photoshop, Picasa, GIMP etc.,
12.1.1 Familiar Image Formats
GIF (Graphical Interchange Format)
This format is one of the popular format for animated images. It was developed by
CompuServe. Usually this image format is suitable for presenting tiny animated images, logos,
icons, line art etc., It is not suitable for photographic work, because it uses maximum of 256
colours. Animated GIF do not support sound or playback control.
JPEG (Joint Photographic Experts Group)
JPEG is the most popular image format supported by all web browsers. This format is
suitable for photographic images. Unlike GIF, JPEG can include any number of colours.
PNG (Portable Network Graphics)
PNG is designed as a replacement for GIF. It is also supported by all browsers.
SVG (Scalable Vector Graphics)
SVG is a graphics format that was developed for web. It was standardized by World
Wide Web Consortium (W3C) in 2001. All current web browsers supports basic features of
SVG.
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12.1.2 Inserting Images with HTML document
The <IMG> tag along with the attribute src (Source) is used to add images in HTML
document.
General format:
<img src = image_name_with_extension>
(OR)
<img src = URL>
Example:
<img src = image1.gif>
Src attribute is the main attribute used to specify the file name of the image to be
inserted. If the image is not in the current working folder, the image file name should clearly
specify with the path of the file or URL, where the file is available.
Example:
<img src = “D:\images\animals\cat.jpeg”>
Illustration 12.1: An HTML code to insert an inline image
<html>
<head>
<title> Inserting Images </title>
</head>
<body>
<h1 align = center> Bharathiyar </h1>
<img src = bharathiyar.gif>
</body>
</html>
The output will be:
Inserting images

E:\CS_TestBook_Final\

File

Edit

View

Favorites

Tools

Help

Bharathiyar
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12.1.3 Other Attributes of <img> tag:
Other than src, the <img> tag has many attributes the enable to control how the image
is presented on the page.
Alt (Alternative Text)
The alt attribute within <img> tag is used to describe the image, so that some text is
conveyed even when the image cannot be displayed.
Example:
<img src = bharathiyar.gif alt = “National Poet of India”>
Width and Height:
Width and Height attributes are used to set the width and height of an image. The values
of these attributes should be either pixels or percentage of its actual size. If these attributes are
not specified, the browser displays the image in its original size.
Vspace (Vertical Space) and Hspace (Horizontal Space):
Vspace and Hspace attributes are used to set Vertical and Horizontal space between the images.
Illustration 12.2: An HTML code to demonstrate <img> attributes
<html>
<head>
<title> Inserting Images </title>
</head>
<body>
<h1 align = center> Mahakavi Bharathi </h1>
<img src = bharathiyar.gif alt = "National Poet of India" Width = 20%
vpace = 20 Hspace = 20>
<img src = bharathiyar.gif alt = "National Poet of India" Width = 20%
vpace = 20 Hspace = 20>
<img src = bharathiyar.gif alt = "National Poet of India" Width = 20%
vpace = 20 Hspace = 20> <br>
<img src = bharathiyar.gif alt = "National Poet of India" Width = 20%
vpace = 20 Hspace = 20>
<img src = bharathiyar.gif alt = "National Poet of India" Width = 20%
vpace = 20 Hspace = 20>
<img src = bharathiyar.gif alt = "National Poet of India" Width = 20%
vpace = 20 Hspace = 20> <br>
</body>
</html>

Height = 25%
Height = 25%
Height = 25%
Height = 25%
Height = 25%
Height = 25%
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The output will be:
E:\CS_TestBook_Final\

File

Edit

View

Favorites

Inserting images
Tools
Help

Mahakavi Bharathi

Align:
The align attribute used to aligns the image with respect to the base line of the text. This
attribute has the following values.
• Bottom – Aligns the bottom of the image with the baseline of the text. This is the default
setting.
• Middle – Aligns the middle of the image with the baseline of the text.
• Top – Aligns the top of the image with the baseline of the text.
Left and Right values of Align attribute:
Using left and right values with align attribute, displayed the image on the left and right
side of the text.
Illustration 12.3: An HTML code to demonstrate baseline of text
<html>
<head>
<title> Attributes of <img> tag </title>
</head>
<body>
<h2> Attributes of image tag </h2>
<img src="D:\Images\Bird.jpg" alt="Parrot Image">
This text is aligned in the bottom of the image by default <br> <br> <br>
<img src="D:\Images\Bird.jpg" alt="Parrot Image" align=top>
This text is aligned in the top of the image <br><br>
<img src="D:\Images\Bird.jpg" alt="Parrot Image" align=middle>
This text is aligned on the middle of the image
</body>
</html>
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The output will be:
D:\CS_TestBook_Final\

File

Edit

View

Favorites

Attributes of <img>tag

Tools

Help

Attributes of image tag

This text is aligned in the bottom of the image by default
This text is aligned in the top of the image

This text is aligned in the middle of the image

12.2 Scrolling text using <Marquee>

In HTML, a piece of text or image can be moved horizontally or vertically by using
<marquee> tag. This feature makes a web page as more attractive.
General format:
		<marquee> Text or image to be scroll </marquee>
Attributes of <marquee>
Height and Width
These attributes are used to set height and width of the marquee. The values should be
either in pixels or in percentage of browser window.
Direction
This is used to specify the direction of the movement of text or image. The text or image
will move towards right to left by default. So, the default direction is left. The Possible values
are ‘up’, ‘down’, ‘left’ or ‘right’.
Behaviour:
This attribute is used to specify the type of scrolling. The values are ‘scroll’, ‘slide’ and
‘alternate’.
Scrolldelay:
This attribute is used to define the time delay between each jump. The time unit should
be in seconds.
Scrollamount:
This is used to define the speed of the scroll.
Loop:
This is for defining how many times the marquee element should repeat on the screen.
The default value is ‘infinite’, which means the marquee element scrolls endlessly.
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Bgcolor:
This is used to specify the background color to the marquee elements.
Hspace and Vspace:
This is for defining the horizontal and vertical space around the marquee. The value can
be in pixels or percentage.
Illustration 12.4: An HTML code to demonstrate marquee
<html>
<head>
<title> Marquee </title>
</head>
<body>
<marquee> <b> The Government of Tamilnadu </b>, Directorate of School
Education </marquee>
<marquee direction=right> Welcome to <b> The State Council of Educational
Research and Training </b>, Tamilnadu </marquee>
</body>
</html>

12.3 Adding Video and Sound
Video and Sound are the core part of the modern web pages. In HTML, a video or
audio content may be included as Inline or external data. The inline refers to audio or video
files are handled as part of the page. These media files play the audio or video when the page is
visible in the browser window. The external refers, linking external audio or video files as url.
The <embed> tag is used to attach an audio or video file easily within webpage. This
tag includes the controls of the multimedia automatically in the browser. The <noembed> tag
may be used as an alternate to display some other media file, in the case of the browser does
not support <embed> tag.
Src is the primary attribute used with <embed> tag. The src attribute used to specify the
name of the media file with its source location. Other attributes such as alt, height, width and
align are used as it is used with <img>.
General Format:
<embed src = audio / video file name with location> </embed>
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Illustration 12.5: An HTML code to demonstrate adding audio and video files
(internal source)
<html>
<head>
<title> Adding Multimedi Files </title>
</head>
<body>
<img src="D:\Images\TN_Logo.png" alt="Govt. of Tamilnadu Logo" height=25%
width=15%>
<marquee> Welcome to <b> The State Council of Educational Research and Traning
</b>, Tamilnadu </marquee>
<embed src="D:\CS_Videos\CS_Video.mp4" width=50% height=50%> </embed>
</body>
</html>

12.3.1 Background music:
Music can be played in the background to a webpage, while the page is viewed. This is
known as ‘inline’ sound or movie. The <bgsound> tag is used to attach an inline sound file in
HTML. The src attribute is used to define the location of the media file. Volume attribute used
to adjust volume control. The loop attribute defines the duration of play. The ‘infinite’ value
causes the audio play as long as the page is in view.
General Format:
		<bgsound src=music file name with location>
Illustration 12.6: An HTML code to demonstrate inline sound
<html>
<head>
<title> Inline Sound </title>
</head>
<body>
<img src="D:\Images\TN_Logo.png" alt="Govt. of Tamilnadu Logo" height=25%
width=15%>
<marquee> Welcome to <b> The State Council of Educational Research and
Training </b>, Tamilnadu </marquee>
<bgsound src="D:\CS_Videos\Tamil Thai Vazhthu.mp3" loop=infinite>
</body>
</html>
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12.4 Working with Forms
Forms are used to receive information from the user. Forms are commonly used to
allow users to register on a Web site, to log in to a Web site, to order a product, and to send
feedback. In search engines, forms are used to accept the keywords for search.
The <form> tag is used to create a form. An HTML from starts with <form> and ends
with </form> tag. Forms contain many types of form elements, such as text boxes, radio
buttons, check boxes, buttons and drop-down lists.
The form has a special element, which is submit button, which will submit the entries
of a form to a server application to process the entries. Each element in the form is assigned a
name using the name attribute. Users enter values into the text boxes, or make selections from
the radio buttons, check boxes, and drop down lists. The values they enter or select are passed
with the name of the corresponding form element to the Web server.
12.4.1 Attributes frequently used with <form> tag
The important attributes used with the <form> tag are method and action attributes.
Method
The method attribute of the
form tag is used to identify how the
form element names and values will
be sent to the server. The get method
will append the names of the form
elements and their values to the URL.
The post method will send the names
and values of the form elements as
packets.
Action

HTML - Form and Co..

D:\CS_TestBook_Final\

File

Edit

View

Favorites

Tools

Help

Students Data Entry Form
Student Name:
Text Boxes

Email:
Gender:

Boy

Subjects:

Tamil

Girl

Radio Buttons

Telugu

English

Economics
Check boxes

City / Town: Madurai
Comments:

Physics

Select box

The action attribute identifies
the server side program or script that
will process the form. The action will Clear Submit
Text Area
Push buttons
be the name of a Common Gateway
Interface (CGI) program written in
Figure 12.1 HTML Form Controls
programming languages like Perl,
JavaScript, PHP or Active Server Pages (ASP). (This will be discussed with JavaScript in this
book).
General Format of <form> tag
<Form method=get/post action= “back_end_server_script”>
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Form elements
</Form>
12.4.2 Form Controls:
In HTML, there are different types of form controls are used to collect data. They are
Text box, Password, Checkbox, Radio buttons, Text area, Select box, Submit and Reset Button.
12.4.2.1 <Input> Tag
Most of the form controls are created by using <input> tag. The <input> is an empty tag
used to create different form elements or controls such as text box, radio buttons so on.
Attributes of <input> tag:
Type:
This attribute is used define the type of control to be created by <input> tag. The values
of type attribute is listed below:
Table: 12.1
Value of type
attribute

Description

Text

Create a Text Box. The element used to get all kind of text input such
as name, address etc.,

Password

Similar as Text box. But, while entering data, the characters are
appearing as coded symbols such as asterisk.

Checkbox

Check box is an element appearing like a small square box. When
the user click on the square a tiny tick mark will appear inside the
square. This element is used to select multiple options.

Radio Button

Radio button is used to select any one of the multiple options from
the list. This element looks like a small circle, when the user select
an item, a tiny dot will appear within the circle. If the user selects
another option, previously selected option will be deselected. This
means, user can select any one of the given option form a group.

Reset

It is a special command button used to clear all the entries made in
the form.

Submit

It is also a special command button used to submit all the entries
made in the form to the backend server.

Button

This is a standard graphical button on the form used to call functions
on click.
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Name:

This attribute of <input> tag is used to assign a name to the input controls. When the
form is submitted, the data values are passed to the server along with the names of the controls.
Value:
This attribute is used to define default value to some controls.
Size:
This is used to set the width of the input text in terms of characters. It is applicable only
for textbox and password boxes.
Maxlength:
This attribute of <input> tag is used to set the length of the input character (number of
characters to be inputted) to the textbox and password boxes.
Illustration 12.7: An HTML code to demonstrate Form and Form controls
(Login form)
<html>
<head>
<title> Login Form </title>
<body>
<h3 align=center> TamilNadu State Council of Educational Research and Training,
Chennai </h3>
<Form Action = "mailto:abcd.xyz@com" method=post>
<p> User Name:
<Input type = text name="user_name" size = 20 maxlength = 15> </p>
<p> Password:
<Input type = password name="pass" size = 20 maxlength = 15> </p>
<Input type = reset value = "Clear">
<Input type = submit value = "Login">
</Form>
</body>
</html>
The output will be:
Login Form

D:\CS_TestBook_Final\

File

Edit

View

Favorites

Tools

Help

TamilNadu State Council of Educational Research and
Traning, Chennai
User Name:

Password:
Clear

Login

Note: Data received from the user can send to receiver through mail using “mailto” action.
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Illustration 12.8: An HTML code to demonstrate Form and Form controls
(Text box, checkbox and radio buttons)
<html>
<head>
<title> HTML - Form and Controls </title>
</head>
<body>
<h3 align=center> Forms and Controls </h3>
<Form action="mailto:abcd.xyz@com" method=post>
<p> Student Name:
<Input type=text name=name size=30 maxlength=25></p>
<p> Gender:
<input type=radio name=gender value=boy> Boy
<input type=radio name=gender value=girl> Girl
</p>
<p> Subjects:
<input type=checkbox name=sub value=Tam> Tamil
<input type=checkbox name=sub value=Tel> Telugu
<input type=checkbox name=sub value=Eng> English
<input type=checkbox name=sub value=Phy> Physics
<input type=checkbox name=sub value=Eco> Economics
</p>
<input type=reset name=reset value="Clear">
<input type=submit name=submit value="Submit">
</Form>
</body>
</html>
The output will be:
D:\CS_TestBook_Final\

File

Edit

View

Favorites

HTML - Form and Co..

Tools

Help

Forms and Controls
Student Name :
Gender:
Subjects:
Clear

Boy
Tamil

Girl
Telugu

English

Physics

Economics

Submit
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12.4.2.2 <Select> Tag
The <select> tag is used to create dropdown list box in HTML. It provides a list of
various options as a dropdown list. This element is more helpful when a number of options are
to be displayed in a limited space. The <option> tag is used to specify list items.
Attributes of <Select> tag:
Name – Provide the name to the control, which is sent to the server.
Size – Determine the style of dropdown list box.
Size = 1 dropdown list box
Size = 2 List box
Multiple – Allows user to select multiple values.
Attributes of <Option> tag:
Selected – Indicate default selection
Value – Value to be submitted to server
Illustration 12.9: An HTML code to demonstrate Form and Form controls
(Dropdown List box)

<html>
<head>
<title> HTML - Form and Controls </title>
</head>
<body>
<h3 align=center> Forms and Controls </h3>
<Form action="mailto:abcd.xyz@com" method=post>
<p> Student Name:
<Input type=text name=name size=30 maxlength=25></p>
<p> City / Town:
<Select name = area size= 1>
<option value = CHN> Chennai </option>
<option value = MDR selected> Madurai </option>
<option value = CBO> Coimbatore </option>
<option value = KKM> Kanyakumari </option>
</Select> </p>
<input type=reset name=reset value="Clear">
<input type=submit name=submit value="Submit">
</Form>
</body>
</html>
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The output will be
D:\CS_TestBook_Final\

File

Edit

View

Favorites

HTML - Form and Co..

Tools

Help

Forms and Controls
Student Name :
Chennai

City / Town: Madurai
Clear

Coimbatore
Kanniyakumari

Submit

12.4.2.3 <Textarea> tag
The <Textarea> tag is used to receive multi line text data as input. It is a container tag.
The main attributes of <Textarea> are
Name – Used to define name to the control
Rows – Specifies the number of rows in the text area control
Cols – Specifies the number of columns in the text area. (number of characters in a line)
Illustration 12.10: An HTML code to demonstrate Form and Form controls
(Text Area – Multiline input)
<html>
<head>
<title> HTML - Form and Controls </title>
</head>
<body>
<h3 align=center> Forms and Controls </h3>
<Form action="mailto:abcd.xyz@com" method=post>
<p> Student Name:
<Input type=text name=name size=30 maxlength=25></p>
<p> Email:
<input type=text name=mail size=30 maxlength=25> </p>
<p> Comments: <br>
<Textarea rows=5 cols=50 name=comments> </Textarea>
</p>
<input type=reset name=reset value="Clear">
<input type=submit name=submit value="Submit">
</Form>
</body>
</html>
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The output will be:
HTML - Form and Co..

D:\CS_TestBook_Final\

File

Edit

View

Favorites

Tools

Help

Forms and Controls
Student Name:
Email:
Comments:

Clear

Submit

Illustration 12.11: An HTML code to demonstrate All Form controls discussed
in this chapter
<html>
<head>
<title> HTML - Form and Controls </title>
</head>
<body>
<h3 align=center> Students Data Entry Form </h3>
<Form action="mailto:abcd.xyz@com" method=post>
<p> Student Name:
<Input type=text name=name size=30 maxlength=25></p>
<p> Email:
<input type=text name=mail size=30 maxlength=25> </p>
<p> Gender:
<input type=radio name=gender value=boy> Boy
<input type=radio name=gender value=girl> Girl
</p>
<p> Subjects:
<input type=checkbox name=sub value=Tam> Tamil
<input type=checkbox name=sub value=Tel> Telugu
<input type=checkbox name=sub value=Eng> English
<input type=checkbox name=sub value=Phy> Physics
<input type=checkbox name=sub value=Eco> Economics
</p>
<p> City / Town:
<Select name = area>
<option value = CHN> Chennai </option>
<option value = MDR selected> Madurai </option>
<option value = CBO> Coimbatore </option>
<option value = KKM> Kanyakumari </option>
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</Select> </p>
<p> Comments: <br>
<Textarea rows=5 cols=50 name=comments> </Textarea>
</p>
<input type=reset name=reset value="Clear">
<input type=submit name=submit value="Submit">
</Form>
</body>
</html>
The output will be:
D:\CS_TestBook_Final\

File

Edit

View

Favorites

HTML - Form and Co..

Tools

Help

Students Data Entry Form
Student Name:
Email:
Gender:

Boy

Subjects:

Tamil

Girl
Telugu

English

Physics

Economics

City / Town: Madurai
Comments:

Clear

Submit

Points to Remember:
• Images are essential element to make an HTML presentation as more attractive
manner.
• Most of the browsers supports, GIF, JPEG and PNG images formats.
• The <IMG> tag along with the attribute src (Source) is used to add images in HTML
document.
• In HTML, a piece of text or image can be move horizontally or vertically by using
<marquee> tag.
• In HTML, a video or audio content may be included as Inline or external data.
• The <embed> tag is used to attach an audio or video file easily within webpage.
• Music can be played in the background to a webpage, while the page is viewed.
• The <bgsound> tag is used to attach an inline sound file in HTML.
• Forms are used to receive information from the user.
• An HTML from starts with <form> and ends with </form> tag.
• Most of the form controls are created by using <input> tag.
• The <select> tag is used to create dropdown list box in HTML.
• The <Textarea> tag used to receive multi line text data as input.
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Workshop:
1. Write an HTML code insert Image, Music and Video elements
2. Write an HTML code to display an application for as shown below:
D:\CS_TestBook_Final\

File

Edit

View

Favorites

Students Entry From

Tools

Help

Govt. Hr. Sec. School, Thiruvallur
Name of the Student:
Date of Birth:
Gender:

Boy

Girl

Mother Tongue:
Tamil
Telugu
Malayhalam

Optional Subjects (Select any 2):
Environmental Science
History of Science
Political Science
Information Technology
Reset

Submit

Evaluation
Part – I

Choose the correct answer
1.
PNG
2.

Which image format was standardize by W3C?
(A) JPEG		(B) SVG		(C) GIF		( D )
The tag used to insert an image in HTML:
(A) Image		

3.

(C) Img		

(B) <img>		

(C) <embed>		

(C) <bgsound>

(D) <sound>

Which value causes the audio play as long as the page is in view?
(A) Stop		

6.

(D) <text>

Inline sound can be inserted using which of the following tag?
(A) <inline> (B) <backgroundsound>

5.

(D) Pic

In HTML, a piece of text or image can be moved horizontally or vertically by using:
(A) <marquee>

4.

(B) Picture		

(B) Never Stop

(C) Continue		

(D) Infinite

The important attributes used with the <form> tag are
(A) method and action 			

(B) name and size

(C) post and get				

(D) type and name
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7.

The tag is used to create dropdown list box in HTML is:
(A) <dropdown>

8.

(B) <select>		

(C) <listbox>		

(D) <input>

Match the following:
(a) <textarea>

-

(1) inline

(b) <input>		

-

(2) Video

(c) <bgsound>

-

(3) Multiline input

(d) <embed>		

-

(4) Password

		(a)		(b)		(c)		(d)
(A)

3		1		4		2

(B)

3		4		1		2

(C)

2		3		4		1

(D)

2		1		3		4
Part – II

Very Short Answers
1.
List out the popular image formats.
2.

Write down the general format of marquee

3.

What is inline sound or movie?

4.

What is the purpose of <input> tag?

5.

Which tag is used to specify the list of items in dropdown list box?

6.

What are the major attributes are available in <textarea> tag?
Part-III

Short Answers
1.
Write a short note on familiar images format.
2.

How will you scroll the text in HTML?

3.

Explain the main attributes used with <form> tag.

4.

Explain the values of <input> tag’s type attribute.

5.

Explain the attributes of <select> and <option> tags.

Case study:
Create a website of your own interest which includes all the features learned from these
chapters for your school
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GLOSSARY
GIF

Graphical Interchange Format.

JPEG

Joint Photographic Experts Group.

PNG

Portable Network Graphics.

SVG

Scalable Vector Graphics.

Photoshop

Familiar Photo editing tool developed by adobe.

Picasa

Free image organizer and editing tool developed by Lifescape.

GIMP

Open source image editing tool.

HTML 5

Latest version of HTML authorized by w3c

W3C

The World Wide Web Consortium; an International standards
organization for the www.

References:
1. Mastering HTML, CSS & JavaScript Web Publishing – Laura Lemay, Rafe Colburn, Jennifer
Kyrnin – BPB Publications.
2. Informatics Practices, A text book for CBSE class XII – Sumita Arora – Dhanpat Rai & Co.
3. Computer Application (Commerce) – Text book of XII – Department of Education –
SCERT, Kerala.
4. https://www.w3schools.com/html/default.asp

285

Chapter 12 Pages 93-115.indd 285

3/20/2020 11:43:04 AM

Unit III

Web Page Development using
HTML and CSS

CHAPTER

13

CSS - Cascading Style Sheets
Learning Objectives:
After learning this chapter, the student will be able to
• Understand the uses of CSS
• How to create separate CSS Files to format various elements of HTML
• How to use a CSS file in HTML 9.1 Necessity of Internet
Introduction:
In the previous chapters we discussed about the variety of HTML tags and the attributes
to design a webpage. As you already know about the formatting tags and its attributes, in some
situations, you may need to use a tag uniformly in the entire document. To do so, we can use
<style> tag. A style tag is used to change the default characteristics of a particular tag inthe
entire web document wherever that tag is used.
For example, if you want to display <h3> tag in a particular font style and size with blue
colour in the entire page,You can use <style> tag to define its properties in head section as
follows.
<html>
<head>
<title> Usage of the <style> tag </title>
<style>
h3
{ color:blue;
font-family: "Copperplate Gothic Bold";
font-size:14pt; }
</style>
</head>
<body>
<h3> Welcome to learn HTML </h3>
<h3> Welcome to learn CSS </h3>
<h3> Welcome to lean JavaScript </h3>
</body>
<html>
In the above code segment, the style of <h3> header tag is clearly defined. So, hereafter,
the content between <h3> and </h3> will be displayed as per its definition.The output of the
above code is shown as below:
The <style> tag controls the presentation styles of a particular HTML document.
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If you want to use a particular tag with the same style applied in one HTML document to
another is not possible. Thus, the <style> tags are called as “Page-Level Styles” or “Internal
Style sheets”.
The “Internal Style sheet” is defined and implemented only within an HTML document.
If you want use the same style to multiple pages, you should define styles as a separate style
file. These separate style files are known as “Sitewide Style sheets” or “External Style Sheets”.
Professional web developers do not use internal styles.
There is another style method called “Inline style” ,which is used to define style for a
particular tag anywhere in an HTML document. You can define styles for any tag within an
HTML document. But it is applicable only on that line where it is defined . If you use the same
tag, again in the same document, it does not reflect the new style.
In this chapter, we are going to discuss about External Style Sheets or Sitewide Style
Sheets that is about CSS.
Sitewide Style Sheets:
Cascading Style Sheets (CSS) are also called as Sitewide Style sheets or external style.
CSS is a style sheet language used for describing the formatting of a document written in
HTML. Using CSS, you can control the font colour, font style, spacing between pages, columns
size, border colour, background image or colour and various other effects in a web page. In
external styles, you can store all style information in a separate file and include it in your web
pages using an HTML tag. The separate file should be saved with the extension .css
Advantages of CSS
Maintainability -CSS are also defined and stored as separate files. So, the style and appearance
of a web page can be dynamically changed and maintain with less effort.
Reusability - The styles defined in CSS can be reused in multiple HTML pages.
Easy to understand - The tags in web pages are well organized with style specifications and
therefore it is easy to understand.
HakonWium Lie

CSS was invented by HakonWium Lie on October ,10
1994 and maintained through a group of people within
the W3C called the CSS Working Group.
CSS – Style definition rules
The body of the style sheet consists of a series of rules.
Selector
HTML Tag

Declaration
{ Properties : Values; }
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CSS style declaration consists of two major parts; Selector and Declaration. The Selector
refers an HTML tag in which you want to apply styles. The Declaration is a block of code
contains style definition. It should be surrounded by curly braces. You can include any number
of properties for each selector, and they must be separated by semicolons. The property name
and its value should be separated by a colon. Each declaration should be terminated by a
semicolon ( ; ).
Example:
Selector
P

Declaration of properties and values
{

Font-size : 16pt;
color : red;
font-weight : bold;

}

In the above example, the style properties are defined to <p> tag. Hereafter, whenever
you use the <p>, the contents will be displayed with modified properties. If you want to use
the above style definition as an internal style then it should be specified within <style> ……
,</style> block in head section. If you want store the above definition for using all your web
pages, you should save the above code as a separate file with extension .css
CSS – Frequently using Text formatting Properties and Values
Table: 13.1
Formatting
Text Colour

Properties
Color

Values
Predefined_Color_Name

Text Alignment

Text-align

Center / Left / Right / Justify

Font type

Font-family

Font_name

Font Style

Font-style

Normal / Italic

Example
P
{
color:pink;
}
H1
{
color : MediumSeaGreen;
}
P
{
Text-align : center;
}
P
{
Font-family : “Times New
Roman”;
}
P
{
Font-family : “Times New
Roman”;
Font-style : Italic;
}
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Formatting

Properties

Values

Example

Font Style (Bold) Font-weight

Normal / Bold

P
{
Font-family : “Times New
Roman”;
Font-style : Italic;
Font-weight : bold;
}

Font size

Font-size

Size in pixels

Background
Colour

Background
Colour

Predefined_Color_Name

P
{
Font-family : “Times New
Roman”;
Font-style : Italic;
Font-size : 14px;
}
Body
{
background-color : violet;
}

Border Colour

Border

Border thickness
<space> border style
<space>Predefined_
borderColor_Name

H2 { border : 2px solid red; }

HTML supports nearly 140 color names.
Background
Image

Paragraph
Margin

Backgroundimage

URL (“image name with
extension”)

Backgroundrepeat

norepeat

Backgroundposition

Direction

Margin-top
Marginbottom
Margin-left
Margin-right

Margin size in pixels

Body
{
background-image : url
(“Flower.gif ”);
}
Body
{
background-image : url
(“Flower.gif ”);
background-repeat :
norepeat;
}
Body
{
background-image : url
(“Flower.gif ”);
background-repeat :
norepeat;
background-position : right
top;
}
P
{
Margin-top : 50px;
Margin-left : 50px;
}
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Creating CSS style sheets:
• Open an empty notepad.
• Type the style properties and their values as given in the table given above.
• Save the file with extension .css
Illustration 13.1 My First CSS file
P{
font-style : Italic;
color :MediumSeaGreen;
}
H1
{
border:2px solid red;
}
The above code should be saved with extension .css
Linking CSS with HTML
The <link> tag is used to add CSS file with HTML in head section. While using <link> tag, the
following attributes are also included along with standard values.
rel = “stylesheet”
type = “text/css”
The href attribute is used to link the .css file.
General format of <Link> tag
<Link rel = “stylesheet” type = “text/css” href = CSS_File_Name_with_Extension>
Illustration 13.2 Formatting HTML element through CSS
H1
{

Mystyle.css

font-family : "Comic Sans MS";
Font-weight : Bold;
border:2px solid blue; }
P{
font-style : Italic;
color :MediumSeaGreen; }
--- CSS_Test.htm --<html>
<head>
<title> Demonstration of using CSS </title>
<link rel="stylesheet" type="text/css" href="mystyle.css">
</head>
<body>
<H1> Welcome to CSS </H1>
<P>
CSS was invented by HakonWium Lie on October 10, 1994 and maintained through
a group of people within the W3C called the CSS Working Group. The CSS Working
Group creates documents called specifications. When a specification has been
discussed and officially ratified by W3C members, it becomes a recommendation.
</P>
</body>
</html>
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Output will be:

Illustration 13.3 Changing background color of browser using CSS
body
{
background-color : pink;
}

--- Back_Color.css ---

--- Background_CSS.htm ---

<html>
<head>
		
<title> Changing Background using CSS </title>
		
<link rel = "stylesheet" type="text/css" href="Body_Color.css">
</head>
<body>
		
<H1> Welcome to CSS </H1>
</body>
</html>
CSS Comments
Many times, you may need to put additional comments in your style sheet blocks. So, it is very
easy to comment any part in style sheet. You can simplyput your comments inside /*.....this is
a comment in style sheet.....*/.
CSS - Workshop
• Develop a web page about your school with CSS.
• Develop a web page describing about your district. Use CSS to format HTML structural
tags.
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Points to Remember:
•
•
•
•
•
•
•
•

The <style> tag controls the presentation styles of a particular HTML document.
The <style> tags are called as “Page-Level Styles” or “Internal Style sheets”.
Professional web developers do not use internal styles.
The separate style files are known as “Sitewide Style sheets” or “External Style Sheets”
or CSS
CSS is easy to learn and understand but it provides powerful control over the
presentation of an HTML document.
Most commonly, CSS is combined with the markup languages HTML or XHTML.
There is another style method called “Inline style” which is used to define style for a
particular tag anywhere in an HTML document.
Electronic governance or e-governance is the application of information and
communication technology (ICT) for delivering government services.

Evaluation
Part – I

Choose the correct answer
1.

Expansion of CSS
(A) Cascading Style Schools		
(C) Cascading Style Sheets			

2.

Which of the following is the page level style?
(A) <Page>			(B) <Style>		(C) <Link>		(D) <H>

3.

CSS is also called as:
(A) Sitewide Style Sheets			
(C) Inline Style Sheets			

(B) Internal Style Sheets
(D) Internal Inline Sheets

4.

The extension of CSS file is
(A) .ssc		
(B) .css		

(C) .csc		

5.

What is selector?
(A) Property		

(C) HTML tag		

6.

The Declaration block of CSS is surrounded by
(A) ( )			
(B) [ ]			
(C) { }			

7.

The declaration should be terminated by
(A) :			(B) ;			(C) .			(D) ,

8.

What is the property to set text as bold?
(A) Font-Style
(B) Font-Weight
(C) Font-Property

9.

Which of the following indicates that the text included is a comment ?
(A) /* */			
(B) !* *!		
(C) <* *> (D) \* *\

(B) Cascading Style Scheme
(D) Cascading Style Shares

(B) Value		

(D) .htm
(D) name

(D) <>

(D) Font-Bold
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10.

Which of the following ways below is correct to write a CSS?
(A) p{color:red; text-align:center};
(B) p {color:red; text-align:center}
(C) p {color:red; text-align:center;}
(D) p (color:red;text-align:center;)
Part – II

Very Short Answers
1.
What is the use of <style> tag?
2.
What is CSS?
3.
Write the general format of linking CSS with HTML.
4.
What is Inline Style?
5.
Write down general format of CSS declaration.
Part-III
Short Answers
1.
What are the advantages of using CSS?
2.
Write a short note on rule of CSS.
3.
Write a CSS file to define text color and alignment to <p> tag.
4.
Write a CSS file to define font type, style and size to <h1> tag.
Part-IV
Explain in Detail
1. Write an HTML document to display the following paragraph as per the given description
Using CSS:
• Font Name : Cooper Black
• Style : Bold Italics
• Color : Blue
	“The State Institute of Education (SIE) was established in 1965 to provide for systematic
study of problems relating to School Education under the administration of Directorate
of School Education.”
2. List and explain the Font and text element properties and values used CSS.
GLOSSARY
Style Sheet

-

A separate file contains the style of appearance.

Selector

-

An HTML element

Property

-

Attribute of an HTML tag

Link

-

Connecting with another file

References:
• Mastering HTML, CSS & JavaScript Web Publishing – Laura Lemay, Rafe Colburn, Jennifer
Kyrnin – BPB Publications.
• Informatics Practices, A text book for CBSE class XII – SumitaArora – DhanpatRai& Co.
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Unit IV

JavaScript

CHAPTER

14

Introduction to JavaScript
Learning Objectives:
• To understand about JavaScript Language and advantages of JavaScript
• To understand the importance of Client side code, Steps to follow to
JavaScript Programs.
• To understand JavaScript Variables, Declaring Variables and Rules for
naming Variables – Scope of Variables and assigning values to variables.
• To develop the skills of Web page development using HTML and CSS
• To acquire the skills of web scripting using JavaScript
• To develop the skills of Internet and Online applications

14.1 Introduction to JavaScript:
On December 4, 1995, Netscape and Sun Inc. jointly introduced JavaScript 1.0.
JavaScript had truly bridged the gap between the simple world of HTML and the more complex
Common Gateway Interface (CGI) programs on the Server. It provides a common scripting
language for Web developers to design, test and deploy Internet Applications.
The JavaScript client-side technology provides many advantages over traditional CGI
Server-side scripts. For example, JavaScript code can be used to check if the user has entered
a valid e-mail address in a form field. The JavaScript code is executed when the user click
Submit button in the form, and only if all the entries are valid, they would be submitted to the
Web Server.

14.2 Advantages of JavaScript Programming Language
• In HTML chapter we have learnt how to develop static web pages. But in real life web pages
must be interactive. So to develop such interactive pages (Dynamic Web page ) JavaScript
programming language is used.
• User entered data in the Dynamic Web page can be validated before sending it to the
server. This saves server traffic, which means less load on your server.
• JavaScript includes such items as Textboxes, Buttons, drag-and-drop components and
sliders to give a Rich Interface to site visitors. For example Creating a New email account
in any service provider.

14.3 Using JavaScript in HTML page with <script> tag :
JavaScript can be implemented using <script>... </script> tags. The <script> tag
containing JavaScript can be placed anywhere within in the web page, but it is normally
recommended that should be kept it within the <head> tags. The <script> tag alerts the
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browser program to start interpreting all the text between these tags as a script commands.
The syntax of JavaScript segment in Hyper Text Markup Language (HTML) or Dynamic
Hyper Text Markup Language (DHTML) is as follows:
<script language="javascript" type="text/javascript">
JavaScript code
</script>
The <SCRIPT> tag takes two important attributes −
Language − This attribute specifies that the scripting language. Typically, its value will
be javascript. Although recent versions of HTML (EXtensible HyperText Markup Language XHTML, its successor) have phased out the use of this attribute is optional.
Type − This attribute is used to indicate the scripting language and its value should be
set to "text/javascript".
14.3.1 Steps to follow to code JavaScript Language
• Enter HTML and JavaScript code using any text editor.
• Save the latest version of this code.
• Use any browser to see the result. For example : Internet Explorer, Google Crome, etc.,
• If this is a new document, open the file via browser's Open Menu. If the document is
already loaded in the Memory, to reload the file into the browser use "Refresh" or press
F5 button.
14.3.2 First JavaScript Program
Illustration 14.1 Simple JavaScript Program
<Html>
<Head>
<Title>My First JavaScript Program</Title>
<script language="javascript" type="text/javascript">
document.write("Hello World!")
</script>

Output:

</Head>
<Body>
</Body>
</Html>

14.4 Lexical Structure of a JavaScript Program
The lexical structure of a programming language is the set of elementary rules that
specifies how to write programs in that language. It is the lowest-level syntax of a language. The
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Lexical structure specifies variable names, the delimiter characters for comments, and how
one program statement is separated from the next.
• Though JavaScript is a case-sensitive language. It is good programming practice to type the
command in lowercase.
• JavaScript ignores spaces that appear between tokens (identifiers, operators, punctuator,
constants and keywords) in programs.
• JavaScript supports two styles of comments. Any text follow a “//” and the end of a line
is treated as a single line comment and is ignored by JavaScript. Any text between the
characters “ /* */” is also treated as a multiline comment.
• JavaScript uses the semicolon (;) to separate statements. Many JavaScript programmers
use semicolons to explicitly mark the ends of statements.
• A literal is a data value for variable that appears directly in a program.
• An identifier is simply a name. In JavaScript, identifiers are used to name variables,
functions and to provide labels for certain loops in JavaScript code.
• In JavaScript certain keywords are used as reserved words, These words cannot used as
identifiers in the programs

14.5 JavaScript Variables:

Variable is a memory location where value can be stored. Variable is a symbolic name
for a value. Variables are declared with the var keyword in JavaScript. Every variable has a
name, called identifier.
14.5.1 Basic Data types and Declaring variables:
Every variable has a data type that indicates what kind of data the variable holds. The
basic data types in JavaScript are Strings, Numbers, and Booleans.
• A string is a list of characters, and a string literal is indicated by enclosing the characters
in single or double quotes. Strings may contain a single character or multiple characters,
including whitespace and special characters such as \n (the newline).
• Numbers can be integer or floating-point numerical value and numeric literals are specified
in the natural way.
• Boolean can be any one of two values: true or false. Boolean literals are indicated by using
true or false directly in the source code.
Variables are declared in JavaScript using var keyword that allocates storage space for
new data and indicates to the interpreter that a new identifier is in use. Declaring a variable in
JavaScript as follows:
var no;
var no1,no2;
The var no; statement tells the interpreter that a new variable no is about to be used
and var no1,no2; tells the interpreter that no1 and no2 are variables.
14.5.2 Rules for naming variable
1. The first character must be a letter or an underscore (_). Number cannot be as the first
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character.
2. The rest of the variable name can include any letter, any number, or the underscore. You
can't use any other characters, including spaces, symbols, and punctuation marks.
3. JavaScript variable names are case sensitive. That is, a variable named RegisterNumber is
treated as an entirely different variable than one named registernumber.
4. There is no limit to the length of the variable name.
5. JavaScript's reserved words cannot be used as a variable name. All programming languages
have a supply of words that are used internally by the language and that cannot be used for
variable names.
14.5.3 Scope of variables
The scope of a variable is the life time of a variable of source code in which it is defined.
• A global variable has global scope; it can be defined everywhere in the JavaScript code.
• Variables declared within a function are defined only within the body of the function. They
are local variables and have local scope.
14.5.4 Assigning values to variables
Variables can be assigned initial values when they are declared as follows:
var numericData1 = 522;
var stringData = "JavaScript has strings\n It sure does";
var numericData = 3.14;
var booleanData = true;
Illustration 14.2 Declaring Variables
<Html>
<Head>
<Title>Demo Program - Declaring Variables in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var numericData1 = 522;
var stringData = " JavaScript has strings\n It sure does";
var numericData = 3.14;
var booleanData = true;
document.write("Numeric Data : "+numericData1);
document.write("<br> String Data : "+stringData);
document.write("<br> Floating Data : "+numericData);
</script>
</Body>
</Html>
297

Chapter 14 Pages 127-153.indd 297

3/20/2020 11:44:36 AM

Output

In addition, multiple variables can be declared with one var statement, if the variables
are separated by commas:
var no1=50, no2=5065;
JavaScript allows the implicit declaration of variables by using them on the left-hand
side of an assignment. In JavaScript there is no need to indicate data type during variable
declarations. JavaScript variables are untyped and it is dynamically datatyped which means
initially you can assign a value of any data type to a variable and later you can assign a value of
different data type to the same variable. For example:
var value=100;
var value=”JavaScript”;
14.5.5 JavaScript Literals
A literal is a fixed value given to a variable in source code. Literals are often used to
initialize variables. Values may be Integer, Floating point, Character, String and Boolean. For
Example,
var int_const=250; //Integer constant//
var float_const=250.85; //Floating point constant//
var char_const=’A’; //Character constant//
var string_const=”Raman”; //String constant//
var boolean_const=true; //Boolean constant//

write statement:
General Syntax:

document write ("string " + var);
14.5.6 Type casting in JavaScript.
Type conversion is the act of converting one data type into a different data type which
is also called as casting. In JavaScript there are two type of casting,
• Implicit casting and
• Explicit casting
Implicit casting occurs automatically in JavaScript when you change the data stored in
a variable:
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14.6 JavaScript Operators and Expressions
An operator combines the values of its operands in some way and evaluates to a new
value. Operators are used for JavaScript’s arithmetic expressions, comparison expressions,
logical expressions, assignment expressions.
An expression is a phrase of JavaScript that a JavaScript interpreter can evaluate to
produce a value. The data types are used directly as literals or within variables in combination
with simple operators, such as addition, subtraction, and so on, to create an expressions. An
expression is a code fragment that can be evaluated to some data type the language supports.
An expression is simply one or more variables and/or constants joined by operators. An
expression is evaluated and produces a result. The result of all expressions may be either an
integer or floating-point value or Boolean value. There are three types of expressions as follows,
• Arithmetic expressions
• Relational expressions
• Logical expressions
14.6.1 Arithmetic Operators
JavaScript supports all the basic arithmetic operators like addition (+), subtraction (–),
multiplication (*), division (/), and modulus (%, also known as the remainder operator).
Table: 14.1 – Arithmetic Operators
Arithmetic
Operator
+
-

Meaning

Example

Result

Addition
Subtraction

var sum = 20 + 120
var diff = 20 – 120

Variable sum = 140
Variable diff = 100

*

Multiplication

var prod = 10 * 100

Variable prod = 1000

/

Division

var res = 100/522

%

Modulus operator var rem = 100 % 522

Variable res = 5.22
Variable rem = 22
(remainder)

Illustration 14.3 Using Arithmetic Operators
<Html>
<Head>
<Title>Demo Program – To test Arithmetic Operators in JavaScript
</Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
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var value1 = 522, value2=10;
document.write("<br>Data1 : "+value1);
document.write("<br>Data2 : "+value2);
var sum = value1+value2;
var diff = value1-value2;
var prod = value1*value2;
var res = value1/value2;
var rem = value1%value2;
document.write("<br><br>The Sum of Data1 and Data2 : "+sum);
document.write("<br>The Difference of Data1 and Data2 : "+diff);
document.write("<br>The Product of Data1 and Data2 : "+prod);
document.write("<br>The Result after Division of Data1 and Data2 : "+res);
document.write("<br>The Remainder after Division of Data1 and Data2 :
"+rem);
</script>
</Body>
</Html>
Output:

14.6.2 Assignment Operator
An assignment operator is the operator used to assign a new value to a variable.
Assignment operator can also be used for logical operations such as bitwise logical operations
or operations on integral operands and Boolean operands.
In JavaScript = is an assignment operator, which is used to assign a value to a variable.
Often this operator is used to set a variable to a literal value, for example,
var number1=10;
var number2=number1;
var name=”Computer Science”;
var booleanvar=true;
The assignment operator is used to assign a value to a single variable, but it is possible
to perform multiple assignments at once by stringing them together with the = operator. For
example, the statement
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var m = n = z = 25; // sets all three variables to a value of 25//
The assignment operator can also be used to set a variable to hold the value of an
expression. For example,
var x = 102 + 5 - 50; // x set to 57 //
JavaScript supports some shorthand arithmetic operators like +=, -=, *=, /= and %= to
evaluate arithmetic calculations.
Table: 14.2 Shorthand Arithmetic operators
Shorthand
Arithmetic
Operator

Meaning

+=

Add and assign

-=

Subtract and assign

*=

Multiply and assign

/=

Division

%=

Modulus operator

Example
var sum = 120;
sum += 20;
var diff = 120;
diff –= 20;
var prod = 100;
prod *=10;
Var res = 522;
Res/=100
Var rem = 522;
rem %= 100

Result
Variable sum = 140
Variable diff = 100
Variable prod = 1000
Variable res = 5.22
Variable rem = 22 (remainder)

Illustration 14.4 Using Arithmetic Shorthand Operators
<Html>
<Head>
		
<Title>Demo Program - To test Arithmetic Shorthand Operators in JavaScript
</Title>
</Head>
<Html>
<Head>
		
<Title>Demo Program - To test Arithmetic Shorthand Operators in JavaScript
</Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var value1 = 522, value2=10;
document.write("<br>Data1 : "+value1);
document.write("<br>Data2 : "+value2);
var sum = value1; sum+=value2;
var diff = value1; diff-=value2;
var prod = value1; prod*=value2;
var res = value1; res/=value2;
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var rem = value1; rem%=value2;
document.write("<br><br>The Sum of Data1 and Data2 Using += : "+sum);
document.write("<br>The Difference of Data1 and Data2 Using -= : "+diff);
document.write("<br>The Product of Data1 and Data2 Using *= : "+prod);
document.write("<br>The Result after Division of Data1 and Data2 using /= : "+res);
document.write("<br>The Remainder after Division of Data1 and Data2 Using %= : "+rem);
</script>
</Body>
</Html>

Output:

Assignment:
Develop JavaScript code for the following:
1. To find Simple Interest for the given Principle, Number of years and Rate of interest.
2. To find Compund Interest for the given Principle, Number of years and Rate of interest.
3. To find difference between Simple Interest and Compound Interst.
14.6.3 Relational or Comparison Operators:
Relational operators are also called as Comparison operators, they compares two values
and the result is true or false. JavaScript provides a rich set of relational operators including ==
(equal to), != (not equal to), < (less than), > (greater than), <= (less than or equal to), and >=
(greater than or equal to). Using a relational operator in an expression causes the expression
to evaluate as true if the condition holds or false if otherwise.
Table: 14.3 Relational or Comparison operators
Relational
(Comparison)
Meaning
Operator
Assume x=10 and y=20
==
Equality
!=
In-equality
<
Less-than
>
Greater-than
<=
Less-than or equal to
>=
Greater-than or equal to

Example

x==y
x!=y
x<y
x>y
x<=y
x>=y

Result

False
True
True
False
True
False
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Illustration 14.5 Using Relational Operators
<Html>
<Head>
<Title>Demo Program - To test Relational(Comparison) Operators in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var value1 = 522, value2=10;
document.write("<br>Data1 : "+value1);
document.write("<br>Data2 : "+value2);
document.write("<br><br>Whether Data1 = Data2 : "+(value1==value2));
document.write("<br>Whether Data1 < Data2 : "+(value1<value2));
document.write("<br>Whether Data1 > Data2 : "+(value1>value2));
document.write("<br>Whether Data1 <= Data2 : "+(value1<=value2));
document.write("<br>Whether Data1 >= Data2 : "+(value1>=value2));
document.write("<br>Whether Data1 != Data2 : "+(value1!=value2)); </script>
</Body> </Html>

Output:

14.6.4 Logical Operators:
Logical operators perform logical (boolean) operations. Logical operators combine or
invert boolean values. Once comparisons are made, the logical operators && (AND), || (OR)
and ! (NOT) can be used to create more complex conditions.
Table: 14.4 Logical or Boolean operators
Logical
Operator
&&

Example
((4>5( && )10<5))
((expr1) && (expr2))

||

((4>5( || )10<5))
((expr1) || (expr2))

!

!(10<5)
!(expr1)

Meaning

Result

(Logical AND) Returns true if
True
expr1 and expr2 both true.
(Logical OR) Returns true if either
expr1 or expr2 is true, or both are True
true.
(Logical NOT) Returns true if
expr1 is false; otherwise, returns False
false.
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Usage :
Best practice is to use logical operators on boolean operands. However, operands of any
type can be combined. The strict rules are as follows:
• For && (AND) the result is false if the first operand is false; otherwise, the result is the
Boolean value of the second operand.
• For || (OR) the result is true if the first operand is true; otherwise, the result is the Boolean
value of the second operand.
• For ! (NOT) the result is true if the operand is false; otherwise, the result is true.
Illustration 14.6 Using Logical Operators
<Html>
<Head>
<Title>Demo Program - To test Logical Operators in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var value1 = 522, value2=10;
document.write("<br>Data1 : "+value1);
document.write("<br>Data2 : "+value2);
var res1=((value1>100) && (value1>601));
var res2=((value1>100) || (value1>601));
var res3=(!(value1!=value2));
document.write("<br><br>Whether Data1>100 AND Data1>601 : "+res1);
document.write("<br><br>Whether Data1>600 OR Data1>601 : "+res2);
document.write("<br>Whether !Data1 != Data2 : "+res3);
</script>
</Body>
</Html>

Output:
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14.6.5 String Operators:
One of the built-in features of JavaScript is the ability to concatenate strings. The +
operator performs addition on numbers but also serves as the concatenation operator
for strings. Because string concatenation has precedence over numeric addition, + will be
interpreted as string concatenation if any of the operands are strings. + operator which is also
called as the string concatenation operator. For example:
Illustration 14.7 Using + Operator for concatenating String
<Html>
<Head>
<Title>Demo Program - To Concatenating (+) Operators in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var String1 = "Java";
var String2 = "Script";
var String3=String1+String2;
document.write("<br>String1 : "+String1);
document.write("<br>String2 : "+String2);
document.write("<br><br>Concatenated String of String1 and String2 : "+String3);
</script>
</Body>
</Html>

Output:

14.6.6 Increment and Decrement Operators:
The ++ operator increments its single operand. The operator converts its operand to a
number, adds 1 to that number, and assigns the incremented value back into the variable. The
return value of the ++ operator depends on its position relative to the operand. When ++ is
used before the operand, where it is known as the pre-increment operator, it increments the
operand and evaluates to the incremented value of that operand. When used after the operand,
where it is known as the post-increment operator, it increments its operand but evaluates to
the un-incremented value of that operand. Consider the difference between these two lines of
code:
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var m = 1, n = ++m; // m and n are both 2
var m = 1, n = m++; // m is 2, n is 1
The -- operator decrements its single operand. It converts the value of the operand to
a number, subtracts 1, and assigns the decremented value back to the operand. Like the ++
operator, the return value of -- depends on its position relative to the operand. When used
before the operand, it decrements and returns the decremented value. When used after the
operand, it decrements the operand but returns the undecremented value.
var m = 2, n = --m; // m and n are both 1
var m = 2, n = m--; // n is 2, n is 1
Illustration 14.8 Using ++ and -- Operator – both Prefix and Suffix
<Html>
<Head>
<Title>Demo Program - ++ and -- Operators in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var number1 = 150;
var number2 = number1++;
document.write("<br><h4>Post Increment - number++</h4>");
document.write("Number1 = "+number1+" Number2 = "+number2);
document.write("<br><h4>Pre Increment - ++number</h4>");
var number1 = 150;
var number2 = ++number1;
document.write("Number1 = "+number1+" Number2 = "+number2);
var number1 = 150;
var number2 = number1--;
document.write("<br><h4>Post Decrement - number--</h4>");
document.write("Number1 = "+number1+" Number2 = "+number2);
document.write("<br><h4>Pre Decrement - --number</h4>");
var number1 = 150;
var number2 = --number1;
document.write("Number1 = "+number1+" Number2 = "+number2);
</script>
</Body>
</Html>
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Output:

14.6.7 Unary + and - Operator:
+ has no effect on numbers but causes non-numbers to be converted into
numbers
– Negation (changes the sign of the number or converts the expression to a
number and then changes its sign)
14.6.8 typeof Operator:
The typeof operator is used to get the data type (returns a string) of its operand. The
operand can be either a literal or a data structure such as a variable, a function, or an object.
The operator returns the data type.
Syntax
typeof operand
or
typeof(operand)
typeof returns: boolean, function, number, string, and undefined. The following table
summarizes possible values returned by the typeof operator.
Table: 14.5
Type of Operand

Result

Number

“number”

Boolean

“Boolean”

String

“string”

Functions

“function”

Undefined

“undefined”
307

Chapter 14 Pages 127-153.indd 307

3/20/2020 11:44:36 AM

Illustration 14.9 typeof operator
<Html>
<Head>
<Title>Demo Program - To test typeof Operator in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var value1 = 522, value2="JavaSript"; value3=true;
document.write("<br>Value1 ="+value1+" and its data Type is : "+typeof(value1));
document.write ("<br>Value2 ="+value2+" and its data Type is : "+typeof(value2));
document.write ("<br>Value3 ="+value3+" and its data Type is : "+typeof(value3));
</script>
</Body>
</Html>

Output:

14.6.9 Conditional Operator (?:)
The ?: is the conditional operator in JavaScript, which requires three operands, hence
it is called the ternary operator. The syntax is
var variablename=(condition) ? value1 : value2;
In the syntax condition may be relational expression or logical expression. First condition will
be evaluated, if the condition returns true then the value of the left side of the colon is assigned
to the variable otherwise the value of the right side of the colon will be assigned the variable.
For example,
var result=(10>15) ?100 :150;
In the above example, since the condition returns false the value 150 will be assigned
to result.
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Illustration 14.10 Condtional Operator
<Html>
<Head>
<Title>Demo Program - To test Conditional Operator in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var value1 = 522, value2=150, value3;
value3=(value1<value2) ? value1: value2;
document.write("<br>The Value of Data1 = "+value3);
</script>
</Body>
</Html>

Output:

14.7 JavaScript Popup or Dialog Boxes:
JavaScript supports three important types of dialog boxes. Dialog boxes are also called
as Popup Boxes. These dialog boxes can be used to raise an alert, or to get confirmation on any
input or to have a kind of input from the users. JavaScript supports three kind of popup boxes:
Alert box, Confirm box, and Prompt box.
14.7.1 Alert Dialog Box:
An alert dialog box is mostly used to give a warning message to the users. For example,
if one input field requires to enter some text but the user does not provide any input, then as
a part of validation, you can use an alert box to give a warning message. Alert box gives only
one button "OK" to select and proceed.
The syntax of alert box is
Alert(“Message”);
(or) Window.alert(“Message”);
Example:
alert(“Name is compulsory entry”);
(or) window.alert(“Name is compulsory entry”);
309

Chapter 14 Pages 127-153.indd 309

3/20/2020 11:44:36 AM

Illustration 14.11 Alert Dialog Box
<Html>
<Head>
<Title>Demo Program - To test Alert Dialog Box in JavaScript </Title>
</Head>
<Body>
	
<script language="javascript" type="text/javascript">
Output:
var value1 = 522, value2=10;
window.alert("Data1 : "+value1);
alert(“Data1 :”+value2);
</script>
</Body>
</Html>
14.7.2 Confirm Dialog Box:
A confirmation dialog box is mostly used to take user's consent on any option. It
displays a dialog box with two buttons: OK and Cancel. If the user clicks on the OK button,
the confirm() will return true. If the user clicks on the Cancel button, then confirm() returns
false.
The syntax of confirm dialog box is
confirm(“message”);
		
(or)
window.confirm(“message”);
Example:
confirm(“Hai Do you want to continue:”);
			
(or)
window.confirm(“Hai Do you want to continue:”);
Illustration 14.12 Confirm Dialog Box
<Html>
<Head>
<Title>Demo Program - To test Confirm Dialog Box in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var value1 = 522, value2=10;
window.confirm("Data1 : "+value1);
confirm("Data2 :"+value2);
</script>
</Body>
</Html>
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Output:

14.7.3 Prompt Dialog Box:
The prompt dialog box is very useful when the user want to pop-up a text box to get
user input. Thus, it enables you to interact with the user. The user needs to fill in the text box
field and then click OK.
The prompt dialog box is displayed using a method called prompt() which takes two
parameters: (i) a label which you want to display in the text box and (ii) a default string to
display in the text box. This dialog box has two buttons: OK and Cancel. If the user clicks the
OK button, the prompt() will return the entered value from the text box. If the user clicks the
Cancel button, the prompt() returns null. The Syntax of prompt dialog box is,
Prompt(“Message”,”defaultValue”);
(or)
window.prompt("sometext","defaultText");
Example:
prompt(“Enter Your Name:”,”Name”);
(or)
window.prompt(“Enter Your Name:”,”Name”);
Illustration 14.13 Prompt Dialog Box
<Html>
<Head>
<Title>Demo Program - To test Prompt Dialog Box in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var sname = prompt("Please enter your name", "Name");
</script>
</Body>
</Html>
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Output:

14.8 Comments in JavaScript:
Very important aspect of good programming style is to insert remarks and commentary
directly in source code, making it more readable to yourself as well as to others. Any comments
you include will be ignored by the JavaScript interpreter. There are two types of comments,
Single line and Multiple lines comments. Single-line comments begin with a double slash (//),
causing the interpreter to ignore everything from that point to the end of the line. Multiple line
comments begins with /* and ends with */.
For example:
// JavaScript single line comment//
Multiple line comments begins with /* and ends with */
Points to Remember:
• The <script> tag alerts the browser program to start interpreting all the text between
these tags as a script
• JavaScript is a case sensitive language
• The scope of a variable is the life time of a variable of source code in which it is
defined
• A literal is a fixed value given to a variable in source code.
• An expression is a code fragment that can be evaluated to some data type the language
supports.
• Java Script supports all basic arithmetic operators like +, - , *, / & %
• Java scripts has an in built feature of concatenating strings.
• The types of operator is used to get the data type of a variable.
• JavaScript supports important types of dialog boxes also called as pop up boxes, alert
box, confirm dialog box and prompt dialog box.
• ?: is the conditional operator in Java Script also called as ternary operator.
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Evaluation

Choose the correct answer:

Part-I

1.

Which provided a common scripting language to web developers to design, test and
deploy Internet Application
A) C				
B) C++		
C) Java		
D) JavaScript

2.

Expand CGI

3.

A) Common Gateway Interface		

B) Complex Gateway Information

C) Common Gateway Information		

D) Complex Gateway Interface

JavaScript programming language is used to develop the
A) Dynamic Web Page

4.

6.

8.

D) Home Page

B) Route		

C) Traffic		

D) Pvath

User entered data, is validated before sending it to server is called
A) Server traffic				

B) Dynamic Web Page

C) Server Route 				

D) Web server

Java Scripts can be implemented using which statements?
A) <head> 			

7.

C) Web Page		

The Dynamic Web Page help to save server’s
A) Work			

5.

B) Window		

B) <Java>		

C) <script>		

D) <text>

Expand
A) Distance Hyper Text Markup language

B) Dynamic Hyper Text Markup
language

C) Distance High Text Markup language		

D) Dynamic High Text Markup
language

How many attributes specifies that <script> tag in the scripting
A) 2				B) 3			C) 4			D) 5

9.

Which attribute is used to indicate the scripting language and its value should be sent to
“ Text/JavaScript”
A) Language		

10.

B) Text1		

C) Type		

D) Body

The file reload into the browser use the shortcut key is
A) F2			B) F3			C) F4			D) F5

11.

JavaScript ignores spaces that appear between
A) Command		

12.

C) Tokens		

D) Text

A Data value for variable that appears directly in a program by using a
A) loop 			

13.

B) Scripts		
B) Literal		

C) Statement		

D) Text

Which is mostly used to give a warning message to users?
A) Alert Dialog Box				

B) Confirm box

C) Prompt box					

D) Display box
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14. In the below snippet, value of x is

var x = 250 + 2 – 200;

A) 50			B) 52			C) 48 			D) 42
Part – II
Very Short Answers
1.
Write a syntax of <script> tag
2.
What is scope of variables and types of scope variable?
3.
Write a notes to type casting in JavaScript
4.
How many Literals in JavaScript and mention its types.
5.
What is conditional operator give suitable example.
6.
What are the comments in Java Script?
7.
Write note on types of Operator.
8.
Write the role of variable in JavaScript.
9.
What is the uses of prompt dialog box?
Part-III
Short Answers
1.
What are the advantages of programming language?
2.
Brief the basic data types in Java Scripts.
3.
Write note on string Operator.
4.
Write about <script> tag
5.
What are the uses of Logical Operators?
6.
Difference between the increment and Decrement operator.
Part –IV
Explain in Detail
1.

Explain about the popup dialog boxes in JavaScript.

2.

Explain about the Arithmetic operator with suitable example.

Case study:
Develop a program for online registration form with some of the client side validation features
Reference :
1. Title - Pure JavaScript Author : R.Allen Wyke, Jason D. Gilliam and Charlton Ting,
Publisher : Techmedia
2. Computer Application Text Book – Govt. of Kerala
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Unit IV

JavaScript

CHAPTER

15

Control Structure in JavaScript
Learning Objectives:
•
•
•
•

To learn about control structures
To learn about logical operators in JavaScript
To learn about loops and their types
To acquire knowledge of developing JavaScript programs.

15.1 Conditional Statements in JavaScript:

Statements are executed in the order they are found in a script. Conditional statements
execute or skip one or set of statements depending on the value of a specified conditional
expression. There are two types of controls,
• Branching / Selection
• Looping / repetitive
15.1.1 Branching Statements:
JavaScript supports branching statements which are used to perform different actions
based on different conditions. Branching is a transfer of control from the current statement to
another statement or construct in the program unit. A branch alters the execution sequence.
There are different branching statements. They are,
• if statement
• if … else statement
• else if statement
• switch statement
15.1.1.1 if and if..else Statement:
The if statement is the fundamental control statement that allows JavaScript to make
decisions to execute statements conditionally. This statement has two forms. The form is for
only true condition. The syntax is
if (condition)
{
		True block;
}
In the if form, condition contains relational/logical expression is evaluated. If the
resulting value is true the true block is executed. True block may contain one or more than
one statement. For example
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Illustration 15.1 Demo to Test if command
<Html>
<Head>
<Title>Demo Program - To test if command in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var age = prompt("Please enter your Age :", "0");
if(age>=16)
{
alert("You Are Eligible to Vote ....");
}
</script>
</Body>
</Html>
The output will be
Demo Program - To test

← →

X

-

X

X

file:///C:/Users/ELCOT/Desktop/SCERT/Fin...

.
.
.

This page says
Please enter your Age:
35
OK

Demo Program - To test

← →

X

Cancel

-

X

file:///C:/Users/ELCOT/Desktop/SCERT/Fin...

X
.
.
.

This page says
You Are Eligible to Vote....
OK

The second form of the if statement is an else clause that is the program to follow
either of two branches depending on the condition. In the simple if construction, no special
processing is performed when the condition evaluates to false. But if processing must follow
one of two paths, hence need to use if...else format. Its syntax is:
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if (expression)
		
{
statements if true }
else
		
{
statements if false }
This form is similar to if statement but the only difference is the else keyword, which
provides an alternate path for execution to follow if the condition evaluates to false.
Illustration 15.2 Using if.. else statement
<Html>
<Head>
<Title>Demo Program - To test if..else command in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var age = prompt("Please enter your Age :", "0");
if(age>=18)
{ 		
alert("You Are Eligible to get Driving Licence..");
}
else
{
alert("You Are Not Eligible to get Driving Licence.."); }
</script>
</Body>
</Html>
The output will be
←

→

X

C:\User\ELCOT\Desktop\SCER ^

-

^

Search...

X

Demo Program - To test if c... X

X

Explorer User Prompt
Script Prompt:
Please enter you Age:

OK
Cancel

35
X

Message from webpage

Explorer User Prompt

! You Are Eligible to get Driving Licence..

X

OK

Script Prompt:

Cancel

Please enter your Age:
15
OK

X

Message from webpage

! You Are Not Eligible to get Driving Licence..
OK
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15.1.1.2 else if Statement:
The if ... else statement evaluates an expression and executes one of two pieces of
code, depending on the outcome. The else if statement to specify a new condition if the first
condition is false.
if (n == 10)
{ 		
// Execute code block #1 }
else if (n == 20)
{ 		
// Execute code block #2 }
else if (n == 30)
{ 		
// Execute code block #3 }
else
{ 		
// If all else fails, execute block #4 }
Illustration 15.3 Using Logical Operators and else if Statement
<Html>
<Head>
<Title>Program - To test else ..if command in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var marks = prompt("Please enter your Marks/100 :", "0");
if(marks>90)
{
document.write("Your Grade is Outstanding.."); }
else if((marks>70) && (marks<=90))
{
document.write("Your Grade is Excellent..");
}
else if((marks>50) && (marks<=70))
{
document.write("Your Grade is Good..");
}
else if((marks>40) && (marks<=50))
{
document.write("Your Grade is Satisfectory.."); }
else
{ document.write("Your Grade Poor and have to re-appear Exam.."); }
</script>
</Body>
</Html>
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The output will be

There is nothing special about this code. It is just a series of if statements, where each following
if is a part of the else clause of the previous statement. Using the else if idiom is preferable
to, and more legible than, writing these statements out in their syntactically equivalent, fully
nested form:
if (n == 10)
{

// Execute code block #1

}

else
{
		

if (n == 20)
{

// Execute code block #2

}

		else
		{
			

if (n == 30)

			

{

// Execute code block #3

}

			else
			

{

// If all else fails, execute block #4 }

		}
}
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15.1.1.3 switch case Statement:
JavaScripts offers the switch statement as an alternate to using if...else structure. The
switch statement is especially useful when testing all the possible results of an expression. The
syntax of a switch structure as the following:
switch(expression)
{
`
case label1:
		statements1;
		break;
case label2:
		statements2;
		break;
case labeln;
		
statements - N;
		break;
default:
		statements;
}
15.1.1.4 Break and Default Statement
The switch statement begins by evaluating an expression placed between parenthesis,
much like the if statement. The result compared to labels associated with case structure that
follow the switch statement. If the result is equal to a label, the statements in the corresponding
case structure are executed. The default structure is can be at the end of a switch structure if
the result of the expression that do not match any of the case labels. The break statement is also
used commonly within switch to exit the statement once the appropriate choice is found.
Illustration 15.4 Using Switch Statement
<Html>
		<Head>
		
<Title>Program - To test witch command in JavaScript </Title>
		</Head>
<Body>
<script language="javascript" type="text/javascript">
var grade=0;
var marks=prompt(“Please enter your marks/100:”,”0”);
if(marks>90)
{grade=1;}
else if(marks>70)&&(marks<=90)
{grade=2;}
else if(marks>50)&&(marks<=70)
{grade=3;}
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else if(marks>40v)&&(marks<=50)
{grade=4;}
else
{grade=5;}
switch(grade)
{
case 1:
document.write("Your Grade is Outstanding..");
		break;
		case 2:
document.write("Your Grade is Excellent..");
		break;
		case 3:
document.write("Your Grade is Good..");
break;
case 4:
document.write("Your Grade is Satisfectory..");
		break;
default:
document.write("Your Grade Poor and have to re-appear Exam..");
}
</script>
</Body>
</Html>
The output will be
-

^
X Search...
Demo Program - To test else c...i.. Program - To test witch co... X
C:\User\ELCOT\Desktop\SCER ^

X

X

Explorer User Prompt
Script Prompt:
Please enter your Marks/100:

OK
Cancel

98
-

^
X Search...
Demo Program - To test else c...i.. Program - To test witch co... X
C:\User\ELCOT\Desktop\SCER ^

X

Your Grade is Outstanding...
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15.2 Looping / repetitive
In JavaScript there are times when the same portion of code needs to be executed many
times with slightly different values is called Loops. JavaScript supports three kinds of looping
statements. They are
• for loop
• while loop
• do..while loop
15.2.1 for loop
The for loop is a very rigid structure that loops for a pre-set number of times. In
JavaScript for structure is very flexible, which makes this type is very useful. The syntax of the
for loop looks like the following:
for(initialization; condition; increment/decrement)
{
		Body of the loop;
}
The for structure within parenthesis there are three parts each separated by semicolon.
They are,
1. The first part of the loop initialize a variable which is also called as control variable. In most
case the control variable is declared as well as initialized.
2. The second part is the conditional statement that determines how many times the loop will
be iterated.
3. The third and final part determines how the value of control variable is changed
(Incremented/Decremented)
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Illustration 15.5 Using for loop
<Html>
<Head>
<Title> Program - To test for statement in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
var no1 = prompt("Please enter Table You want :", "0");
document.write("<h2> Multiplication for your need </h2>");
for( var no2=0;no2<=10;no2++)
{
document.write(no1+" x "+no2+" = "+no1*no2+"<br>");
}
</script>
</Body>
</Html>

-

X

C:\User\ELCOT\Desktop\SCER ^ Search...

Demo Program - To test Pr..
Multiplication for your need
3x3=0
3x1=3
3x2=6
3x3=9
3 x 4 = 12
3 x 5 = 15
3 x 6 = 18
3 x 7 = 21
3 x 8 = 24
3 x 9 = 27
3 x 10 = 30
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15.2.2 break and continue statement
JavaScript also supports statements used to modify flow control, specifically break and
continue. The break statement will terminate the loop early. For example,
for(var n=0;n<=10;n++)
{

if(n==5)

		{

break; 		}

		document.write(n+"<br>");
}
In the above example, which writes out the value of n starting from 0, when n is equal
to 5 the break statement is executed and the loop is terminated and the output is as follows,
Illustration 15.6 Using break statement
<Html>
<Head>
<Title>Demo Program - To test Break command in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
document.write("<h2> Using Break Statement </h2>");
for( var no2=0;no2<=10;no2++)
{
if(no2==5)
{break;}
document.write(no2+" ");
}
</script>
</Body>
</Html>
-

X

C:\User\ELCOT\Desktop\SCER ^ Search...

Demo Program - To test Pr..
Using Break Statement
01234
The continue statement will skip back to the loop condition check. When the continue
statement is executed, the current iteration of the enclosing loop is terminated, and the next
iteration begins. For example,
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for(var n=0;n<=10;n++)
{
		if(n==5)
{
continue;
}
		document.write(n+"<br>");
}
In the above example, which writes out the value of n starting from 0, when n is equal
to 5 the continue statement is executed and the continue statement continues the loop without
printing the value 5 and the output is as follows,
Illustration 15.7 Using continue statement
<Html>
<Head>
<Title>Demo Program - To test Continue command in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
document.write("<h2> Using continue Statement </h2>");
for( var no2=0;no2<=10;no2++)
{
if(no2==5)
{continue;}
document.write(no2+" ");
}
</script>
</Body>
</Html>
-

X

C:\User\ELCOT\Desktop\SCER ^ Search...

Demo Program - To test Pr..
Using Continue Statement
0 1 2 3 4 6 7 8 9 10
15.2.3 while loop
In JavaScript while loop is another most basic loop. The purpose of a while loop is to
execute a statement /block of statement repeatedly as long as an expression is true.
The while statement creates a loop that executes a specified statement as long as the test
condition evaluates to true. The condition is evaluated before executing the statement.
325

Chapter 15 Pages 154-175.indd 325

3/20/2020 11:44:53 AM

The syntax is:
while (condition)
{
		

body of the loop

}
Illustration 15.8 Using while loop
<Html>
<Head>
<Title>Program - To test while statement in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
document.write("<h2> Using while Statement </h2>");
var no2=0;
while(no2<=5)
{
document.write(no2+" ");
no2=no2+1;
}
</script>
</Body>
</Html>
-

X

C:\User\ELCOT\Desktop\SCER ^ Search...

Demo Program - To test Pr..
Using While Statement
01234
To execute a while statement, the interpreter first evaluates expression. If the value of
the expression is true the interpreter executes the statement and repeats, jumping back to the
top of the loop and evaluating expression again. In the above example let us see how the while
command is executed,
1. Initial value of the variable no2 is set to 0
2. The expression in the while statement is executed
3. If the condition is true then body of the loop will be executed once otherwise body of the
loop will be skipped and control will jump to next statement to end of the loop.
4. Then the value of the control variable is executed and control jumps to condition again go
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to step 3
15.2.4 do .. while loop
The do..while loop is like a while loop, except that the loop expression is tested at the
end of the loop rather than at the beginning. This means that the body of the loop is always
executed at least once. The syntax is:
do
{
		

body of the loop

} while (expression);
An important difference between while and do..while statement is in the do..while loop
body of the loop always executed at least once before the condition can be executed. In a while
loop, first condition will be evaluated and then only based on the result of the condition the
body of the loop will be executed or not.
Illustration 15.9 Using do..while loop
<Html>
<Head>
<Title>Program - To test do..while statement in JavaScript </Title>
</Head>
<Body>
<script language="javascript" type="text/javascript">
document.write("<h2> Using do..while Statement </h2>");
var no2=0;
Output:
do
{
X
document.write(no2+" ");
C:\User\ELCOT\Desktop\SCER ^ Search...
no2=no2+2;
}while(no2<=10);
Demo Program - To test Pr..
</script>
Using do..while Statement
</Body>
0 2 4 6 8 10
</Html>
Exercise
Write a JavaScript Program for the following:
a) To display Odd number from 1 to N numbers.
b) To display any Multiplication table as the user required.
c) To display as 10,9,8,……0
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Points to Remember:
• Conditional Statements help to alter the normal sequence of execution of a program
by two types of controls - Branching and Looping.
• The three logical operators in Jave Script are &&, !! & !.
• The break statement is commonly used to exit the statement once the appropriate
choice is found.
• The for is a very rigid, flexible structure that loops for a pre set number of times.
• The break statement terminates the loop irrespective of the condition and the
continue statement executes the next iteration of the loop.

Evaluation
Part-I

Choose the correct answers:
1. Which conditional statement is used to transfer control from current statement to
another statement?
(a) Branching		
(b) Sequencing
(c) Looping		
(d) Interating
2.

_______ statement can be used as alterative to if-else statement.
(a) While		
(b) If			
(c) Else-if		
(d) Switch

3.

Which statement in switch case is used to exit the statement once the appropriate choice
is found?
(a) Exit			
(b) Default		
(c) Case		
(d) Break

4.

Which of the following is not a looping statement?
(a) Switch		
(b) While		
(c) Do-While

(d) For

5.

Which part of the loop statement determines the number of times, the loop will be
iterated?
(MOT)
(a) First		
(b) Second		
(c) Third		
(d) Final

6.

Which of the following is not a branching statement?
(a) Loop		
(b) If-else		
(c) Switch		

7.

(d) For

What will be the output for the following snippet:
For (var n=0; n<10; n+1)
{
if (n==3)
{
break;
}
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document write (n+"<br>");
}
(a) 0 1 2		
(b) 0 1 2 3		
8.

(d) 0, 1, 3

In which loop the condition is evaluated, before executing a statement?		
(a) While		

9.

(c) 0 1 2 3 4

(b) Do while		

(c) Break		

(MOT)

(d) Continue

The _______ statement is especially useful when testing all the possible results of an
expression.		 (LOT)
(a) While		

(b) Do while

(c) Switch		

(d) If

10. In the _____ loop, body of the loop always executed at least once before the condition
can be executed.		
(LOT)
(a) For			

(b) While		

(c) If			

(d) Do while

11. <script type = "text / javascript">
x = 6 + "3";
document write (x);
<script> what will be the output?
(a) 6		

(b) 9		

(c) 63		

(d) Error

Part – II
Very Short Answers
1.

What are the different types of control statement used in JavaScript?

2.

What is meant by conditional statements in JavaScript?

3.

List out the various branching statements in JavaScript?

4.

Write the general syntax for switch statement

5.

Differentiate the break and continue statement.
Part-III

Short Answers
1. What is if statement and write its types.
2.

Write the syntax for else-if statement.

3.

What is called a loop and what are its types?

4.

Differentiate between while and do while statements
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5.

What message will be displayed, if the input for age is given as 20, for the following
snippet.
if (age> = 18 )
{
alert ("you are eligible to get Driving licence"}
}
else
alert ("you are not eligible to get driving licence");
}
Part –IV

Explain in Detail
1.

Explain for loop with example

2.

Explain switch case statement with example

3.

Write the output for the following program
<Html>
<Head>
<Title> for statement</title>
<Head>
<Body>
<script language= "java Script" type = "text / javaScript")
var no1= prompt ("please enter table you want:", "0" );
document write ("<h2> multiplication for your need </h2>")
for (Var no2= 0; no2<=10; no2++)
{
document write (no1+ "x" + no2+ "=" + no1+no2+ "<br>);
}
</script>
</body>
</Html>

4.

Write a Java Script program using while statement to display 10 numbers.
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Unit IV

JavaScript

CHAPTER

16

JavaScript Functions
Learning Outcomes
The students will learn the following:
• How to implement the function in JavaScript
• How to use Pre-defined functions
• How to create and use user-defined functions
• To create an Online application

16.1 Introduction
A function is a block of JavaScript code that is defined once but may be executed or
invoked any number of times. Functions are used to encapsulate code that performs a specific
task. Sometimes functions are defined for commonly required tasks to avoid the repetition
entailed in typing the same statements over and over. More generally, they are used to keep
code that performs a particular job in one place in order to enhance reusability and program
clarity.
JavaScript functions are parameterized or non-parameterized. A parameterized
function definition may include a list of identifiers, known as parameters that work as local
variables for the body of the function. Function invocations provide values or arguments for
the function’s parameters. Functions often use their argument values to compute a return value
that becomes the value of the function invocation expression.
JavaScript supports two types functions. They are
• Pre-defined or Library Functions
• User-defined Functions
16.2 Some common pre-defined functions.
Pre-defined functions are already defined in the JavaScript library which are also called
Library functions. For example isNaN(), toUpperCase(), toLowerCase(), length(), alert(),
prompt(),write() etc., are pre-defined functions.
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Table: 16.1 Predefined functions
Function
toUpperCase()
toLowerCase()
length
parseInt()
parseFloat()

Description
Used to convert
given string into
uppercase
Used to convert
given string into
lowercase
Used to find length
of the given string
Used to convert the
given float value into
an integer
Used to convert the
given string into a
integer

Example
x=”java”
x.toUpperCase();

Result

x=”JAVA”
x.toLowerCase();

java

x=”JAVA”
x.length();
parseInt(34.234);

4

parseInt(“34.23”);

34.23

JAVA

34

16.3 User defined functions
User-defined functions allow the programmer to modularize a program. Most computer
programs that solve real-world problems are much large, occupy more space in the computer
memory and takes more time to execute. Hence such large programs are divided into small
programs are called modules.
Function Definition
The format of a function definition is
		
Function function-name(parameters list)
		{

{

Declaration of variable
Executable statements;

{

		

Function Body

		}
Note:
• The function-name is any valid identifier.
For Example: sum
• The parameter list contains one or more valid variable name.
• Parameter list contains more than one variable then comma must be there between the
variable. For example: function sum(x,y)
• The function body must be enclosed by braces.
Example:
function sum(x,y)
{
		var m=x+y;
		return m;
}
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Listing 16.1 Using Function
<html>
<head>
<title>Function Example</title>
<script type="text/JavaScript">
<!-var input1=window.prompt("Enter Value1 :", "0");
var input2=window.prompt("Enter Value2 :", "0");
var v1=parseInt(input1);
var v2=parseInt(input2);
var s=sum(v1,v2);
document.writeln("<br><h4><u>Example for Function</u></h4>");
document.writeln("First No :" + v1 + " <br>Second No :" + v2 + "<br> The Sum = " + s);
function sum(x, y)
{
var s=x+y;
return s;
}
//-->
</script>
</head>
<body>
</body>
</html>
Output:
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The isNaN() function is used to check whether the given value or variable is valid
number. This function returns true if the given value is not a number. For example isNaN(“12”),
isNaN(“A”).
Listing 16.2 Using isNaN() Function
<html>
<title>Example Program to test isNan() Function</title>
<head> </head>
<body>
<h4><u>Example Program to test isNan() Function</u></h4>
<script language="JavaScript">
function checknum()
{
var n=document.form1.text1.value;
if(isNaN(n)==true)
{
document.form1.text2.value="Not a Number : "+n;
}
else
{
document.form1.text2.value="It is Number : "+n;
}
}
</script>
<form name="form1">
Enter a Number1:
<input type="text" name="text1" size=3>
<br><br>
<input type="button" value="Click to Check" onClick="checknum()">
<input type="text" name="text2" size=30>
<br>
</form>
</body>
</html>
Output:
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Listing 16.3 Using Function (on-line quiz)
<html>
<head>
<title>On-line Quize</title>
<script type="text/JavaScript">
function checkAnswer()
{
//var myQuiz=document.getElementById("myQuiz");
if ( document.getElementById("myQuiz").elements[0].checked)
alert("Congratulations, Your Answer is correct");
else
alert("Your Answer is incorrect, Please try Again");
}
</script>
</head>
<body>
<form id="myQuiz" action="JavaScript:checkAnswer()">
<p> Which is not a Programming Language: <br>
<input type="radio" name="radiobutton" value="Word" />
<label> MS-Word</label>
<input type="radio" name="radiobutton" value="Cobol" />
<label> COBOL</label>
<input type="radio" name="radiobutton" value="CPP" />
<label> C++</label>
<input type="radio" name="radiobutton" value="VB" />
<label>Visual BASIC</label><br><br>
<input type="submit" name="submit" value="Submit" />
<input type="reset" name="reset" value="Reset" />
</p> </form>
</body>
</html>
Output:

Note:
•

The getElementById() method returns the element that has the ID attribute with the
specified value. (In this example, ID is received from form tag).

•	elements[0] indicates the first option given in the question (Ms-word)
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Points to Remember:
• A function is a block of JavaScript code that is defined once but can be invoked for
any number of times.
• There are 2 types of functions predefined and user defined functions
• Predefined functions are also called Library function
• User defined functions allow the programmer to modularize a program
• Larger programs divided into smaller are called modules.

Evaluation
Part-I

Choose the correct answer:
1. The parameters work as
A) Local variable				
B) Global Variable
C) File variable				
D) block variable
2. Predefined functions are also called as
A)Library functions				
B) storage functions
C) instructions				
D) commands
3. Larger programs are divided into smaller are called
A) modules				
B) block
C) sets				
D) Group
4. Which of the following is used to enhance reusability and program clarity.
A) functions				
B) modules
C) sets				
D) instructions
5. Which of the following allow the programmer to modu/arize a program
A) Library functions				
B) user defined functions
C) Normal functions				
D) Ordinary functions
Part – II
Very Short Answers
1. What is a function in JavaScript?
2. What is the use of function?
3. Write a note on Library functions.
4. Write a note on user defined functions.
5. Write the syntax of functions.
Part-III
Short Answers
1. Write a program in JavaScript to find the cube of a number using function
2. Write a program in JavaScript to find the sum of 10 numbers using function.
Case study
Display a menu as web page, Accept the choice as input and display the result using function.
The menu to be displayed is
1. Sum of numbers upto a given limit
2. Sum of numbers from a starting limit to ending limit.
336

Chapter 16 Pages 176-183.indd 336

3/20/2020 11:45:08 AM

Unit V

COMPUTER ETHICS AND
CYBER SECURITY

CHAPTER

17

Computer Ethics and Cyber Security
Learning Objectives

GUIDELINES OF ETHICS

After learning this chapter,
the students will be able to

Generally, the following guidelines
should be observed by computer users:
1. Honesty: Users should be truthful while
using the internet.
2. Confidentiality: Users should not
share any important information with
unauthorized people.
3. Respect: Each user should respect the
privacy of other users.
4. Responsibility: Each user should take
ownership and responsibility for their
actions
Ethics is a set of moral principles
that govern the behavior of
an individual in a society,
and Computer ethics is set of
moral principles that regulate the use of
computers by users.

• To know about cyber-crimes.
• To understand the guidelines and need
for ethics in cyber-world.
• To understand issues related to cybercrimes.
• To know the functionality of firewalls
and proxy servers.
• To learn about encryption and
decryption.
• To gain knowledge on IT Act.

17.1 INTRODUCTION

Internet is a communication media
which is easily accessible and open to all.
Information Technology is widespread
through computers, mobile phones and
internet. There is a lot of scope and possibility
for misuse of Information Technology.

17.2 ETHICAL ISSUES

Computer systems in general are
vulnerable.Special care must be taken
explicitly in order to ensure that the valuable
data do not get into wrong hands. Hence,
the data need to be protected.

An Ethical issue is a problem or
issue that requires a person or organization
to choose between alternatives that must
be evaluated as right (ethical) or wrong
(unethical). These issues must be addressed
and resolved to have a positive influence in
society.
Some of the common ethical issues are listed
below:
• Cyber crime
• Software Piracy
• Hacking
• Use of computers to commit fraud

A cyber-crime is a crime which
involves computer and network.This is
becoming a growing threat to society .
ETHICS
Ethics is a set of moral principles that govern
the behavior of an individual in a society, and
Computer ethics is set of moral principles
that regulate the use of computers by users.
337

Chapter 17.indd 337

3/20/2020 4:34:14 PM

• Sabotage in the form of viruses
• Making false claims using computers
CYBER CRIME
Cybercrime is an intellectual, whitecollar crime. Those who commit such crimes
generally manipulate the computer system
in an intelligent manner.
For example – illegal money transfer via
internet.
Examples of some Computer crimes and
their functions are listed below in Table
17.1:
Table 17.1 Computer Crime
Crime
Function
Malware
Malicious programs that
can perform a variety
of functions including
monitoring user’s computer
activity without their
permission.
Harvesting A person or program
collects login and password
information from a
legitimate user to illegally
gain acces s to others’
account(s).
Spam
Distribute unwanted e-mail
to a large number ofinternet
users.
SOFTWARE PIRACY
Software
Piracy
is
“unauthorized copying of software”.
Figure 17.2 shows a diagrammatical
representation of software piracy.

An entirely different approach to
software piracy is called Shareware. Shareware
publishers encourage users to give copies of
programs to friends and colleagues but ask
everyone who uses that program regularly to
pay a registration fee to the program’s author
directly. Commercial programs that are made
available to the public illegally are often called
Warez.
HACKING
Hacking is intruding into a computer
system to steal personal data without the
owner’s permission or knowledge (like
to steal a password). It is also gaining
unauthorized access to a computer system,
and altering its contents. It may be done
in pursuit of a criminal activity or it may
be a hobby. Hacking may be harmless if
the hacker is only enjoying the challenge
of breaking systems’ defenses, but such
ethical hacking should be practiced only as
controlled experiments. Figure 17.3 shows
a diagrammatic representation of Hacking.
The act of gaining illegal
access to a computer

HACKING

SOFTWARE PIRACY

Duplicating and
selling copyrighted
programs

Leads to

Identity theft or
gaining personal
information

Downloading
software illegally
through network

Protected by

Firewalls, passwords
and user Id’s , anti
hacking software

Figure 17.3 Diagramatic representation of
Hacking

Figure 17.2- Diagrammatic representation
of Software piracy
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To prevent unauthorized access, Firewalls,
Intrusion Detection Systems (IDS), Virus
and Content Scanners, Patches and Hot fixes
are used.
CRACKING

may look like a legitimate e-mail from bank
or other official institution.

17.3 Cyber Security and Threats
Cyber attacks are launched primarily
for causing significant damage to a
computer system or for stealing important
information from an individual or from an
organization.Cyber security is a collection
of various technologies, processes and
measures that reduces the risk of cyber
attacks and protects organizations and
individuals from computer based threats.

Cracking is where someone edits
a program source so that the code can be
exploited or modified. A cracker (also called
a black hat or dark side hacker) is a malicious
or criminal hacker. “Cracking” means trying
to get into computer systems in order to
steal, corrupt, or illegitimately view data.
A cracker is someone who breaks into
someone else's computer system, often on a
network, bypassing passwords or licenses in
computer programs.

TYPES OF CYBER ATTACKS
Malware is a type of software
designed through which the criminals gain
illegal access to software and cause damage.
Various types of cyber-attacks and their
functions are given inTable 17.2.

They may send official e-mail
requesting some sensitive information. It

Table 17.2 – Cyber Attacks and Functions
S.No.

1.

2.

3.

4.

Cyber
Attack

Function

A virus is a small piece of computer code that can repeat itself
and spreads from one computer to another by attaching itself to
another computer file. One of the most common virus is Trojan.
Virus
A Trojan virus is a program that appears to perform one function
(for example, virus removal) but actually performs malicious
activity when executed.
Worms are self- repeating and do not require a computer program
to attach themselves. Worms continually look for vulnerabilities
Worms
and report back to the author of the worm when weaknesses are
discovered.
Spyware can be installed on the computer automatically when
Spyware
the attachments are open, by clicking on links or by downloading
infected software.
Ransomware is a type of malicious program that demands payment
after launching a cyber-attack on a computer system. This type of
Ransomware
malware has become increasingly popular among criminals and
costs the organizations millions each year.
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Cyber Security Threats
In recent years, most of the individuals
and enterprises are facing problems due
to the weaknesses inherent in security
systems and compromised organizational
infrastructures. Different types of Cyber
Security Threats are categorized as below:
Phishing
Phishing is a type of computer crime
used to attack, steal user data, including login
name, password and credit card numbers
e.t.c. through emails.
Pharming
Pharming is a scamming practice
in which malicious code is installed on a
personal computer or server, misdirecting
users to fraudulent web sites without their
knowledge or permission. Pharming has
been called "phishing without a trap”. It is
another way hackers attempt to manipulate
users on the Internet. It is a cyber-attack
intended to redirect a website's traffic to a
fake site.
Cookies
A cookie is a small piece of data
sent from a website and stored on the user's
computer memory (Hard drive) by the user's
web browser while the user is browsing
internet.
Web sites typically use cookies for the
following reasons:
• To collect demographic information
about who has visited the Web site.
• Sites often use this information to track
how often visitors come to the site and
how long they remain on the site.
Firewall and Proxy Servers
A firewall is a computer network
security based system that monitors and
controls incoming and outgoing network
traffic based on predefined security rules.
A firewall commonly establishes a block
between a trusted internal computer

network and entrusted computer outside
the network.
A proxy server acts as an intermediary
between the end users and a web server. The
proxy server examines the request, checks
authenticity and grants the request.
Encryption and Decryption
Encryption and decryption are
processes that ensure confidentiality that
only authorized persons can access the
information.
Encryption is the process of translating the
plain text data (plaintext) into random and
mangled data (called cipher-text).
Decryption is the reverse process
of converting the cipher-text back to
plaintext.Encryption and decryption are
done by cryptography. In cryptography a
key is a piece of information (parameter)
that determines the functional output of a
cryptographic algorithm.
Encryption is used to protect data in
communication system, for example data
being transferred via networks (e.g. the
Internet, ecommerce), mobile telephones,
wireless microphones, wireless intercom
systems, Bluetooth devices and bank
automatic teller machines.

17.4 INTRODUCTION TO
INFORMATION TECHNOLOGY
ACT
In the 21st century, Computer,
Internet and ICT or e-revolution has
changed the life style of the people. Apart
from positive side of e-revolution there
is also negative side of computer, that
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is, the internet and ICT in the hands of
criminals .To tackle the problems of cyber
crimes Cyber Law or Cyber Space Law or
Information Technology Law or Internet
Law were introduced.

2.	
Commercial
programs
made
available to the public illegally are
known as

In India Cyber law and IT Act 2000
, modified in 2008 are being articulated
to prevent computer crimes. IT Act 2000
is an act to provide legal recognition for
transactions carried out by means of
ElectronicData Interchange(EDI) and
other means of electronic communication.
It is the primary law in India dealing with
cybercrime and electronic commerce(eCommerce). e-Commerce is electronic data
exchange or electronic filing of information.

3.

a. freeware		
c. free software

Which one of the following are selfrepeating and do not require a computer
program to attach themselves?

a. viruses
b. worms
c. spyware d. Trojans
4.	Which one of the following tracks a
user visits a website?
a. spyware
c. worms

b. cookies
d. Trojans

5.	
Which of the following is not a
malicious program on computer
systems?
a. worms
d. Trojans
c. spyware d. cookies
6. A computer network security that
monitors and controls incoming and
outgoing traffic is
a. Cookies b.Virus
c. Firewall d. worms
7.	The process of converting cipher text
to plain text is called
a. Encryption		
b. Decryption
c. key			
d. proxy server
8.
e-commerce means
a. electronic commerce

PREVENTION
25% of cyber crime remains unsolved. To
protect the information the following points
are to be noted:
• Complex password setting can make
your surfing secured.
• When the internet is not in use,
disconnect it.
• Do NOT open spam mail or emails that
have an unfamiliar sender.
• When using anti-virus software, keep it
up-to-date.

Evaluation

b. electronic data exchange

PART - I
Choose the best Answer.

c. electric data exchange
d. electronic commercialization.

1.	
Which
of
the
following is a set of
moral principles that
regulate the use of computers ?
a. piracy
c. virus

b. warez
d. software

9.	
Distributing unwanted e-mail to
others is called.
a. scam
c. fraud

b. spam
d. spoofing

b. programs
d. computer ethics
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10.	
Legal recognition for transactions
are carried out by
a. Electronic Data Interchange
b. Electronic Data Exchange
c. Electronic Data Transfer
d. Electrical Data Interchange

3.	
What are the guidelines to be
followed by any computer user?
4.
What are ethical issues? Name some.
Part –IV
Explain in Detail
1.	
What are the various crimes
happening using computer?
2.	What is piracy? Mention the types of
piracy? How can it be prevented?
3.	
Write the different types of cyber
attacks.

Part – II
Very Short Answers
1.
What is Harvesting ?
2.
What are Warez?
3.
Write a short note on cracking.
4.
Write two types of cyber attacks.
5.
What is a Cookie?

Reference :
• Computer Network Security and Cyber
Ethics by Joseph MiggaKizza
• “Investigating Cyber Law and Cyber
Ethics: Issues, Impacts and Practices: 1”
by Alfreda Dudley and James Braman

Part-III
Short Answers
1.
What is the role of firewalls?
2.	
Write about encryption
decryption.

and

GLOSSARY
WORD

MEANING

Authenticity

The quality of being real or true.

Computer Crime

Computer crime is an intellectual crime to manipulate computer system.

Ethics

Moral principles that govern a person's behaviour or the conducting of
an activity.

Hacking

Hacking is gaining unauthorized access to computer system without
the owner’s permission.

Perpetrator

A person who carries out a harmful, illegal, or immoral act.

Software Piracy

Software Piracy is the copyright violation of software created originally by one person and illegally used by someone else.
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Unit VI

COMPUTER ETHICS AND
CYBER SECURITY

CHAPTER

18

Tamil Computing
18.1 Introduction
“ பிறநாட்டு நல்லறிஞர் சாத்திரங்கள்
தமிழ்மொழியிற் பெயர்த்தல் வேண்டும்;
இறவாத புகழுடைய புதுநூல்கள்
தமிழ்மொழியில் இயற்றல் வேண்டும்;
மறைவாக நமக்குள்ளே பழங்கதைகள்
ச�ொல்வதில�ோர் மகிமை இல்லை;
திறமான புலமையெனில் வெளிநாட்டோர்;
அதை வணக்கஞ் செய்தல் வேண்டும்.”
- மகாகவி பாரதி

18.2 Tamil in Internet

Human civilization developed with
the innovation of computer in the twentieth
century. Computer development began as a
early calculating tool and has now become
a essential ingredient for gigantic growth
for the existence of human life without
computers.

We know that the internet today
plays a vital role in every man's life. Internet
is the best information technological device,
through which we get know information.
In 2017 a study conducted by KPMG
a Singapore based organization along with
google, reported that, Tamil topped the list,
among the most widely used languages in
India, where 42% are using the Internet in
Tamil

It is true that any language will be
outdated when it does not have the ability
to adapt itself to the changing technologies.
Tamil is a living language for thousands of
years. Development of modern technologies,
does not affect the growth of classical
Tamil as it is ready to adopt the growing
technological changes. Tamil is not just a
language, it is our identity, our life and our
sense.
“எங்கள் வாழ்வும், எங்கள் வளமும் மங்காத
தமிழென்று சங்கே முழங்கு” – புரட்சி கவி.
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As per study, by 2021, 74% of people in India will access internet using Tamil and it will be in
the top usage of Internet in India.

These statistical data will be useful to improve internet services in Tamil.
18.3 Search Engines in Tamil
The “Search Engines” are used to
search any information from the cyber space.
Although there are many search engines, but
only a few of them are frequently in use. In
the top ten search engines, Google, Bing and
Yahoo take first three places respectively.
Google and Bing provide searching facilities
in Tamil, which means you can search
everything through Tamil. The Google
search engine gives you an inbuilt Tamil
virtual keyboard.

உள்ளீட்டுக் கருவிகள்

Figure 18.1(b) Google Search Engine
(Singapore)

உள்ளீட்டுக் கருவிகள்

Figure 18.2 Searching in Tamil
Figure 18.1(a) Google Search Engine
(India)
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18.4 e – Governance:
Getting Government services through
internet is known as e-Governance. Govt.
of Tamilnadu has been giving its services
through Internet. One can communicate
with Govt. of Tamilnadu from any corner
of the World. One can get important
announcements, government orders, and
government welfare schemes from the web
portal of Govt. of. Tamilnadu.
E-Governance through Tamil
Official Website of Govt. of Tamilnadu
Department of Agricultural Engineering
Department of Environment
Directorate of Govt. Examinations
Tamilnadu Health Department
Tamilnadu Micro, Small and Medium
Enterprises Department
Rural Development and Panchayat Raj
Department
Backward, Most Backward and Minorities
Welfare Department
Tamilnadu Forest Department
Hindu Religious and Charitable
Endowments Department.
Tamil Nadu Public Service Commission
(TNPSC)
Official Website of Govt. of Srilanka

Figure 18.3 Official Website of Govt. of
Tamilnadu
Web Address
http://www.tn.gov.in/ta
http://www.aed.tn.gov.in/
http://www.environment.tn.nic.in/
http://www.dge.tn.nic.in/
http://www.tnhealth.org/
http://www.msmeonline.tn.gov.in/
http://www.tnrd.gov.in/
http://www.bcmbcmw.tn.gov.in/
https://www.forests.tn.gov.in/
http://www.tnhrce.org/
http://www.tnpsc.gov.in/tamilversion/index.
html
https://www.gov.lk/index.php

Outside India, Government of
Srilanka provides all their services through
the official website in Tamil.

services provide thousands of Tamil Books
as ebooks mostly at free of cost. It is the most
useful service to Tamil people who live far
away from their home land.

18.5 e-Library
E-Libraries are portal or website
of collection of e-books. Tamil e-Library
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Tamil e-Library
Tamilnadu School Education
and Teacher Education Training
Textbooks and Resource Books
Tamil Virtual Academy
Connemara Public Library
Tamil Digital Library
Chennai Library
Thamizhagam
Project Madurai
Old Books and Manuscripts
Noolaham
Anna Centenary Libraray

Website address
http://www.textbooksonline.tn.nic.in/
http://www.tamilvu.org/library/libindex.htm
http://connemarapubliclibrarychennai.com/
Veettukku_oru_noolagam/index.html
http://tamildigitallibrary.in/
http://www.chennailibrary.com/
http://www.thamizhagam.net/parithi/
parithi.html
http://www.projectmadurai.org/pmworks.
html
http://www.tamilheritage.org/old/text/
ebook/ebook.html
http://www.noolaham.org/wiki/index.php/
http://www.annacentenarylibrary.org/

18.6 Tamil Typing and Interface software
Tamil is mostly used to type
documents in word processors and search
information on the internet. Typing Tamil
using Tamil interface software is a familiar
one among the different methods of typing.
This is the simplest method of typing Tamil
in both Computer and Smart phones.

Figure 18.4 eKalappai Opening screen
18.7 Tamil Office Automation
Applications

18.6.1 Familiar Tamil Keyboard Interface:

Famous Office automation software
like Microsoft Office, Open Office etc.,
provides complete Tamil interface facility.
These softwares are downloadable and
installed in your computer. After installation,
your office automation software environment
will completely change to Tamil. Menu bars,
names of icons, dialog boxes will be shown
in Tamil. Moreover, you can save files with
Tamil names and create folders with Tamil
names.

• NHM Writer, E-Kalappai and Lippikar
– are familiar Tamil keyboard interfaces
software that is used for Tamil typing
which works on Tamil Unicode, using
phonetics.
• Sellinam and Ponmadal – are familiar
Tamil keyboard layouts that works on
Android operating system in Smart
phone using phonetics.
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Tamil language. This encoding scheme
was registered in IANA (Internet Assigned
Numbers Authority) a unit of ICANN.
ISCII (Indian Script Code for Information
Interchange)
This is one of the encoding schemes
specially designed for Indian languages
including Tamil. It was unified with Unicode.

Figure 18.5 Libra Office Writer
Environments in Tamil
Apart from that Tamil Libra Office,
Tamil Open Office, Azhagi Unicode Editor,
Ponmozhi, Menthamiz, Kamban, Vani
are office automation software working
exclusively for Tamil. You can use these
applications to work completely in Tamil.

Unicode:
Unicode is an encoding system,
designed to handle various world languages,
including Tamil. Its first version 1.0.0 was
introduced in October 1991. Unicode is the
best suitable to handle Tamil.

18.8 Tamil Translation Applications

18.11 Tamil Operating System

Thamizpori (தமிழ்பொறி) is a Tamil
tranlation application having more than
30000 Tamil words equalent to English
words. Using this application, we can
translate small english sentences into Tamil.
Google also gives an online translation
facility.

An operating system is needed to access
electronic systems such as computer and
smart phone. Microsoft Windows is very
popular operating system for personal
computers. Linux is another popular
open source operating system. Operating
systems are used to access a computer easily.
An operating system should be easy to
work and its environment should be in an
understandable form. Thus, all operating
systems used in computers and smart phones
are offered in Tamil environment.

18.9 Tamil Programming Language
Programming languages to develop
software in computers and smart phones are
available only in English. Based on Python
programming language, the first Tamil
programming language “Ezhil” (எழில்) is
designed.

Windows
Tamil
Environment
interface should be downloaded and
installed from the internet. It displays all
window elements such as Taskbar, desktop
elements, names of icons, commands in
Tamil.

18.10 Tamil Information Interchange
Coding Systems
TSCII (Tamil Script Code for Information
Interchange)
Computers handle data and
information as binary system. Computers
use ASCII encoding system to handle data
and information. The ASCII encoding
system is applicable only for handling
English language. Therefore, TSCII (Tamil
Script Code for Information Interchange)
is the first coding system to handle our

18.12 Organisation and projects to
develop Tamil
Tamil Virtual Academy:
With the objectives of spreading
Tamil to the entire world through internet,
Tamil Virtual University was established
on 17th February 2001 by the Govt. of
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Tamilnadu. Now, this organisation functions
with the name of “Tamil Virtual Academy”.
It offers different courses in Tamil language,
Culture, heritage etc., from kindergarten to
under graduation level.

literary classics. This means either typing-in
or scanning old books and archiving the text
is one of the most readily accessible formats
for use on all popular computer platforms.
Since its launch in 1998, Project
Madurai etexts released are in Tamil script
form as per TSCII encoding. Since 2004
we have started releasing etexts in Tamil
unicode as well.
Web Site: http://www.projectmadurai.org/

Website: http://www.tamilvu.org/index.php
Tamil Language Council, Singapore
With the objectives
of promoting the awareness
and greater use of Tamil
among the Singaporeans, in
2001 the council of Tamil
Language was formed by the ministry of
Information Communications and Arts,
Govt. of Singapore. The council is called as
“வளர்தமிழ் இயக்கம்”.
Website: http://tamil.org.sg/ta
Madurai Project
Project Madurai is an open and
voluntary initiative to collect and publish
free electronic editions of ancient tamil
•
•
•
•
•
•
•
•

Tamil Wikipedia:
Wikipedia is a open source
encyclopedia where any person can write
an article about any subject. There are more
than One lakh articles in Tamil Wikipedia.

Web Site: https://ta.wikipedia.org/
In order to make Tamil as a living
language, it is the duty of every Tamilian to
actively use Tamil in the development of
technology.
Points to Remember:
Tamil topped the list of the most widely used regional languages in India by the end of
2016, among 42% are using the Internet.
Google and Bing provide searching facilities in Tamil.
Getting Government services through internet is known as e-Governance.
Tamil e-Library services provide thousands of Tamil Books as ebooks mostly at free of
cost.
Thamizpori (தமிழ்பொறி) is a Tamil tranlation application having more than 30000
Tamil words equalent to English words.
The first Tamil programming language is “Ezhil” (எழில்)
Unicode is an encoding system, designed to handle various world languages, including
Tamil.
Windows Tamil Environment interface should be downloading and install from
internet.

Evaluation
Very Short Answers
1. List the search engines supported by Tamil language.
2. What are the keyboard layouts used in Android?
3. Write a short note about Tamil Programming Language.
4. What is TSCII?
5. Write a short note on Tamil Virtual Academy.
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PRACTICAL

11

COMPUTER APPLICATION

Practical Programs – Hand Book
Instructions:
1.
2.
3.

One exercise from Writer, Calc and CSS, Three exercises from HTML, and Four
exercises from JavaScript are to be practiced in the practical classes.
Ansewer to any one question from Practical Book with internal choice
Distribution of Marks
I. Internal Assessment:
Record Book

5 Marks

II. External Assessment:

15 Marks

5 Marks

(a) Writer or Calc

– Procedure

HTML or CSS or JavaScript

– Coding

(b) Execution & Output

10 Marks

5 Marks
Total

20 Marks

INDEX
Sl. No.
1
2
3
4
5
6
7
8
9
10

Question
Number
CA1
CA2
CA3
CA4
CA5
CA6
CA7
CA8
CA9
CA10

Program Name
Open Office Writer - Formatting Invoice
Open Office Calc – Interest Calculation
HTML – Form Design
HTML – Height and Weight Table
HTML – Nested List
CSS – Formatting Webpage
JavaScript – Display Text
JavaScript – Multiplication Table
JavaScript – Display Weekdays in Words
JavaScript – Login Form
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CA1 – FORMATTING INVOICE
Type the following Invoice in OpenOffice Writer and apply the formatting
features as given below:

CA-1

Invoice
SAIRAM MEDICAL STORES
P.B.No: 617
70, New Avadi Road,
Chennai 600 010.

Mobile No : 9002416000
Mail Address : sairam@gmail.com
No: 70/162
M/s.

Eswari Medical Stores,
No: 72, N.S.C. Bose Road,
Puduchery - 6210110

Quantity (Nos)
20
10
5

23rd Nov 2017

Particulars

Rate

Johnson Baby Powder
Nestle Milk Powder
Wood Wards Gripe Water
Total
Add: GST @ 3%
Net Payable

Amount
25
100
70

500
1000
350

For Sriram Medical Stores
Sales Manager

•

Use formula to calculate Total and Net Payable
Procedure
Step-1. OpenOffice Writer and choose Text document or File → New → Text Document.
Step-2. Type the text and apply the format as per the given format.

Note: Select the required text before formatting.
Text

Format

Method

INVOICE

Center and apply red

Ctrl + E and choose Red color from
font color pallete or any method.

SAIRAM MEDICAL
STORES

Center and apply blue

Ctrl + E and Blue color from font
color pallete or any method.

Eswari Medical
Stores

Bold

Ctrl + B or any method.
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Step-3 Create a table using any one of the method Ctrl + F12 or Insert → Table or
Table → Insert → Table or Insert Table icon from toolbar. with 4 columns and 7 rows
Step–4. Enter the data as per the given format.
Step-5. Select first three columns in 5th Row and Right Click → Cell → Merge and
type as "Total"
Step-6. Repeat Step-5 for 7th Row, and type as "Net payable"
Step-7. To find the Total, Enter the following formula at Total → Amount Column as
=<D2>+<D3>+<D4> OR = Sum (<D2:D4>)
Step-8. To find the GST @ 3% Enter the formula as = <B5> *0.03
Step-9. To calculate Netpayable amount, Enter the formula as =<B5>+<D6>
Output

Invoice
SAIRAM MEDICAL STORES
P.B.No: 617
70, New Avadi Road,
Chennai 600 010.

Mobile No : 9002416000
Mail Address : sairam@gmail.com
No: 70/162
M/s.

Eswari Medical Stores,
No: 72, N.S.C. Bose Road,
Puduchery - 6210110

Quantity (Nos)
20
10
5

23rd Nov 2017

Particulars

Rate

Johnson Baby Powder
Nestle Milk Powder
Wood Wards Gripe Water
Total
Add: GST @ 3%
Net Payable

Amount
25
100
70

500
1000
350
1850
55.5
1905.5

For Sriram Medical Stores
Sales Manager

CA2 - INTEREST CALCULATION
Create statement of interest using OpenOffice Calc with the following particCA-2
ulars:
Sara Ltd., sells goods. Their policy is to charge interest @ 2% p.a., for the number of
days. From the following data, find out the amount to be collected from each customer.
Assume 365 days in the year.
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Customer

Sales

Date of Sale

NO. of days

Tharani

25000

10/04/2017

60

Mahalakshmi

14000

28/05/2017

30

Kumar

28000

14/07/2017

45

Arulmozhi

54000

03/08/2017

90

Date of
settlement

Procedure
Step -1. Open OpenOffice Calc and choose Spreadsheet or File → New → Spreadsheet.
Step -2. Type the Headings in cell A1 to E1 (Customer, Sales, Date of Sale, Number of days
and Date of settlement) as per the given data.
Step -3. In cell F1 and G1 type (Interest Amt and Amount to be paid) respectively.
Step -4. In cell E2 enter the formula = C2 + D2 to arrive the date of settlement and to the
remaining cells (E2 to E5). Use Edit → Fill → Down command
Step -5. In cell F2 enter the formula =ROUND((B2*2/100)*D2/365) to arrive the Interest
amount to the remaining cells (F2 to F5). Use Edit → Fill → Down command
Step -6. In cell G2 enter the formula = B2 + F2 to arrive the Amount to be paid to the remaining
cells (G2 to G5). Use Edit → Fill → Down command
Output

CA3 – FORM DESIGN
CA-3 Write an HTML code to design a form like the one shown below.
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Coding
<html>

<head>
<title> User Registration </title>
</head>
<body>
<h1 align = center> Registration Form </h1>
<form id=reg_form method = post action = " ">
User Name: <input type = text name=uname > <br><br>
Password: <input type = password name=pword1 > <br><br>
Re-type Password: <input type = password name=pword2 > <br><br>
Gender:
<input type = radio name=male value="M" > Male
<input type = radio name=female value="F" > Female
<h2 align=center> Additional Information </h2>
Optional Subject:
<select name=subj>
<option value = CT> Computer Technology
<option value = Paint> Painting
<option value = SG> Sports and Games
</select>
<br><br>
<input type = checkbox name=mail > Put me on mail list <br> <br>
<input type = reset value=Reset >
<input type = submit value=Submit >
</form>
</body>
</html>
Output
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CA4 - HEIGHT AND WEIGHT TABLE
CA-4 Write an HTML code to display the following.

Height and Weight
Name

Mani
Vasu
Murali
Pallavai

Class
XII - G
XI - H
XI - B
XII - D

Height
5'0"
5'4"
5'1"
4'5"

Weight
45
49
51
50

Coding
<html>
<head>
<title> Height and Weight Table </title>
<head>
<body>
<table border=10>
<caption> Height and Weight </caption>
<tr>
<th width=40%> Name </th>
<th width=20%> Class </th>
<th width=20%> Height </th>
<th width=20%> Weight </th>
</tr>
<tr>
<td> Mani </td>
<td> XII – G </td>
<td> 5’0” </td>
<td> 45 </td>
</tr>
<tr>
<td> Vasu </td>
<td> XI – H </td>
<td> 5’4” </td>
<td> 49 </td>
</tr>
<tr>
<td> Murali </td>
<td> XI – B </td>
354

Computer Application Practical.indd 354

3/20/2020 4:36:19 PM

<td> 5’1” </td>
<td> 51 </td>
</tr>
<tr>
<td> Pallavai </td>
<td> XII - D </td>
<td> 4’5” </td>
<td> 50 </td>
</tr>
</table>
</body>
</html>
Output
Height and Weight
Name
Mani
Vasu
Murali
Pallavai

Class
XII - G
XI - H
XI - B
XII - D

Height
5'0"
5'4"
5'1"
4'5"

Weight
45
49
51
50

CA5 - NESTED LIST
CA-5

Write an HTML code to create a webpage to display the following sets of
lists:
• Languages
o Tamil
o Malayalam
o Telugu
• Science
o Physics
o Chemistry
o Zoology
• Humanities
o History
o Commerce
o Economics

1. Tamilnadu
a. Chennai
b. Madurai
2. Andhra Pradesh
a. Amaravathi
b. Vijayawada
3. Kerala
a. Thiruvananthapuram
b. Cochin
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</OL>
<UL>
<LI> Languages
		 <UL type=circle>
			
<LI> Tamil
			
<LI> Malayalam
			
<LI> Telugu
		</UL>
<LI> Science
		 <UL type=circle>
			
<LI> Physics
			
<LI> Chemistry
			
<LI> Zoology
		</UL>
<LI> Humanities
		 <UL type=circle>
			
<LI> History
			
<LI> Commerce
			
<LI> Economics
		</UL>
</UL>
</body>
</html>

Coding
<html>
<head>
<title> Sets of Lists </title>
</head>
<body>
<OL>
<LI> Tamilnadu
		 <OL type=a>
			
<LI> Chennai
			
<LI> Madurai
		</OL>
<LI> Andhra Pradesh
		 <OL type=a>
			
<LI> Amaravathi
			
<LI> Vijayawada
		</OL>
<LI> Kerala
		 <OL type=a>
			
<LI> Thiruvananthapuram
			
<LI> Cochin
		</OL>
Output

1. Tamilnadu
a. Chennai
b. Madurai
2. Andhra Pradesh
a. Amaravathi
b. Vijayawada
3. Kerala
a. Thiruvananthapuram
b. Cochin
• Languages
o
Tamil
o
Malayalam
o
Telugu
• Science
o
Physics
o
Chemistry
o
Zoology
• Humanities
o
History
o
Commerce
o
Economics
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CA6 - FORMATTING WEBPAGE
CA-6 Create a webpage as given description using CSS
Tamil
Tamil is a Dravidian language predominantly spoken by the Tamil people of India
and Sri Lanka, and by the Tamil diaspora, Sri Lankan Moors, Burghers, Douglas, and
Chindians. Tamil is an official language of two countries: Sri Lanka and Singapore.
It has official status in the Indian state of Tamil Nadu and the Indian Union Territory
of Puducherry. It is used as one of the languages of education in Malaysia, along with
English, Malay and Mandarin.
Tamil is spoken by significant minorities in the four other South Indian states of
Kerala, Karnataka, Andhra Pradesh and Telangana and the Union Territory of the Andaman
and Nicobar Islands. It is one of the 22 scheduled languages of India.
Description:
Element

Font

Style

Alignment

Color

H1

Arial Black

-

Center

P1

Century

Bold

-

Red

P2

Boockman Old Style

Italic

-

Blue

P3

Century Gothic

-

-

Green

Border 2px
solid blue

Note: Create two files. 1. Mystyle.css and 2. CA6.html
color : Red;
}
P2
{
font-family: "Bookman Old Style";
font-style : Italic;
color : Blue;
}
P3
{
font-family: "Century Gothic";
color : Green;
}

Coding -1
Mystyle.css
H1
{
font-family: "Arial Black";
text-align:center;
border : 2px solid blue;
}
P1
{
font-family: "Century";
font-style : Bold;
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It has official status in the Indian state of
Tamil Nadu
and the Indian Union Territory of
Puducherry.
It is used as one of the languages of education in Malaysia,
along with English, Malay and Mandarin.
</P2> <br> <P3>
Tamil is spoken by significant minorities in
the four other
South Indian states of Kerala, Karnataka,
Andhra Pradesh
and Telangana and the Union Territory of
the Andaman and
Nicobar Islands. It is one of the 22 scheduled languages of
India.
</P3>
</body>
</html>

Coding -2
CA6.html
<html>
<head>
<title> Tamil </title>
<link
rel="stylesheet"
type="text/css"
href="mystyle.css">
</head>
<body>
<H1> Tamil </H1>
<P1>
Tamil is a Dravidian language predominantly spoken
by the Tamil people of India and Sri Lanka,
and by the
Tamil diaspora, Sri Lankan Moors, Burghers, Douglas,
and Chindians. Tamil is an official language
of two countries:
Sri Lanka and Singapore.
</P1> <br> <P2>
Output

Tamil
Tamil is a Dravidian language predominantly sopken
by the Tamil people of India and SriLankan Moors, Burghers,
Douglas, and Chindians. Tamil is an official language of two
countries: Sri Lanka and Singapore.
It has official status in the Indian state of Tamil Nadu
and the Indian Union Territory of Puducherry. It is used as one
of the languages of educatiooon in Malaysia, along with English,
Malay and Mandarin.
Tamil is spoken by significant minorities in the four
other south Indian states of Kerala, Karnataka, Andhra Pradesh
and Telangana and the Union Territory of the andaman and
Nicobar Islands. It is one of the 22 scheduled languages of India.
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CA7 - DISPLAY TEXT
CA-7 Create a webpage using JavaScript to display the following text.
Welcome to JavaScript
State Council of Educational Research and Training (SCERT),
Tamilnadu, Chennai.
Coding
<html>
<head>
<title> Display text using JavaScript </title>
</head>
<body align=center>
<p>
<script>
document.write ("<h1 align=center>Welcome to JavaScript <br>");
document.write ("State Council of Educational Research and Training (SCERT),<br>");
document.write ("Tamilnadu, Chennai. </h1>");
</script>
</p>
</body>
</html>
Output

Welcome to JavaScript
State Council of Educational Research and Training (SCERT),
Tamilnadu, Chennai.
CA8 – MULTIPLICATION TABLE
Create a webpage using JavaScript to display multiplication table by prompting
CA-8
number of rows and columns.
Coding
<html>
<head>
<title>Multiplication Table</title>
<script type="text/javascript">
var rows = prompt("How many rows for your multiplication table?");
var cols = prompt("How many columns for your multiplication table?");
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if(rows == "" || rows == null)
		 rows = 10;
if(cols== "" || cols== null)
		 cols = 10;
createTable(rows, cols);
function createTable(rows, cols)
{
var j=1;
var output ="<table border='1' width='500'
cellspacing='0'cellpadding='5'>";
for(i=1;i<=rows;i++)
{
output = output + "<tr>";
while(j<=cols)
{

output = output + "<td>" + i*j + "</

td>";
		 j = j+1;
		 }
		 output = output + "</tr>";
		 j = 1;
}
output = output + "</table>";
document.write(output);
}
</script>
</head>
<body>
</body>
</html>

Output

1
2
3
4
5
6
7
8
9
10
11
12

2
4
6
8
10
12
14
16
18
20
22
24

3
6
9
12
15
18
21
24
27
30
33
36

4
8
12
16
20
24
28
32
36
40
44
48

5
10
15
20
25
30
35
40
45
50
55
60

6
12
18
24
30
36
46
48
54
60
66
72

CA9 - DISPLAY WEEKDAYS IN WORDS
CA-9

Create a webpage using JavaScript to display Weekday in words by getting
input as a number using switch.
{
case (n="1"):
document.write("Sunday");
break;
case (n="2"):
document.write("Monday");
break;
case (n="3"):

Coding
<html>
<head>
<title> Weekday </title>
<script type="text/javascript">
var n=prompt("Enter a number between 1
and 7");
switch (n)
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document.write("Tuesday");
break;
case (n="4"):
document.write("Wednesday");
break;
case (n="5"):
document.write("Thursday");
break;
case (n="6"):
document.write("Friday");
break;
case (n="7"):
document.write("Saturday");
break;
default:
document.write("Invalid Weekday");

break;
}
</script>
</head>
</html>
Output

Thursday

CA10 - LOGIN FORM
Create a Form using JavaScript to get username, password and address,
CA-10
validate the inputs.
<p align="center">
User Name:<input type="text"
id="t1"><br><br>
Password:<input type="text"
id="t2"><br><br>
Confirm Password:<input type="text"
id="t3"><br><br>
Address:<textarea rows="2" cols="25"
id="t4"></textarea><br><br>
<input type="button" value="Submit" onclick="sub()">
<input type="reset" value="Clear All">
</p>
</form>
</body>
</html>

Coding
<html>
<head>
<script type="text/javascript">
function sub()
{
if(document.getElementById("t1").
value == "")
alert("Please enter your name");
else if(document.getElementById("t2").
value == "")
alert("Please enter a password");
else if(document.getElementById("t2").
value != document.getElementById("t3").
value)
alert("Please enter correct password");
else if(document.getElementById("t4").
value == "")
alert("Please enter your address");
else
alert("Form has been submitted");
}
</script>
</head>
<body>
<form>

Output
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